Forum

Author Topic: orthomosaic color error around edges near vertical areas  (Read 6614 times)

bisenberger

  • Sr. Member
  • ****
  • Posts: 307
    • View Profile
    • Digital Mapping & Graphics
orthomosaic color error around edges near vertical areas
« on: February 21, 2016, 04:18:58 PM »
Digital Mapping & Graphics LLC
https://digital-mapping.net/

bisenberger

  • Sr. Member
  • ****
  • Posts: 307
    • View Profile
    • Digital Mapping & Graphics
Re: orthomosaic color error around edges near vertical areas
« Reply #1 on: February 23, 2016, 05:26:59 PM »
Anyone else having this issue? I have it showing up on several near vertical edges. I have tried different meshing methods and different point cloud densities, but the results are the same.
Digital Mapping & Graphics LLC
https://digital-mapping.net/

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 13918
    • View Profile
Re: orthomosaic color error around edges near vertical areas
« Reply #2 on: February 24, 2016, 05:34:33 PM »
Hello Bill,

Is it possible that some of the images related to the highlighted area are of the different brightness/contrast level compared to other images? What happens, when you use Assign images option for the problematic area - are there color issues?
Best regards,
Alexey Pasumansky,
Agisoft LLC

bisenberger

  • Sr. Member
  • ****
  • Posts: 307
    • View Profile
    • Digital Mapping & Graphics
Re: orthomosaic color error around edges near vertical areas
« Reply #3 on: February 26, 2016, 10:11:54 PM »
Hi Alexey,
Here are three screen grabs of different images assigned. The first one is the single image assign "img_5186.tif", the second one is single image assign "img_5187.tif", and the third image is multiple image assign "img_5186.tif" and "img_5187.tif". The photos are 16bit tif's.

single assigned img_5186.tif


single assigned img_5187.tif


multiple assigned img_5186.tif and img_5187.tif
« Last Edit: February 26, 2016, 10:15:59 PM by bisenberger »
Digital Mapping & Graphics LLC
https://digital-mapping.net/

bisenberger

  • Sr. Member
  • ****
  • Posts: 307
    • View Profile
    • Digital Mapping & Graphics
Re: orthomosaic color error around edges near vertical areas
« Reply #4 on: February 28, 2016, 05:54:23 PM »
Hello Bill,

Is it possible that some of the images related to the highlighted area are of the different brightness/contrast level compared to other images? What happens, when you use Assign images option for the problematic area - are there color issues?
Forgot to mention, the images are all similar in brightness/contrast.
Digital Mapping & Graphics LLC
https://digital-mapping.net/

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 13918
    • View Profile
Re: orthomosaic color error around edges near vertical areas
« Reply #5 on: March 03, 2016, 12:27:03 PM »
Hello Bill,

Can you provide a part of this project, so that we can reproduce the problem on our side?
Best regards,
Alexey Pasumansky,
Agisoft LLC

bisenberger

  • Sr. Member
  • ****
  • Posts: 307
    • View Profile
    • Digital Mapping & Graphics
Re: orthomosaic color error around edges near vertical areas
« Reply #6 on: March 10, 2016, 03:43:28 PM »
Okay Alexey, I'll send a link via email once it is uploaded.

It doesn't happen when blend mode is disabled.

This image is with blending mode Mosaic:



This image is with blending mode disabled:


All photos were taken with same aperture, shutter speed, and iso.
« Last Edit: March 10, 2016, 04:48:51 PM by bisenberger »
Digital Mapping & Graphics LLC
https://digital-mapping.net/

bisenberger

  • Sr. Member
  • ****
  • Posts: 307
    • View Profile
    • Digital Mapping & Graphics
Re: orthomosaic color error around edges near vertical areas
« Reply #7 on: March 10, 2016, 06:26:06 PM »
I recreated the project with JPEG images and there were no color issues with the orthomosaic. It appears to only be related to 16bit images and blending.
Digital Mapping & Graphics LLC
https://digital-mapping.net/

James

  • Hero Member
  • *****
  • Posts: 733
    • View Profile
Re: orthomosaic color error around edges near vertical areas
« Reply #8 on: March 10, 2016, 06:47:46 PM »
I had a similar thing, although not related to vertical edges rather just seams between photos, using 16bit tiffs.

mosaic blending gave nasty colours and dark/light effects, with colour correction making no difference.

blending disabled looked considerably better, and blending disabled with colour correction was almost perfect.

these were far from ideal photos taken in poor conditions, i had originally put it down to the funny camera angles and shadows in images.

sample ortho outputs attached

bisenberger

  • Sr. Member
  • ****
  • Posts: 307
    • View Profile
    • Digital Mapping & Graphics
Re: orthomosaic color error around edges near vertical areas
« Reply #9 on: March 10, 2016, 07:06:54 PM »
Hi James,
Thanks for posting.
I also have the issues related to photo seams with 16bit images and blending that you indicate.

« Last Edit: March 10, 2016, 07:10:44 PM by bisenberger »
Digital Mapping & Graphics LLC
https://digital-mapping.net/

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 13918
    • View Profile
Re: orthomosaic color error around edges near vertical areas
« Reply #10 on: March 10, 2016, 09:46:59 PM »
Thank you for the important information about 16-bit images. Looks like we've been able to reproduce it now and will try to fix it in the next update.
Best regards,
Alexey Pasumansky,
Agisoft LLC

bisenberger

  • Sr. Member
  • ****
  • Posts: 307
    • View Profile
    • Digital Mapping & Graphics
Re: orthomosaic color error around edges near vertical areas
« Reply #11 on: March 24, 2016, 06:32:55 PM »
Thank you for the important information about 16-bit images. Looks like we've been able to reproduce it now and will try to fix it in the next update.
Hi Alexey,
Glad you were able to reproduce the problem. I was going to send you some of the photos that I was having the issues with, but I got busy with some other stuff. Let me know if you still want me to upload them.
Bill
Digital Mapping & Graphics LLC
https://digital-mapping.net/

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 13918
    • View Profile
Re: orthomosaic color error around edges near vertical areas
« Reply #12 on: March 24, 2016, 06:34:54 PM »
Hello Bill,

Could you try to generate orthomosaic in the version 1.2.4 and report back if the issue is solved:
http://www.agisoft.com/downloads/installer/
Best regards,
Alexey Pasumansky,
Agisoft LLC

bisenberger

  • Sr. Member
  • ****
  • Posts: 307
    • View Profile
    • Digital Mapping & Graphics
Re: orthomosaic color error around edges near vertical areas
« Reply #13 on: March 25, 2016, 06:36:13 AM »
Hi Alexey,
It appears to be fixed. Thank you.  :)
« Last Edit: March 25, 2016, 06:50:38 AM by bisenberger »
Digital Mapping & Graphics LLC
https://digital-mapping.net/