Forum

Author Topic: Dense Point Cloud after reset alignment  (Read 3975 times)

martinmokros

  • Newbie
  • *
  • Posts: 7
    • View Profile
Dense Point Cloud after reset alignment
« on: March 05, 2016, 10:30:48 AM »
Hi everyone,
I have a problem with build dense point cloud. I am aligning more thn 300 pictures. In first step around 100 pictures stayed not aligned. I have used reset camera alignment and align selected cameras. But when I build dense point cloud there are points just for photoos that were aligned in first place and not for those photos aligned by reset camera alignment and align selected cameras. What I am doing wrong?

Martin

megan9851

  • Newbie
  • *
  • Posts: 5
    • View Profile
Re: Dense Point Cloud after reset alignment
« Reply #1 on: March 08, 2016, 05:42:30 AM »
I am having this problem as well. The photos I use don't all align during the first processing step and so I go back and align them one by one- adding them to the sparse cloud until I have what I need. For example out of 544 images only 145 aligned during processing, then I was able to align them so that 359 were aligned in the end. I then try to build a dense point cloud but it seems like it only will build it based on the original 145 that aligned and not of the whole sparse cloud.
So right now my dense point cloud is only producing exactly the same number of points as the sparse cloud- around 26k- and looks terrible.

Anyone have any advice?

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 14890
    • View Profile
Re: Dense Point Cloud after reset alignment
« Reply #2 on: March 08, 2016, 03:56:24 PM »
Hello,

If you turn on "Keep depth maps" option in the Preferences window you'll be able to see the cameras with the depth maps generated in the Photos pane (the icons in the thumbnail corner will appear after the dense cloud stage). So if you find the cameras without the depth maps you can open View Matches window to check whether there is sufficient number of matching points between the selected photo and other images. In case there are too few matching points between any pair of images, such pair is being assumed as non-overlapping.
Best regards,
Alexey Pasumansky,
Agisoft LLC

James

  • Hero Member
  • *****
  • Posts: 748
    • View Profile
Re: Dense Point Cloud after reset alignment
« Reply #3 on: March 08, 2016, 05:12:44 PM »
The other possibility is that the bounding box region is not updated after using align selected cameras, and so does not include the area covered by the 'newly' aligned cameras after 'align selected cameras' and so is not processed during 'build dense cloud'.

Solution is to use tools->reset region or rotate/resize region tools to include the required volume before building dense cloud.

martinmokros

  • Newbie
  • *
  • Posts: 7
    • View Profile
Re: Dense Point Cloud after reset alignment
« Reply #4 on: March 10, 2016, 09:00:48 AM »
Thank you Alexey and James for your answers.

James you save my day  ;D It was the problem with boundaries. Thank you very much :)

Martin