Forum

Author Topic: Yaw, pitch, roll not loading as reference  (Read 2371 times)

mskancke

  • Newbie
  • *
  • Posts: 12
    • View Profile
Yaw, pitch, roll not loading as reference
« on: July 06, 2016, 01:15:03 PM »
Hi

I have a dataset collected with a DJI Phantom 3 Pro and Pix4Dcapture app.

I loaded the photos into PS and lat/long is automatically inserted since its embedded in the exif data.
I have cleaned up the log from Pix4D which contains yaw, pitch and roll.
Created a new txt file which contains camera name and the orientation data.

When I try to import the orientation, I mess around with the column numbers to match the data in in the txt file.

Click OK, and no data is imported.
The existing lat/long is still there, but nothing added to yaw, pitch or roll

Is it not possible to do this task, or am I doing something wrong?

Dataset and logfile can be sent if needed, it ain't big since this is a test run..

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 14968
    • View Profile
Re: Yaw, pitch, roll not loading as reference
« Reply #1 on: July 06, 2016, 01:26:21 PM »
Hello mskancke,

Please send the project file (in PSZ format) and text file to support@agisoft.com.
Best regards,
Alexey Pasumansky,
Agisoft LLC

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 14968
    • View Profile
Re: Yaw, pitch, roll not loading as reference
« Reply #2 on: July 06, 2016, 01:38:57 PM »
Hello mskancke,

Thanks for sending the text file. Seems that you are trying to import only orientation angles without XYZ coordinates, but it is not supported at the moment. So you need to include both X,Y,Z, yaw, pitch, roll to the file and load all those values.
Best regards,
Alexey Pasumansky,
Agisoft LLC