Forum

Author Topic: Orthomosaic Export Problems with v1.2.5 (2735) and Float32 image data  (Read 3595 times)

ruadi

  • Newbie
  • *
  • Posts: 16
    • View Profile
Hello,
we are using a FLIR-camera and the same set of images works fine concerning aligning,dense cloud,etc. with v116 and v125.
Each input image is a 1-channel Float32 TIFF, containing temperature values, typically 10..40.
With v116 I get a descent temperature  Orthomosaic in channel 1.
With the current v125 the scaling of the Orthomosaic is now somehow strangely normalized (I tried also with  PhotoScan.BlendingMode=DisabledBlending).
How to get the channel layout (and disabled scaling ) of v116 ?
Ruedi

Float32-images with v1.1.6
 
Band 1 Block=2647x32 Type=Float32, ColorInterp=Gray
  Minimum=-17.021, Maximum=49.017, Mean=10.409, StdDev=9.912
  Metadata:
    STATISTICS_MAXIMUM=49.017379760742
    STATISTICS_MEAN=10.409090188344
    STATISTICS_MINIMUM=-17.020740509033
    STATISTICS_STDDEV=9.9120056741228
Band 2 Block=2647x32 Type=Float32, ColorInterp=Alpha
  Minimum=0.000, Maximum=1.000, Mean=0.541, StdDev=0.498
  Metadata:
    STATISTICS_MAXIMUM=1
    STATISTICS_MEAN=0.5414550280809
    STATISTICS_MINIMUM=0
    STATISTICS_STDDEV=0.49827851714359


Float32-images with v1.2.5 (2735)

Band 1 Block=256x256 Type=Float32, ColorInterp=Gray
  Min=0.000 Max=0.000
  Minimum=0.000, Maximum=0.000, Mean=0.000, StdDev=0.000
  Overviews: 1376x836, 688x418, 344x209, 172x105
  Metadata:
    STATISTICS_MAXIMUM=0
    STATISTICS_MEAN=0
    STATISTICS_MINIMUM=0
    STATISTICS_STDDEV=0
Band 2 Block=256x256 Type=Float32, ColorInterp=Alpha
  Min=0.000 Max=1.000
  Minimum=0.000, Maximum=1.000, Mean=0.663, StdDev=0.473
  Overviews: 1376x836, 688x418, 344x209, 172x105
  Metadata:
    STATISTICS_MAXIMUM=1
    STATISTICS_MEAN=0.66312668646378
    STATISTICS_MINIMUM=0
    STATISTICS_STDDEV=0.47264117908128

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 14937
    • View Profile
Re: Orthomosaic Export Problems with v1.2.5 (2735) and Float32 image data
« Reply #1 on: August 12, 2016, 11:35:07 AM »
Hello ruadi,

Can you please send any small sample dataset that we can use to reproduce the problem? Also please specify, whether the orthomosaic is displayed correctly in the Ortho view of PhotoScan window.
Best regards,
Alexey Pasumansky,
Agisoft LLC