Forum

Author Topic: Agisoft PhotoScan 1.3.0 pre-release  (Read 192061 times)

andrey.d

  • Newbie
  • *
  • Posts: 26
    • View Profile
Re: Agisoft PhotoScan 1.3.0 pre-release
« Reply #270 on: January 20, 2017, 12:22:55 PM »
Hello andrey.d,

For me it looks like the camera orientation angles loaded to the Reference pane is incorrect - so the model orientation in space in also incorrect. I've input very large number as "camera accuracy (deg)" to the Reference pane settings and then Updated the Reference pane - the orientation of the model after that looked valid.

I have image_name, longitude, latitude, altitude, yaw, pitch, roll
Could you give right format of csv file in my case?

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 14927
    • View Profile
Re: Agisoft PhotoScan 1.3.0 pre-release
« Reply #271 on: January 20, 2017, 12:50:30 PM »
Hello andrey.d,

I can suggest to skip loading yaw, pitch and roll, or to use the following lines to lower the accuracy of the angles after you load the CSV:
Code: [Select]
chunk.camera_rotation_accuracy = (1E5, 1E5, 1E5)
chunk.updateTransform()
Best regards,
Alexey Pasumansky,
Agisoft LLC

Mak11

  • Sr. Member
  • ****
  • Posts: 374
    • View Profile
Re: Agisoft PhotoScan 1.3.0 pre-release
« Reply #272 on: January 20, 2017, 11:44:01 PM »
Just grabed 1.3.0 do test it out and things are definitely broken. My photos are simply not aligning correctly at all (this is with OpenCL enabled. (in some cases the point cloud is sliced in half an translated to a different axis...wth) I also noticed that a big chuck of the photos are ignored in the process. Just retest in 1.23 and everything works fine. will do some testing without OpenCL now.
I'm attaching the Log and some screens of my second run where the "slicing wasn't as severe as the first time where literally the whole point cloud was perfectly slice in half vertically and shifted on the X axis)
« Last Edit: January 21, 2017, 12:30:22 AM by Mak11 »

Mak11

  • Sr. Member
  • ****
  • Posts: 374
    • View Profile
Re: Agisoft PhotoScan 1.3.0 pre-release
« Reply #273 on: January 20, 2017, 11:46:42 PM »
And here's the log attached.
« Last Edit: January 20, 2017, 11:50:22 PM by Mak11 »

Mak11

  • Sr. Member
  • ****
  • Posts: 374
    • View Profile
Re: Agisoft PhotoScan 1.3.0 pre-release
« Reply #274 on: January 21, 2017, 12:47:26 AM »
Just ran the alignment without OpenCL and things aren't better. A handful of cameras are not correctly aligned at all and a big chuck of the model is in the air..but this time only 2 of the 509 photos were dismissed (way less than with OpenCL). The second screenshot is how it looks in 1.2.6 (all cameras should be at ground level etc..)
« Last Edit: January 21, 2017, 01:12:42 AM by Mak11 »

Mak11

  • Sr. Member
  • ****
  • Posts: 374
    • View Profile
Re: Agisoft PhotoScan 1.3.0 pre-release
« Reply #275 on: January 21, 2017, 02:55:23 AM »
Ok, so I uninstalled 1.3.0 and re-installed 1.2.6. Opened the same project, hit align without changing anything and everything was re-aligned perfectly. Something definitely fishy in 1.3.0.

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 14927
    • View Profile
Re: Agisoft PhotoScan 1.3.0 pre-release
« Reply #276 on: January 21, 2017, 11:22:36 AM »
Hello Mak11,

Can you provide the sample dataset were you are observing the problem to support@agisoft.com?

Also please specify if you are using exactly the same parameters for alignment.
Best regards,
Alexey Pasumansky,
Agisoft LLC

lunar

  • Newbie
  • *
  • Posts: 36
    • View Profile
Re: Agisoft PhotoScan 1.3.0 pre-release
« Reply #277 on: January 21, 2017, 01:03:00 PM »
i`ve got the same problem, with openCl poor align (1/3 of photos), turning off gfx card all photos aligned

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 14927
    • View Profile
Re: Agisoft PhotoScan 1.3.0 pre-release
« Reply #278 on: January 21, 2017, 01:34:21 PM »
Hello lunar,

Could you specify the 1.3 build number and GPU model used?
Best regards,
Alexey Pasumansky,
Agisoft LLC

lunar

  • Newbie
  • *
  • Posts: 36
    • View Profile
Re: Agisoft PhotoScan 1.3.0 pre-release
« Reply #279 on: January 21, 2017, 03:06:52 PM »
1.3.3620  - old HD7800 pitcairn 1024MB - this maybe a problem - very old card

Mak11

  • Sr. Member
  • ****
  • Posts: 374
    • View Profile
Re: Agisoft PhotoScan 1.3.0 pre-release
« Reply #280 on: January 21, 2017, 03:28:40 PM »
Hello Mak11,

Can you provide the sample dataset were you are observing the problem to support@agisoft.com?

Also please specify if you are using exactly the same parameters for alignment.

Hello Alexey,

Yes as far I as could see I was using exactly the same parameters for alignement. I initially though that it was an OpenCL bug but the CPU only run was messed too (but a lot better than the OpenCL run) so alignment was incorrect in both modes while it's perfect every time I run it in 1.2.6.

The dataset is over 10GB of DNG photos :-( I don't think I could upload the whole thing in less than a week with my current internet connection.
« Last Edit: January 21, 2017, 03:34:09 PM by Mak11 »

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 14927
    • View Profile
Re: Agisoft PhotoScan 1.3.0 pre-release
« Reply #281 on: January 21, 2017, 03:35:50 PM »
Hello Mak11,

Maybe the same issue can be reproduced on the subset of images for JPGs, for example?
Best regards,
Alexey Pasumansky,
Agisoft LLC

Mak11

  • Sr. Member
  • ****
  • Posts: 374
    • View Profile
Re: Agisoft PhotoScan 1.3.0 pre-release
« Reply #282 on: January 21, 2017, 03:37:31 PM »
Alexey,

I'll try this out this week-end and let you know.

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 14927
    • View Profile
Re: Agisoft PhotoScan 1.3.0 pre-release
« Reply #283 on: January 21, 2017, 03:39:03 PM »
Thank you Mak11,

Maybe you can also send the report files generated from 1.2.6 and 1.3.0 projects, just for case we can find something unusual there and try to reproduce the problem on similar dataset.
Best regards,
Alexey Pasumansky,
Agisoft LLC

Mak11

  • Sr. Member
  • ****
  • Posts: 374
    • View Profile
Re: Agisoft PhotoScan 1.3.0 pre-release
« Reply #284 on: January 21, 2017, 03:40:45 PM »
How do I grab the report files? is it just the log (like the one I posted above?) or do I have to do anything else?