Forum

Author Topic: DEM creation problems with to merged point clouds  (Read 2393 times)

frank.stremke

  • Full Member
  • ***
  • Posts: 206
    • View Profile
DEM creation problems with to merged point clouds
« on: April 13, 2017, 06:55:18 PM »
Hi
i created a model from to chuks with a core model being in a higher resolution and a extended area model ...
now i have prepared clasefied and cut the point clouds leaving a hole in the overview and a excactly fitting core area to fill it
in the model view it looks very nice and there is no real overlap and noise in the cut area it looks realy nice
however when i create a DEM or mesh the different resolution of the clouds semmes to mess up the processing and it looks wrong
the center area is displayed correctly and everything is fine
the surounding is displayed just very corse mch worse then the actual resolution in the point cloud maybe 5% of the points seems to be used
this is the case also when i create with the option use all points insted of just the ground points
any idea how i can force ps to use this points as well..
frank
here is the point cloud view

and here the DEM

frank.stremke

  • Full Member
  • ***
  • Posts: 206
    • View Profile
Re: DEM creation problems with to merged point clouds
« Reply #1 on: April 19, 2017, 08:46:47 PM »
i tried again with different settings but got the same results
ps should not no this and i dont get it why it is doing this...
anyone?
frank

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 14104
    • View Profile
Re: DEM creation problems with to merged point clouds
« Reply #2 on: April 19, 2017, 08:58:09 PM »
Hello Frank,

I've tried to reproduce the issue, but it worked as expected. Could you please specify, if dense clouds have been generated in the same quality in the chunks that have been merged?

Could you please also provide the output for every chunk that was aligned and for the merged chunk running the following command in the Console pane after the corresponding chunk is switched to active status:
Code: [Select]
PhotoScan.app.document.chunk.dense_cloud.meta
Best regards,
Alexey Pasumansky,
Agisoft LLC

frank.stremke

  • Full Member
  • ***
  • Posts: 206
    • View Profile
Re: DEM creation problems with to merged point clouds
« Reply #3 on: April 27, 2017, 11:21:35 AM »
hello alexey
thanks for your reply
here is the two cunks and the merge

PhotoScan.app.document.chunk.dense_cloud.meta
Out[2]: 2017-04-27 10:18:04 {'dense_cloud/density': '100', 'dense_cloud/depth_downscale': '2', 'dense_cloud/depth_filter_mode': '2', 'dense_cloud/duration': '15728.681', 'dense_cloud/resolution': '0.00200377260553607'}

PhotoScan.app.document.chunk.dense_cloud.meta
Out[3]: 2017-04-27 10:18:14 {'dense_cloud/density': '100', 'dense_cloud/depth_downscale': '2', 'dense_cloud/depth_filter_mode': '2', 'dense_cloud/duration': '1551.936', 'dense_cloud/resolution': '0.00200959661626811'}

PhotoScan.app.document.chunk.dense_cloud.meta
Out[4]: 2017-04-27 10:18:24 {'dense_cloud/depth_downscale': '2', 'dense_cloud/depth_filter_mode': '2', 'dense_cloud/resolution': '0.00231038693081674'}

both chunks were created in high but the altitude is different one was flown at around 100 to 120 m the other at 500m
however i have the idea it might have to do wit the points being classified
thanks a lot!
frank

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 14104
    • View Profile
Re: DEM creation problems with to merged point clouds
« Reply #4 on: April 28, 2017, 06:11:32 AM »
Hello Frank,

Can you please also check that the bounding box of the merged chunk contains the whole dense point cloud and not just a part of it?
Best regards,
Alexey Pasumansky,
Agisoft LLC