Forum

Author Topic: I keep getting CUDA errors and blue screens during Dense Cloud. error log.  (Read 1995 times)

joacampb

  • Newbie
  • *
  • Posts: 12
    • View Profile
New to Photoscan.

Working with about 900 images of a statue.

I broke the images up into two chunks.

I can align and then optimize cameras just fine.

However, during the dense cloud workflow step for either chunk I keep getting the following error:

Quote
2017-06-15 09:08:47 Depth reconstruction devices performance:
2017-06-15 09:08:47  - 2%    done by CPU
2017-06-15 09:08:47  - 97%    done by GeForce GTX 1070
2017-06-15 09:08:47 Total time: 280.894 seconds
2017-06-15 09:08:47
2017-06-15 09:08:47 Warning: all CUDA-capable devices are busy or unavailable
2017-06-15 09:08:48 Warning: all CUDA-capable devices are busy or unavailable
2017-06-15 09:08:49 Error: 2017-06-15 09:08:49 Saving project...
unspecified launch failure at line 217
2017-06-15 09:08:49 saved project in 0.016 sec


Its not every time. But its enough to prevent me from completing this model for the last two weeks.

I have successfully created over 10 models, and sometimes this will happen. but for this specific model I am really having a hard time.

Any idea where I can start trouble shooting?

My machine:

Windows 10 Pro.
AMD FX-8350 CPU
GeForce GTX 1070 graphics card
MSI Gamining 970 mother board
32 GB RAM
All SSD

I am using the newest version of Photoscan.

Thanks.

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 14104
    • View Profile
Hello joacampb,

Can you please provide the full processing log related to the failed operation?

Also please check if there are other intensive processes that drain GPU resources (you can check it using NVIDIA-SMI).
Best regards,
Alexey Pasumansky,
Agisoft LLC

joacampb

  • Newbie
  • *
  • Posts: 12
    • View Profile
Thanks for looking into this.

I attached the output from the console. Hope that is enough.

During processing , photoscan is the only major program running. background processes include MSI Afterburner, a monitor calibration program ( dispcal/ argyllCMS) and Windows Defender.

I will have to run a report from NVIDIA-SMI later today when I am with the machine.

thank You!