Forum

Author Topic: Problem with overlapping images !  (Read 4596 times)

Ramadnio

  • Newbie
  • *
  • Posts: 17
    • View Profile
Problem with overlapping images !
« on: May 16, 2017, 12:00:13 PM »
is there a solution for this problem ?!



drone : Phantom 4 pro
altitude : 300 m
F overlap : 70 %
S overlap : 35 %

Laptop
ASUS GAMING ROG
CPU : i7
GPU : GEFORCE GTX 880m
RAM : 32 GB


PhotoScan 1.3.1

1- Align Photos


2- Build Mesh
Spare Cloud - High

3- Build Orthomosaic
nothing changed

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 14004
    • View Profile
Re: Problem with overlapping images !
« Reply #1 on: May 16, 2017, 12:09:34 PM »
Hello Ramadnio,

The provided overlap values are for the ground level or for the building top level? Also note that we suggest to have at least 80% of forward overlap and 60% of side overlap, urban areas with tall buildings may require even higher values to provide the reasonable overlap for the roofs.
Anyway, I think you need to generate more accurate model and not use very sparse cloud to generate the rough model.

Use at least 20 000 for key point limit and at least 4 000 for tie point limit during the camera alignment. Optimize the camera alignment for all suggested parameters and F, Cx, Cy, B1, B2 if they are not suggested for optimization(including the rolling shutter optimization).
Build dense cloud in medium/high quality (maybe you should use Mild depth filtering option), then build mesh or DEM basing on the dense cloud (not from sparse cloud).
Best regards,
Alexey Pasumansky,
Agisoft LLC

Ramadnio

  • Newbie
  • *
  • Posts: 17
    • View Profile
Re: Problem with overlapping images !
« Reply #2 on: May 16, 2017, 12:23:21 PM »
Hello Ramadnio,

The provided overlap values are for the ground level or for the building top level? Also note that we suggest to have at least 80% of forward overlap and 60% of side overlap, urban areas with tall buildings may require even higher values to provide the reasonable overlap for the roofs.
Anyway, I think you need to generate more accurate model and not use very sparse cloud to generate the rough model.

Use at least 20 000 for key point limit and at least 4 000 for tie point limit during the camera alignment. Optimize the camera alignment for all suggested parameters and F, Cx, Cy, B1, B2 if they are not suggested for optimization(including the rolling shutter optimization).
Build dense cloud in medium/high quality (maybe you should use Mild depth filtering option), then build mesh or DEM basing on the dense cloud (not from sparse cloud).

thank u

i will try this

but when i make build orthomosaic from dense cloud

i have more distortions
and the pictures look unreal

so i like spare cloud

and i found this problems just in tall buildings

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 14004
    • View Profile
Re: Problem with overlapping images !
« Reply #3 on: May 16, 2017, 12:34:56 PM »
Hello Ramadnio,

Can you post a screenshot of the Solid mesh view mode for the corresponding building area from your project with the mesh generated out of the sparse point cloud?
Best regards,
Alexey Pasumansky,
Agisoft LLC

Ramadnio

  • Newbie
  • *
  • Posts: 17
    • View Profile
Re: Problem with overlapping images !
« Reply #4 on: May 16, 2017, 04:12:59 PM »
Hello Ramadnio,

Can you post a screenshot of the Solid mesh view mode for the corresponding building area from your project with the mesh generated out of the sparse point cloud?


stihl

  • Sr. Member
  • ****
  • Posts: 408
    • View Profile
Re: Problem with overlapping images !
« Reply #5 on: May 16, 2017, 04:26:55 PM »
Hi Ramadnio,

What you'd like to do is create a Mesh based on the *ground* points of the Dense cloud.

This will ensure that you can create an artifact free Orthomosaic.

After generating the Dense Point Cloud, run the automated classify ground points alghoritm with the default parameters.

Then generate a new Mesh with only these ground points. This can be done in the Build Mesh window.

Once that's done simply doubleclick on the Orthomosaic in the workspace pane and create polygons around objects and buildings to manually select an appropriate image for that particular polygon.

BobvdMeij

  • Full Member
  • ***
  • Posts: 157
    • View Profile
Re: Problem with overlapping images !
« Reply #6 on: May 17, 2017, 02:53:34 PM »
is there a solution for this problem ?!



drone : Phantom 4 pro
altitude : 300 m
F overlap : 70 %
S overlap : 35 %

Laptop
ASUS GAMING ROG
CPU : i7
GPU : GEFORCE GTX 880m
RAM : 32 GB


PhotoScan 1.3.1

1- Align Photos


2- Build Mesh
Spare Cloud - High

3- Build Orthomosaic
nothing changed

As Alexey already stated you might want to change your sideward overlap. Please bear in mind that the overlap set in the mission planning software calculates this on your set altitude, which is generally expressed in altitude above the take-off location.

Imagine your takeoff location is on ground level and is set to 300m, as it is in your case, then the mission planning software will define the flight line spacing and trigger intervals based on this altitude. However, when you are flying over a building your altitude to that building is actually (much) lower than 300m. If the building is 50m high, you are actually flying only 250m in altitude (as the building's roof now represents the 'ground' that you are capturing). HOWEVER, your drone is still taking images based on the 300m altitude that you set. Generally speaking, as elevation of the terrain increases your actual overlap factually DECREASES.

Considering that 30% sideward overlap is already (very!) low, I reckon increasing this to at least 60% (although 80% might be advisable in this instance) will help a whole lot!