Forum

Author Topic: Agisoft PhotoScan 1.4.0 pre-release  (Read 165993 times)

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 13822
    • View Profile
Re: Agisoft PhotoScan 1.4.0 pre-release
« Reply #90 on: October 13, 2017, 05:07:46 PM »
I have been playing around with the new version and there is a bug where you can't set a custom resolution for the mesh generation. The field is disabled when using the arbitrary 3D mode. The Ultra High setting doesn't give enough detail to generate a sharp normal map from the data.

Hello Willi,

Do you mean the new (experimental) mesh reconstruction option?

The polygon count is selected automatically for it currently. To improve the quality of the mesh you can use Refine Mesh option after the polygonal model has been reconstructed. Mesh refinement would likely increase the polygon count to improve the level of detail on the mesh surface.

Best regards,
Alexey Pasumansky,
Agisoft LLC

Willi Hammes

  • Newbie
  • *
  • Posts: 11
    • View Profile
    • MAWI United GmbH
Re: Agisoft PhotoScan 1.4.0 pre-release
« Reply #91 on: October 16, 2017, 08:59:15 PM »
Hi Alexey,

yes noticed that too after looking through the menus.
This indeed helped a lot with the detail, a lot cleaner as well, compared to 1.3s output.

I tried to use it on older scans made with 1.3 but it keeps crashing on all of the meshes.
I guess the base meshes are way to dense to also run the refinement tool on them.

Will do some more tests with new data in 1.4.

But the idea of having the relative displacement stored in a baked texture would still be a cool feature to have.

Best regards
Willi Hammes

school

  • Newbie
  • *
  • Posts: 12
    • View Profile
Re: Agisoft PhotoScan 1.4.0 pre-release
« Reply #92 on: October 16, 2017, 09:17:44 PM »
Im using 1.4 at the moment, and when trying to "Build Orthomosaic" with a particular image set, it fails with "TiffReadTile: unexpected error". This probably isnt a 1.4 specific problem, but could not find any posts about this on the forum, so figured it might be a new thing? Any clue what would cause this error? Thanks!

Console says:
Quote
2017-10-16 14:13:47 boundaries extracted in 0.053 sec
2017-10-16 14:13:47 region overflow: reading [1071, -12194] - [1080, -12185] from 17x13 image
2017-10-16 14:13:47 libtiff error: 1024: Col out of range, max 16
2017-10-16 14:13:47 region overflow: reading [1071, -12194] - [1080, -12185] from 18x19 image
2017-10-16 14:13:47 libtiff error: 1024: Col out of range, max 17
2017-10-16 14:13:47 Finished processing in 70.297 sec (exit code 0)
2017-10-16 14:13:47 Error: TIFFReadTile: unexpected error

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 13822
    • View Profile
Re: Agisoft PhotoScan 1.4.0 pre-release
« Reply #93 on: October 16, 2017, 09:21:24 PM »
Hello school,

Do the images work without any issues in 1.3.4 and if there are any similar error messages when aligning, building dense cloud in 1.4?

If so, can you send please any sample source image to support@agisoft.com that we can use for testing purposes?
Best regards,
Alexey Pasumansky,
Agisoft LLC

school

  • Newbie
  • *
  • Posts: 12
    • View Profile
Re: Agisoft PhotoScan 1.4.0 pre-release
« Reply #94 on: October 16, 2017, 09:48:46 PM »
Hi Alexey,

There was nothing surprising with aligning and dense cloud building in 1.4. Let me switch over to 1.3.4 and see what happens.

The only thing I did differently in this image set compared to the last several image sets I processed in 1.4 was that I used masks.

I will send the images to you if there is no problem in 1.3.4.

Thanks!

LuisM

  • Newbie
  • *
  • Posts: 4
    • View Profile
Re: Agisoft PhotoScan 1.4.0 pre-release
« Reply #95 on: October 19, 2017, 05:12:22 PM »
Hi,


Everything worked well for me in addition to exporting the report, I do not get any pictures in the report.

Regards,
Luis

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 13822
    • View Profile
Re: Agisoft PhotoScan 1.4.0 pre-release
« Reply #96 on: October 19, 2017, 05:29:35 PM »
Hello Luis,

Does the report generation of the same project works fine in 1.3.4?

Usually missing images in report are related to the referencing problems - either it is incorrect, or some cameras with wrong coordinates are present (like 0,0,0).
Best regards,
Alexey Pasumansky,
Agisoft LLC

macsurveyr

  • Jr. Member
  • **
  • Posts: 65
    • View Profile
Re: Agisoft PhotoScan 1.4.0 pre-release
« Reply #97 on: October 19, 2017, 06:29:59 PM »
I have been playing with the new Model View <Camera><Show Images> feature.  Objects I work with tend to be symmetric.  The new feature shows the image on both side of the camera; when looking through the camera as well as when you are looking into the camera.  It should only display the image when looking through the camera at the object, otherwise you can't tell which side of a symmetric object you took the picture from!

I would also like to seem indication of which side of the thumbnail is towards the object.

In addition, it would also be helpful to have an indication of camera groups. Perhaps a different border color for each workspace camera group?

Tom

ivan-zd

  • Newbie
  • *
  • Posts: 7
    • View Profile
Re: Agisoft PhotoScan 1.4.0 pre-release
« Reply #98 on: October 23, 2017, 08:48:48 AM »
Hi Agisoft team, the new features look quite interesting and useful, can you please tell me some approximate date when we can expect stable version of this release for download? Maybe you already wrote somewhere but I couldn't find.
Thanks

gEEvEE

  • Jr. Member
  • **
  • Posts: 64
    • View Profile
Re: Agisoft PhotoScan 1.4.0 pre-release
« Reply #99 on: October 23, 2017, 09:43:04 AM »
Hi All,

Am I blind or did the extremely useful "Gradual selection" option just vanish in the latest release?

Cheers,

Geert

wojtek

  • Sr. Member
  • ****
  • Posts: 275
    • View Profile
Re: Agisoft PhotoScan 1.4.0 pre-release
« Reply #100 on: October 23, 2017, 12:11:07 PM »
Hi All,

Am I blind or did the extremely useful "Gradual selection" option just vanish in the latest release?

Cheers,

Geert

They moved it to another tab (Model) I think.

I will repeat my humble request to add a keyboard shortcut for this option in here :)

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 13822
    • View Profile
Re: Agisoft PhotoScan 1.4.0 pre-release
« Reply #101 on: October 23, 2017, 12:21:00 PM »
Hi Agisoft team, the new features look quite interesting and useful, can you please tell me some approximate date when we can expect stable version of this release for download? Maybe you already wrote somewhere but I couldn't find.

Hello ivan-zd,

I think that the release of 1.4.0 may be expected in the upcoming winter, hopefully in the end of December.
Best regards,
Alexey Pasumansky,
Agisoft LLC

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 13822
    • View Profile
Re: Agisoft PhotoScan 1.4.0 pre-release
« Reply #102 on: October 23, 2017, 12:28:53 PM »
Hello wojtek,

In the next update of 1.4.0 (build 5251) that should be available in a few minutes from the first post of the thread you would be able to find the customizeable shortcuts for the Main Menu items (General tab of PhotoScan Preferences window).


Please check the links - version is updated.
« Last Edit: October 23, 2017, 12:42:26 PM by Alexey Pasumansky »
Best regards,
Alexey Pasumansky,
Agisoft LLC

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 13822
    • View Profile
Re: Agisoft PhotoScan 1.4.0 pre-release
« Reply #103 on: October 23, 2017, 03:16:19 PM »
For photogrammetry of sculpture more capabilities in dealing with the dense cloud is really the only thing I miss in what is otherwise a fantastic product.

We have added Filter By Selection option for the dense cloud points view in Standard edition (1.4.0 build 5251), so you can check this one now.
Best regards,
Alexey Pasumansky,
Agisoft LLC

RHenriques

  • Full Member
  • ***
  • Posts: 208
    • View Profile
Re: Agisoft PhotoScan 1.4.0 pre-release
« Reply #104 on: October 23, 2017, 06:23:57 PM »
Hi Alexey

This version crashes immediately under MacOS. Turned off Gatekeeper and it did not solve the problem.

Console says:

default   16:21:09.766925 +0100   kernel   AGC:: [PhotoScanPro pid 8570 mux-aware] exiting, non-mux-aware app count 1, runtime: 0:00:06.176
default   16:21:09.767497 +0100   kernel   AGC:: [PhotoScanPro pid 8570 non-mux-aware] exiting, non-mux-aware app count 0, runtime: 0:00:00.792
default   16:21:09.767530 +0100   kernel   AGC::  IGD (usr IGD extdisp 0 WS-ready 1 capture 0 non-mux-aware app 0 ac 0)
default   16:21:09.767549 +0100   kernel   AGC:: Switching from PEG to IGD
default   16:21:09.784420 +0100   CommCenter   #I handleLSNotitifcation_sync: Application exited: <private>
default   16:21:09.789524 +0100   launchservicesd   UNIX error exception: 22
default   16:21:09.792344 +0100   launchservicesd   MacOS error: -67062
default   16:21:09.795081 +0100   launchservicesd   CHECKIN:0x0-0x632632 8571 org.mozilla.crashreporter


RH