Forum

Author Topic: Photoscan not responding during non-processing activities  (Read 1254 times)

lefsky

  • Newbie
  • *
  • Posts: 27
    • View Profile
Photoscan not responding during non-processing activities
« on: June 19, 2018, 08:29:42 PM »
I am running photoscan-pro on an AWS instance with the following setup:

g3.4xlarge
16 virtual cpus
122 gb of memory
250 Gb SSD
1 Tesla M5 GPU
3.5 Gbps ethernet

and having to wait for long periods (15+ minutes) when the process is "Not Responding". The twist is that I am not doing any processing and have no other significant processes running.

For instance, I currently have the Open File dialog open and it has been "Not Responding" for 15 minutes and this has happened many times under similar circumstances. CPU utilization is ~20% and only 11 Gb of ram is being used. The files being used are on the SSD so access should be quick.

Has anyone else experienced this type of problem and if so, have you found a solution?

M






Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 12940
    • View Profile
Re: Photoscan not responding during non-processing activities
« Reply #1 on: June 19, 2018, 09:17:56 PM »
Hello lefsky,

Do you observe such freezes even when you click Open project button in the empty PhotoScan window?

Does it happen with any Open file / Save file dialog boxes?
Best regards,
Alexey Pasumansky,
Agisoft LLC

lefsky

  • Newbie
  • *
  • Posts: 27
    • View Profile
Re: Photoscan not responding during non-processing activities
« Reply #2 on: June 19, 2018, 09:24:48 PM »
It seems to be any time I try to open or save a file and when I try to press on any part of the interface (e.g. button, pull-down menu, etc.)

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 12940
    • View Profile
Re: Photoscan not responding during non-processing activities
« Reply #3 on: June 19, 2018, 09:36:13 PM »
Hello lefsky,

Which OS you are using on that instance and what are the starting lines in the Console pane of PhotoScan window?
Best regards,
Alexey Pasumansky,
Agisoft LLC

lefsky

  • Newbie
  • *
  • Posts: 27
    • View Profile
Re: Photoscan not responding during non-processing activities
« Reply #4 on: June 19, 2018, 10:28:26 PM »
The OS is Windows Server 2016 Datacenter

The output is as follows:
2018-06-19 19:15:01 No license found.
2018-06-19 19:15:01 Details: Wrong host for license (-4)
2018-06-19 19:15:01 Agisoft PhotoScan Professional Version: 1.4.2 build 6205 (64 bit)
2018-06-19 19:15:01 Platform: Windows
2018-06-19 19:15:01 CPU: Intel(R) Xeon(R) CPU E5-2686 v4 @ 2.30GHz (server)
2018-06-19 19:15:01 CPU family: 6 model: 79 signature: 406F1h
2018-06-19 19:15:01 RAM: 122.0 GB
2018-06-19 19:15:01 OpenGL Vendor: Google Inc.
2018-06-19 19:15:01 OpenGL Renderer: ANGLE (Microsoft Basic Render Driver Direct3D9Ex vs_3_0 ps_3_0)
2018-06-19 19:15:01 OpenGL Version: OpenGL ES 2.0 (ANGLE 2.1.99f075dade7c)
2018-06-19 19:15:01 Maximum Texture Size: 16384
2018-06-19 19:15:01 Quad Buffered Stereo: not enabled
2018-06-19 19:15:01 ARB_vertex_buffer_object: supported
2018-06-19 19:15:01 ARB_texture_non_power_of_two: supported
2018-06-19 19:15:01 Using simple console. Rich console can be enabled in Preferences dialog.
>>>

lefsky

  • Newbie
  • *
  • Posts: 27
    • View Profile
Re: Photoscan not responding during non-processing activities
« Reply #5 on: June 20, 2018, 11:41:44 PM »
I created a new instance using Server 2012 and the problem has been resolved.

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 12940
    • View Profile
Re: Photoscan not responding during non-processing activities
« Reply #6 on: June 22, 2018, 01:19:28 PM »
Hello lefsky,

Then the issue could be related to some system properties, like graphic card drivers, for example.
Best regards,
Alexey Pasumansky,
Agisoft LLC