Forum

Author Topic: Masked areas generated in texture  (Read 1784 times)

jwoods

  • Newbie
  • *
  • Posts: 23
    • View Profile
Masked areas generated in texture
« on: January 30, 2018, 06:32:55 PM »
In older versions of Photoscan, areas that were masked in the photos would not be used to generate the texture for the mesh model.  With the newest versions I have noticed that this is no longer the case and that masking has no effect on what is or isn't included in the texture.

Many of the models I create involve roadways with moving vehicles and it's been helpful for me to mask out the cars from photo to photo so that the rendered texture is only of the roadway.  Otherwise there are ghosted images of anything that has moved in and out of the frame from photo to photo.

Is there a feature or option that I am missing that can reenable this?

FLuca

  • Jr. Member
  • **
  • Posts: 55
    • View Profile
    • Another-me
Re: Masked areas generated in texture
« Reply #1 on: January 30, 2018, 07:14:39 PM »
+1 for this feature to be active again

or at least an option to activate/deactivate the masking in the texture setting overlay
Fred Lucazeau - Body Scan - www.another-me.fr
Sketchfab gallery: https://sketchfab.com/fredlucazeau

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 12940
    • View Profile
Re: Masked areas generated in texture
« Reply #2 on: January 30, 2018, 07:40:46 PM »
Hello,

Which version you are using?

The problem was observed in the version 1.3.4 and should be fixed in 1.3.5 and 1.4.0.
Best regards,
Alexey Pasumansky,
Agisoft LLC

jwoods

  • Newbie
  • *
  • Posts: 23
    • View Profile
Re: Masked areas generated in texture
« Reply #3 on: January 30, 2018, 10:10:29 PM »
I'm using 1.3.4 build 5067.  I didn't know there was an update; when I click check for updates the software says that it is up to date and the latest version.

ruyi7952

  • Full Member
  • ***
  • Posts: 101
    • View Profile
    • My Blog
Real Scene Model Professional Contractor

Collect、Process、Publish

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 12940
    • View Profile
Re: Masked areas generated in texture
« Reply #5 on: January 30, 2018, 10:23:02 PM »
I'm using 1.3.4 build 5067.  I didn't know there was an update; when I click check for updates the software says that it is up to date and the latest version.

You can find the links to the latest 1.3 and 1.4 versions on the Installers page:
http://www.agisoft.com/downloads/installer/
Best regards,
Alexey Pasumansky,
Agisoft LLC