Forum

Author Topic: Workflow for Sketchfab Export? SSL Error on Direct Upload?  (Read 3667 times)

jazzyj

  • Jr. Member
  • **
  • Posts: 83
    • View Profile
Workflow for Sketchfab Export? SSL Error on Direct Upload?
« on: February 01, 2018, 01:19:09 AM »
But when I tried to use the Upload to Sketchfab option with API key, it failed immediately saying SSL connection unavailable or something like that.

Not sure what's going on.

« Last Edit: February 01, 2018, 01:22:25 AM by jazzyj »

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 13051
    • View Profile
Re: Workflow for Sketchfab Export? SSL Error on Direct Upload?
« Reply #1 on: February 01, 2018, 01:20:57 AM »
Hello jazzyj,

You need to install OpenSSL. Please check the solution mentioned on Sketchfab forum:
https://forum.sketchfab.com/t/agisoft-photoscan-direct-upload-issue-error-creating-ssl/14040/22
Best regards,
Alexey Pasumansky,
Agisoft LLC

jazzyj

  • Jr. Member
  • **
  • Posts: 83
    • View Profile
Re: Workflow for Sketchfab Export? SSL Error on Direct Upload?
« Reply #2 on: February 01, 2018, 01:53:20 AM »
I'm running Windows Server 2016.  I installed OpenSSL-Light.  Still get the error.  Strangely the instructions you provided a link to say:

6) Double-clicked the EXE file: Win32OpenSSL_Light-1_0_2L
7) With SEARCH I confirmed that the two dlls were installed. On my system, these files were placed in /Windows/sysWOW64 folder. I did not have to move these files to a different location.
8) In browser opened my account at Sketchfab.com
9) Clicked the UPLOAD button, upper left corner of window.
10) Navigated to the folder MODEL, double-clicked "model"
11) Photoscan recognizes the presence of the doc.XML, mesh.PLY, and texture.PNG files, and
12 UPLOAD proceeds without error.

#8 and #11 don't make sense as one says "in browser" and the steps after that appear to be using upload function on sketchfab website and #11 says "Photoscan recognizes"  I think they mean Sketchfab recognizes as the function in Photo scan is File > Upload > Sketchfab > Specify info including API key -- there's no browser involved!

I still get the SSL error.  Do I need to restart Photoscan or the server?

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 13051
    • View Profile
Re: Workflow for Sketchfab Export? SSL Error on Direct Upload?
« Reply #3 on: February 03, 2018, 06:13:55 PM »
Hello jazzyj,

Some users with similar problem recently have reported that installing OpenSSL v1.0.2n or OpenSSL v1.0.2n Light works fine.
Best regards,
Alexey Pasumansky,
Agisoft LLC

SteveHoo

  • Newbie
  • *
  • Posts: 1
    • View Profile
Re: Workflow for Sketchfab Export? SSL Error on Direct Upload?
« Reply #4 on: February 28, 2019, 10:59:45 AM »
https://slproweb.com/products/Win32OpenSSL.html

Win64 OpenSSL v1.0.2r worked for me, after much faffing. I had to quit and restart Metashape, though.