Forum

Author Topic: weird tall pixel artifacts in Z-axis  (Read 1804 times)

kiwi4669

  • Newbie
  • *
  • Posts: 2
    • View Profile
weird tall pixel artifacts in Z-axis
« on: February 27, 2018, 07:23:21 PM »
Hi,

I'm having a weird issue with a data set i'm trying to solve.

Some of the geometry/meshes are being rendered with very long(tall), perfectly straight pixel groups -almost like "voxels" shooting up in the Z axis.

The dataset is about 600 20mpix 3:2 images from a Phantom 4 Pro. I'm using High/mild for my Mesh and Texture filtering settings. ALso using the split groups python script to break it into 5x5 grid for memory management. I've got 32GB in the machine and havn't used over 28GB that i've seen so far.

screen shot and mesh attached...

Any ideas?

Thanks in Advance!

macsurveyr

  • Jr. Member
  • **
  • Posts: 69
    • View Profile
Re: weird tall pixel artifacts in Z-axis
« Reply #1 on: February 27, 2018, 07:48:58 PM »
You must chosen Height field for the surface type.

Choosing Arbitrary (3D) will model everything but will definitely take more time and resources.

Tom

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 14927
    • View Profile
Re: weird tall pixel artifacts in Z-axis
« Reply #2 on: February 27, 2018, 07:49:09 PM »
Hello kiwi4669,

It's Height Field mesh generation result, that builds model in 2.5D. Maybe there's some noise or very sparse cloud in the area, so it looks like spikes.
Best regards,
Alexey Pasumansky,
Agisoft LLC

kiwi4669

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: weird tall pixel artifacts in Z-axis
« Reply #3 on: February 27, 2018, 08:53:35 PM »
aww dang. I had changed HeightFeild to Arbitrary in the script originally- and then i forgot to change that again when I re-downloaded the original script and made more changes...

Thanks - here we go again for another 30+ hour render...

You must chosen Height field for the surface type.

Choosing Arbitrary (3D) will model everything but will definitely take more time and resources.

Tom

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 14927
    • View Profile
Re: weird tall pixel artifacts in Z-axis
« Reply #4 on: February 28, 2018, 06:07:00 PM »
Hello kiwi4669,

We have updated the script on GitHub - https://github.com/agisoft-llc/photoscan-scripts/blob/master/src/split_in_chunks_dialog.py
Now the dense cloud quality and meshing option can be selected in the script dialog.

If there are any issues with the new script version, please let me know.
Best regards,
Alexey Pasumansky,
Agisoft LLC