Forum

Author Topic: Thermal photos fail to align  (Read 945 times)

Andre78

  • Newbie
  • *
  • Posts: 2
    • View Profile
Thermal photos fail to align
« on: April 21, 2020, 05:35:11 PM »
Hello,
I am used Micasense Altum over a wheat field. I flew at 80 m altitude for 85% image overlap. I successfully processed the multispectral but the thermal images (which have lower resolution) were not able to align over the field where all is green (images on the edge of the field were successfully aligned). I think the issue is in the coarse resolution of thermal and the uniformity of the field to find enough tie points. I tried to play with the align photo settings ( removed generic preselection, increased the key point and reduced the tie point limits), reset  and re-align camera, optimize the camera but with no success. Is there is any trick that I am missing? will I be able to save the thermal data obtained for that mission?
Thank you in advance
Andre

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 13150
    • View Profile
Re: Thermal photos fail to align
« Reply #1 on: April 21, 2020, 09:54:51 PM »
Hello Andre,

If you check the View Matches dialog, do you see any considerable number of the tie points on the images from the inner part of the area?

Also have you tried to follow the MicaSense data processing workflow and use multi-camera system approach (both thermal and multispectral bands processed at once) - does it allow to get the thermal band layer in the final orthomosaic?
Best regards,
Alexey Pasumansky,
Agisoft LLC

Andre78

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: Thermal photos fail to align
« Reply #2 on: April 21, 2020, 10:19:24 PM »
Hi Alex, thanks for your prompt reply.
Yes, I have processed all images together (multi-camera system). and I tried to process thermal alone. In both cases, I had the same issue (20% of the thermal images can be aligned and those are the ones on the field edge). For those images that have failed to align,  they have numbers between 50 to 20 tie points for at least 4 to 5 images but all are classified as invalid and non as valid. Probably if we can make those invalid tie points as valid, we might be able to solve the problem, though I am not sure how much the quality will be compromised. For that field, I will not be worried much about the stitching quality as I will be looking for an average thermal value  over large parts of the field.

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 13150
    • View Profile
Re: Thermal photos fail to align
« Reply #3 on: April 21, 2020, 10:32:57 PM »
Hello Andre,

If it is possible, I would ask you to send the complete image dataset (including the multispectral images) to support@agisoft.com as a link to any file sharing service, so that we could try both approach on our side.
Best regards,
Alexey Pasumansky,
Agisoft LLC