Forum

Author Topic: photos do not display properly when double clicked  (Read 9083 times)

srm9r6

  • Newbie
  • *
  • Posts: 1
    • View Profile
photos do not display properly when double clicked
« on: May 04, 2018, 12:50:31 AM »
Hello,

I am trying to place reference markers in my photos individually. When I double click a photo, the program does not display it and locks me out of all of the other toolbars and windows. When I do get the photo to display, it does not let me zoom in or pan on it and when I right click it does not display the normal menu for adding markers etc.


Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 13913
    • View Profile
Re: photos do not display properly when double clicked
« Reply #1 on: May 04, 2018, 12:53:19 AM »
Hello srm9r6,

Please check the solution from the following thread:

http://www.agisoft.com/forum/index.php?topic=7556.msg36560#msg36560
Best regards,
Alexey Pasumansky,
Agisoft LLC

William Ringle

  • Newbie
  • *
  • Posts: 40
    • View Profile
Re: photos do not display properly when double clicked
« Reply #2 on: June 30, 2018, 10:26:57 PM »
I too am having this trouble and need to inspect my photo masks. I tried the work around by changing the properties of my icon to:

""C:\Program Files\Agisoft\PhotoScan\" --opengl angle"

but still the photo will not display when double-clicked and locks the system, as several other users have reported.

I am running the current version (1.4.2 build 6205). The specifics of my computer are:

Acer Predator G3-571
Intel Core i7-7700HQ CP @ 2.80 GHz 2.81 GHz
RAM: 16.0 GB
64 bit OS
NVIDIA GeForce GTX 1060
OS: Windows 10

Here is the console report when loaded:
2018-06-30 15:22:29 Agisoft PhotoScan Standard Version: 1.4.2 build 6205 (64 bit)
2018-06-30 15:22:29 Platform: Windows
2018-06-30 15:22:29 CPU: Intel(R) Core(TM) i7-7700HQ CPU @ 2.80GHz (laptop)
2018-06-30 15:22:29 CPU family: 6 model: 158 signature: 906E9h
2018-06-30 15:22:29 RAM: 15.9 GB
2018-06-30 15:22:29 OpenGL Vendor: NVIDIA Corporation
2018-06-30 15:22:29 OpenGL Renderer: GeForce GTX 1060/PCIe/SSE2
2018-06-30 15:22:29 OpenGL Version: 4.6.0 NVIDIA 388.16
2018-06-30 15:22:29 Maximum Texture Size: 32768
2018-06-30 15:22:29 Quad Buffered Stereo: not enabled
2018-06-30 15:22:29 ARB_vertex_buffer_object: supported
2018-06-30 15:22:29 ARB_texture_non_power_of_two: supported

Thanks

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 13913
    • View Profile
Re: photos do not display properly when double clicked
« Reply #3 on: July 01, 2018, 01:12:52 PM »
Hello William,

According to the log the application is not started in ANGLE compatibility mode.

To modify the shortcut, create a new one for photoscan.exe (from PhotoScan installation directory), then in the shortcut properties modify the "Target" field:
Code: [Select]
"C:\Program Files\Agisoft\PhotoScan\photoscan.exe" --opengl angle
Best regards,
Alexey Pasumansky,
Agisoft LLC

Mike25660

  • Newbie
  • *
  • Posts: 20
    • View Profile
Re: photos do not display properly when double clicked
« Reply #4 on: July 13, 2018, 07:52:02 PM »
I am having the same problem with displaying photos. Double-clicking an image file in either the Workspace or Photos pane displays only a blank image, but with the image file name correctly included on the tab.

My shortcut was modified as Alex suggested, but that has not corrected the problem.

I'm using the latest build, v.1.4.2 (6205).


Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 13913
    • View Profile
Re: photos do not display properly when double clicked
« Reply #5 on: July 13, 2018, 08:48:00 PM »
Hello Mike25660,

Can you please provide the Console pane output from the ANGLE run? And also the screenshot of the "target" field from the modified shortcut properties?
Best regards,
Alexey Pasumansky,
Agisoft LLC

Mike25660

  • Newbie
  • *
  • Posts: 20
    • View Profile
Re: photos do not display properly when double clicked
« Reply #6 on: July 15, 2018, 12:33:22 AM »
Alex,

I copied the opengl angle command from your previous message and pasted it into the properties panel for the shortcut. I also update to the version 1.4.3, but the behavior is the same.

Also attached is a screenshot showing the Console after trying to display a photo.

Mike

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 13913
    • View Profile
Re: photos do not display properly when double clicked
« Reply #7 on: July 15, 2018, 06:25:06 AM »
Hello Mike,

According to the screenshot the application is not run in ANGLE mode.

Please create a new shortcut for photoscan.exe and modify the Target field (on the screenshot the modification is applied to "start in'" field which doesn't give any effect).
Best regards,
Alexey Pasumansky,
Agisoft LLC

Mike25660

  • Newbie
  • *
  • Posts: 20
    • View Profile
Re: photos do not display properly when double clicked
« Reply #8 on: July 15, 2018, 09:47:40 AM »
Alex,

Thank you. I was using the shortcut made from the Windows Start menu. It would not let me enter anything into the Target box. Then I created a shortcut directly by clicking on photoscan.exe. That shortcut allowed me to enter the command you previously posted. Now photos are viewable in the usual way.

Mike

Leland

  • Newbie
  • *
  • Posts: 1
    • View Profile
Re: photos do not display properly when double clicked
« Reply #9 on: July 16, 2018, 10:13:30 AM »
After poking at this bug for a while, I discovered that the system isn't actually locked, or at least you can unlock it easily.

You can "unlock" PhotoScan by clicking on the Model tab.  Clicking back on the photo will display it.  Of course, this is a gruesome workaround and makes a very long workflow even longer.

To pan and zoom, I have to go to full-screen mode.

P.S. Coming back from Fullscreen view is an adventure and is presumably a different bug (but could be related.

-Leland

__________________________________UPDATE________________________________________________________
Setting the shortcut to use the  --opengl angle switch appears to have done the trick.  I can only have one photo tab open at a time, but maybe that's the standard behavior.  Haven't checked yet to see if returning from Fullscreen is wonky.

You have to add the  --opengl angle switch to the TARGET field in the shortcut properties box.  Adding it to the 'Start in' field does nothing.

Go to where your PhotoScan EXE file is (probably c:\Program Files\Agisoft\PhotoScan), right-click photoscan.exe and select 'Create shortcut'.  After you add the ANGLE switch, you can drop the shortcut into your Start Menu (C:\ProgramData\Microsoft\Windows\Start Menu\Programs).
« Last Edit: July 16, 2018, 10:45:47 AM by Leland »

SAV

  • Hero Member
  • *****
  • Posts: 710
    • View Profile
Re: photos do not display properly when double clicked
« Reply #10 on: July 23, 2018, 05:21:01 AM »
Hi Alexey,

After upgrading from 1.4.2 to 1.4.3 on Win 10 this issue appeared for me as well. The --opengl angle compatibility mode did the trick though and it's all working again. However, it can be REALLY annoying for new and/or inexperienced PhotoScan users when such problems arise. Not everyone is using this forum.
It would be great if Agisoft could fix this issue so it does not occur at all (or is handled automatically by Photoscan).

Regards,
SAV

 

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 13913
    • View Profile
Re: photos do not display properly when double clicked
« Reply #11 on: July 23, 2018, 12:19:16 PM »
Hello SAV,

We were not able to reproduce this issue on our Windows 10 test configurations yet. So it is not yet possible to say, whether PhotoScan would be able to track the incorrect driver behavior.

The fact that application works properly in ANGLE compatibility mode is likely indicating on the driver issue. As since all the reports are from Windows 10 users, it might be some compatibility problem on Windows side and not in GPU driver itself.
Best regards,
Alexey Pasumansky,
Agisoft LLC