Forum

Author Topic: Coordinates of a PointCloud Do Not Match the Local Coordinates of Markers  (Read 1374 times)

mcrous

  • Newbie
  • *
  • Posts: 2
    • View Profile
Problem:
Coordinates of a PointCloud do not match the local coordinates enforced by markers.

Context
Recently I set out to create an orthomosaic of a solar panel field.
Whilst doing this I wanted to be able to select tie points according to local coordinates.
To achieve this I set local coordinates with markers, as can be seen here https://ibb.co/ieZKsJ.
Then, I run the following script to select all tie points with an x and y coordinate of ±1 relative to the origin.

Code: [Select]
doc = PhotoScan.app.document
chunk = doc.chunk
point_cloud = chunk.point_cloud
points = point_cloud.points

x = 0
y = 0

offset = 1
selected_points = []


for point in points:
    if point.coord[0] < (x + offset) \
    and point.coord[0] > (x - offset) \
    and point.coord[1] < (y + offset) \
    and point.coord[1] > (y - offset):

        selected_points.append(point)
        point.selected = True

Executing this code in the PhotoScan console does not select tie points near the origin defined by markers.
Instead, points are selected at a seemingly arbitrary location (see https://ibb.co/nzqLzy).
Does anybody know how to solve this problem?

Note
I have already tried clicking the 'Update' button in the Reference pane.
The same question remained unanswered in http://www.agisoft.com/forum/index.php?topic=5550.msg27146#msg27146
« Last Edit: July 02, 2018, 11:50:33 PM by mcrous »

mcrous

  • Newbie
  • *
  • Posts: 2
    • View Profile
Anyone have any ideas?