Forum

Author Topic: CL_BUILD_PROGRAM_FAILURE(-11) at line 586  (Read 934 times)

tweezlednutball

  • Newbie
  • *
  • Posts: 23
    • View Profile
CL_BUILD_PROGRAM_FAILURE(-11) at line 586
« on: September 09, 2018, 01:18:43 AM »
2018-09-08 15:17:01 Building kernels for Ellesmere...
2018-09-08 15:17:01 Device 1
2018-09-08 15:17:01    Program build log:
2018-09-08 15:17:01 Error: HSAIL doesn't support OpenCL extension spir.
2018-09-08 15:17:01 An invalid option was specified.
2018-09-08 15:17:01 Error: BRIG code generation failed.
2018-09-08 15:17:01
2018-09-08 15:17:01
2018-09-08 15:17:01 Building kernels for Ellesmere...
2018-09-08 15:17:01 Device 1
2018-09-08 15:17:01    Program build log:
2018-09-08 15:17:01 Error: HSAIL doesn't support OpenCL extension spir.
2018-09-08 15:17:01 An invalid option was specified.
2018-09-08 15:17:01 Error: BRIG code generation failed.
2018-09-08 15:17:01
2018-09-08 15:17:01
2018-09-08 15:17:01 Finished processing in 1.987 sec (exit code 0)
2018-09-08 15:17:01 Error: CL_BUILD_PROGRAM_FAILURE (-11) at line 586

Radeon Software Version
18.8.2

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 9871
    • View Profile
Re: CL_BUILD_PROGRAM_FAILURE(-11) at line 586
« Reply #1 on: September 09, 2018, 08:26:57 AM »
Hello tweezlednutball,

I can recommend to roll-back to the previous driver version, as it seems that in the latest AMD drivers the functionality has been limited.
Best regards,
Alexey Pasumansky,
AgiSoft LLC

tweezlednutball

  • Newbie
  • *
  • Posts: 23
    • View Profile
Re: CL_BUILD_PROGRAM_FAILURE(-11) at line 586
« Reply #2 on: October 02, 2018, 08:12:00 AM »
Hello Alexey,

It seems AMD has dropped support for SPIR for the newer SPIR-V.  Would it be beneficial to update Photoscan to support SPIR-V or OpenCL 2.1 in terms of performance improvements and better hardware compatibility?

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 9871
    • View Profile
Re: CL_BUILD_PROGRAM_FAILURE(-11) at line 586
« Reply #3 on: October 04, 2018, 01:51:50 PM »
Hello tweezlednutball,

It seems that OpenCL 2.1 is not yet supported for all AMD devices by the latest available drivers.
Best regards,
Alexey Pasumansky,
AgiSoft LLC