Forum

Author Topic: Any chance to publish PhotoScan as AUR packages  (Read 1924 times)

dobedobedo

  • Newbie
  • *
  • Posts: 31
    • View Profile
Any chance to publish PhotoScan as AUR packages
« on: September 18, 2018, 11:34:25 AM »
Hi,
Just wondering that whether we can get AUR packages for PhotoScan (Pro) for convenient installation/upgrade for Arch-based Linux system?
I'm glad to make one but don't know the process to install PhotoScan (Pro). Is it just (1) Download tar.gz file, (2) unzip to a specific folder (e.g. /opt), then (3) sudo ./photoscan.sh ? When does activation take part?
Cheers,

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 14890
    • View Profile
Re: Any chance to publish PhotoScan as AUR packages
« Reply #1 on: September 18, 2018, 07:45:57 PM »
Hello dobedobedo,

Currently we are not planning to publish AUR packages.

The activation procedure for the node-locked license can be performed after the archive contents are unpacked:
Code: [Select]
./photoscan.sh --activate 11111-22222-33333-44444-55555to deactivate, use another command:
Code: [Select]
./photoscan.sh --deactivate
Best regards,
Alexey Pasumansky,
Agisoft LLC

dobedobedo

  • Newbie
  • *
  • Posts: 31
    • View Profile
Re: Any chance to publish PhotoScan as AUR packages
« Reply #2 on: September 29, 2019, 11:03:54 PM »
Hi,
It's been a while since I start to have the idea, but I finally make a prototype of the PKGBUILD to install MetaShape Pro on Manjaro Linux. I also attach the PKGBUILD and INSTALL file here for you to give me some feedback. At the moment I have some problem with this PKGBUILD:
  • I can't find the icon for each desktop entry (agisoft-metashape-pro, agisoft-network-monitor, and agisoft-viewer). Could you please advise me where to get them?
  • Are there any files that MetaShape will create during usage? Like config files under HOME folder or under /etc /var? I can write backup information in PKGBUILD and a post_remove function in the INSTALL information to remove those files after uninstallation.
  • Does the user need sudo for product activation and deactivation?
Another problem is that during the makepkg process, when Stripping unneeded symbols from binaries and libraries, it gave me the following message:
Code: [Select]
strip: ./opt/metashape-pro/python/lib/python3.5/site-packages/zmq/.libs/stg7BaCf: not enough room for program headers, try linking with -N
strip:./opt/metashape-pro/python/lib/python3.5/site-packages/zmq/.libs/stg7BaCf[.note.gnu.build-id]: bad value
strip: ./opt/metashape-pro/python/lib/python3.5/site-packages/zmq/backend/cython/stMFmwvq: not enough room for program headers, try linking with -N
strip:./opt/metashape-pro/python/lib/python3.5/site-packages/zmq/backend/cython/stMFmwvq[.note.gnu.build-id]: bad value
strip: ./opt/metashape-pro/python/lib/python3.5/site-packages/zmq/backend/cython/st8hqlgq: not enough room for program headers, try linking with -N
strip:./opt/metashape-pro/python/lib/python3.5/site-packages/zmq/backend/cython/st8hqlgq[.note.gnu.build-id]: bad value
strip: ./opt/metashape-pro/python/lib/python3.5/site-packages/zmq/backend/cython/stKVIEhp: not enough room for program headers, try linking with -N
strip:./opt/metashape-pro/python/lib/python3.5/site-packages/zmq/backend/cython/stKVIEhp[.note.gnu.build-id]: bad value
strip: ./opt/metashape-pro/python/lib/python3.5/site-packages/zmq/backend/cython/st8Ywr8o: not enough room for program headers, try linking with -N
strip:./opt/metashape-pro/python/lib/python3.5/site-packages/zmq/backend/cython/st8Ywr8o[.note.gnu.build-id]: bad value
strip: ./opt/metashape-pro/python/lib/python3.5/site-packages/zmq/backend/cython/stcckUfs: not enough room for program headers, try linking with -N
strip:./opt/metashape-pro/python/lib/python3.5/site-packages/zmq/backend/cython/stcckUfs[.note.gnu.build-id]: bad value
strip: ./opt/metashape-pro/python/lib/python3.5/site-packages/zmq/backend/cython/stFuvU3r: not enough room for program headers, try linking with -N
strip:./opt/metashape-pro/python/lib/python3.5/site-packages/zmq/backend/cython/stFuvU3r[.note.gnu.build-id]: bad value
strip: ./opt/metashape-pro/python/lib/python3.5/site-packages/zmq/backend/cython/stgVujfr: not enough room for program headers, try linking with -N
strip:./opt/metashape-pro/python/lib/python3.5/site-packages/zmq/backend/cython/stgVujfr[.note.gnu.build-id]: bad value
strip: ./opt/metashape-pro/python/lib/python3.5/site-packages/zmq/backend/cython/stSjph2q: not enough room for program headers, try linking with -N
strip:./opt/metashape-pro/python/lib/python3.5/site-packages/zmq/backend/cython/stSjph2q[.note.gnu.build-id]: bad value
strip: ./opt/metashape-pro/python/lib/python3.5/site-packages/zmq/backend/cython/stQMMkVq: not enough room for program headers, try linking with -N
strip:./opt/metashape-pro/python/lib/python3.5/site-packages/zmq/backend/cython/stQMMkVq[.note.gnu.build-id]: bad value
strip: ./opt/metashape-pro/python/lib/python3.5/site-packages/zmq/devices/stltxQMo: not enough room for program headers, try linking with -N
strip:./opt/metashape-pro/python/lib/python3.5/site-packages/zmq/devices/stltxQMo[.note.gnu.build-id]: bad value
strip: ./opt/metashape-pro/python/lib/python3.5/site-packages/PySide2/stUuOBlm: not enough room for program headers, try linking with -N
strip:./opt/metashape-pro/python/lib/python3.5/site-packages/PySide2/stUuOBlm[.note.gnu.build-id]: bad value
strip: ./opt/metashape-pro/python/lib/python3.5/site-packages/PySide2/stljwwar: not enough room for program headers, try linking with -N
strip:./opt/metashape-pro/python/lib/python3.5/site-packages/PySide2/stljwwar[.note.gnu.build-id]: bad value
strip: ./opt/metashape-pro/python/lib/python3.5/site-packages/PySide2/stFO4jSq: not enough room for program headers, try linking with -N
strip:./opt/metashape-pro/python/lib/python3.5/site-packages/PySide2/stFO4jSq[.note.gnu.build-id]: bad value
strip: ./opt/metashape-pro/python/lib/python3.5/site-packages/PySide2/stmLK76t: not enough room for program headers, try linking with -N
strip:./opt/metashape-pro/python/lib/python3.5/site-packages/PySide2/stmLK76t[.note.gnu.build-id]: bad value
strip: ./opt/metashape-pro/python/lib/python3.5/site-packages/PySide2/stQ8WkRu: not enough room for program headers, try linking with -N
strip:./opt/metashape-pro/python/lib/python3.5/site-packages/PySide2/stQ8WkRu[.note.gnu.build-id]: bad value
strip: ./opt/metashape-pro/python/lib/python3.5/site-packages/PySide2/st1t6vCu: not enough room for program headers, try linking with -N
strip:./opt/metashape-pro/python/lib/python3.5/site-packages/PySide2/st1t6vCu[.note.gnu.build-id]: bad value
strip: ./opt/metashape-pro/python/lib/python3.5/site-packages/PySide2/stSrmcuu: not enough room for program headers, try linking with -N
strip:./opt/metashape-pro/python/lib/python3.5/site-packages/PySide2/stSrmcuu[.note.gnu.build-id]: bad value
strip: ./opt/metashape-pro/python/lib/python3.5/site-packages/PySide2/stdZIk2s: not enough room for program headers, try linking with -N
strip:./opt/metashape-pro/python/lib/python3.5/site-packages/PySide2/stdZIk2s[.note.gnu.build-id]: bad value
strip: ./opt/metashape-pro/python/lib/python3.5/site-packages/PySide2/stiwhfuw: warning: allocated section `.dynstr' not in segment
strip: ./opt/metashape-pro/python/lib/python3.5/site-packages/PySide2/stZiVYhw: not enough room for program headers, try linking with -N
strip:./opt/metashape-pro/python/lib/python3.5/site-packages/PySide2/stZiVYhw[.note.gnu.build-id]: bad value
strip: ./opt/metashape-pro/python/lib/python3.5/site-packages/PySide2/stvFUp4v: not enough room for program headers, try linking with -N
strip:./opt/metashape-pro/python/lib/python3.5/site-packages/PySide2/stvFUp4v[.note.gnu.build-id]: bad value
strip: ./opt/metashape-pro/python/lib/python3.5/site-packages/PySide2/sta729Rv: not enough room for program headers, try linking with -N
strip:./opt/metashape-pro/python/lib/python3.5/site-packages/PySide2/sta729Rv[.note.gnu.build-id]: bad value
strip: ./opt/metashape-pro/python/lib/python3.5/site-packages/PySide2/stYlgJnx: not enough room for program headers, try linking with -N
strip:./opt/metashape-pro/python/lib/python3.5/site-packages/PySide2/stYlgJnx[.note.gnu.build-id]: bad value
strip: ./opt/metashape-pro/python/lib/python3.5/site-packages/PySide2/styCAG1w: not enough room for program headers, try linking with -N
strip:./opt/metashape-pro/python/lib/python3.5/site-packages/PySide2/styCAG1w[.note.gnu.build-id]: bad value
strip: ./opt/metashape-pro/python/lib/python3.5/site-packages/PySide2/stHYR2Lx: not enough room for program headers, try linking with -N
strip:./opt/metashape-pro/python/lib/python3.5/site-packages/PySide2/stHYR2Lx[.note.gnu.build-id]: bad value
strip: ./opt/metashape-pro/python/lib/python3.5/site-packages/PySide2/stJ7kd1A: warning: allocated section `.dynstr' not in segment
strip: ./opt/metashape-pro/python/lib/python3.5/site-packages/PySide2/stU4Ag5C: not enough room for program headers, try linking with -N
strip:./opt/metashape-pro/python/lib/python3.5/site-packages/PySide2/stU4Ag5C[.note.gnu.build-id]: bad value
strip: ./opt/metashape-pro/python/lib/python3.5/site-packages/PySide2/st7ioeRD: not enough room for program headers, try linking with -N
strip:./opt/metashape-pro/python/lib/python3.5/site-packages/PySide2/st7ioeRD[.note.gnu.build-id]: bad value
strip: ./opt/metashape-pro/python/lib/python3.5/site-packages/PySide2/st9zQJsC: not enough room for program headers, try linking with -N
strip:./opt/metashape-pro/python/lib/python3.5/site-packages/PySide2/st9zQJsC[.note.gnu.build-id]: bad value
strip: ./opt/metashape-pro/python/lib/python3.5/site-packages/PySide2/st4FSBdC: not enough room for program headers, try linking with -N
strip:./opt/metashape-pro/python/lib/python3.5/site-packages/PySide2/st4FSBdC[.note.gnu.build-id]: bad value
strip: ./opt/metashape-pro/python/lib/python3.5/site-packages/PySide2/stQRDO7B: not enough room for program headers, try linking with -N
strip:./opt/metashape-pro/python/lib/python3.5/site-packages/PySide2/stQRDO7B[.note.gnu.build-id]: bad value
Not sure whether this will cause any problem.
Appreciated for your help. Hopefully, this can benefit Arch-based users for using MetaShape Pro.

« Last Edit: September 29, 2019, 11:10:18 PM by dobedobedo »