First run tutorial:
Orthophoto and DEM Generation with Agisoft PhotoScan Pro 1.0.0
(with Ground Control Points)
PhotoScan Preferences
Open PhotoScan Preferences dialog from Tools menu using corresponding command.

Set the following values for the parameters in the General tab:
Stereo Mode: Disabled
Stereo Parallax: 1.0
Write log to file: specify directory where Agisoft PhotoScan log would be stored
(in case of contacting the software support team it could be required)
Set the parameters in the OpenCL tab as following: Check on any OpenCL devices
detected by PhotoScan in the dialog and reduce the number of active CPU cores by one for
each OpenCL device enabled.
Set the following values for the parameters in the Advanced tab:
Project compression level: 6
Keep depth maps: enbled
Store absolute image paths: disabled
Check for updates on program startup: enabled
Enable VBO support: disabled

Add Photos
To add photos select Add Photos... command from the Workflow menu or
click Add Photos
button located on Workspace toolbar.
In the Add Photos dialog browse the source folder and select files to be processed. Click Open
button.

Load Camera Positions
At this step coordinate system for the future model is set using camera positions.
Note: If camera positions are unknown this step could be skipped. The align photos procedure,
however, would take more time in this case.
Open Ground Control pane using the corresponding command from the View menu.
Click
Import button on the Ground Control pane toolbar and select file containing camera
positions information in the Open dialog.
The easiest way is to load simple character-separated file (*.txt) that contains x- and ycoordinates and height for each camera position (camera orientation data, i.e. pitch, roll and yaw
values, could also be imported, but the data is not obligatory).
In Import CSV dialog indicate the delimiter according to the structure of the loading file and select
the row to start loading from. Note that # character indicates a commented line that is not counted
while numbering the rows. Indicate for the program what parameter is specified in each column
through setting correct column numbers in the Columns section of the dialog. Check your settings in
the sample data field in Import CSV dialog.

Click Open button. The data will be loaded into the Ground Control pane.
Import EXIF Ground Control pane toolbar button can also be used to load camera positions
information if EXIF meta-data is available.
Then click on the
Settings button in the Ground Control pane and in the Ground Control
Settings dialog select corresponding coordinate system from the list.

Click OK and camera positions will be marked in Model View using their geographical
coordinates:

Align Photos
At this stage PhotoScan refines the camera position for each photo and builds the point cloud
model.
Select Align Photos command from the Workflow menu.

Set the following recommended values for the parameters in the Align Photos dialog:
Accuracy: High (lower accuracy setting can be used to get the rough camera positions in
the shorter time)
Pair preselection: Ground Control (in case camera positions are unknown Generic
preselection mode can be used)
Constrain features by mask: Disabled (Enabled in case any areas has been masked prior
to processing)
Point limit: 40000
Click OK button to start photo alignment.

Place Markers
Markers are used to optimize camera positions and orientation data, which allows for better model
reconstruction results.
To generate accurate orthophoto at least 10 – 15 ground control points (GCP) should be
distributed evenly within the area of interest to be processed.
To be able to follow guided marker placement approach (that would be faster and easier) you need
to reconstruct geometry first.
Select Build Mesh command from the Workflow menu and specify following parameters in the
Build Mesh dialog:

Click OK button.
Then, when the geometry is built (it usually takes a few seconds to reconstruct mesh based on the
sparse point cloud), open a photo where a GCP is visible in Photo View by double-clicking on its
icon in the Photo pane. Zoom in to locate the GCP on the photo and place a marker in the
corresponding point of the image using
Create Marker command from the photo context menu
available on right-click on the opened photo in the corresponding position:

Select the marker on the Ground Control pane. Then filter images in Photos pane using
Filter by Markers option in the context menu available by right-clicking on the markers label in the
Workspace pane.

Now you need to check the marker location on every related photo and refine its position if
necessary to provide maximum accuracy. Open each photo where the created marker is visible.
Zoom in and drag the marker to the correct location while holding left mouse button. Repeat the
described step for every GCP.

Input Marker Coordinates
Finally, import marker coordinates from a file. Click
Import button on the Ground Control
pane toolbar and select file containing GCP coordinates data in the Open dialog. The easiest way is to
load simple character-separated file (*.txt) that contain markers name, x-, y- coordinates and height.

In Import CSV dialog indicate the delimiter according to the structure of the file and select the row
to start loading from. Note that # character indicates a commented line that is not counted while
numbering the rows. Indicate for the program what parameter is specified in each column through
setting correct column numbers in the Columns section of the dialog.
Check your settings in the sample data field in Import CSV dialog:

Click OK button. The data will be loaded into the Ground Control pane.

Optimize Camera Alignment
To achieve higher accuracy in calculating camera external and internal parameters and to correct
possible distortion (e.g. “bowl effect” and etc.) optimization procedure should be run. This step is
especially recommended if the ground control point coordinates are known almost precisely (several
centimeters accuracy) (marker based optimization procedure).
Click the
Settings button in the Ground Control pane and in the Ground Control Settings
dialog select corresponding coordinate system from the list according to the GCP coordinates data.
Set the following values for the parameters in Measurement accuracy section:

Camera accuracy: 10
Marker accuracy: 0.005 (The marker accuracy is recommended to be set at 0 value if the
real marker accuracy is within 0.02 m. In this case PhotoScan will assume
that markers coordinates are known exactly, which can help to obtain more
accurate results.)
Scale bar accuracy: 0.001
Projection accuracy: 0.1
Tie point accuracy: 4
Click OK button.
On the Ground Control pane uncheck all photos and check the markers to be used in optimization
procedure. The rest of the markers that are not taken into account can serve as control points to
evaluate the optimization results.
Click
Optimize button on the Ground Control pane toolbar.

Select camera parameters you would like to optimize. Click OK button to start optimization
process.

Set Bounding Box
Bounding box is resizable and rotatable with the help of
Region tools from the Toolbar.

Resize Region and

Rotate

Important: The red-colored side of the bounding box indicates the plane that would be treated as
ground plane and has to be set under the model.

Build Dense Point Cloud
Based on the estimated camera positions the program calculates depth information for each
camera to be combined into a single dense point cloud.
Select Build Dense Cloud command from the Workflow menu.

Set the following recommended values for the parameters in the Build Dense Cloud dialog:
Quality: Medium (higher quality takes quite a long time and demands more
computational resources, lower quality can be used for fast processing)
Depth filtering: Aggressive (if the geometry of the scene to be reconstructed is complex
with numerous small details or untextured surfaces, like roofs, it is recommended
to set Mild depth filtering mode, for important features not to be sorted out)

Points from the dense cloud can be removed with the help of selection tools and Delete/Crop
instruments located on the Toolbar.

Build Mesh
After dense point cloud has been reconstructed it is possible to generate polygonal mesh model
based on the dense cloud data.
Select Build Mesh command from the Workflow menu.

Set the following recommended values for the parameters in the Build Mesh dialog:
Surface type: Height Field
Source data: Dense cloud
Polygon count: Medium (maximum number of faces in the resulting model. The values
indicated next to High/Medium/Low preset labels are based on the number of
points in the dense cloud)
Interpolation: Enabled
Click OK button to start mesh reconstruction.

Edit Geometry
Sometimes it is necessary to edit geometry before building texture atlas and exporting the model.
Unwanted faces could be removed from the model. Firstly, you need to indicate the faces to be
deleted using selection tools from the toolbar. Selected areas are highlighted with red color in the
Model View. Then, to remove the selection use Delete Selection button on the Toolbar (or DEL key)
or use Crop Selection button on the Toolbar to remove all but selected faces.
If the overlap of the original images was not sufficient, it may be required to use Close Holes
command from the Tools menu at geometry editing stage to produced holeless model. In Close Holes
dialog select the size of the largest hole to be closed (in percentage of the total model size).

PhotoScan tends to produce 3D models with excessive geometry resolution. That's why it is
recommended to decimate mesh before exporting it to a different editing tool to avoid performance
decrease of the external program.
To decimate 3D model select Decimate Mesh... command from the Tools menu. In the Decimate
Mesh dialog specify the target number of faces that should remain in the final model. For PDF export
task or web-viewer upload it is recommended to downsize the number of faces to 100,000-200,000.

Click OK button to start mesh decimation procedure.

Build Texture
This step is not really needed in the orthophoto export workflow, but it might be necessary to
inspect a textured model before exporting it or it might be useful for precise marker placement.
Select Build Texture command from the Workflow menu.

Set the following recommended values for the parameters in the Build Texture dialog:
Mapping mode: Orthophoto
Blending mode: Mosaic
Texture size/count: 8192 (width & height of the texture atlas in pixels)
Enable color correction: disabled (the feature is useful for processing of data sets with
extreme brightness variation, but for general case it could be left unchecked to save
the processing time)
Click OK button to start texture generation.

Generate Orthophoto
Select Export Orthophoto → Export JPEG/TIFF/PNG command from File menu.

Set the following recommended values for the parameters in the Export Orthophoto
dialog:
Projection type: Geographic
Projection: by default the projection set in the Ground Control Settings is used
Blending mode: Mosaic
Enable color correction: disabled (the feature is useful for processing of data sets with
extreme brightness variation, but for general case it could be left unchecked to save
the processing time)
Pixel size: maximum effective resolution is shown by default
Split in blocks: 10000 x 10000 (if the exported area is large it is recommended to enable
Split in Blocks feature, since the memory consumption is rather high at exporting
stage)
Region: set the boundaries of the model's part that should be projected and presented as
orthophoto.
Click Export... button and then specify target file name and select type of the exported file
(e.g. GeoTIFF). Click Save button to start orthophoto generation.

Generate DEM
Select Export DEM → Export GeoTIFF/BIL/XYZ command from File menu.

Set the following recommended values for the parameters in the Export DEM dialog:
Projection type: Geographic
Projection: by default the projection set in the Ground Control Settings is used
Crop invalid DEM: check this option to crop the regions with unreliable elevation data,
since they are visible on less than two source photos
Pixel size: you can increase the effective resolution compared to the default value
Split in blocks: 10000 x 10000 (if the exported area is large it is recommended to enable
Split in blocks feature, since the memory consumption is rather high at exporting
stage)
Region: set the boundaries of the model's part that should be presented as DEM.
Click Export... button and then specify target file name and select type of the exported file
(e.g. GeoTIFF). Click Save button to start DEM generation.

