# Table of Contents

Overview .................................................................................................................. v  
How it works .............................................................................................................. v  
About the manual ..................................................................................................... vi

1. Installation and Activation ................................................................................... 1  
   System requirements ............................................................................................. 1  
   GPU recommendations ......................................................................................... 1  
   Installation procedure .......................................................................................... 2  
   30-day trial and demo mode .................................................................................. 3  
   Activation procedure ........................................................................................... 3  
   Floating licenses .................................................................................................. 5

2. Capturing scenarios ............................................................................................... 8  
   Equipment ............................................................................................................. 8  
   Camera settings ................................................................................................... 8  
   Object/scene requirements ................................................................................... 8  
   Image preprocessing .............................................................................................. 8  
   Capturing scenarios ............................................................................................. 9  
   Restrictions .......................................................................................................... 10  
   Lens calibration ................................................................................................... 11  
   Automated mission planning .............................................................................. 13  
   Excessive image elimination .............................................................................. 17

3. General workflow .................................................................................................. 18  
   Preferences settings ............................................................................................ 18  
   Loading images .................................................................................................... 19  
   Aligning photos ................................................................................................... 27  
   Building dense point cloud .................................................................................. 33  
   Building mesh ...................................................................................................... 35  
   Building model texture ....................................................................................... 38  
   Building tiled model ............................................................................................ 44  
   Building digital elevation model ......................................................................... 46  
   Building orthomosaic ........................................................................................... 49  
   Saving intermediate results .................................................................................. 54  
   Exporting results .................................................................................................. 54  
   Camera track creation and fly through video rendering ......................................... 70

4. Referencing ............................................................................................................ 72  
   Camera calibration ............................................................................................... 72  
   Setting coordinate system ................................................................................... 76  
   Optimization ........................................................................................................ 86  
   What do the errors in the Reference pane mean? .................................................. 90  
   Working with coded and non-coded targets ......................................................... 91

5. Measurements ....................................................................................................... 94  
   Performing measurements on 3D model ............................................................ 94  
   Performing measurements on DEM .................................................................... 96  
   Vegetation indices calculation ............................................................................. 99  
   Powerlines detection ............................................................................................ 103  
   Stereoscopic measurements and vectorization .................................................... 104

6. Editing ..................................................................................................................... 106  
   Using masks ......................................................................................................... 106  
   Editing point cloud .............................................................................................. 112  
   Classifying dense point cloud ............................................................................. 117  
   Editing model geometry ....................................................................................... 120  
   Shapes ................................................................................................................... 125
Orthomosaic seamlines editing .................................................. 127
Editing textures ........................................................................ 128
7. Automation .............................................................................. 130
   Using chunks ......................................................................... 130
   4D processing ......................................................................... 136
   Python scripting ..................................................................... 139
   Java API ................................................................................ 140
8. Distributed processing ............................................................... 141
   Local network processing ....................................................... 141
   Cloud processing .................................................................... 146
A. Graphical user interface ............................................................ 150
   Application window ............................................................... 150
   Menu commands ..................................................................... 156
   Toolbar buttons ..................................................................... 166
   Hot keys ................................................................................ 170
B. Supported formats .................................................................... 172
   Images .................................................................................. 172
   Camera calibration .................................................................. 172
   Camera flight log .................................................................... 172
   GCP locations ........................................................................ 173
   Interior and exterior camera orientation parameters ............... 173
   Tie points ............................................................................... 173
   Sparse/dense point cloud ....................................................... 174
   Mesh model .......................................................................... 174
   Texture maps ......................................................................... 175
   Orthomosaic ......................................................................... 175
   Digital elevation model (DSM/DTM) ...................................... 175
   Tiled models ......................................................................... 176
   Laser Scans .......................................................................... 176
   Shapes and contours .............................................................. 176
   Video ................................................................................... 176
C. Camera models ........................................................................ 178
   Frame cameras ....................................................................... 179
   Fisheye cameras ..................................................................... 179
   Spherical cameras (equirectangular projection) ......................... 179
   Spherical cameras (cylindrical projection) ............................... 180
D. What do some error messages in Metashape mean? .................... 181
Overview

Agisoft Metashape is a stand-alone software product that performs photogrammetric processing of digital images (aerial and close-range photography, satellite imagery) and generates 3D spatial data to be used in GIS applications, cultural heritage documentation, and visual effects production as well as for indirect measurements of objects of various scales.

The software allows to process images from RGB, thermal or multispectral cameras, including multi-camera systems, into the spatial information in the form of dense point clouds, textured polygonal models, georeferenced true orthomosaics and DSMs/DTMs. Further post-processing enables to eliminate shadows and texture artifacts from the models, calculate vegetation indices and extract information for farming equipment action maps, automatically classify dense point clouds, etc. Metashape is capable of processing of 50 000+ photos across a local cluster, thanks to distributed processing functionality. Alternatively, the project can be sent to the cloud to minimize hardware investment, with all the processing options being still available. Wisely implemented digital photogrammetry technique enforced with computer vision methods results in smart automated processing system that, on the one hand, can be managed by a new-comer in the field of photogrammetry, yet, on the other hand, has a lot to offer to a specialist who can benefit from advanced features like stereoscopic mode and have complete control over the results accuracy, with detailed report being generated at the end of processing.

How it works

Typical tasks for a photogrammetry processing project in Metashape are to build a 3D surface and an orthomosaic. Imagery data processing procedure with Agisoft Metashape consists of three main steps.

1. The first step is called alignment. It includes aerial triangulation (AT) and bundle block adjustment (BBA). At this stage Metashape searches for feature points on the images and matches them across images into tie points. The program also finds the position of the camera for each image and refines camera calibration parameters (estimates internal (IO) and external (EO) camera orientation parameters).

   The results of these procedures are visualized in the form of a sparse point cloud and a set of camera positions. The sparse point cloud represents the results of image alignment and will not be directly used in further processing (except for the sparse point cloud based surface reconstruction method, which is suitable only for quick estimates, e.g., of completeness of a data set). But the sparse point cloud is necessary for the determination of depth maps (based on the sparse cloud selected stereo pairs). However it can be exported for further usage in external programs. For instance, a sparse point cloud model can be used in a 3D editor as a reference. On the contrary, the set of camera positions is required for further 3D surface reconstruction by Metashape.

2. The second step is generation of a surface in 3D (mesh) and/or 2.5D (DEM). Polygonal model (mesh) can be textured for photorealistic digital representation of the object/scene and exported in numerous formats compatible with post-processing software, both for CAD and 3D-modeling workflows.

   For city-scale projects to provide for fast model visualization response and allow for smooth navigation across the whole scene, Metashape enables to generate tiled models. Such hierarchical representation preserves original resolution of the images applied to the model as a texture and is compatible with stand-alone and web-based viewers.

   Dense point cloud can be built by Metashape based on the estimated camera positions and images themselves (dense stereo matching). Generated photogrammetric point cloud can be merged with LIDAR data or automatically divided into several semantic classes following the project tasks.
If the digital elevation model (DEM) is generated based on the dense point cloud data, it can include either both terrain and all the objects above the ground, like trees, buildings and other man-made structures (digital surface model, DSM), or only show the landscape of the territory (digital terrain model, DTM).

3. The third step is creating of Orthomosaic, which can be georeferenced and used as a base layer for various types of maps and further post processing analysis and vectorization. Orthomosaic is generated by projecting the images according to their EO/IO data on a surface of the user's choice: DEM or mesh.

For multispectral imagery projects, orthomosaic can represent NDVI and other vegetation indices information. Reflectance calibration feature of Metashape allows to correctly interpret radiometric imagery data, providing that radiometric panel has been used in the project and/or sun sensor information is available in the images meta data.

About the manual

Basically, the sequence of actions described above covers most of the data processing needs. All these operations are carried out automatically according to the parameters set by user. Instructions on how to get through these operations and descriptions of the parameters controlling each step are given in the corresponding sections of the Chapter 3, General workflow chapter of the manual.

In some cases, however, additional actions may be required to get the desired results. In some capturing scenarios masking of certain regions of the photos may be required to exclude them from the calculations. Application of masks in Metashape processing workflow as well as editing options available are described in Chapter 6, Editing. Camera calibration issues are discussed in Chapter 4, Referencing, that also describes functionality to optimize camera alignment results and provides guidance on model referencing. A referenced model, be it a mesh or a DEM serves as a ground for measurements. Area, volume, profile measurement procedures are tackled in Chapter 5, Measurements, which also includes information on vegetation indices calculations. While Chapter 7, Automation describes opportunities to save up on manual intervention to the processing workflow, Local network processing presents guidelines on how to organize distributed processing of the imagery data on several nodes.

It can take up quite a long time to reconstruct a 3D model. Metashape allows to export obtained results and save intermediate data in a form of project files at any stage of the process. If you are not familiar with the concept of projects, its brief description is given at the end of the Chapter 3, General workflow.

In the manual you can also find instructions on the Metashape installation and activation procedures and basic rules for taking "good" photographs, i.e. pictures that provide most necessary information for 3D reconstruction. For the information refer to Chapter 1, Installation and Activation and Chapter 2, Capturing scenarios.
Chapter 1. Installation and Activation

System requirements

**Minimal configuration**

- Windows 7 SP 1 or later (64 bit), Windows Server 2008 R2 or later (64 bit), macOS High Sierra or later, Debian/Ubuntu with GLIBC 2.19+ (64 bit)
- Intel Core 2 Duo processor or equivalent
- 4 GB of RAM

**Recommended configuration**

- Windows 7 SP 1 or later (64 bit), Windows Server 2008 R2 or later (64 bit), macOS Mojave or later, Debian/Ubuntu with GLIBC 2.19+ (64 bit)
- Intel Core i7 or AMD Ryzen 7 processor
- Discrete NVIDIA or AMD GPU (4+ GB VRAM)
- 32 GB of RAM

The number of photos that can be processed by Metashape depends on the available RAM and reconstruction parameters used. Assuming that a single photo resolution is of the order of 10 MPix, 4 GB RAM is sufficient to make a model based on 30 to 50 photos. 16 GB RAM will allow to process up to 300-400 photographs.

**GPU recommendations**

Metashape supports accelerated image matching; depth maps reconstruction; depth maps based mesh, DEM and tiled model generation; texture blending; photoconsistent mesh refinement operation due to the graphics hardware (GPU) exploiting.

**NVIDIA**

GeForce GTX 7xx series and later with CUDA support.

**AMD**

Radeon R9 series and later with OpenCL 1.2 support.

Metashape is likely to be able to utilize processing power of any CUDA enabled device with compute capability 3.0 and higher or OpenCL 1.2 and higher enabled device with SPIR support for stages specified above, provided that CUDA/OpenCL drivers for the device are properly installed. However, because of the large number of various combinations of video chips, driver versions and operating systems, Agisoft is unable to test and guarantee Metashape's compatibility with every device and on every platform.

The processing performance of the GPU device is mainly related to the number of CUDA cores for NVIDIA video chips and the number of shader processor units for AMD and Intel video chips. Additionally depth maps based mesh, DEM and tiled model reconstruction as well as photoconsistent mesh refinement operations and texture blending would benefit from larger amount of VRAM available.
The table below lists currently supported devices (on Windows platform only). Agisoft will pay particular attention to possible problems with Metashape running on these devices.

Table 1.1. Supported Desktop GPUs on Windows platform

<table>
<thead>
<tr>
<th>NVIDIA</th>
<th>AMD</th>
</tr>
</thead>
<tbody>
<tr>
<td>GeForce RTX 3080</td>
<td>Radeon RX 6800</td>
</tr>
<tr>
<td>GeForce RTX 2080 Ti</td>
<td>Radeon VII</td>
</tr>
<tr>
<td>Tesla V100</td>
<td>Radeon RX 5700 XT</td>
</tr>
<tr>
<td>Tesla M60</td>
<td>Radeon RX Vega 64</td>
</tr>
<tr>
<td>Quadro P6000</td>
<td>Radeon RX Vega 56</td>
</tr>
<tr>
<td>Quadro M6000</td>
<td>Radeon Pro WX 7100</td>
</tr>
<tr>
<td>GeForce TITAN X</td>
<td>Radeon RX 580</td>
</tr>
<tr>
<td>GeForce GTX 1080 Ti</td>
<td>FirePro W9100</td>
</tr>
<tr>
<td>GeForce GTX TITAN X</td>
<td>Radeon R9 390x</td>
</tr>
<tr>
<td>GeForce GTX 980 Ti</td>
<td>Radeon R9 290x</td>
</tr>
<tr>
<td>GeForce GTX TITAN</td>
<td></td>
</tr>
<tr>
<td>GeForce GTX 780 Ti</td>
<td></td>
</tr>
</tbody>
</table>

Metashape supports texture blending on GPU using Vulkan technology on Linux and Windows OS. GPU accelerated texture blending is currently supported for frame and fisheye type cameras on NVIDIA cards since GeForce GTX 8XX / Quadro M4000 and driver versions from 435.xx and on AMD cards since Radeon R9 29x series / FirePro W9100 and 17.1.x drivers. Some older GPUs and older driver versions could also support texture blending using Vulkan, however, it is not guaranteed.

Although Metashape is supposed to be able to utilize other compatible GPU models and being run under a different operating system, Agisoft does not guarantee that it will work correctly. However, all GPU-based processing issues should be reported to Agisoft support team for more detailed investigation.

>Note

- Use CPU enable flag to allow calculations both on CPU and GPU for GPU-supported tasks. However if at least one powerful discrete GPU is used it is recommended to disable CPU flag for stable and rapid processing.
- Using GPU acceleration with mobile or integrated graphics video chips is not recommended because of the low performance of such GPUs.

Due to lack of CUDA support on certain macOS versions Metashape will automatically switch to OpenCL implementation for GPU-based processing on NVIDIA graphic devices.

**Installation procedure**

**Installing Metashape on Microsoft Windows**

To install Metashape on Microsoft Windows simply run the downloaded msi file and follow the instructions.
Installing Metashape on macOS

Open the downloaded dmg image and drag Metashape application bundle to the desired location on your hard drive (for example, to Applications folder. Do not run Metashape directly from the dmg image to avoid issues on license activation step.

Installing Metashape on Debian/Ubuntu

Unpack the downloaded archive with a program distribution kit to the desired location on your hard drive. Also, install the package: `sudo apt install libxcb-xinerama0`. Start Metashape by running `metashape.sh` script from the program folder.

30-day trial and demo mode

Once Metashape is downloaded and installed on your computer you can run it either in the Demo mode or in the full function mode. On every start until a license key sequence is entered it will show on activation dialog offering three options: (1) activate Metashape using a valid license code, (2) start a free 30-day trial, (3) continue using Metashape in Demo mode. Starting a 30-day trial period allows to evaluate the functionality of the program and explore the software in full-function mode, including save and export features. Trial license is intended to be used for evaluation purposes only and any commercial use of a trial license is prohibited.

If you are not ready yet to start the trial period, you can opt for the Demo mode. The employment of Metashape in the Demo mode is not time limited. Several functions, however, are not available in the Demo mode. These functions are the following:

- save the project;
- build tiled model;
- build orthomosaic;
- build digital elevation model (DEM);
- DEM and orthomosaic related features (such as vegetation index calculation, DEM-based measurements);
- some Python API commands;
- all export features, including exporting reconstruction results (you can only view a 3D model on the screen);
- using network and cloud processing features.

To use Metashape in the full function mode for various projects you have to purchase a license. On purchasing you will get a license code to be entered into the activation dialog of Metashape. Once the license code is entered you will get full access to all functions of the program and the activation dialog will no longer appear upon program start, unless the license is deactivated.

Activation procedure

Metashape node-locked license activation

The Node-locked license for Metashape allows to activate the software on one machine at a time. Node-locked license files are unique for each computer, and are tied to the system hardware. If you are to replace
major system components or re-install operational system, the license should be deactivated first and then the same key could be used to activate the license on the renewed system.

**Note**

- The node-locked license activation on Windows OS and macOS may require administrator privileges. During the activation process additional confirmation dialog will appear to apply the elevated privileges.
- To deactivate the license select *Activate Product* command from *Help* menu and use *Deactivate* button or argument *--deactivate* in the command line (terminal) to Metashape executable.
- When Metashape software is being uninstalled on Windows OS the license deactivation attempt will be automatically performed, however, it is recommended to deactivate the license manually before uninstalling the application.

Metashape software requires a license key (a digital code) to be activated. First of all, make sure that you have a valid license key at hand. The number of activation/deactivation operations is not effectively limited for manual license transfer scenarios. But we recommend technical possibility to transfer a node-locked license to a new computer not to be exploited in automated scenarios involving activation/deactivation of the node-locked license on regular basis.

**Note**

- Excessive usage of activation/deactivation mechanism may result in the situation when user gets blocked in the activation system.
- For scenarios which involve virtual machines and frequent license activation/deactivation operations it is recommended to consider floating license option, in which case the license is automatically returned to the license server when the Metashape is stopped or the related process is killed unexpectedly.

Standard activation procedure, which allows to activate the product in the means of seconds, requires the machine to be connected to the Internet. If it is your case, please follow the online activation procedure as described below. In case the system cannot be connected to the Internet, please opt for the offline activation procedure, which is also described in this section of the manual.

**Online Activation Procedure - To activate Metashape on a machine with Internet connection**

1. Launch Metashape software, previously installed on your machine, and go to *Help* menu for *Activate product...* command.

2. In *Activation* dialog insert license key according to the suggested 5 digit blocks structure. Please note that license codes never include zero digit - only letter “O”.

3. If the license code has been input correctly, then the *OK* button will become active. Click on it to complete the activation procedure. If the button is still grayed out, please make sure that the key you are using is meant for the product you are trying to activate: a license key for the Standard Edition, for example, will not activate the Professional Edition.

**Offline Activation Procedure - To activate Metashape on a machine with NO Internet connection**

1. Launch Metashape software, previously installed on your machine, and go to *Help* menu for *Activate product...* command.
2. In Activation dialog insert license key according to the suggested 5 digit blocks structure. Please note that license codes never include zero digit - only letter "O". Click OK button.

3. Click Save Activation Request button. Browse to the destination folder for the activation_request.act file in the Save as dialog, type in the file name and click Save button.

4. Send the file saved at previous step to support@agisoft.com. Agisoft support team will process your activation request and send the special license file to your e-mail with the instructions to complete the activation process.

If you would like to activate/deactivate Metashape software in headless mode, please see the list of relevant commands below:

- metashape --activate license_key
- metashape --deactivate
- metashape --activate-offline license_key file_name.act
- metashape --deactivate-offline file_name.act

Run "metashape --help" to see the complete list of the commands available.

**Floating licenses**

Metashape software can be used under floating license conditions. A floating license allows to install the software on an unlimited number of machines, which are connected to a server network. However, at any one time, Metashape can only run on the maximum number of computers for which licenses have been purchased. Since Metashape can be installed on more systems than the number of licenses purchased, this enables the licensee to efficiently share the product across the organization.

A software utility called Floating License Server (FLS) deployed on the server machine issues licenses to client machines, up to the number of floating licenses purchased. If all floating licenses are in use, no more computers can run Metashape until a license is returned to the FLS, i.e. until Metashape process is finished on one of the machines.

Metashape floating licenses are borrowable. A borrowed license can be used on a machine disconnected from the server network for a certain period (up to 30 days).

Floating license activation procedure is performed on the server machine and includes two steps:

- FLS installation and activation
- Floating license activation

Thus, to activate a floating license you will need 3 components:

- FLS archive (to be downloaded from the link provided upon license purchase)
- FLS activation key (to be provided on purchasing a floating license)
- Floating license activation key (to be provided on purchasing a floating license), and the number of floating licenses associated with the key.

**Note**

- By default, FLS cannot be installed on a virtual machine. In case the the virtual environment is the only option to deploy the license server, please contact support@agisoft.com for additional instructions on the matter.
To activate Floating License Server

1. Unpack the FLS archive and run FLS utility (rlm/rlm.exe) on the server machine.

2. Go to http://server_address:5054 to use web-interface of the license management system. Enter Status section of the left hand side menu. Find "agisoft" line in the ISV Servers table. Click agisoft button in ACTIVATE column of the table.

3. Set the following values for the parameters on the Activate/Deactivate Alternate Server Hostid page. ISV: agisoft, Activation Key: enter FLS activation key. Leave Deactivate? box unchecked. Click Activate/Deactivate Alternate Server Hostid button.

4. The FLS is successfully activated now.

5. To complete the procedure, go to the folder where the FLS utility has been unpacked to and delete mock license file - agisoft.lic.

6. Return to web-interface of the license management system and go to Reread/Restart Servers section of the left hand side menu. Select "-all-" from the dropdown list of the ISV field. Click REREAD/RESTART button.

7. The FLS activation procedure is completed.

The next step is activation of the floating license itself.

To activate a floating license

1. Go to http://server_address:5054 to use web-interface of the license management system. Enter Activate License section of the left hand side menu. Click BEGIN License Activation button on License Activation page.

2. Do not change the suggested value of the ISV activation website parameter. Click Next.

3. On step 2 of License activation procedure set ISV parameter to "agisoft" value and enter Floating license activation key into the License activation key textbox. Click Next.

4. Go to the folder where the FLS utility has been unpacked to, open rlm_agisoft_FLS-activation-key.lic file. Copy string "license=server-serial-number" from the first line of the file and enter the data into the License Server or Node-lock hostid: textbox on the 3d step of the License activation procedure.

5. Indicate the number of floating licenses to be activated in the License count (for floating licenses) field. The number should not exceed the total amount of floating licenses associated with the floating license activation key. Click Next.

6. On step 4 indicate the name of the license file to be created. Click Next.

7. On step 5 check Activation Request Data and if everything is correct, click REQUEST LICENSE button.

8. Click (Re)Start License Server. Select "agisoft" from the dropdown list of the ISV field. Click REREAD/RESTART button.

9. Floating license activation procedure is completed. You can run Metashape on the client machines connected to the server.

To run Metashape on a client machine, where the software has been installed, the client machine should have network connection to the server, where FLS has been deployed. In case the connection is not via
Installation and Activation

a local network, then a specially prepared *.lic file should be properly placed to the Metashape folder on the client machine. The data in the file should be the following string: "HOST FLS_address". In case the server uses a port different from the standard 5053 one, then the string should be: "HOST FLS_address any the_port_number".

**To transfer the Floating License Server**

1. Deactivate FLS in web-interface of the license management system: http://server_address:5054. Enter Status section of the left hand side menu. Find “agisoft” line in the ISV Servers table. Click agisoft button in ACTIVATE column of the table. Set the following values for the parameters on the Activate/Deactivate Alternate Server Hostid page. ISV: agisoft, check Deactivate? box. Click Activate/Deactivate Alternate Server Hostid button.

2. Activate FLS on a new server following steps 1-3 from the Floating License Server activation procedure described above.

3. Copy all floating license files (i.e. all *.lic files but for the rlm_agisoft_license server activation key.lic) from the original server machine to the new server to the folder where floating license server has been unpacked to.

4. Modify the server host name in the first line of the copied floating license files to the name of the new server machine.

5. Follow steps 5-6 from the Floating License Server activation procedure described above.

There is no need to perform Floating license activation procedure since the floating license is already activated. Metashape can be run on the client machines connected to the new server.

**To borrow a floating license**

1. Connect the machine you would like to borrow the license for to the server machine and make sure that there is a spare floating license in the server pool.

2. Run Metashape software on the machine. Select Activate Product... command from Help menu.

3. Click Borrow License button in the Metashape Activation dialog. Set the number of days you would like to borrow the license for and click OK button. The number of days should not exceed 30.

4. Now the machine can be disconnected from the server network, with Metashape being kept activated on it.

5. To return the borrowed license connect the computer to the license server network, start Metashape, select Activate Product... command from the Help menu and click Return License button in Activate dialog window. Otherwise the license will be automatically returned to the server pool after the borrowing period is over.
Chapter 2. Capturing scenarios

Photographs suitable for 3D model reconstruction in Metashape can be taken by any digital camera (both metric and non-metric), as long as you follow some specific capturing guidelines. This section explains general principles of taking and selecting pictures that provide the most appropriate data for 3D model generation.

IMPORTANT! Make sure you have studied the following rules and read the list of restrictions before you get out for shooting photographs.

Equipment

- Use a digital camera with reasonably high resolution (5 MPix or more).
- Avoid ultra-wide angle and fisheye lenses. The best choice is 50 mm focal length (35 mm film equivalent) lenses. It is recommended to use focal length from 20 to 80 mm interval in 35mm equivalent. If a data set was captured with fisheye lens, appropriate camera sensor type should be selected in Metashape Camera Calibration dialog prior to processing.
- Fixed lenses are preferred. If zoom lenses are used - focal length should be set either to maximal or to minimal value during the entire shooting session for more stable results, for intermediate focal lengths separate camera calibration groups should be used.

Camera settings

- Using RAW data losslessly converted to the TIFF files is preferred, since JPG compression may induce unwanted noise to the images.
- Take images at maximal possible resolution.
- ISO should be set to the lowest value, otherwise high ISO values will induce additional noise to images.
- Aperture value should be high enough to result in sufficient focal depth: it is important to capture sharp, not blurred photos.
- Shutter speed should not be too slow, otherwise blur can occur due to slight movements.

Object/scene requirements

- Avoid not textured, shiny, highly reflective or transparent objects.
- If still have to, shoot shiny objects under a cloudy sky.
- Avoid unwanted foregrounds.
- Avoid moving objects within the scene to be reconstructed.
- Avoid absolutely flat objects or scenes.

Image preprocessing

- Metashape operates with the original images. So do not crop or geometrically transform, i.e. resize or rotate, the images.
Capturing scenarios

Generally, spending some time planning your shot session might be very useful.

• Number of photos: more than required is better than not enough.

• Number of "blind-zones" should be minimized since Metashape is able to reconstruct only geometry visible from at least two cameras.

In case of aerial photography the overlap requirement can be put in the following figures: 60% of side overlap + 80% of forward overlap. When making a survey over a forest, it is recommended to increase the overlap value to 80% and 90% respectively.

• Each photo should effectively use the frame size: object of interest should take up the maximum area. In some cases portrait camera orientation should be used.

• Do not try to place full object in the image frame, if some parts are missing it is not a problem providing that these parts appear on other images.

• Good lighting is required to achieve better quality of the results, yet blinks should be avoided. It is recommended to remove sources of light from camera fields of view. Avoid using flash.

• If you are planning to carry out any measurements based on the reconstructed model, do not forget to locate at least two markers with a known distance between them on the object. Alternatively, you could place a ruler within the shooting area.

• In case of aerial photography and demand to fulfill georeferencing task, even spread of ground control points (GCPs) (at least 10 across the area to be reconstructed) is required to achieve results of highest quality, both in terms of the geometrical precision and georeferencing accuracy. Yet, Agisoft Metashape is able to complete the reconstruction and georeferencing tasks without GCPs, too.

The following figures represent advice on appropriate capturing scenarios:

Facade (Incorrect)  Facade (Correct)
Restrictions

In some cases it might be very difficult or even impossible to build a correct 3D model from a set of pictures. A short list of typical reasons for photographs unsuitability is given below.

Modifications of photographs

Metashape can process only unmodified photos as they were taken by a digital photo camera. Processing the photos which were manually cropped or geometrically warped is likely to fail or to produce highly inaccurate results. Photometric modifications do not affect reconstruction results.

Lack of EXIF data

Metashape calculates initial values of sensor pixel size and focal length parameters based on the EXIF data. The better initial approximation of the parameter values is, the more accurate autocalibration of the camera can be performed. Therefore, reliable EXIF data is important for accurate reconstruction results. However 3D scene can also be reconstructed in the absence of the EXIF data. In this case Metashape assumes that focal length in 35 mm equivalent equals to 50 mm and tries to align the photos in accordance with this assumption. If the correct focal length value differs significantly from 50 mm, the alignment can give incorrect results or even fail. In such cases it is required to specify initial camera calibration manually.

The details of necessary EXIF tags and instructions for manual setting of the calibration parameters are given in the Camera calibration section.
Capturing scenarios

Lens distortion

The distortion of the lenses used to capture the photos should be well simulated with the camera model used in the software. Generally, Brown’s distortion model implemented in Metashape works well for frame cameras. However, since fisheye/ultra-wide angle lenses are poorly simulated by the mentioned distortion model, it is crucial to choose proper camera type in Camera Calibration dialog prior to processing of such data - the software will switch to the appropriate distortion model.

Lens calibration

It is possible to use Metashape for automatic lens calibration. Metashape uses LCD screen as a calibration target (optionally it is possible to use a printed chessboard pattern, providing that it is flat and all its cells are squares). Lens calibration procedure supports estimation of the full camera calibration matrix, including non-linear distortion coefficients. The details of camera models are given in the Appendix C, Camera models section.

Note

- Lens calibration procedure can usually be skipped in common workflow, as Metashape calculates the calibration parameters automatically during Align Photos process. However, if the alignment results are unstable, for example, due to the lack of the tie points between the images, the lens calibration may be useful.

The following camera calibration parameters can be estimated:

\( f \)

Focal length measured in pixels.

\( cx, cy \)

Principal point coordinates, i.e. coordinates of lens optical axis interception with sensor plane in pixels.

\( b1, b2 \)

Affinity and Skew (non-orthogonality) transformation coefficients.

\( k1, k2, k3, k4 \)

Radial distortion coefficients.

\( p1, p2 \)

Tangential distortion coefficients.

Before using lens calibration tool a set of photos of calibration pattern should be loaded in Metashape.

To capture photos of the calibration pattern:

1. Select Show Chessboard... command from the Lens submenu in the Tools menu to display the calibration pattern.

2. Use mouse scroll wheel to zoom in/out the calibration pattern. Scale the calibration pattern so that the number of squares on each side of the screen would exceed 10.

3. Capture a series of photos of the displayed calibration pattern with your camera from slightly different angles, according to the guidelines, outlined below. Minimum number of photos for a given focal length is 3.
4. If you are calibrating zoom lens, change the focal length of your lens and repeat the previous step for other focal length settings.

5. Click anywhere on the calibration pattern or press Escape button to return to the program.

6. Upload the captured photos to the computer.

When capturing photos of the calibration pattern, try to fulfill the following guidelines:

• Make sure that the focal length keeps constant throughout the session (in case of zoom lens).

• Avoid glare on the photos. Move the light sources away if required.

• Preferably, the whole area of the photos should be covered by calibration pattern. Move the camera closer to the LCD screen if required.

To load photos of the calibration pattern:

1. Create new chunk using Add Chunk toolbar button on the Workspace pane or selecting Add Chunk command from the Workspace context menu (available by right-clicking on the root element on the Workspace pane). See information on using chunks in Using chunks section.

2. Select Add Photos... command from the Workflow menu.

3. In the Open dialog box, browse to the folder, containing the photos, and select files to be processed. Then click Open button.

4. Loaded photos will appear in the Photos pane.

Note

• You can open any photo by double clicking on its thumbnail in the Photos pane. To obtain good calibration, the photos should be reasonably sharp, with crisp boundaries between cells.

• If you have loaded some unwanted photos, you can easily remove them at any time.

• Before calibrating fisheye lens you need to set the corresponding Camera Type in the Camera Calibration... dialog available from the Tools menu. See information on other camera calibration settings in Camera calibration section.

To calibrate camera lens

1. Select Calibrate Lens... command from the Lens submenu in the Tools menu.

2. In the Calibrate Lens dialog box, select the desired calibration parameters. Click OK button when done.

3. The progress dialog box will appear displaying the current processing status. To cancel processing click the Cancel button.

4. The calibration results will appear on the Adjusted tab of the Camera Calibration... dialog available from the Tools menu. The adjusted values can be saved to file by using Save button on the Adjusted tab. The saved lens calibration data can later be used in another chunk or project, providing that the same camera and lens is used.
Capturing scenarios

Note

• After you have saved the calibration parameters for the lens, you may proceed with the workflow steps in a separate chunk for the actual image set captured by the same camera and lens. To protect the calibration data from being refined during Align Photos process one should check Fix calibration box on the Initial tab for the chunk with the data to be processed. In this case initial calibration values will not be changed during Align Photos process.

After calibration is finished, you will be presented with the following information:

Detected chessboard corners are displayed on each photo (the photo can be opened by double clicking on its name in the Photos pane). It is preferable when the majority of the corners were detected correctly. For each detected corner the reprojection error between the detected corner position and estimated position according to the calculated calibration is also displayed. The errors are scaled x20 times for display.

Automated mission planning

Metashape introduces functionality for obtaining optimal sets of camera positions based on rough model and creating mission plans using these optimal sets.

Mission planning feature works as follows. At first, photos captured during a simple overhead flight are used to create a rough polygonal model. Then, a set of the viewpoints which are enough to cover the surface of the object with sufficient overlap is automatically generated. Finally, a round-trip passing through all the generated viewpoints is computed and can be exported in KML file format to be used for drone controlling application.

Note

• This tool is suitable for DJI drones. We recommend using aircraft/drones with RTK GPS to significantly enhance flight safety and precision.

1. Make an overhead flight over the region of interest to capture a basic imagery set. To capture vertical and concave surfaces better, you may use an oblique survey preset in your drone app instead of taking only nadir photos.

2. Import photos to Metashape and align them, then build a model of the object. As only rough geometry is needed for mission planning step, you can build mesh from sparse cloud or using low quality settings to speedup computations. Check Bounding Box to include entire geometry of interest.

3. Specify home point for the drone at the expected take-off point. This can be done by placing a Point shape on the rough model. To place point precisely, you can build texture for the model or pick point from an overhead photo that observes home point.

4. Select Plan Mission submenu from the Tools menu. Specify parameters and run processing.

5. Import files to drone app that supports KML flight plans with gimbal orientation.

Note

• Please note that each flight must be watched by a pilot ready to take manual control over the drone in case of GPS issues or unreconstructed obstacles such as wires or trees.

• Specify flight zones. To enhance flight safety, you can specify zones allowed and restricted to fly in.
Capturing scenarios

- If drone battery gets low during the flight, replace it and restart the drone at the same altitude as that of specified home point. You will need to manually navigate drone to the position from which the last visited waypoint is in line of sight to resume automatic flight safely.

- You may need to disable built-in drone obstacle avoidance feature in order to perform range flights. Be even more careful after disabling obstacle avoidance as drone will longer stop or slow down in case of any obstacle on the way. It's not recommended to disable obstacle avoidance feature when flying using GNSS signal without RTK.

Plan Mission parameters
The following parameters control the photo alignment procedure and can be modified in the Plan Mission dialog box:
Focus on model selection
To consider only selected triangles of the model as target for reconstruction. In any case all reconstructed triangles will be used for obstacle avoidance.

Focus on interesting zone
Polygons from the selected shape layer are used for the area selection. All mesh faces are selected that fall into the polygonal shapes from the chosen layer when viewed from above. If any mesh faces are used for Focus on model selection along with the zone, then both sources will be considered: manually selected mesh faces and mesh faces corresponding to the selected shape layer.

Camera model
Choose a camera from the list, with a certain focal length in mm.

Resolution
Target image resolution. Can either be specified as GSD or distance in meters from the surface of the rough model.

Image overlap
Choose the desired overlap percentage.

Improve hard-to-reach regions coverage
Optimize coverage of hard-to-reach regions of interest by generating additional viewpoints from allowed space.

Enable multi-photo waypoints (DJI Pilot only)
Convert close waypoints to rotate-and-shoot actions without changing drone position.

Safety distance
Distance from the object which is restricted for putting waypoints within or planning path through. Focus on selection parameter is ignored here - all parts of the object available in the rough model are considered.

Min altitude
Relative altitude to home point (in meters) which is restricted for putting waypoints within or planning path through.

Safety zone
Shape layer with allowed regions.

Restricted zone
Shape layer with restricted regions.

Powerlines layer
Shape layer with the detected powerlines.

Home point
The desired take-off point can be defined as 3D point shape placed in scene.

Min waypoints spacing
Minimal distance between consecutive waypoints. The default value is set to 0.5 meters according to DJI drones firmware.

Max waypoints per flight
Maximal possible number of waypoints per KML file. If flight plan has more waypoints than specified value, it will be split into chunks. The default value is set to 99 according to DJI drones firmware.
Capturing scenarios

Min pitch
Minimal pitch angle allowed by the drone gimbal.

Max pitch
Maximal pitch angle allowed by the drone gimbal.

Prefer horizontal movement
Traverse flat surfaces in horizontal zig-zag fashion instead of a vertical one. Vertical movement is simpler to keep direct eye contact with the drone, while the horizontal movement may be more battery efficient.

Excessive image elimination
Reduce overlap feature is made for analyzing excessive image sets to understand which images are useful and which are redundant and may be disabled or removed.

1. Align photos using entire dataset and build rough mesh model from the sparse cloud.
2. Select Reduce Overlap dialog available from the Tools menu.
3. Choose parameters in Reduce Overlap dialog box.
4. Click OK button.
5. The progress dialog box will appear displaying the current processing status. To cancel processing click the Cancel button.
6. After the operation is finished all the cameras which are not included into optimal subset will get disabled.

Reduce overlap parameters

"Reduce overlap” dialog

Reduce overlap dialog parameters:

Focus on selection
To consider only selected triangles of the polygonal model as target for reconstruction. Cameras that do not have any of the selected polygons in the field of view would be automatically disabled.

Surface coverage
Number of cameras observing each point from different angles.
Chapter 3. General workflow

Processing of images with Metashape includes the following main steps:

- loading images into Metashape;
- inspecting loaded images, removing unnecessary images;
- aligning cameras;
- building dense point cloud;
- building mesh (3D polygonal model);
- generating texture;
- building tiled model;
- building digital elevation model (DEM);
- building orthomosaic;
- exporting results.

If you are using Metashape in the full function (not the Demo) mode, intermediate results of the image processing can be saved at any stage in the form of project files and can be used later. The concept of projects and project files is briefly explained in the Saving intermediate results section.

The list above represents all the necessary steps involved in the construction of a textured 3D model, DEM and orthomosaic from your photos. Some additional tools, which you may find to be useful, are described in the successive chapters.

Preferences settings

Before starting a project with Metashape it is recommended to adjust the program settings for your needs. In Preferences dialog (General tab) available through the Tools menu you can indicate the path to the Metashape log file to be shared with the Agisoft support team in case you face any problem during the processing. Here you can also change GUI language to the one that is most convenient for you. The options are: English, Chinese, French, German, Italian, Japanese, Portuguese, Russian, Spanish.

Switch Theme in case you have preferences between Dark or Light program GUI or leave it as Classic for the simplest view. Shortcuts for the menu commands can be adjusted for your convenience on the General tab as well.

On the GPU tab you need to make sure that all discrete GPU devices detected by the program are checked. Metashape exploits GPU processing power that speeds up the process significantly. However, Agisoft does not recommend to use integrated graphic card adapters due to their possible unstable work under heavy load. If you have decided to switch on GPUs to boost the data processing with Metashape, it is recommended to uncheck Use CPU when performing GPU accelerated processing option, providing that at least one discrete GPU is enabled for processing.

Advanced tab allows to switch on such advanced features like rich Python console, for example. Furthermore, you can enable loading of extra camera data from XMP (camera calibration, camera orientation angles, camera location accuracy, GPS/INS offset).
General workflow

Keep depth maps option can be beneficial in terms of saving up the processing time, in case there might be a need to rebuild dense point cloud, once generated, for a smaller part of the scene, or if both mesh and dense cloud are based on the same quality depth maps.

Fine-level task subdivision option is useful in cases when large datasets are to be processed. Enabled option provides internal splitting of some tasks to the sub-jobs, thus allowing to reduce the memory consumption during the processing. The tasks that are supported for fine-level distribution are the following: Match Photos, Align Cameras, Build Depth Maps, Build Dense Cloud, Build Tiled Model, Build DEM, Build Orthomosaic and Classify Points.

Metashape allows for incremental image alignment, which may be useful in case of some data missing in the initially aligned project. If this may be the case, you should switch on the Keep key points option on the Advanced tab of the Preferences dialog before you start the processing of the data.

Loading images

Before starting any operation it is necessary to point out which images will be used as a source for photogrammetric processing. In fact, images themselves are not loaded into Metashape until they are needed. So, when Add photos command is used, only the links to the image files are added to the project contents to indicate the images that will be used for further processing.

Metashape uses the full color range for image matching operation and is not downsampling the color information to 8 bit. The point cloud points, orthomosaic and texture would also have the original bit depth, providing that they are exported in the formats that support non 8-bit colors.

To load a set of photos

1. Select Add Photos... command from the Workflow menu or click Add Photos toolbar button on the Workspace pane.
2. In the Add Photos dialog box browse to the folder containing the images and select files to be processed. Then click Open button.

Note

- Metashape accepts the following image formats: JPEG, JPEG 2000, TIFF, DNG, PNG, OpenEXR, BMP, TARGA, PPM, PGM, SEQ, ARA (thermal images) and JPEG Multi-Picture Format (MPO). Image files in any other format will not be displayed in the Add Photos dialog box. To work with such images is it necessary to convert them to one of the supported formats.

If some unwanted images have been added to the project, they can be easily removed at any moment.

To remove unwanted images

1. On the Workspace pane select the cameras to be removed.
2. Right-click on the selected cameras and choose Remove Items command from the opened context menu, or click Remove Items toolbar button on the Workspace pane. The related images will be removed from the working set.
Camera groups

If all the photos or a subset of photos were captured from one camera position - camera station, for Metashape to process them correctly it is obligatory to move those photos to a camera group and mark the group as Camera Station. It is important that for all the photos in a Camera Station group distances between camera centers were negligibly small compared to the camera-object minimal distance. Photogrammetric processing will require at least two camera stations with overlapping photos to be present in a chunk. However, it is possible to export panoramic picture for the data captured from only one camera station. Refer to Exporting results section for guidance on panorama export.

Alternatively, camera group structure can be used to manipulate the image data in a chunk easily, e.g. to apply disable/enable functions to all the cameras in a group at once.

To move photos to a camera group

1. On the Workspace pane (or Photos pane) select the photos to be moved.
2. Right-click on the selected photos and choose Move Cameras - New Camera Group command from the opened context menu.
3. A new group will be added to the active chunk structure and selected photos will be moved to that group.
4. Alternatively selected photos can be moved to a camera group created earlier using Move Cameras - Camera Group - Group_name command from the context menu.

To mark group as camera station, right click on the camera group name and select Set Group Type command from the context menu.

Inspecting loaded images

Loaded images are displayed on the Workspace pane along with flags reflecting their status.

The following flags can appear next to the camera label:

NC (Not calibrated)
Notifies that the EXIF data available is not sufficient to estimate the camera focal length. In this case Metashape assumes that the corresponding photo was taken using 50mm lens (35mm film equivalent). If the actual focal length differs significantly from this value, manual calibration may be required. More details on manual camera calibration can be found in the Camera calibration section.

NA (Not aligned)
Notifies that external camera orientation parameters have not been estimated for the current image yet.

Images loaded to Metashape will not be aligned until you perform the next step - photos alignment.

Sn

Notifies that Camera Station type was assigned to the group.

Scanned images

Metashape supports processing of scanned photos. All the scanned photos from the same analog camera should be placed in a designated calibration group. Metashape will automatically put the photos in the same calibration group, providing that they have been scanned to the images of the same resolution.
To load scanned photos

1. Add scanned photos to the project using Add Folder... command from the Workflow menu.

2. In the Add Folder dialog box browse to the parent folder containing subfolders with images. Then click Select Folder button.

3. Click OK button to close the dialog. Display of images in Metashape window.

Read more in Scanned images section.

Multispectral imagery

Metashape supports processing of multispectral images saved as multichannel (single page) TIFF files. The main processing stages for multispectral images are performed based on the primary channel, which can be selected by the user. During orthomosaic export, all spectral bands are processed together to form a multispectral orthomosaic with the same bands as in source images.

The overall procedure for multispectral imagery processing does not differ from the usual procedure for normal photos, except the additional primary channel selection step performed after adding images to the project. For the best results it is recommended to select the spectral band which is sharp and as much detailed as possible.

To select primary channel

1. Add multispectral images to the project using Add Photos... command from the Workflow menu or Add Photos toolbar button.

2. Select Multi-camera system data layout in the Add Photos dialog.

3. Select Set Primary Channel... command from the chunk context menu in the Workspace pane.

4. In the Set Primary Channel dialog select the channel to be used as primary and click OK button. Display of images in Metashape window will be updated according to the primary channel selection.

Note

- Set Primary Channel... command is available for RGB images as well. You can either indicate only one channel to be used as the basis for photogrammetric processing or leave the parameter value as Default for all three channels to be used in processing.

Multispectral orthomosaic export is supported in GeoTIFF format only. When exporting in other formats, only primary channel will be saved.

Vignetting is modeled in Metashape using a 3 degree bivariate polynomial:

\[ V(x, y) = \exp\left(\sum_i c_{ij} \cdot x^i \cdot y^j\right) \]

- where \( x \) and \( y \) represent normalized pixel coordinates, so that top left corner of the image has coordinates \((-1, -1)\), and bottom right corner has coordinates \((1, 1)\).

To compensate vignetting in the image each pixel value is divided by corresponding vignetting factor.

\[ I'_{ij} = I_{ij} / \exp\left(\sum_i c_{ij} \cdot x^i \cdot y^j\right) \]
where

\[ x = 2 \times \frac{(i + 0.5)}{w} - 1 \]
\[ y = 2 \times \frac{(j + 0.5)}{h} - 1 \]

i, j - integer column and row pixel coordinates
w, h – image width and height in pixels
x, y - normalized pixel coordinates

\[ I_{ij} \] - pixel intensity in the original image with vignetting
\[ I'_{ij} \] - pixel intensity in the corrected image without vignetting

**Thermal images**

Metashape supports processing of thermal images. You can use data from AscTec ARA and WIRIS TIFF cameras. The AscTec ARA camera file format is ARA. WIRIS supports TIFF format. Thermal images contain information about object temperature.

**To load thermal images**

1. Add thermal images to the project using **Add Folder**… command from the **Workflow** menu.
2. In the **Add Folder** dialog box browse to the parent folder containing subfolders with images. Then click **Select Folder** button.
3. Click **OK** button in dialog window, if you want to add Palette for images.
4. Select or create Palette for images in **Raster Calculator** dialog.
5. Click **Apply** button. The operation is completed.
6. Click **OK** button to close the dialog. Display of images in Metashape window.

**Satellite images**

Metashape can process panchromatic and multispectral satellite images, provided that sufficiently accurate Rational Polynomial Coefficients (RPC) data is available for each image.

RPC coefficients are loaded automatically if they are present in RPC coefficient image tag. Alternatively, they can be loaded from supplementary rpc.txt or .rpb files (if available).

**To load satellite images**

1. If RPC coefficients are provided in supplementary rpc.txt or .rpb files make sure that **Load satellite RPC data from auxiliary TXT files** option is enabled in the **Advanced** tab of the **Preferences** dialog before adding images to the project.
2. Add satellite images to the project using **Add Photos** command from the **Workflow** menu.
3. Make sure that RPC coefficients are loaded correctly. To do this, check that **Camera type** is set to **RPC** for all calibration groups which contain the satellite images in **Camera Calibration** dialog.
Satellite images often have very large resolution and navigation in the Photo view may be slow. Metashape can take advantage of multi resolution TIFF files with overviews, which greatly improve user experience. If the available satellite images do not contain overviews, it is highly recommended to create them first. This can done using Convert Images command from the Export submenu from the File menu.

**To generate optimized TIFF images for faster navigation**

1. Add original images to an empty project as described in the previous procedure.
2. Select Convert Images... command from the File/Export menu.
3. In the Convert Images dialog make sure that Write tiled TIFF and Generate TIFF overviews options are enabled. If your images are larger than 4GB you will also need to enable Write BigTIFF file option.
4. Make sure that Filename template is set to some reasonable value. The default {filename}.{fileext} value should work in most cases.
5. In the Apply to section select All cameras and click OK button.
6. In the Select Folder dialog select a folder to save optimized images. It is recommended to select a new empty folder for the images to make sure that original files are not overwritten.
7. Click Select Folder button to start conversion.
8. After conversion is complete generated images can be loaded into a new project for processing.

**Note**

- Convert Images command automatically embeds RPC coefficients in the generated files, so it is not necessary to copy auxiliary TXT files to the new images folder.

**Working with tiled satellite imagery**

High resolution satellite images are often provided in a tiled form, where each image is split in multiple TIFF files. Before loading into Metashape such data needs to be converted to combined TIFF files first. This can be done using gdal_translate utility from GDAL package.

Below are example commands that can be used to perform conversion for different formats. These commands will generate multi-resolution TIFF files with overviews and with embedded RPC coefficients.

### Converting DIMAP datasets

DIMAP images contain an XML index file for each image, which can be used for conversion using the following commands:

```bash
gdal_translate DIM_<datasetname>.XML combined.tif -co TILED=YES
gdaladdo -r average combined.tif 2 4 8 16 32
```

### Converting DigitalGlobe datasets

Tiled DigitalGlobe images contain a TIL tile index file for each image, which needs to be used for conversion:

```bash
gdal_translate <datasetname>.TIL combined.tif -co TILED=YES
gdaladdo -r average combined.tif 2 4 8 16 32
```
Rigid camera rigs

Metashape supports processing of multispectral datasets captured with multiple synchronized cameras operating in different spectral ranges. In this case multiple images (planes) are available for each position and Metashape will estimate separate calibration for each plane as well as their relative orientation within camera rig.

The default assumption is that synchronized cameras have the same position in space. In case distance between the cameras cannot be neglected, it is possible for Metashape to calculate relative camera offset. If offset parameters are known you can set them manually.

To calculate relative camera offset for synchronized cameras

1. Select Camera Calibration command from the Tools menu.
2. In the left-hand part of the Camera Calibration dialog box select slave camera to calculate relative offset for.
3. Switch to Slave offset tab.
4. Check Adjust location option.
5. The distance for the active camera will be calculated in relation to master camera - the camera whose images were loaded to the project first of all.
6. If needed repeat procedure for each slave camera.

To change master camera, you can use the corresponding command from the context menu of the camera group displayed in the lefthand part of the Camera Calibration dialog.

Metashape uses the following directions for slave camera offsets:

- X axis points to the right edge of the image.
- Y axis points to the bottom edge of the image.
- Z axis points along the viewing direction of the master camera.

Slave Camera Offset calculated by the following formula:

\[ \mathbf{P}_{\text{master}} = R_x(\omega) \cdot R_y(\phi) \cdot R_z(\kappa) \cdot \mathbf{P}_{\text{slave}} + \mathbf{T} \]

Where:

- \( \mathbf{P}_{\text{slave}} \) – point coordinates in slave camera coordinate system.
- \( \mathbf{P}_{\text{master}} \) – point coordinates in master camera coordinate system.
- \( R_x(\omega) \), \( R_y(\phi) \), \( R_z(\kappa) \) – rotation matrices around corresponding axes in clockwise direction.
- \( \mathbf{T} \) – slave camera offset.

Multiplane layout is formed at the moment of adding photos to the chunk. It will reflect the data layout used to store image files. Therefore it is necessary to organize files on the disk appropriately in advance. The following data layouts can be used with Metashape:

a. All image planes from each position are contained in a separate multilayer image. The number of multilayer images is equal to the number of camera positions.
b. Corresponding planes from all camera positions are contained in a separate subfolder. The number of subfolders is equal to the number of planes.

c. For a special case of MicaSense cameras (RedEdge, Altum), Parrot Sequoia and DJI Phantom 4 Multispectral no special layout is required. In this case the arrangement of images into cameras and planes will be performed automatically based on available meta data.

Once the data is properly organized, it can be loaded into Metashape to form multiplane cameras. The exact procedure will depend on whether the multilayer layout (variant a), multifolder layout (variant b) or if MicaSense data is used.

**To set relative camera offset for synchronized cameras manually**

1. Select *Camera Calibration* command from the *Tools* menu.
2. In the left-hand part of the *Camera Calibration* dialog box select slave camera to set up offset
3. Switch to *Slave offset* tab.
4. Check *Enable reference* option.
5. Set up the relative camera offset manually.
6. If needed repeat procedure for each slave camera.

To change master camera, you can use the corresponding command from the context menu of the camera group displayed in the lefthand part of the *Camera Calibration* dialog.

In case of rigid camera rigs variance of relative offset can be inspected in the *GPS/INS Offset* tab of *Camera Calibration* dialog, see *Variance* column. Values in the *Variance* column are equal to squared standard deviation of relative offset. Read more in *Covariance matrix* section.

**To create a chunk from multilayer images**

1. Select *Add Photos...* command from the *Workflow* menu or click ![Add Photos](image) toolbar button.
2. In the *Add Photos* dialog box browse to the folder containing multilayer images and select files to be processed. Then click *Open* button.
3. In the *Add Photos* dialog select the data layout *Multi-camera system*.
4. Created chunk with multispectral cameras will appear on the *Workspace* pane.

When you create chunk with multispectral cameras from multilayer images you need to set up unique *Layer index* for each slave band.

**To set up unique *Layer index* for a slave band**

1. Select *Camera Calibration* command from the *Tools* menu.
2. Check slave band in the left hand side menu.
3. In the band tab set up unique *Layer index*.
4. If needed repeat procedure for each slave camera.
To create a chunk from multifolder layout

1. Select Add Folder... command from the Workflow menu.
2. In the Add Folder dialog box browse to the parent folder containing subfolders with images. Then click Select Folder button.
3. In the Add Photos dialog select the data layout Multi-camera system.
4. Created chunk with multispectral cameras will appear on the Workspace pane. The labels of the multispectral cameras would be taken from the image filenames of the first image folder used.

To create a chunk from MicaSense (RedEdge, Altum), Parrot Sequoia, DJI Phantom 4 Multispectral cameras

1. Select Add Photos... command from the Workflow menu or click Add Photos toolbar button.
2. In the Add Photos dialog box browse to the folder containing MicaSense images and select files to be processed. Then click Open button.
3. In the Add Photos dialog select Multi-camera system.
4. Created chunk with multispectral cameras will appear on the Workspace pane. The labels of the multispectral cameras would be taken from the first band image filenames.

After chunk with multispectral cameras is created, it can be processed in the same way as normal chunks. For these chunks additional parameters allowing to manipulate the data properly will be provided where appropriate.

For multispectral cameras the default bands order is defined by the CentralWavelength value from the images metadata (bands with lower value are added first, the transparency alpha channel is added last). The default order can be changed from Camera Calibration dialog available from Tools menu. On the Bands tab the Layer index can be set for each band as described previously for multilayer images.

You can execute to the reflectance calibration of multispectral image data acquired using MicaSense (RedEdge, Altum and etc.), Parrot Sequoia, DJI Phantom 4 Multispectral cameras. Read more in Vegetation indices calculation section.

Laser scans data

The integration of terrestrial laser scanning data into photogrammetry processing workflow is available in Metashape based on spherical panoramas acquired by laser scanner for the image matching (the intensity map in utilized instead, if the scanner used is not capable of saving spherical panoramas). During the dense cloud or depth maps based mesh generation operations, photogrammetric depth maps are merged with the depth information coming from the laser scanner.

To import laser scans data

1. Select Import Laser Scans... command from the Import submenu of the File menu.
2. Select files with structured point cloud data in ASTM E57 or PTX formats in the Open dialog.
3. Specify the folder where the pre-processed laser scans will be saved to (can be re-used from that location later without a need of completing the pre-processing procedure again).
4. Click OK button to add the data to the active chunk.
5. If necessary common digital camera images for the same scene can be loaded to the same chunk using Add Photos... command in the Workflow menu.

**Video Data**

Metashape allows for video data processing as well, which can be beneficial for quick inspection scenarios, for example. The video is to be divided into frames which will be further used as source images for 3D reconstruction.

**To import a video file**

1. Select Import Video... command from the File menu.
2. In the Import Video dialog you can inspect the video and set the output folder for the frames.
3. Set the filename pattern for the frames and indicate the frame extraction rate.
4. You can import part of the video, specify the parameters: Start from and End at.
5. Click OK button for the frames to be automatically extracted and saved to the designated folder. The images extracted from the video will be automatically added to the active chunk.

**Note**

- In Metashape you can choose the automatic frame step (Small, Medium, Large) which may be helpful to skip similar sequential frames or set manually via Custom option. Once the parameter value is set, the program calculates the shift for the images to be captured. For Small value, the shift of about 3% of the image width will be taken into account. For Medium, it corresponds to 7% and for Large - 14% of the image width.

After the frames have been extracted you can follow standard processing workflow for the images.

**Aligning photos**

The camera position at the time of image capture is defined by the interior and exterior orientation parameters.

Interior orientation parameters include camera focal length, coordinates of the image principal point and lens distortion coefficients. Before starting processing in Metashape the following configuration steps should be performed:

- Separate calibration groups should be created for each physical camera used in the project. It is also recommended to create a separate calibration group for each flight or survey. For details see Camera groups subsection of Loading images.

- For each calibration group initial approximation of interior orientation parameters should be specified. In most cases this is done automatically based on EXIF meta data. When EXIF meta data is not available, initial interior orientation parameters needs to be configured according to the camera certificate.

- When using images captured with analog camera, it is necessary to set the camera calibration parameters manually and also add fiducial marks on each image (for additional information see Scanned images section).

Exterior orientation parameters define the position and orientation of the camera. They are estimated during image alignment and consist of 3 translation components and 3 Euler rotation angles (see Camera
orientation angles conventions subsection of Setting coordinate system). In many cases survey systems are equipped with GPS/GNSS systems for measuring exterior orientation parameters during capture which can be used as additional measurements during bundle adjustment. To import a file with exterior images orientation parameters see Assigning reference coordinates subsection of Setting coordinate system.

Exterior and interior image orientation parameters are calculated using aerotriangulation with bundle block adjustment based on collinearity equations. Aerotriangulation allows to jointly adjust photogrammetric measurements of tie points together with onboard measurements. As a result, more accurate and reliable exterior orientation parameters of images are obtained.

The result of this processing step consists of estimated exterior (translation and rotation) and interior camera orientation parameters together with a sparse point cloud containing triangulated positions of matched image points.

**To align a set of photos**

1. Select Align Photos... command from the Workflow menu.
2. In the Align Photos dialog box select the desired alignment options. Click OK button when done.
3. The progress dialog box will appear displaying the current processing status. To cancel processing click Cancel button.

Alignment having been completed, computed camera positions and a sparse point cloud will be displayed. You can inspect alignment results and remove incorrectly positioned photos, if any. To see the matches between any two photos use View Matches... command from a photo context menu in the Photos pane.

Incorrectly positioned photos can be realigned.

**To realign a subset of photos**

1. Reset alignment for incorrectly positioned cameras using Reset Camera Alignment command from the photo context menu.
2. Set markers (at least 4 per photo) on these photos and indicate their projections on at least two photos from the already aligned subset. Metashape will consider these points to be true matches. (For information on markers placement refer to the Setting coordinate system section).
3. Select photos to be realigned and use Align Selected Cameras command from the photo context menu.
4. The progress dialog box will appear displaying the current processing status. To cancel processing click Cancel button.

When the alignment step is completed, the point cloud and estimated camera positions can be exported for processing with another software if needed.

**Image quality**

Poor input, e.g. vague photos, can influence alignment results badly. To help you to exclude poorly focused images from processing Metashape suggests automatic image quality estimation feature. Images with quality value of less than 0.5 units are recommended to be disabled and thus excluded from photogrammetric processing, providing that the rest of the photos cover the whole scene to be reconstructed. To disable a photo use Disable button from the Photos pane toolbar.

Metashape estimates image quality for each input image. The value of the parameter is calculated based on the sharpness level of the most focused part of the picture.
General workflow

To estimate image quality

1. Switch to the detailed view in the Photos pane using Details command from the Change menu on the Photos pane toolbar.

2. Select all photos to be analyzed on the Photos pane.

3. Right button click on the selected photo(s) and choose Estimate Image Quality command from the context menu.

4. Once the analysis procedure is over, a figure indicating estimated image quality value will be displayed in the Quality column on the Photos pane.

Alignment parameters

"Align Photos" dialog

The following parameters control the photo alignment procedure and can be modified in the Align Photos dialog box:
Accurate

Higher accuracy settings help to obtain more accurate camera position estimates. Lower accuracy settings can be used to get the rough camera positions in a shorter period of time.

While at High accuracy setting the software works with the photos of the original size, Medium setting causes image downscaling by factor of 4 (2 times by each side), at Low accuracy source files are downscaled by factor of 16, and Lowest value means further downscaling by 4 times more. Highest accuracy setting upscales the image by factor of 4. Since tie point positions are estimated on the basis of feature spots found on the source images, it may be meaningful to upscale a source photo to accurately localize a tie point. However, Highest accuracy setting is recommended only for very sharp image data and mostly for research purposes due to the corresponding processing being quite time consuming.

Generic preselection

The alignment process of large photo sets can take a long time. A significant portion of this time period is spent on matching of detected features across the photos. Image pair preselection option may speed up this process due to selection of a subset of image pairs to be matched.

In the Generic preselection mode the overlapping pairs of photos are selected by matching photos using lower accuracy setting first.

Note

Using only Reference preselection mode without Generic preselection fits best the case when only a few tie points are detected during the image matching stage, it may happen, for example, for aerial surveys of forested areas or crop fields.

Reference preselection

In the Source preselection mode the overlapping pairs of photos are selected based on the measured camera locations (if present). For oblique imagery it is necessary to set Capture distance value (average ground height in the same coordinate system which is set for camera coordinates data) in the Settings dialog of the Reference pane to make the preselection procedure work efficiently. Capture distance information must be accompanied with yaw, pitch, roll/omega, phi, kappa data for cameras. Rotation parameters should be input in the Reference pane. Then the preselection based on the new 3D points calculated as original 3D point and vector in the direction of the camera view with the length equal to the input Capture Distance value.

The Estimated preselection mode takes into account the calculated exterior orientation parameters for the aligned cameras. That is, if the alignment operation has been already completed for the project, the estimated camera locations will be considered when the Align Photos procedure is run again with the Estimated preselection selected.

When using Sequential preselection mode the correspondence between the images is determined according to the sequence of photos (the sequence number of the image) it is worth noting that with this adjustment, the first with the last images in the sequence will also be compared.

Reset current alignment

If this option is checked, all the tie, and key, and matching points will be discarded and the alignment procedure will be started from the very beginning.

Additionally the following advanced parameters can be adjusted.

Key point limit

The number indicates upper limit of feature points on every image to be taken into account during current processing stage. Using zero value allows Metashape to find as many key points as possible, but it may result in a big number of less reliable points.
Tie point limit
The number indicates upper limit of matching points for every image. Using zero value doesn't apply any tie point filtering.

Apply mask to
If **apply mask to key points** option is selected, areas previously masked on the photos are excluded from feature detection procedure. **Apply mask to tie points** option means that certain tie points are excluded from alignment procedure. Effectively this implies that if some area is masked at least on a single photo, relevant key points on the rest of the photos picturing the same area will be also ignored during alignment procedure (a tie point is a set of key points which have been matched as projections of the same 3D point on different images). This can be useful to be able to suppress background in turntable shooting scenario with only one mask. For additional information on the usage of masks please refer to the Using masks section.

Exclude stationary tie points
Excludes tie points that remain stationary across multiple different images. This option enables alignment without masks for datasets with a static background, e.g. in a case of a turntable with a fixed camera scenario. Also enabling this option will help to eliminate false tie points related to the camera sensor or lens artefacts.

Guided image matching
This option allows to effectively boost the number of keypoints per image as if the value of Key point limit was straightforwardly increased, but without significant growth of processing time. Using this parameter can improve results for images with vegetation (wooded terrain, grass, cornfields and so on), spherical cameras and high resolution images (captured by professional grade cameras, satellites or acquired by high-resolution scanning of the archival aerial images). To enable Guided image matching, check corresponding option in Align Photos dialog and adjust **Key point limit per Mpx** if needed. The number of detected points per image is calculated as (Keypoint limit per Mpx) * (image size in Mpx). Small fraction will be extensively matched and used as guidance for matching of remaining points.

Adaptive camera model fitting
This option enables automatic selection of camera parameters to be included into adjustment based on their reliability estimates. For data sets with strong camera geometry, like images of a building taken from all the sides around, including different levels, it helps to adjust more parameters during initial camera alignment. For data sets with weak camera geometry, like a typical aerial data set, it helps to prevent divergence of some parameters. For example, estimation of radial distortion parameters for data sets with only small central parts covered by the object is very unreliable. When the option is unchecked, Metashape will refine only the fixed set of parameters: focal length, principal point position, three radial distortion coefficients (K1, K2, K3) and two tangential distortion coefficients (P1, P2).

Note
- Tie point limit parameter allows to optimize performance for the task and does not generally effect the quality of the further model. Recommended value is 4000. Too high or too low tie point limit value may cause some parts of the dense point cloud model to be missed. The reason is that Metashape generates depth maps only for pairs of photos for which number of matching points is above certain limit. This limit equals to 100 matching points, unless moved up by the figure "10% of the maximum number of matching points between the photo in question and other photos, only matching points corresponding to the area within the bounding box being considered."
- The number of tie points can be reduced after the alignment process with **Tie Points - Thin Point Cloud** command available from Tools menu. As a results sparse point cloud will be thinned, yet the alignment will be kept unchanged.
Components

Some image subsets may be not aligned as the result of the Align Photos operation, if the sufficient amount of tie points was not detected between such subsets. Such subsets which are not aligned with the main subset will be grouped into individually aligned parts - Components.

The components into which the camera alignment have been split after the Align Photos operation will be displayed in the chunk's contents of the Workspace pane inside the Components folder.

To align components with each other

1. Manually create markers which would connect the components with each other. It is required to use at least 3 markers between each pair of components that do not lay on the same line. See information about placing markers in Setting coordinate system section.

2. In order to switch between the components double-click with the left mouse button on the component's label in the Workspace pane.

3. After all the components have been aligned with the help of markers, select them in the Workspace pane and then use the Merge Components command from the context menu.

Incremental image alignment

In case some extra images should be subaligned to the set of already aligned images, you can benefit from incremental image alignment option. To make it possible, two rules must be followed: 1) the scene environment should not have changed significantly (lighting conditions, etc); 2) do not forget to switch on Keep key points option in the Preferences dialog, Advanced tab BEFORE the whole processing is started.

To subalign some extra images added to the chunk with already aligned set of images

1. Add extra photos to the active chunk using Add photos command from the Workflow menu.

2. Open Align photos dialog from the Workflow menu.

3. Set alignment parameters for the newly added photos. IMPORTANT! Uncheck Reset alignment option.

4. Click OK. Metashape will consider existing key points and try to match them with key points detected on the newly added images.

Point cloud generation based on imported camera data

Metashape supports import of external and internal camera orientation parameters. Thus, if precise camera data is available for the project, it is possible to load them into Metashape along with the photos, to be used as initial information for 3D reconstruction job.

To import external and internal camera parameters

1. Select Import Cameras command from the File menu.

2. Select the format of the file to be imported.
3. Browse to the file and click *Open* button.

4. The data will be loaded into the software. Camera calibration data can be inspected in the *Camera Calibration* dialog, *Adjusted* tab, available from *Tools* menu. If the input file contains some reference data (camera position data in some coordinate system), the data will be shown on the *Reference* pane, *View Estimated* tab.

Camera data can be loaded in one of the following formats: Agisoft (*.xml), BINGO (*.dat), Inpho Project File (*.prj), Blocks Exchange (*.xml), Bundler (*.out), Autodesk FBX (*.fbx), VisionMap Detailed Report (*.txt), Realviz RZML (*.rzml), Alembic (*.abc).

Once the data is loaded, Metashape will offer to build point cloud. This step involves feature points detection and matching procedures. As a result, a sparse point cloud - 3D representation of the tie-points data, will be generated. *Build Point Cloud* command is available from *Tools > Tie Points* menu. Parameters controlling Build Point Cloud procedure are the same as the ones used at Align Photos step (see above).

### Building dense point cloud

Metashape allows to create a dense point cloud based on the calculated exterior and interior image orientation parameters.

Dense point cloud generation is based on depth maps calculated using dense stereo matching. Depth maps are calculated for the overlapping image pairs considering their relative exterior and interior orientation parameters estimated with bundle adjustment. Multiple pairwise depth maps generated for each camera are merged together into combined depth map, using excessive information in the overlapping regions to filter wrong depth measurements.

Combined depth maps generated for each camera are transformed into the partial dense point clouds, which are then merged into a final dense point cloud with additional noise filtering step applied in the overlapping regions. The normals in the partial dense point clouds are calculated using plane fitting to the pixel neighborhood in the combined depth maps, and the colors are sampled from the images.

For every point in the final dense point cloud the number of contributing combined depth maps is recorded and stored as a confidence value. This confidence value can be used later to perform additional filtering of low confidence points using the *Filter by Confidence...* command from the *Tools > Dense Cloud* menu.

Metashape tends to produce extra dense point clouds, which are of almost the same density, if not denser, as LIDAR point clouds. A dense point cloud can be edited and classified within Metashape environment and used as a basis for such processing stages as Build Mesh, Build DEM, Build Tiled Model. Alternatively, the point cloud can be exported to an external tool for further analysis.

### To build a dense point cloud

1. Check the reconstruction volume bounding box. To adjust the bounding box use the *Resize Region*, *Move Region* and *Rotate Region* toolbar buttons. To resize the bounding box, drag corners of the box to the desired positions; to move - hold the box with the left mouse button and drag it to the new location.

2. Select the *Build Dense Cloud...* command from the *Workflow* menu.

3. In the *Build Dense Cloud* dialog box select the desired reconstruction parameters. Click *OK* button when done.
4. The progress dialog box will appear displaying the current processing status. To cancel processing click *Cancel* button.

**Note**

- More than one instance of Dense cloud can be stored in one chunk. In case you want to save current Dense cloud instance and build new one in current chunk, right-click on Dense cloud and uncheck *Set as default* option. In case you want to save current Dense cloud instance and edit its copy, right-click on Dense cloud and choose *Duplicate* option.

**Build Dense Cloud parameters**

![Build Dense Cloud dialog](image)

**Quality**

Specifies the desired quality of the depth maps generation. Higher quality settings can be used to obtain more detailed and accurate geometry, but they require longer time for processing. Interpretation of the quality parameters here is similar to that of accuracy settings given in Photo Alignment section. The only difference is that in this case Ultra High quality setting means processing of original photos, while each following step implies preliminary image size downscaling by factor of 4 (2 times by each side).

Additionally the following advanced parameters can be adjusted.

**Depth filtering modes**

At the stage of dense point cloud generation reconstruction Metashape calculates depth maps for every image. Due to some factors, like noisy or badly focused images, there can be some outliers among the points. To sort out the outliers Metashape has several built-in filtering algorithms that answer the challenges of different projects.

If there are important small details which are spatially distinguished in the scene to be reconstructed, then it is recommended to set *Mild* depth filtering mode, for important features not to be sorted out as outliers. This value of the parameter may also be useful for aerial projects in case the area contains poorly textured roofs, for example. *Mild* depth filtering mode is also required for the depth maps based mesh reconstruction.

If the area to be reconstructed does not contain meaningful small details, then it is reasonable to choose *Aggressive* depth filtering mode to sort out most of the outliers. This value of the
Moderate depth filtering mode brings results that are in between the Mild and Aggressive approaches. You can experiment with the setting in case you have doubts which mode to choose.

Additionally depth filtering can be Disabled. But this option is not recommended as the resulting dense cloud could be extremely noisy.

The filtering modes control noise filtering in the raw depth maps. This is done using a connected component filter which operates on segmented depth maps based on the pixel depth values. The filtering preset control a maximum size of connected components that are discarded by the filter.

Note

• Stronger filter presets remove more noise, but also may remove useful information in case there are small and thin structures in the scene.

Reuse depth maps

Depth maps available in the chunk can be reused for the dense cloud generation operation. Select respective Quality and Depth filtering parameters values (see info next to Depth maps label on the Workspace pane) in Build Dense Cloud dialog and then check Reuse depth maps option.

Calculate point colors

This option can be unchecked in case the points color is not of interest. This will allow to save up processing time.

Calculate point confidence

If the option is enabled, the Metashape will count how many depth maps have been used to generate each dense cloud point. This parameter can used for dense cloud filtering (see Editing point cloud).

Import point cloud

Metashape allows to import a point cloud to be interpreted at further processing stages as a dense point cloud. If you want to upload a dense point cloud got from some external source (photogrammetry technology, laser scanning, etc), you can use Import points command from the File menu. In the Import points dialog browse to a file in one of the supported formats and click Open button.

Dense point cloud can be imported in one of the following formats: Wavefront OBJ, Stanford PLY, ASPRS LAS, LAZ, ASTM E57, ASCII PTS.

Building mesh

Mesh based on point cloud or depth maps data

Metashape can reconstruct polygonal mesh model based on the point cloud information (Dense Cloud, Sparse Cloud, Point Cloud imported from external source) or based on the depth maps data.

To build a mesh

1. Check the reconstruction volume bounding box. If the model has already been referenced, the bounding box will be properly positioned automatically. Otherwise, it is important to control its position manually.
To adjust the bounding box manually, use the Resize Region, Move Region and Rotate Region toolbar buttons. Rotate the bounding box and then drag corners of the box to the desired positions - only part of the scene inside the bounding box will be reconstructed. If the Height field reconstruction method is to be applied, it is important to control the position of the red side of the bounding box: it defines reconstruction plane. In this case make sure that the bounding box is correctly oriented.

2. Select the Build Mesh... command from the Workflow menu.

3. In the Build Mesh dialog box select the desired reconstruction parameters. Click OK button when done.

4. The progress dialog box will appear displaying the current processing status. To cancel processing click Cancel button.

**Note**

- More than one instance of Mesh can be stored in one chunk. In case you want to save current Mesh instance and build new one in current chunk, right-click on Mesh and uncheck Set as default option. In case you want to save current Mesh instance and edit its copy, right-click on Mesh and choose Duplicate option.

**Build Mesh parameters**

Metashape supports several reconstruction methods and settings, which help to produce optimal reconstructions for a given data set.
Source data
Specifies the source for the mesh generation procedure.

- **Sparse cloud** can be used for fast 3D model generation based solely on the sparse point cloud.

- **Dense cloud** setting will result in longer processing time but will generate high quality output based on the previously reconstructed dense point cloud.

- **Depth maps** setting allows to use all the information from the input images more effectively and is less resource demanding compared to the dense cloud based reconstruction. The option is recommended to be used for Arbitrary surface type reconstruction, unless the workflow used assumes dense cloud editing prior to the mesh reconstruction.

Surface type

- **Arbitrary** surface type can be used for modeling of any kind of object. It should be selected for closed objects, such as statues, buildings, etc. It doesn't make any assumptions on the type of the object being modeled, which comes at a cost of higher memory consumption.

- **Height field** surface type is optimized for modeling of planar surfaces, such as terrains or basereiefs. It should be selected for aerial photography processing as it requires lower amount of memory and allows for larger data sets processing.

Quality
Specifies the desired reconstruction quality of the depth maps, providing that they are selected as a source option. Higher quality settings can be used to obtain more detailed and accurate geometry, but they require longer time for the processing.

Interpretation of the quality parameters here is similar to that of accuracy settings given in Photo Alignment section. The only difference is that in this case Ultra High quality setting means processing of original photos, while each following step implies preliminary image size downscaling by factor of 4 (2 times by each side). For depth maps based mesh generation **Mild filtering** option is used by default, unless **Reuse depth maps** option is enabled. **Aggressive filtering** can be used if the excessive geometry (such as isolated mesh components around the reconstructed object) is observed, however, some fine level thin elements may be lost due to this depth filtering mode selection.

Face count
Specifies the maximum number of polygons in the final mesh. Suggested values (High, Medium, Low) present optimal number of polygons for a mesh of a corresponding level of detail. For the dense cloud based reconstruction they are calculated based on the number of points in the source dense point cloud: the ratio is 1/5, 1/15, and 1/45 respectively. It is still possible for a user to indicate the target number of polygons in the final mesh through the Custom value of the Face count parameter. Please note that while too small number of polygons is likely to result in too rough mesh, too huge custom number (over 10 million polygons) is likely to cause model visualization problems in external software.

Additionally the following advanced parameters can be adjusted.

Interpolation
If interpolation mode is **Disabled** it leads to accurate reconstruction results since only areas corresponding to dense point cloud points are reconstructed. Manual hole filling is usually required at the post processing step. With **Enabled (default)** interpolation mode Metashape will interpolate some surface areas within a circle of a certain radius around every dense cloud point. As a result some holes can be automatically covered. Yet some holes can still be present on the model and are to be filled at the post processing step. In **Extrapolated** mode the program generates holeless model with
extrapolated geometry. Large areas of extra geometry might be generated with this method, but they could be easily removed later using selection and cropping tools.

**Point classes**

Specifies the classes of the dense point cloud to be used for mesh generation. For example, select only *Ground Points* class to produce a DTM as opposed to a DSM. Preliminary Classifying dense point cloud procedure should be performed for this option of mesh generation to be active. Option is only applicable to dense cloud based reconstruction.

**Calculate vertex colors**

If source data has color information (point cloud colors or images are present for the depth maps based calculation) enabling this option would allow to calculate the colors for the mesh vertices and display the interpolated colors for the mesh polygons in Shaded view mode.

**Use strict volumetric masking**

When this option is enabled, space volume covered with mask from at least one photo will be suppressed. Each mask is strict - so you should use them as little as possible to prevent accidental suppressing some surface parts. Each mask also makes mesh reconstruction slower. For example strict volumetric masks are useful to suppress noise between fingers by masking space between them from single camera. Also this is useful to suppress textureless background stuck to object contours - by masking out background from single camera. For additional information on the usage of masks please refer to the Using masks section. The option is only applicable for the Depth Maps source option selected.

**Reuse depth maps**

If available depth maps should be reused for mesh generation, select respective Quality (see info next to Depth maps label on the Workspace pane in the chunk’s contents) and then check Reuse depth maps option. The option is applicable to the depth maps based reconstruction method only.

**Note**

- Metashape tends to produce 3D models with excessive geometry resolution, so it may be reasonable to perform mesh decimation after geometry computation. More information on mesh decimation and other 3D model geometry editing tools is given in the Editing model geometry section.

## Building model texture

### Color calibration

If the lighting conditions have been changing significantly during capturing scenario, it is recommended to use Calibrate colors option from the Tools menu before Build texture procedure. The option can help to even brightness and white balance of the images over the data set. Please note that for large data sets Calibrate colors procedure can turn out to be quite time consuming.

**To calibrate colors**

1. Select Calibrate colors... command from the Tools menu.
2. Select the desired colors calibration parameters in the Calibrate colors dialog box. Click OK button when done.
3. The progress dialog box will appear displaying the current processing status. To cancel processing click Cancel button.
Color calibration parameters

![Calibrate Colors dialog]

**Source data**
Defines what data should be taken as the basis for overlapping areas estimation.
- **Sparse cloud** - the quickest yet the roughest estimation available.
- **Model** - gives more precise results, but only on condition that the surface is detailed enough. This parameter value is the recommended one if the aim is to calibrate colors to improve the quality of the model texture.
- **DEM** - is a reasonable alternative to Model value for large data sets when it is not feasible to reconstruct solid polygonal model (mesh).

**Calibrate white balance**
Additional option to be switched on if white balance should be evened as well.

In Metashape it is possible to manually set color level adjustments for one or more images using the Adjust color levels tool. The Adjust Color Levels tool is available from the selected images context menu in the Photos pane. If the image is very dark or overexposed, you can manually set adjust the levels for each channel of the image in the Color levels dialog of the tool or set the Average value for all channels.

Build Texture

The texture feature allows to build different types of textures for a model.

**To generate 3D model texture**

1. Select **Build Texture...** command from the Workflow menu.

2. Select the desired texture generation parameters in the Build Texture dialog box. Click **OK** button when done.

3. The progress dialog box will appear displaying the current processing status. To cancel processing click **Cancel** button.

Texture generation parameters
The following parameters control various aspects of texture atlas generation:

**Texture type**

- **Diffuse map** - the basic texture that stores the colors of the model surface.
- **Normal map** - texture map that allows to calculate the illumination of the model parts from different light sources in the post-processing workflow.
- **Occlusion map** - a texture that contains pre-calculated shading information from background lighting.

**Source data**

- **Images** - allow to build a color texture map (diffuse map) based on the aligned images of the model or transferred from another model with already generated color texture map.
- **3D model** - the normal and occlusion texture maps can be built based on another model and the relief of the model specified in the **Source data** field will be transferred to the current model. Usually it is recommended to use the more detailed model as a source data for the Normal and Occlusion map generation for the 3D model with the lower polygon count. **Normal map** option will not be available in the **Source data** field, if less than two 3D model instances are present in the active chunk.

**Mapping mode**

The texture mapping mode determines how the object texture will be packed in the texture atlas. Proper texture mapping mode selection helps to obtain optimal texture packing and, consequently, better visual quality of the final model.

The default mode is the **Generic** mapping mode; it allows to parametrize texture atlas for arbitrary geometry. No assumptions regarding the type of the scene to be processed are made; program tries to create as uniform texture as possible.

In the **Orthophoto** mapping mode the whole object surface is textured in the orthographic projection. The **Orthophoto** mapping mode produces even more compact texture representation than the **Adaptive orthophoto** mode at the expense of texture quality in vertical regions.
In the **Adaptive orthophoto** mapping mode the object surface is split into the flat part and vertical regions. The flat part of the surface is textured using the orthographic projection, while vertical regions are textured separately to maintain accurate texture representation in such regions. When in the **Adaptive orthophoto** mapping mode, program tends to produce more compact texture representation for nearly planar scenes, while maintaining good texture quality for vertical surfaces, such as walls of the buildings.

**Spherical** mapping mode is appropriate only to a certain class of objects that have a ball-like form. It allows for continuous texture atlas being exported for this type of objects, so that it is much easier to edit it later. When generating texture in Spherical mapping mode it is crucial to set the Bounding box properly. The whole model should be within the Bounding box. The red side of the Bounding box should be under the model; it defines the axis of the spherical projection. The marks on the front side determine the 0 meridian.

The **Single camera** mapping mode allows to generate texture from a single image. The image to be used for texturing can be selected from 'Texture from' list.

The **Keep uv** mapping mode generates texture atlas using current texture parametrization. It can be used to rebuild texture atlas using different resolution or to generate the atlas for the model parametrized in the external software.

**Blending mode (not used in Single camera mapping mode)**

Selects the way how color values of pixels from different cameras will be combined in the final texture.

**Mosaic** - implies two-step approach: it does blending of low frequency component for overlapping images to avoid seamline problem (weighted average, weight being dependent on a number of parameters including proximity of the pixel in question to the center of the image), while high frequency component, that is in charge of picture details, is taken from a single image - the one that presents good resolution for the area of interest while the camera view is almost along the normal to the reconstructed surface in that point.

**Average** - uses the weighted average value of all pixels from individual photos, the weight being dependent on the same parameters that are considered for high frequency component in mosaic mode.

**Max Intensity** - the image which has maximum intensity of the corresponding pixel is selected.

**Min Intensity** - the image which has minimum intensity of the corresponding pixel is selected.

**Disabled** - the image to take the color value for the pixel from is chosen like the one for the high frequency component in mosaic mode.

**Texture size / count**

Specifies the size (width & height) of the texture atlas in pixels and determines the number of files for texture to be exported to. Exporting texture to several files allows to archive greater resolution of the final model texture, while export of high resolution texture to a single file can fail due to RAM limitations.

Multi-page texture atlas generation is supported for **Generic** mapping mode only and **Keep UV** option, if the imported model contains proper texture layout.

Additionally the following advanced parameters can be adjusted.

**Enable hole filling**

This option is enabled on default since it helps to avoid salt-and-pepper effect in case of complicated surface with numerous tiny parts shading other parts of the model. Only in case of very specific tasks might it be recommended to switch the function off.
Enable ghosting filter
In case the scene includes some thin structures or moving objects which failed to be reconstructed as part of polygonal model, it can be useful to switch on this option to avoid ghosting effect on the resulting texture.

Note
• HDR texture generation requires HDR photos on input.

Improving texture quality
To improve resulting texture quality it may be reasonable to exclude poorly focused images from processing at this step. Metashape suggests automatic image quality estimation feature. Images with quality value of less than 0.5 units are recommended to be disabled and thus excluded from texture generation procedure. To disable an image use Disable button from the Photos pane toolbar.

Metashape estimates image quality as a relative sharpness of the image with respect to other images in the data set. The value of the parameter is calculated based on the sharpness level of the most focused part of the picture.

You can improve the texture using the Remove Lighting tool. Read more in Editing textures section of the Manual for details.

To estimate image quality
1. Switch to the detailed view in the Photos pane using Details command from the Change menu on the Photos pane toolbar.
2. Select all images to be analyzed on the Photos pane.
3. Right button click on the selected image(s) and choose Estimate Image Quality command from the context menu.
4. Once the analysis procedure is over, a figure indicating estimated image quality value will be displayed in the Quality column on the Photos pane.

View Mesh UVs
In Metashape it is possible to analyze Mesh UV statistic. You can evaluate the quality of the resulting texture using data in this dialog window.

To open UV Mapping dialog window
1. Select View Mesh UVs... command on Mesh submenu from the Tools menu.
2. Check parameters for the texture was built in UV Mapping dialog box. You can save data from this page using Save button.
General workflow

The following parameters can be specified in *UV Mapping* dialog:

**View**

- **Color** - displays the colors of the mesh vertices.

- **Diffuse map** - display the basic texture that stores the colors of the model surface.

- **Scaling** - displays the ratio of the area of the texture triangle to its area on the mesh surface.

- **Overlap** - displays how many pixels in the atlas correspond to more than one triangle in the mesh.

- **Resolution** - displays the detail as a percentage. It is calculated as the ratio of the number of pixels for the triangle from the most detailed photo to the area of the triangle in the atlas.

**Statistics**

- **Fill ratio:** - displays the percentage of occupied pixels (in percent).

- **Overlap ratio:** - value of the overlap in percent (in percent).

- **Min scaling:** - minimum scaling value (in percent).

- **Max scaling:** - maximum scaling value (in percent).

- **Min Resolution:** - minimum resolution value (in percent).
Max Resolution: - maximum resolution value (in percent).

**Building tiled model**

Hierarchical tiles format is a good solution for city scale modeling. It allows for responsive visualization of large area 3D models in high resolution. The tiled model can be either opened in Metashape itself or with Agisoft Viewer - a complementary tool included in Metashape installer package, or with some other external application which supports a hierarchical tiles format.

Tiled model is build based on dense point cloud, mesh or depth maps data. Hierarchical tiles are textured from the source imagery.

**Note**

- Build Tiled Model procedure can be performed only for projects saved in .PSX format.

- More than one instance of Tiled Model can be stored in one chunk. In case you want to save current Tiled Model instance and build new one in current chunk, right-click on Tiled Model and uncheck *Set as default* option. In case you want to save current Tiled Model instance and edit its copy, right-click on Tiled Model and choose *Duplicate* option.

**To build a tiled model**

1. Check the reconstruction volume bounding box - tiled model will be generated for the area within bounding box only. To adjust the bounding box use the *Move Region*, *Resize Region* and *Rotate Region* toolbar buttons. Rotate the bounding box and then drag corners of the box to the desired positions.

2. Select the *Build Tiled Model...* command from the *Workflow* menu.

3. In the *Build Tiled model* dialog box select the desired reconstruction parameters. Click *OK* button when done.

4. The progress dialog box will appear displaying the current processing status. To cancel processing click *Cancel* button.

**Reconstruction parameters**
General workflow

"Build Tiled Model" dialog

**Source data**
- **Depth maps.** Recommended for large projects when Build Mesh procedure is not feasible due to processing time and result management issues.
- **Dense cloud.** Can be used as an alternative to the depth maps based option in case the dense cloud has been already generated for any other purposes, whereas the depth maps are not stored in the project or have been generated with the filtering option different from *Mild*.
- **Mesh.** Allows to keep all the details in the tiled model if a very detailed mesh has been generated previously.

**Pixel size (m)**
Suggested value shows automatically estimated pixel size due to input imagery effective resolution. It can be set by the user in meters.

**Tile size**
Tile size can be set in pixels. For smaller tiles faster visualization should be expected.

**Face count**
Suggested values (High, Medium, Low) present optimal number of polygons for a tiled model block of a corresponding level of detail. It is still possible for a user to indicate the target number of polygons in the final mesh through the Custom value of the Face count parameter.

**Quality**
Specifies the desired reconstruction quality of the depth maps, providing that they are selected as a source option. Higher quality settings can be used to obtain more detailed and accurate geometry, but
they require longer time for the processing. Interpretation of the quality parameters here is similar to that of accuracy settings given in Photo Alignment section. The only difference is that in this case Ultra High quality setting means processing of original photos, while each following step implies preliminary image size downscaling by factor of 4 (2 times by each side). For depth maps based tiled model generation Mild filtering option is used, unless Reuse depth maps option is enabled.

Additionally the following advanced parameters can be adjusted.

**Transfer model texture**
If there is a textured mesh model in the chunk, its texture can be reused for the tiled model texture generation instead of source images. The option is only available if Mesh is selected as a Source option for the tiled model generation.

**Enable ghosting filter**
In case the scene includes some thin structures or moving objects which fails to be reconstructed as part of polygonal model, it can be useful to enable this option to avoid ghosting effect on the resulting texture.

**Reuse depth maps**
Depth maps available in the chunk can be reused for the tiled model generation operation. Select respective Quality and Depth filtering parameters values (see info next to Depth maps label on the Workspace pane) in Build Tiled Model dialog and then check Reuse depth maps option. The option is only available if Depth maps are selected as a Source option for the tiled model generation.

**Merge tiled model**
This option allows to match the grid of tiles with the existing tiled model in the project and merge newly created tiles with the existing model to the single tiled model.

**Import Tiled Model**
In Metashape you can add a tile model to a project using Import Tile Model command from the File menu.

Tiled model can be imported in Agisoft Tiled Model format.

**Building digital elevation model**

Digital elevation model (DEM) is a 2.5D model of a surface represented in a form of a regular grid, with height values stored per every cell of the grid. In Metashape DEM can be rasterized from a dense point cloud, sparse cloud, mesh or generated directly from depth maps.

Metashape allows to create both digital surface model (DSM), i.e. 2.5D model of the Earth surface with all the objects on it, and digital terrain model (DTM) which represents the bare ground surface without any objects like plants and buildings. DTM can be built only based on the dense point cloud data, which should be classified into ground points and other semantic classes before DTM generation step. See Classifying dense point cloud section of the manual for information about options to classify/filter dense point cloud in Metashape software.

Metashape enables to perform DSM/DTM-based point, distance, area, and volume measurements, as well as generate cross-sections for the part of the scene selected by user. Furthermore, DEM can serve as a source for contour lines calculations within Metashape software. More information on measurement functionality can be found in Performing measurements on DEM section of the manual.

**Note**
- Build DEM procedure can be performed only for projects saved in .PSX format.
DEM can be calculated for referenced or scaled projects only. So make sure that you have set a coordinate system for your model or specified at least one reference distance before going to build DEM operation. For guidance on Setting coordinate system please go to Setting coordinate system.

More than one instance of DEM can be stored in one chunk. In case you want to save current DEM instance and build new one in current chunk, right-click on DEM and uncheck Set as default option. In case you want to save current DEM instance and edit its copy, right-click on DEM and choose Duplicate option.

DEM is calculated for the part of the model within the bounding box. To adjust the bounding box use the Resize Region and Rotate Region toolbar buttons. Rotate the bounding box and then drag corners of the box to the desired positions.

To build DEM

1. Select the Build DEM... command from the Workflow menu.

2. In the Build DEM dialog box set Coordinate system for the DEM generation or choose the projection type.

3. Select source data for DEM rasterization.

4. Click OK button when done.

5. The progress dialog box will appear displaying the current processing status. To cancel processing click Cancel button.

Build DEM parameters
Projection type

**Geographic** - allows to choose a geographic coordinate system from the dropdown list or upload parameters of a customized geographical coordinate system. The coordinate system set by default is the coordinate system previously selected for the model itself. You can switch to a different one, providing that corresponding datum transformation parameters are available.

**Planar.** Metashape allows to project DEM onto a plane set by the user. You can select projection plane and orientation of the resulting DEM. The plane can be determined by a set of markers (if there are no 3 markers in a desired projection plane it can be specified with 2 vectors, i.e. 4 markers). Planar projection type may be useful for DEM generation in projects concerning facades, for example.

**Cylindrical** - allows to project DEM on a cylindrical surface. In this case height value is calculated as the distance from the model surface to the cylindrical surface. Refer to Building orthomosaic section to see the options.
General workflow

**Source data**

It is recommended to calculate DEM based on **Dense Cloud** data, as this option allows to perform the point classification and surface generation based on the certain classes only. If the classification is not required and the dense cloud is not needed by the task requirements, **Depths Maps** option is recommended. Preliminary elevation data results can be generated from a **Sparse Cloud**, avoiding Build Dense Cloud step for time limitation reasons. **Mesh** and **Tiled Model** options can be used, if DEM should follow the polygonal model precisely or dense cloud has not been reconstructed.

**Quality**

Specifies the desired reconstruction quality of the depth maps, providing that they are selected as a source option. Higher quality settings can be used to obtain more detailed and accurate model, but they require longer time for the processing. Interpretation of the quality parameters here is similar to that of accuracy settings given in Photo Alignment section. The only difference is that in this case Ultra High quality setting means processing of original photos, while each following step implies preliminary image size downscaling by factor of 4 (2 times by each side).

**Interpolation**

If interpolation mode is **Disabled** it leads to accurate reconstruction results since only areas corresponding to point cloud or polygonal points are reconstructed. Usually this method is recommended for Mesh and Tiled Model data source.

With **Enabled (default)** interpolation mode Metashape will calculate DEM for all areas of the scene that are visible on at least one image. **Enabled (default)** setting is recommended for DEM generation.

In **Extrapolated** mode the program generates holeless model with some elevation data being extrapolated up to the bounding box extents.

**Point classes**

The parameter allows to select a point class (classes) that will be used for DEM calculation.

To generate digital terrain model (DTM), it is necessary to classify dense cloud points first in order to divide them in at least two classes: ground points and the rest. Please refer to Classifying dense point cloud section to read about dense point cloud classification options. Select **Ground** value for **Point class** parameter in **Build DEM** dialog to generate DTM.

Metashape generates DEM only for the area inside the bounding box. To calculate DEM for a particular rectangular part of the project, use Region section of the **Build DEM** dialog. Indicate coordinates of the bottom left and top right corners of the region you would like to build the DEM for. Suggested values indicate coordinates of the bottom left and top right corners of the whole area to be rasterized, the area being defined with the bounding box.

Resolution value shows effective ground resolution for the DEM estimated for the source data. Size of the resulting DEM, calculated with respect to the ground resolution, is presented in **Total size** section fields.

**Building orthomosaic**

Orthomosaic is a combined image created by seamless merging of the original images projected on the object surface and transformed to the selected projection. A polygonal model (mesh) or a digital elevation model can be selected as a surface where the images will be projected to.

Metashape allows using one of the following projection types: Geographic, Planar or Cylindrical. Geographic projection serves for most typical task of creation an orthomosaic in a geographical coordinate system. Planar projection allows to select arbitrary orientation of projection plane which is useful for
projects concerning facades or other non-horizontal surfaces. To minimize distortions for objects of a cylindrical shape, like tubes, round towers, tunnels, etc., a Cylindrical projection type can be used.

Metashape enables to perform orthomosaic seamline editing for better visual results (see Orthomosaic seamlines editing section of the manual).

For multispectral imagery processing workflow Ortho view tab presents Raster Calculator tool for NDVI and other vegetation indices calculation to analyze crop problems and generate prescriptions for variable rate farming equipment. More information on NDVI calculation functionality can be found in Vegetation indices calculation section.

**Note**

- Build Orthomosaic procedure can be performed only for projects saved in .PSX format for chunks with the existing mesh or DEM.

- More than one instance of Orthomosaic can be stored in one chunk. In case you want to save current Orthomosaic instance and build new one in current chunk, right-click on Orthomosaic on the Workspace pane and uncheck Set as default option. In case you want to save current Orthomosaic instance and edit its copy, right-click on Orthomosaic and choose Duplicate option.

- In the Ortho view a Basemap for the orthophotomosaic can be included as a bottom layer. Select Show Basemap from the Ortho view toolbar. In Metashape two modes of the Basemap are supported: Map and Satellite. Map - displays map tiles using Open Street Map. Satellite option display satellite layer.

If the lighting conditions have been changing significantly during capturing scenario, it is recommended to use Calibrate colors option from the Tools menu before Build orthomosaic procedure. The option can help to even brightness and white balance of the images over the data set. Please note that for large data sets Calibrate colors procedure can turn out to be quite time consuming. See information on color calibration parameters in Building model texture section.

**To build Orthomosaic**

1. Select the Build Orthomosaic... command from the Workflow menu.

2. In the Build Orthomosaic dialog box select Coordinate system in which the orthomosaic will be generated or select projection type.

3. Select type of Surface data that will be used to build the orthophoto.

4. Click OK button when done.

5. The progress dialog box will appear displaying the current processing status. To cancel processing click Cancel button.

**Build orthomosaic parameters**
Projection type

**Geographic** - allows to choose a geographic coordinate system from the dropdown list or upload parameters of a customized geographical coordinate system. The coordinate system set by default is the coordinate system previously selected for the model itself. You can switch to a different one, providing that corresponding datum transformation parameters are available.

**Planar.** Metashape allows to project the orthomosaic onto a plane set by the user, providing that mesh is selected as the surface type. You can select projection plane and orientation of the orthomosaic. The plane can be determined by a set of markers (if there are no 3 markers in a desired projection plane it can be specified with 2 vectors, i.e. 4 markers). Planar projection type may be useful for orthomosaic generation in projects concerning facades or other vertical surfaces.
**Cylindrical** - allows to project orthomosaic on a cylindrical surface. It helps to avoid severe distortions while projecting cylindrical objects, like tubes, round towers, tunnels, etc.

To project 3D points on a cylindrical surface one needs to: 1) define the cylinder, i.e. define its axis and its radius; 2) drop a perpendicular from the 3D point to the axis of the cylinder - the point of intersection of the perpendicular and the cylindrical surface is the projection of the 3D point in question; 3) agree on how to define x and y coordinates of a point on the cylinder. For the purpose of orthomosaic and DEM generation in cylindrical projection Metashape defines x and y coordinates of a point on the cylinder in the following way: x - along the curve in the zero-plane, y - along the zero-element of the cylindrical surface (zero-line), where zero-plane and zero-line are to be defined.

Metashape offers four methods to perform projecting on cylindrical surface. They differ in how the four core elements - cylinder axis and radius, zero-plane and zero-line - are defined.

**Current Region.** The cylinder is inscribed in the Bounding box: the axis goes through the cross sign on the bottom side of the Bounding box perpendicular to the bottom plane; the radius is defined as one half of the shorter side of the rectangle in the bottom of the Bounding box. Zero-plane goes through the center of the Bounding box perpendicular to the axis; zero-line belongs to the Bounding box side which is opposite to the side with the vertical marks.

**Current View.** The axis is set as the line from the viewpoint to the center of rotation for the model. Radius is defined as one half of the shortest of all the edges of the Bounding box. Zero-plane goes through the center of rotation for the model perpendicular to the axis; zero-line goes through the highest point (in monitor-related coordinate system) of the curve in the zero-plane.

**Markers.** At least three marker are required. The first pair sets the axis. The third marker defines zero-point, i.e. defines zero-plane and zero-line, on condition that radius is the distance from the third marker to the axis.

**X/Y/Z.** The axis is the line parallel to the corresponding Cartesian axis - X/Y/Z, going through the center of the Bounding box. Radius (r) is defined as one half of the shortest edge of the Bounding box. Zero-plane goes through the center of the Bounding box perpendicular to the axis; zero-line is the line opposite to the cut line. The cut line definition for each of the three possible options is illustrated on the Figure below.

**Interior projection** option allows to switch to projecting on the inner surface of the cylinder.

**Surface**

Orthomosaic creation based on DEM data is especially efficient for aerial survey data processing scenarios allowing for time saving on mesh generation step. Alternatively, mesh surface type allows to create orthomosaic for less common, yet quite demanded applications, like orthomosaic generation for facades of the buildings or other models that might be not referenced at all.
General workflow

**Blending mode**

- **Mosaic (default)** - implements approach with data division into several frequency domains which are blended independently. The highest frequency component is blended along the seamline only, each further step away from the seamline resulting in a less number of domains being subject to blending.
- **Average** - uses the weighted average color value of all pixels from individual images.
- In **Disabled** mode the color value for the pixel is taken from the image with the camera view being almost along the normal to the reconstructed surface in that point.

**Pixel size**

Default value for pixel size in *Export Orthomosaic* dialog refers to ground sampling resolution, thus, it is useless to set a smaller value: the number of pixels would increase, but the effective resolution would not. However, if it is meaningful for the purpose, pixel size value can be changed by the user in coordinate system units or in meters.

**Max. dimension (pix)**

The parameter allows to set maximal dimension for the resulting raster data.

**Back face culling**

The option allows to neglect on projecting parts of the surface where normals are counter directed to the targeted projection plane.

**Enable hole filling**

This option is enabled on default since it helps to avoid salt-and-pepper effect in case of complicated surface with numerous tiny parts shading other parts of the source surface model. Only in case of very specific tasks might it be recommended to switch the function off.

**Enable ghosting filter**

This option uses nadir (or close to nadir) images for orthomosaic generation. Other images will not be taken into account for creating orthomosaic.

**Refine seamlines**

The option is recommended to be used for DTM-based orthomosaics in order to make automatically created seamlines to bypass buildings and other complex objects in order to avoid visual artefacts on the final image and time consuming manual orthomosaic patching.

Metashape generates orthomosaic only for the area inside the bounding box. However, if the orthomosaic should be generated for a particular (rectangular) part of the project, **Region** section of the *Build Orthomosaic* dialog should be used for indication of the coordinates of the bottom left and top right corners of the region to be applied in the left and right columns of the textboxes respectively. **Estimate** button allows you to see the coordinates of the bottom left and top right corners of the whole area.

**Estimate** button also enables to control total size of the resulting orthomosaic data according to the currently selected reconstruction area and resolution (*Pixel size* or *Max. dimension* parameters). The information is shown in the **Total size (pix)** section fields.

**Import Orthomosaic**

Metashape allows to import a orthomosaic in project. You can use *Import Orthomosaic*... command from the *File* menu. In the *Import Orthomosaic* dialog browse to a file and select coordinate system.

Orthomosaic can be imported in GeoTIFF Raster Data format.
General workflow

Saving intermediate results

Certain stages of 3D model reconstruction can take a long time. The full chain of operations could eventually last for 4-6 hours when building a model from hundreds of photos. It is not always possible to complete all the operations in one run. Metashape allows to save intermediate results in a project file.

Metashape project archive (.PSZ)

Metashape Archive files (*.psz) may contain the following information:

• List of loaded photographs with reference paths to the image files.

• Photo alignment data such as information on camera positions, sparse point cloud model and set of refined camera calibration parameters for each calibration group.

• Masks applied to the photos in project.

• Depth maps for cameras.

• Dense point cloud model with information on points classification.

• Reconstructed 3D polygonal model with any changes made by user. This includes mesh and texture if it was built.

• List of added markers as well as of scale-bars and information on their positions.

• Structure of the project, i.e. number of chunks in the project and their content.

Note that since Metashape tends to generate extra dense point clouds and highly detailed polygonal models, project saving procedure can take up quite a long time.

Metashape project file (.PSX)

The software also allows to save Metashape Project file (*.psx) which stores the links to the processing results in *.psx file and the data itself in *.files structured archive. This format enables responsive loading of large data (dense point clouds, meshes, etc.), thus avoiding delays on reopening a thousands-of-photos project. DEM, orthomosaic and tiled model generation options are available only for projects saved in PSX format.

You can save the project at the end of any processing stage and return to it later. To restart work simply load the corresponding file into Metashape. Project files can also serve as backup files or be used to save different versions of the same model.

Project files use relative paths to reference original photos. Thus, when moving or copying the project file to another location do not forget to move or copy photographs with all the folder structure involved as well. Otherwise, Metashape will fail to run any operation requiring source images, although the project file including the reconstructed model will be loaded up correctly. Alternatively, you can enable Store absolute image paths option on the Advanced tab of the Preferences dialog available from Tools menu.

Exporting results

Metashape supports export of processing results in various representations: sparse and dense point clouds, camera calibration and camera orientation data, mesh, etc. Orthomosaics and digital elevation models (both DSM and DTM), as well as tiled models can be generated according to the user requirements.
Point cloud and camera calibration data can be exported right after photo alignment is completed. All other export options are available after the corresponding processing step.

If you are going to export the results (point cloud / mesh / tiled model) for the chunk that is not referenced, please note that the resulting file will be oriented according to a default coordinate system (see axes in the bottom right corner of the Model view), i.e. the model can be shown differently from what you see in Metashape window.

To align the model orientation with the default coordinate system use Rotate object button from the Toolbar. Move object and Scale object instruments can be used to adjust the size and location of the unreferenced model.

In some cases editing model geometry in the external software may be required. Metashape supports model export for editing in external software and then allows to import it back as it is described in the Editing model geometry section of the manual.

Main export commands are available from the File menu.

**Point cloud export**

**To export sparse or dense point cloud**

1. Select Export Points... command from the File menu.
2. Browse the destination folder, choose the file type, and print in the file name. Click Save button.
3. In the Export Points dialog box select desired type of point cloud: Sparse point cloud or Dense point cloud.
4. Specify the coordinate system and indicate export parameters applicable to the selected file type, including the dense cloud classes to be saved.
5. Click OK button to start export.
6. The progress dialog box will appear displaying the current processing status. To cancel processing click Cancel button.

Split in blocks option in the Export Points dialog can be useful for exporting large projects. It is available for referenced models only. You can indicate the size of the section in xy plane (in meters) for the point cloud to be divided into respective rectangular blocks. The total volume of the 3D scene is limited with the Bounding Box. The whole volume will be split in equal blocks starting from the point with minimum x and y values. Note that empty blocks will not be saved.

In some cases it may be reasonable to edit point cloud before exporting it. To read about point cloud editing refer to the Editing point cloud section of the manual.

Metashape supports point cloud export in the following formats:

- Wavefront OBJ (*.obj)
- Stanford PLY (*.ply)
- XYZ Point Cloud (*.txt)
- ASPRS LAS (*.las)
General workflow

- LAZ (*.laz)
- ASTM E57 (*.e57)
- Topcon CL3 (*.cl3)
- ASCII PTS (*.pts)
- Autodesk DXF (*.dxf)
- U3D (*.u3d)
- Adobe PDF (*.pdf)
- Point Cloud Data (*.pcd)
- potree (*.zip)
- Cesium 3D Tiles (*.zip)
- Agisoft OC3 (*.oc3)

**Note**

- Saving color information of the point cloud is not supported by the OBJ and DXF formats.
- Saving point normals information is not supported by the LAS, LAZ, PTS, CL3 and DXF formats.

Metashape supports direct uploading of the point clouds to the following resources: 4DMapper, PointBox, PointScene and Sketchfab. To publish your point cloud online use Upload Data... command from the File menu.

**Tie points and camera calibration, orientation data export**

To export camera calibration and camera orientation data select Export Cameras... command from the File menu.

Metashape supports camera data export in the following formats:

- Agisoft XML structure (*.xml)
- Bundler OUT file format (*.out)
- CHAN file format (*.chan)
- Boujou TXT file format (*.txt)
- Realviz RZML format (*.rzml)
- Omega Phi Kappa text file format (*.txt)
- PATB project (*.pro)
- BINGO project file (*.dat)
- ORIMA file (*.txt)
General workflow

- AeroSys Exterior orientation (*.orn)
- Inpho project file (*.prj)
- Summit Evolution project (*.smtxml)
- Blocks Exchange (*.xml)
- Alembic (*.abc)
- Autodesk FBX (*.fbx)

**Note**

- Camera data export in Bundler and Boujou file formats will save sparse point cloud data in the same file.
- Camera data export in Bundler file format would not save distortion coefficients k3, k4.

To export control points and tie points data one should choose one of the following export formats in the Export Cameras dialog: BINGO, ORIMA, PATB, Summit Evolution or Blocks exchange. Tie points and Control points can be exported only along with interior and exterior orientation parameters of the cameras.

As a result of export in PATB format, the following files will be written:

**example.pro**
- Project file PATB. It contains information on the units of measurement (microns/millimeters). This eliminates the ambiguity in interpreting the data on import.

**example.im**
- File with coordinates of tie points projections on the images.

**example.con**
- File with measured coordinates of the ground control points.

**example.ori**
- File with the calculated parameters of the exterior orientation for the cameras.

**example.at**
- File with the calculated coordinates of tie points (adjusted terrain coordinates).

**Note**

- *.im and *.con formats are input files for PATB and *.ori. and *.at are output formats.

As a result of export in BINGO format, the following files will be written to the destination folder: itera.dat (ITERA file); image.dat (IMAGE COORDINATE file); geoin.dat (GEO INPUT file); gps imu.dat (GPS/IMU data).

As a result of export in Summit Evolution format two files will be created (*.cam, *.smtxml). File in *.cam format includes information about camera calibration parameters. File in *.smtxml format is Summit Evolution project file.

To export / import camera calibration data only select **Camera Calibration...** command from the Tools menu. Using buttons it is possible to load / save camera calibration data in the following formats:

- Agisoft Camera Calibration (*.xml)
General workflow

- Australis Camera Parameters (*.txt)
- Australis v7 Camera Parameters (*.txt)
- PhotoModeler Camera Calibration (*.ini)
- 3DM CalibCam Camera Parameters (*.txt)
- CalCam Camera Calibration (*.cal)
- Inpho Camera Calibration (*.cal)
- USGS Camera Calibration (*.txt)
- Pix4D Camera Calibration (*.cam)
- OpenCV Camera Calibration (*.xml)
- Z/I Distortion Grid (*.dat)

**Panorama export**

Metashape is capable of panorama stitching for images taken from the same camera position - camera station. To indicate for the software that loaded images have been taken from one camera station, one should move those photos to a camera group and assign Camera Station type to it. For information on camera groups refer to Loading images section.

**To export panorama**

1. Select Export Panorama... command from the File menu.
2. Select camera group which panorama should be previewed for.
3. Choose panorama orientation in the file with the help of navigation buttons to the right of the preview window in the Export Panorama dialog.
4. Set exporting parameters: select camera groups which panorama should be exported for and indicate export file name mask.
5. Click OK button
6. Browse the destination folder and click Save button.

Additionally, you can set boundaries for the region of panorama to be exported using Setup boundaries section of the Export Panorama dialog. Text boxes in the first line (X) allow to indicate the angle in the horizontal plane and the second line (Y) serves for angle in the vertical plane limits. Image size (pix) option enables to control the dimensions of the exported image file.

Metashape supports panorama export in the following formats:

- JPEG (*.jpg, *.jpeg)
- JPEG 2000 (*.jp2)
- TIFF (*.tiff, *.tif)
- PNG (*.png)
General workflow

• BMP (*.bmp)
• OpenEXR (*.exr)
• TARGA (*.tga)

3D model export

To export 3D model

1. Select Export Model... command from the File menu.
2. Browse the destination folder, choose the file type, and print in the file name. Click Save button.
3. In the Export Model dialog specify the coordinate system and indicate export parameters applicable to the selected file type.
4. Click OK button to start export.
5. The progress dialog box will appear displaying the current processing status. To cancel processing click Cancel button.

If a model generated with Metashape is to be imported in a 3D editor program for inspection or further editing, it might be helpful to use Shift function while exporting the model. It allows to set the value to be subtracted from the respective coordinate value for every vertex in the mesh. Essentially, this means translation of the model coordinate system origin, which may be useful since some 3D editors, for example, truncate the coordinates values up to 8 or so digits, while in some projects they are decimals that make sense with respect to model positioning task. So it can be recommended to subtract a value equal to the whole part of a certain coordinate value (see Reference pane, Camera coordinates values) before exporting the model, thus providing for a reasonable scale for the model to be processed in a 3D editor program.

Metashape supports model export in the following formats:

• Wavefront OBJ (*.obj)
• 3DS file format (*.3ds)
• VRML models (*.wrl)
• COLLADA (*.dae)
• Stanford PLY (*.ply)
• X3D models (*.x3d)
• STL models (*.stl)
• Alembic (*.abc)
• Autodesk FBX (*.fbx)
• Autodesk DXF Polyline (*.dxf)
• Autodesk DXF 3DFace (*.dxf)
• Open Scene Graph (*.osgb)
• Binary glTF (*.glb)
General workflow

- U3D models (*.u3d)
- Adobe PDF (*.pdf)
- Google Earth KMZ (*.kmz)

Some file formats (OBJ, 3DS, VRML, COLLADA, PLY, FBX) save texture image in a separate file. The texture file should be kept in the same directory as the main file describing the geometry. If the texture atlas was not built only the model geometry is exported.

Metashape supports direct uploading of the models to Sketchfab resource. To publish your model online use Upload Data... command from the File menu.

Tiled model export

To export tiled model

1. Select Export Tiled Model... command from the File menu.
2. Browse the destination folder, choose the file type, and print in the file name. Click Save button.
3. The progress dialog box will appear displaying the current processing status. To cancel processing click Cancel button.

Metashape supports tiled model export in the following formats:

- Cesium 3D Tiles (*.zip)
- Scene Layer Package (*.slpk)
- PhotoMesh Layer (*.zip)
- Agisoft Tiled Model (*.tls)
- Agisoft Tile Archive (*.zip)
- Open Scene Graph (*.osgb)

Agisoft Tiled Model can be visualized in Agisoft Viewer application, which is included in Agisoft Metashape Professional installation package. Thanks to hierarchical tiles format, it allows to responsively visualize large models.

Metashape supports direct uploading of the tiled models to the following resources: 4DMapper, Melown Cloud, Sputnik. To publish your tiled model online use Upload Data... command from the File menu.

Orthomosaic export

To export Orthomosaic

1. Select Export Orthomosaic... command from the File menu.
2. In the Export Orthomosaic dialog box specify coordinate system for the Orthomosaic to be saved in.
3. Check Write KML file and / or Write World file options to create files needed to georeference the orthomosaic in the Google Earth and / or a GIS.
4. Click Export... button to start export.
5. Browse the destination folder, choose the file type, and print in the file name. Click **Save** button.

6. The progress dialog box will appear displaying the current processing status. To cancel processing click **Cancel** button.

**Note**

- Write KML file option is available only if the selected export coordinate system is WGS84 due to the fact that Google Earth supports only this coordinate system.

- World file specifies coordinates of the four corner vertices of the exporting orthomosaic. This information is already included in GeoTIFF file, however, it could be duplicated in the external files for some reason. If orthomosaic is exported in JPEG, PNG or BMP file formats and should have the georeferencing information World file should be written.

If the export file of a fixed size is needed, it is possible to set the length of the longer side of the export file in **Max. dimension (pix)** parameter. The length should be indicated in pixels.

*Split in blocks* option in the Export Orthomosaic dialog can be useful for exporting large projects. You can indicate the size of the blocks (in pix) for the orthomosaic to be divided into. The whole area will be split in equal blocks starting from the point with minimum x and y values. Note that empty blocks will not be saved.

To export a particular part of the project use **Region** section of the Export Orthomosaic dialog. Indicate coordinates of the bottom left and top right corners of the region to be exported in the left and right columns of the text boxes respectively. Estimate button allows you to see the coordinates of the bottom left and top right corners of the whole area.

Alternatively, you can indicate the region to be exported using polygon drawing option in the Ortho view tab of the program window. (For instructions on polygon drawing refer to Shapes section of the manual.) Once the polygon is drawn, right-click on the polygon and set it as a boundary of the region to be exported using **Set Boundary Type** option from the context menu.

Default value for pixel size in Export Orthomosaic dialog refers to ground sampling resolution, thus, it is useless to set a smaller value: the number of pixels would increase, but the effective resolution would not. If you have chosen to export orthomosaic with a certain pixel size (not using **Max. dimension (pix)** option), it is recommended to check estimated **Total size (pix)** of the resulting file to be sure that it is not too large to be correctly saved to the targeted file format.

For (Geo)TIFF export compression type may be set by the user. The following options are available: LZW, JPEG, Packbits, Deflate. Additionally, the file may be saved without compression (None value of the compression type parameter). Write BigTIFF file option allows to save files bigger than standard TIFF limit of 4Gb. **Total size** textbox in the Export Orthomosaic dialog helps to estimate the size of the resulting file. However, it is recommended to make sure that the application you are planning to open the orthomosaic with supports BigTIFF format. Alternatively, you can split a large orthomosaic in blocks, with each block fitting the limits of a standard TIFF file.

While exporting orthomosaic in JPEG format, **JPEG quality** parameter controls balance between compression level (i.e. quality of the result) and export file size: the higher the value of the parameter (%) the more emphasis is on the quality at the expense of a larger resulting file.

The following formats are supported for orthomosaic export:

- TIFF/GeoTIFF (*.tif)
- JPEG 2000 (*.jp2)
General workflow

- JPEG (*.jpg)
- PNG (*.png)
- BMP (*.bmp)
- Google Earth KMZ (*.kmz)
- Google Map Tiles (*.zip)
- MBTiles (*.mbtiles)
- World Wind Tiles (*.zip)
- Tile Map Service Tiles (*.zip)

Metashape supports direct uploading of the orthomosaics to the following resources: 4DMapper, MapBox, Melown Cloud, Picterra, Sputnik. To publish your point cloud online use Upload Data... command from the File menu.

Multispectral orthomosaic export is supported in GeoTIFF format only. When exporting in other formats, only primary channel will be saved. Multispectral orthomosaic has all channels of the original imagery. Optionally the alpha channel may be included that defines transparency being used for no-data areas of the orthomosaic.

**To export Multispectral orthomosaic**

1. Select Export Orthomosaic... command from the File menu.
2. Follow steps 2-3 from Orthomosaic export procedure above.
3. Select None value for Raster transform parameter.
4. Click Export button to start export.
5. Browse the destination folder, choose GeoTIFF type, and print in the file name. Click Save button.
6. The progress dialog box will appear displaying the current processing status. To cancel processing click Cancel button.

**To export Seamlines**

1. Select Generate Seamlines... command from the Orthomosaic submenu from the Tools menu.
2. Click right button on Shapes layer on the Workspace pane.
3. Select Export Layers from the context menu.
4. Browse the destination folder, choose the file type, and print in the file name. Click Save button.
5. The progress dialog box will appear displaying the current processing status. To cancel processing click Cancel button.

The following formats are supported for seamlines export:

- Shape files (*.shp)
- KML files (*.kml)
General workflow

- KMZ files (*.kmz)
- DXF files (*.dxf)
- GeoJSON (*.geojson)

**NDVI data export**

Vegetation index data export is available with the Export Orthomosaic... command from the File menu. Vegetation index data can be saved as two types of data: as a grid of floating point index values calculated per pixel of orthomosaic (multichannel orthomosaic if several vegetation indices have been calculated for the project) or as an orthomosaic in pseudocolours according to a pallet set by user (exports only data for the first vegetation index or combined data for selected 3 vegetation indices, providing that False Color value is set for the Color palette parameter). The format is controlled with Raster transform option in Export Orthomosaic / Export Google KMZ / Export Google Map Tiles / Export MBTiles / Export World Wind Tiles dialogs. None value allows to export orthomosaic generated for the data before any index calculation procedure was performed.

**Digital Elevation Model (DSM/DTM) export**

Metashape allows to calculate and then export both a digital surface model (DSM) and a digital terrain model (DTM) (see Building digital elevation model section).

**To export Digital Elevation Model**

1. Select Export DEM... command from the File menu.
2. In the Export DEM dialog specify coordinate system to georeference the DEM.
3. Check Write KML file and/or Write World file options to create files needed to georeference the DEM in the Google Earth and/or a GIS.
4. Click Export button to start export.
5. Browse the destination folder, choose the file type, and print in the file name. Click Save button.
6. The progress dialog box will appear displaying the current processing status. To cancel processing click Cancel button.

**Note**

- Write KML file option is available only if the model is georeferenced in WGS84 coordinate system due to the fact that Google Earth supports only this coordinate system.
- World file specifies coordinates of the four corner vertices of the exporting DEM. This information is already included in GeoTIFF elevation data as well as in other supported file formats for DEM export, however, you could duplicate it for some reason.

If export file of a fixed size is needed, it is possible to set the length of the longer side of the export file in Max. dimension (pix) parameter. The length should be indicated in pixels.

Unlike orthomosaic export, it is sensible to set smaller pixel size compared to the default value in DEM export dialog; the effective resolution will increase. If you have chosen to export DEM with a certain pixel size (not using Max. dimension (pix) option), it is recommended to check estimated Total size (pix) of the resulting file to be sure that it is not too large to be correctly saved to the targeted file format.
No-data value is used for the points of the grid, where elevation value could not be calculated based on the source data. Default value is suggested according to the industry standard, however it can be changed by user.

Split in blocks option in the Export DEM dialog can be useful for exporting large projects or meeting special DEM requirements. (See Orthomosaic export section for details.)

To export a particular part of the project use Region section of the Export DEM dialog (see Orthomosaic export section for details). Similarly to orthomosaic export, polygons drawn over the DEM on the Ortho tab of the program window can be set as boundaries for DEM export. (For instructions on polygon drawing refer to Shapes section of the manual.)

The following formats are supported for DEM export:

- GeoTIFF elevation data (*.tif)
- Arc/Info ASCII Grid (*.asc)
- Band interleaved file format (*.bil)
- XYZ file format (*.xyz)
- Sputnik KMZ (*.kmz)
- Google Map Tiles (*.zip)
- MBTiles (*.mbtiles)
- World Wind Tiles (*.zip)
- Tile Map Service Tiles (*.zip)

Metashape supports direct uploading of the elevation models to the following resources: 4DMapper, MapBox, Melown Cloud, Sputnik. To publish your elevation model online use Upload Data... command from the File menu.

Note
- In Metashape DEM export colored from RGB palette is supported. Select Palette option in the Raster transform section of the Export DEM dialog box. The palette option is supported for the following export formats: TIFF, JPEG, JPEG2000, PNG.

Render Photos

Metashape allows to render frames from viewpoints specified by the user. This may be useful, for example, in case the target scene is a moving one and it is crucial to keep the number of simultaneously taken frames minimal during capture. A 3D model can be generated based on some optimal number of photos, and later on extra frames can be rendered in Metashape software.

This functionality also allows to correct the initial images in such a way as to make them appropriate for lenticular photography.

Note
- This option is available after Align photos step. Please note that it works only for unreferenced chunk.
To render extra frames from a 3D model

1. Select Render Photos.. command of Export subcommand of File menu.
2. In the Render Photos dialog output image size and filename template.
3. Check Interpolate image positions.
4. Specify the number of images to be rendered.
5. Specify the quality for depth maps calculation (see Building dense point cloud section) and click OK button.
6. In the Model view drag the plane of zero parallax to the desired position.
7. Specify the export area (the part of the scene to be rendered) - adjust the size of the gray plane (drag the corners). Note that yellow rectangles indicate the footprint for all input images.
8. Adjust the step between the viewpoints for images to be rendered. They are marked with blue points. Drag the starting/ending blue dots.
9. Click OK button in the top part of the Model view.
10. Specify the folder for the rendered images to be stored to and click OK button.

To correct the input images for the lenticular photography

1. Select Render Photos.. command of Export subcommand of File menu.
2. In the Render Photos dialog output image size and filename template.
3. Uncheck Interpolate image positions and click OK button.
4. In the Model view drag the plane of zero parallax to the desired position.
5. Specify the export area (the part of the scene to be rendered) - adjust the size of the gray plane (drag the corners). Note that yellow rectangles indicate the footprint for all input images.
6. Adjust the step between the viewpoints for images to be rendered. They are marked with blue points. Drag the starting/ending blue dots.
7. Click OK button in the top part of the Model view.
8. Specify the folder for the rendered images to be stored to and click OK button.

Extra products to export

In addition to main targeted products Metashape allows to export some other processing results, like:

- Convert Images... command is available from Export submenu of the File menu and allows to export free of lens distortions and geometrically corrected images. It also allows to convert large images to a pyramid-optimized TIFF format for prompt navigation in the Photo view mode.

In the Parameters section of the Convert Images dialog window the user can check the following options: Correct distortions, Center principal point, Square pixels, Apply color correction and Update GPS meta data. Metashape supports export of the images with GPS data refined during alignment and additionally corrected basing on the GCPs (if those were used in the project). Filename template for converted images should also be specified in the dialog window.
In the Compression section of the Convert Images dialog window the user can set one of the suggested TIFF compression parameters: LSW, JPEG, Packbits, Deflate; set JPEG quality and specify if Tiled TIFF, BigTIFF file or TIFF overviews should also be saved. The corrections can be applied to all cameras, entire workspace, selected cameras or even to a current photo.

- Depth map for any image (Export Depth... command available from photo context menu). You can export diffuse map, depth map and normal map.

- Individually orthorectified images (Export Orthophotos... command available from Export submenu of the File menu).

- High resolution image of the model as it is shown in the Model view or in Ortho view mode. Capture View command available from the context menu shown on right button click in the Model or Ortho view.

**Note**

- You need to have mesh model generated in the chunk in order to export diffuse map, depth map and normal map.

---

**Survey Statistics**

Metashape generates a report with Survey Statistics. Survey Statistics contains information about camera overlap, camera locations, camera rotations and ground control points. To create a report in the PDF format, read Processing report generation section.

**To create Survey Statistics**

1. Select Survey Statistics command from the Tools menu.

2. The progress dialog box will appear displaying the current processing status. To cancel processing click Cancel button.

3. In the Survey Statistics dialog displayed camera overlap, camera locations, camera rotations and ground control points. Information about survey statistics can be export in the following format: JPEG, JPEG 2000, PNG, TIFF, BMP, OpenEXR, TARGA.

4. Click Close button to close the dialog.

**Survey Statistics Tabs**

**Camera overlap**

Image with camera locations and image overlap.

**Camera locations**

Image with camera locations and error estimates. Z error is represented by ellipse color. X,Y error are represented by ellipse shape. Estimated camera locations are marked with a block dot.

**Camera rotations**

Image shows camera orientations and error estimates

**Ground control points**

Image shows control and check point locations and error estimates. Z error is represented by ellipse color. X,Y errors are represented by ellipse shape. Estimated locations are marked with a dot for control points or T-crossing for check points.
General workflow

Connectivity
During initial image alignment, one or more components are generated, each of which represents a connected photogrammetric network. However, in the process of editing tie points or markers, the connectivity of an individual component may be lost, which will lead to incorrect determination of the relative orientation parameters in the component. The Connectivity tab displays a list of disconnected camera groups, helping to locate possibly misaligned parts in the alignment. The user can add additional markers between listed groups of images or split the groups into separate connected components based on this information.

Processing report generation
Metashape supports automatic processing report generation in PDF format, which contains the basic parameters of the project, processing results and accuracy evaluations.

To generate processing report
1. Select Generate Report... command from the File menu.
2. Browse the destination folder, choose the file type, and print in the file name. Click Save button.
3. The progress dialog box will appear displaying the current processing status. To cancel processing click Cancel button.

Metashape processing report presents the following data:
- Orthomosaic sketch.
- Survey data including coverage area, flying altitude, GSD, general camera(s) info, as well as overlap statistics.
- Camera calibration results: figures and an illustration for every sensor involved in the project.
- Camera positioning and orientation error estimates.
- Ground control and check points error estimates.
- Scale bars estimated distances and measurement errors.
- Digital elevation model sketch with resolution and point density info.
- Processing parameters used at every stage of the project.

Note
- Processing report can be exported after alignment step.

Survey Data
Fig. Camera locations and image overlap - shows the model and position the cameras is shown and the number of overlaps is displayed in color.

Number of images - total number of images uploaded into the project.
Camera stations - number of aligned images.
Flying altitude - average height above ground level.
General workflow

Tie points - total number of valid tie points (equals to the number of points in the sparse cloud).

Ground resolution - effective ground resolution averaged over all aligned images.

Projections - total number of projections of valid tie points.

Coverage area - size of the area that has been surveyed.

Reprojection error - root mean square reprojection error averaged over all tie points on all images.

Table. Cameras - table with the parameters: camera model, resolution, focal length, pixel size, precalibrated.

Reprojection error is the distance between the point on the image where a reconstructed 3D point can be projected and the original projection of that 3D point detected on the photo and used as a basis for the 3D point reconstruction procedure.

Camera Calibration

For precalibrated cameras internal parameters input by the user are shown on the report page. If a camera was not precalibrated, internal camera parameters estimated by Metashape are presented.

Fig. Image residuals for camera - displays the reprojection errors for the tie points detected on the source images, averaged across all the images of the calibration group and inside the certain "cells" on the images.

Camera name (focal length) - camera model name and number of images.

Type - camera type.

Resolution - image dimensions in pixels.

Focal Length - focal length in mm.

Pixel Size - pixel size in µm.

Table. Calibration coefficients and correlation matrix - table with the calibration coefficients and parameters of the covariance matrix (F, Cx, Cy, B1, B2, K1, K2, K3, K4, P1, P2).

Camera Locations

Fig. Camera locations and error estimates - presenting camera locations and error estimates. Z error is represented by ellipse color. X, Y error are represented by ellipse shape. Estimated camera locations are marked with a black dot.

X error (m) - root mean square error for X coordinate for all the cameras.

Y error (m) - root mean square error for Y coordinate for all the cameras.

XY error (m) - root mean square error for X and Y coordinates for all the cameras.

Z error (m) - root mean square error for Z coordinate for all the cameras.

Total error (m) - root mean square error for X, Y, Z coordinates for all the cameras.

Total error = sqrt(Sum_{i=1}^{n} [(X_{i, est} - X_{i, in})^2 + (Y_{i, est} - Y_{i, in})^2 + (Z_{i, est} - Z_{i, in})^2] / n)

X_{i, in} - input value for X coordinate for i camera position,
General workflow

**Camera Orientations**

Fig. **Camera orientations and error estimates** - shows camera orientations and error estimates. Arcs represent yaw error estimates.

- **Yaw error (in degrees)** - error for yaw.
- **Pitch error (in degrees)** - error for pitch.
- **Roll error (in degrees)** - error for roll.
- **Total error (in degrees)** - root mean square error all angles.

**Ground Control and Check Points**

Fig. **GCP locations and error estimates** - displays GCP locations and error estimates. Z error is represented by ellipse color. X,Y errors are represented by ellipse shape. Estimated GCP locations are marked with a dot or crossing.

- **XY error (m)** - root mean square error for X and Y coordinates for a GCP location / check point.
- **Z error (m)** - error for Z coordinate for a GCP location / check point.
- **Error (m)** - root mean square error for X, Y, Z coordinates for a GCP location / check point.
- **Projections** - number of projections for a GCP location / check point over all the images.
- **Error (pix)** - root mean square error for X, Y coordinates on an image for a GCP location / check point averaged over all the images.
- **Total** - root mean square error all the GCP locations / check points.

**Scale Bars**

- **Distance (m)** - scale bar length estimated by Metashape.
- **Error (m)** - difference between input and estimated values for scale bar length.
- **Total** - root mean square error all the scale bars in Control/Check section.

**Digital Elevation Model**

Fig. **Reconstructed digital elevation model** - presenting digital elevation model.

- **Resolution** - effective resolution of the exported DEM. The value depends on the Quality parameter value used at Build point cloud step, providing that DEM has been generated from dense point cloud.
**Point Density** - average number of dense cloud points per square meter.

**Processing Parameters**

Processing report contains processing parameters information, which is also available from Chunk context menu. Along with the values of the parameters used at various processing stages, this page of the report presents information on processing time.

For projects calculated over network processing time will be displayed as a sum of the time spent for processing by each node.

Metashape matches images on different scales to improve robustness with blurred or difficult to match images. The accuracy of tie point projections depends on the scale at which they were located. Metashape uses information about scale to weight tie point reprojection errors. Key point size is the Sigma of the Gaussian blur at the pyramid level of scales at which the key point was found.

In the Reference pane settings dialog tie point accuracy parameter corresponds to the normalized accuracy - i.e. accuracy of tie point projection detected at the scale equal to 1. Tie points detected on other scales will have accuracy proportional to their scales. This helps to obtain more accurate bundle adjustment results.

On the processing parameters page of the report (as well as in chunk information dialog) two reprojection errors are provided: the reprojection error in the units of key point scale (this is the quantity that is minimized during bundle adjustment), and the reprojection error in pixels (for convenience). The Mean key point size value is averaged Key point size value over all key points. Average tie point multiplicity value is the ratio of the total number of projections to the number of tie points.

**Camera track creation and fly through video rendering**

In Metashape you can create an overview video of the model along a certain trajectory. Camera track can be created automatically (using simple preset options), imported from external file and edited manually.

To manually create a track and add a viewpoint, click **Append** button on the **Animation** pane. Append option will add the current viewpoint to the active camera track.

**To create Horizontal track**

1. Select **Animation** command from the **View** menu.
2. Click **Create** button on the **Animation** pane toolbar.
3. Choose **Horizontal** preset parameter in **Create Track** dialog window and set the **Keyframe count**.
4. Click **OK** button.
5. Adjust the position of the viewpoint in the camera track in **Model** view by dragging the left mouse button to display it visually.

**To create Vertical track**

1. Select **Animation** command from the **View** menu.
2. Click **Create** button on the **Animation** pane toolbar.
3. Choose *Vertical* preset parameter in *Create Track* dialog window and set the *Keyframe count*.

4. Click *OK* button.

5. Adjust the position of the viewpoint in the camera track in *Model* view by dragging the left mouse button to display it visually.

**Note**

- To display the camera track path, select *Show animation* command from the *Show/Hide items* submenu on the *Model* menu.

Camera track parameters can be adjusted in the *Animation Settings* dialog window. The following parameters can be changed: Camera Track Label, Duration (in seconds), Field of view (deg), Smooth camera track option, Loop camera track option, Rotation angles convention. Click *Settings* button on the *Animation* pane to open *Animation Settings* dialog.

**To record the video**

1. To record the video according to the created camera track to the external file click on *Capture* on the *Animation* pane toolbar.

2. Select the desired export parameters in the *Capture Video* dialog, such as export video resolution, compression type and frame rate.

3. To save the track path to external file click *Save* button on the *Animation* pane.

Metashape supports camera track export in the following formats:

- Camera Path
- KML

**Note**

- That KML format is only supported for projects georeferenced in geographic/projected systems convertible to WGS84 system.
Chapter 4. Referencing

Camera calibration

Calibration groups

While carrying out photo alignment Metashape estimates both internal and external camera orientation parameters, including nonlinear radial distortions. For the estimation to be successful it is crucial to apply the estimation procedure separately to photos taken with different cameras. Once photos have been loaded in the program, Metashape automatically divides them into calibration groups according to the image resolution and/or EXIF meta data like camera type and focal length. All the actions described below could and should be applied (or not applied) to each calibration group individually.

Calibration groups can be rearranged manually.

To create a new calibration group

1. Select Camera Calibration... command from the Tools menu.
2. In the Camera Calibration dialog box, select photos to be arranged in a new group.
3. In the right-click context menu choose Create Group command.
4. A new group will be created and depicted on the left-hand part of the Camera Calibration dialog box.

To move photos from one group to another

1. Select Camera Calibration... command from the Tools menu.
2. In the Camera Calibration dialog box choose the source group on the left-hand part of the dialog.
3. Select photos to be moved and drag them to the target group on the left-hand part of the Camera Calibration dialog box.

To place each photo into a separate group you can use Split Groups command available at the right button click on a calibration group name in the left-hand part of the Camera Calibration dialog.

Camera types

Metashape supports four major types of camera: frame camera, fisheye camera, spherical camera and cylindrical camera. Additionally RPC camera type is available for satellite imagery that is accompanied with the RPC meta information. Camera type can be set in Camera Calibration dialog box available from Tools menu.

Frame camera. If the source data within a calibration group was shot with a frame camera, for successful estimation of camera orientation parameters the information on approximate focal length (pix) is required. Obviously, to calculate focal length value in pixel it is enough to know focal length in mm along with the sensor pixel size in mm. Normally this data is extracted automatically from the EXIF meta data.

Frame camera with Fisheye lens. If extra wide lenses were used to get the source data, standard Metashape camera model will not allow to estimate camera parameters successfully. Fisheye camera type setting will initialize implementation of a different camera model to fit ultra-wide lens distortions.

Spherical camera (equirectangular projection). In case the source data within a calibration group was shot with a spherical camera, camera type setting will be enough for the program to calculate camera orientation
parameters. No additional information is required except the image in equirectangular representation. This type of camera will also be used for images obtained from Laser Scanners.

Spherical camera **Cylindrical** projection. In case the source data within a calibration group is a set of panoramic images stitched according to cylindrical model, camera type setting will be enough for the program to calculate camera orientation parameters. No additional information is required.

Satellite images with **RPC** coefficients. To automatically detect the camera type, select **Preferences** command from **Tools** menu. Click **Advanced** tab and turn on the check box **Load satellite RPC data from auxiliary TXT files**.

Optionally rolling shutter compensation can be enabled by checking the **Enable rolling shutter compensation** box in the **Camera Calibration** dialog available from **Tools** menu.

In case source images lack EXIF data or the EXIF data is insufficient to calculate focal length in pixels, Metashape will assume that focal length equals to 50 mm (35 mm film equivalent). However, if the initial guess values differ significantly from the actual focal length, it is likely to lead to failure of the alignment process. So, if photos do not contain EXIF meta data, it is preferable to specify focal length (mm) and sensor pixel size (mm) manually. It can be done in **Camera Calibration** dialog box available from **Tools** menu. Generally, this data is indicated in camera specification or can be received from some online source. To indicate to the program that camera orientation parameters should be estimated based on the focal length and pixel size information, it is necessary to set the **Type** parameter on the **Initial** tab to **Auto** value.

## Scanned images

Metashape supports processing of analog aerial images scanned to digital files. On uploading, all the scanned images from the same analog camera should be placed in a designated calibration group. Metashape will automatically put the cameras to the same calibration group, providing that they have been scanned to the images of the same resolution. In case scanned analog images from different cameras have been uploaded to the same chunk, it is required to divide them manually into different calibration groups. It could be done in **Camera Calibration** dialog available from **Tools** menu.

Camera calibration in case of scanned images is performed based on the fiducial marks information. That is why camera calibration starts with fiducial marks detection in this workflow. Metashape enables automatic detection of most of the fiducial mark types. See Figure below.

![Supported fiducial marks.](image)

### Note

- Fiducial marks detection can be only performed for Film cameras. Don't forget to enable the **Film camera with fiducial marks** option in the **Camera Calibration** dialog box for all the groups which contain corresponding scanned images.

#### To calibrate scanned images with automatically detectable fiducial marks

1. Select **Camera Calibration...** command from the **Tools** menu.
2. In the **Camera Calibration** dialog box check **Film camera with fiducial marks** option.
3. Close **Camera Calibration** dialog with **OK** button.
4. Run *Detect Fiducials...* command from the *Markers* submenu from the *Tools* menu.

5. In the *Camera Calibration* dialog box print in coordinates of the automatically detected fiducial marks on the image according to the analog camera certificate. They should be measured in coordinate system associated with the sensor: origin - in the center of the sensor; axes X - to the right, axes Y - downwards; in millimeters (mm).

6. Close *Camera Calibration* dialog with *OK* button and proceed to general Metashape processing workflow starting from *Align Photos...* step. The software will automatically scale and orientate all the photos according to the fiducial marks information.

In case your fiducial marks type is not among those supported for automatic detection (see Figure above), please place a feature request with Agisoft support team: support@agisoft.com. The current version of the software allows to perform calibration of the scanned images based on such fiducial marks manually following the procedure outlined below.

### To calibrate scanned images with non-standard fiducial marks manually

1. Select *Camera Calibration...* command from the *Tools* menu.

2. In the *Camera Calibration* dialog box check *Film camera with fiducial marks* option.

3. On the *Fiducials* tab add fiducial mark instances, the number should be equal to the amount of fiducial marks used on the original photos.

4. Print in coordinates of the fiducial marks on the image according to the analog camera certificate. They should be measured in coordinate system associated with the sensor: origin - in the center of the sensor; axes X - to the right, axes Y - downwards; in millimeters (mm).

5. Close *Camera Calibration* dialog with *OK* button.

6. Then it is necessary to place all the fiducials on each photo from the calibration group.

7. Open the photo in *Photo* view.

8. Zoom in to a fiducial mark center.

9. Right button click on the targeted fiducial mark and use *Place Fiducial* command from the context menu. You will need to choose a corresponding fiducial mark instance from the dropdown list.

10. In case you need to replace one fiducial mark with another right-click fiducial mark and use *Replace Fiducial* command from its context menu. You will need to choose a corresponding fiducial mark instance from the dropdown list.

11. After placing all the fiducial mark instances, you can proceed to general Metashape processing workflow. The software will automatically scale and orientate all the photos according to the fiducial marks information.

**Note**

- If there is no camera certificate with fiducial marks coordinates information for the data set in question, then it will be necessary to additionally run *Calibrate Fiducials...* command from the context menu of the selected images in the *Camera Calibration* dialog box. All the images from the respective calibration group should be selected for the purpose.

- It is recommended to mask out all the margins with auxiliary information on scanned photos to avoid negative effect on the stability of the further processing.
Camera calibration parameters

Photogrammetric calibration of cameras is performed to determine the values of the interior orientation of the cameras, including the parameters of distortion of the camera lens. The camera calibration parameters can be input manually, if they have been acquired as a part of precalibration procedure.

To specify camera calibration parameters

1. Select Camera Calibration... command from the Tools menu.
2. Select calibration group, which requires re-estimation of camera orientation parameters on the left side of the Camera Calibration dialog box.
3. In the Camera Calibration dialog box, select Initial tab.
4. Modify the calibration parameters displayed in the corresponding edit boxes.
5. Set the Type to the Precalibrated value.
6. Repeat to every calibration group where applicable.
7. Click OK button to set the calibration.

The following calibration parameters are available:

- **f**
  - Focal length measured in pixels.

- **cx, cy**
  - Principal point coordinates, i.e. coordinates of lens optical axis interception with sensor plane in pixels.

- **b1, b2**
  - Affinity and Skew (non-orthogonality) transformation coefficients.

- **k1, k2, k3, k4**
  - Radial distortion coefficients.

- **p1, p2**
  - Tangential distortion coefficients.

**Note**

- Alternatively, initial calibration data can be imported from file using Load button on the Initial tab of the Camera Calibration dialog box. In addition to Agisoft calibration file format it is possible to import data from Australis, PhotoModeler, 3DM CalibCam, CalCam, Inpho camera calibration, USGS camera calibration, OpenCV and Z/I Distortion Grid formats.

Initial calibration data will be adjusted during the Align Photos processing step. Once Align Photos processing step is finished adjusted calibration data will be displayed on the Adjusted tab of the Camera Calibration dialog box. The details about distortion models used in Metashape are given in the Appendix C, Camera models section.

If very precise calibration data is available, click Select... button next to Fixed parameters: item. In Fixed parameters dialog choose calibration parameters that are to be fixed and click OK button. The initial values for the chosen parameters will not be changed during Align Photos or Optimize Cameras operations.

In some cases it may be required to estimate some sub-set of parameters individually for each camera in the calibration group. In this case such parameters should be selected in the section Image-variant parameters. Click Select button and choose these parameters in Image-variant parameters dialog box.
Adjusted camera calibration data can be saved to file using *Save* button on the *Adjusted* tab of the *Camera Calibration* dialog box.

**Analyzing calibration results**

Metashape provides a number of tools to analyze camera calibration results available from context menu of a camera group in the *Camera Calibration* dialog.

**Distortion**

*Distortion* tab presents estimated camera distortion plot. Total, Radial, Decentering, Corrections and Residual options are available in the tab. Distortion graph represent the distortion values and direction according to the adjusted calibration coefficient values. It shows the plot in the discrete vectors mode for a central point in the corresponding image cell. Residuals presents residuals graph which allows to evaluate how adequately the camera is described with the applied mathematical model. Note that residuals are averaged per cell of an image and then across all the images in a camera group. Scale reference under the plot indicates the scale of the distortions/residuals.

**Profile**

*Profile* tab presents increase of the corresponding radial and decentering distortions with distance from the center of the photo. Profiles can be saved as image.

**Correlation**

*Correlation* tab presents:

- Adjusted values of the internal camera orientation parameters;
- Errors - standard deviation, read more in *Covariance matrix* section;
- Correlation values for internal camera orientation parameters - reflect the degree of correlation between the corresponding parameters.

**Vignetting**

*Vignetting* tab presents radiometric distortion of the lens. Metashape uses radiometric distortion parameters of the lens from photos metadata, in case there is no information about radiometric distortion of the lens in photo metadata *Vignetting* tab is inactive. You can calculate radiometric distortion manually using *Calibrate Colors* command available from the *Tools* menu, read more in *Building model texture* section.

**Setting coordinate system**

Many applications require data with a defined coordinate system. Setting the coordinate system also provides a correct scaling of the model allowing for surface area and volume measurements and makes model loading in geoviewers and geoinformation software much easier. Some Metashape functionality like digital elevation model export is available only after the coordinate system is defined.

Metashape supports setting a coordinate system based on ground control point (marker) coordinates and/or camera coordinates. In both cases the coordinates are specified in the *Reference* pane and can be either loaded from the external file or typed in manually. Initially Metashape expects both GCPs and camera coordinates data to be specified in the same coordinate system and assigns it as the coordinate system of the chunk. In such a case all the outputs by default will be referenced in this particular coordinate system.

If the GCPs and camera coordinates data is measured in different coordinate systems, Metashape allows to input this data as is, provided that either all the coordinate systems are based on the same datum or for all of them transformation-to-WGS84 parameters are specified in the coordinate system definition or manually set in the datum transformation settings dialog. For Metashape to correctly interpret the coordinates data, it is necessary to enable individual coordinate system selection for cameras and markers in the *Reference* pane.
Referencing

pane settings dialog by checking the corresponding option and selecting proper coordinate systems. In this case coordinate system to reference the model in (coordinate system of the chunk) should be set in the Reference pane settings dialog - in the very first dropdown menu list.

Setting coordinate system based on recorded camera positions is often used in aerial photography processing. However, it may be also useful for processing close-range data sets collected with GPS enabled cameras. Placing markers is not required if recorded camera coordinates are used to initialize the coordinate system.

In case ground control points are used to set up the coordinate system, markers should be placed in the corresponding locations of the scene.

Using camera data for georeferencing is faster since manual marker placement is not required. On the other hand, ground control point coordinates are usually more accurate than telemetry data, allowing for more precise georeferencing. During georeferencing process the model is linearly transformed using 7 parameter similarity transformation (3 parameters for translation, 3 for rotation and 1 for scaling). Such transformation can compensate only for linear model misalignment.

Placing markers

Metashape uses markers to specify locations within the scene. Markers are used for setting up a coordinate system, photo alignment optimization, measuring distances and volumes within the scene as well as for marker based chunk alignment. The position of markers is determined by their coordinates in the images. Alternatively, it is possible to set Drawing Plane for marker placement in the Model view. Read more about setting drawing plane in Shapes section.

To determine the spacial coordinates of the markers, it is necessary to measure planar coordinates of the markers on at least 2 images.

![Note]

- Marker placement is not required for setting up a coordinate system based on recorded camera coordinates. Instead the ground control points (GCPs) can be used to improve the accuracy of results.

Metashape supports two approaches to marker placement: manual marker placement and guided marker placement. Manual approach implies that the marker projections should be indicated manually on each photo where the marker is visible. Incorrect projection markers affect accuracy. Be careful when placing the markers on the images, specify the exact position, and see that the markers are not obscured by foreign objects (for example, grass or foliage). In such cases, it is better not to put a marker on such an image. Manual marker placement does not require 3D model and can be performed even before photo alignment.

In the guided approach marker projection is specified for a single photo only. Metashape automatically projects the corresponding ray onto the model surface and calculates marker projections on the rest of the photos where marker is visible. Marker projections defined automatically on individual photos can be further refined manually. Reconstructed 3D model surface is required for the guided approach.

Guided marker placement usually speeds up the procedure of marker placement significantly and also reduces the chance of incorrect marker placement. It is recommended in most cases unless there are any specific reasons preventing this operation.

Ground control and check points

In Metashape you can use two types of markers. They are control and check points. Control points are used to reference the model. While check points are used to validate accuracy of the camera alignment and optimization procedures results.
To create a control/check point

1. Select marker on the Reference pane.

2. Ensure that the selected marker has at least two projections placed on the aligned images. You should check points box. If the check box is enabled, the point is the control point. When check box is disable, the point is the check point.

3. Input control/check point coordinates information to the Source Values tab of the Reference pane.

4. Enable marker on the Reference pane to make it a control point or disable to use it as a check point.

5. Control and check point errors can be inspected on the Errors Values tab.

Note

• After you change the point type click Update toolbar button from the Reference pane.

• After use the Update button, the 7th parametric transformation is performed.

To place a marker using guided approach

1. Open a photo where the marker is visible by double clicking on its name.

2. Switch to the marker editing mode using Show Markers toolbar button.

3. Right click on the photo at the point corresponding to the marker location.

4. Select Add Marker command from the context menu. New marker will be created and its projections on the other photos will be automatically defined.

Note

• If the 3D model is not available or the ray at the selected point does not intersect with the model surface, the marker projection will be defined on the current photo only.

• Guided marker placement can be performed in the same way from the 3D view by right clicking on the corresponding point on the model surface and using Create Marker command from the context menu. While the accuracy of marker placement in the 3D view is usually much lower, it may be still useful for quickly locating the photos observing the specified location on the model.

To view the corresponding photos use Filter Photos by Markers command again from the 3D view context menu. If the command is inactive, please make sure that the marker in question is selected on the Reference pane.

• If the circle under the flag is red in the Model view, the marker is selected. If yellow - the marker is not selected.

To place a marker using manual approach

1. Create marker instance using Add marker button on the Workspace pane or by Add Marker command from the Chunk context menu.

2. Open the photo where the marker projection needs to be added by double clicking on the photos name.
3. Switch to the marker editing mode using \textit{Show Markers} toolbar button.

4. Right click at the point on the photo where the marker projection needs to be placed. From the context menu open \textit{Place Marker} submenu and select the marker instance previously created. The marker projection will be added to the current photo.

5. Repeat the previous step to place marker projections on other photos if needed.

To save up time on manual marker placement procedure Metashape offers guiding lines feature. When a marker is placed on an aligned photo, Metashape highlights lines, which the marker is expected to lie on, on the rest of the aligned photos.

\begin{itemize}
  \item If a marker has been placed on at least two aligned images Metashape will find the marker projections on the rest of the photos. The calculated marker positions will be indicated with icon on the corresponding aligned photos in \textit{Photo} view mode.
\end{itemize}

Automatically defined marker locations can be later refined manually by dragging their projections on the corresponding photos.

The commands \textit{Unpin marker} and \textit{Block marker} are available from the context menu of the marker on the image. To reset the updated marker position, select \textit{Unpin marker} command, the marker will display as a blue flag. If \textit{Blocks marker} option is selected, then the marker projection on particular image will not be displayed.

\section*{To refine marker location}

1. Open the photo where the marker is visible by double clicking on the photo's name. Automatically placed marker will be indicated with icon.

2. Switch to the marker editing mode using \textit{Edit Markers} toolbar button.

3. Move the marker projection to the desired location by dragging it using left mouse button. Once the marker location is refined by user, the marker icon will change to icon.

\begin{itemize}
  \item To list photos where the marker locations are defined, select the corresponding marker on the \textit{Workspace} pane. The photos where the marker is placed will be marked with a icon on the \textit{Photos} pane. To filter photos by marker use \textit{Filter by Markers} command from the 3D view context menu.
\end{itemize}

In those cases when there are hesitations about the features depicted on the photo, comparative inspection of two photos can prove to be useful. To open two photos in Metashape window simultaneously \textit{Move to Other Tab Group} command is available from photo tab header context menu.

Metashape supports automatic marker projection refinement based on the image content. Choose \textit{Refine Markers} command from the \textit{Markers} submenu of the \textit{Tools} menu.

\section*{To open two photos simultaneously}

1. In the \textit{Photos} pane double click on one photo to be opened. The photo will be opened in a new tab of the main program window.
2. Right click on the tab header and choose Move to Other Tab Group command from the context menu. The main program window will be divided into two parts and the photo will be moved to the second part.

3. The next photo you will choose to be opened with a double click will be visualized in the active tab group.

Metashape automatically assigns default labels for each newly created marker. These labels can be changed using the Rename... command from the marker context menu in the Workspace / Reference pane.

**Assigning reference coordinates**

To reference the model, real world coordinates of at least 3 points of the scene should be specified. Depending on the requirements, the model can be referenced using marker coordinates, camera coordinates, or both. Real world coordinates used for referencing the model along with the type of coordinate system are specified in the Reference pane.

The model can be located in either local Euclidean coordinates or in georeferenced coordinates. Metashape supports a wide range of various geographic and projected coordinate systems, including widely used WGS84 coordinate system. Besides, almost all coordinate systems from the EPSG registry are supported as well.

**Methods to input coordinates data**

Reference coordinates can be specified in one of the following ways:

- Loaded from a separate text file (using character separated values format).
- Entered manually in the Reference pane.
- Loaded from GPS EXIF tags (if present).

**To load reference coordinates from a text file**

1. Click Import toolbar button on the Reference pane. (To open Reference pane use Reference command from the View menu.) Browse to the file containing recorded reference coordinates and click Open button.
2. In the Import CSV dialog set the coordinate system if the data presents geographical coordinates.
3. Select the delimiter and indicate the number of the data column for each coordinate.
4. Indicate columns for the orientation data if present. Make sure that the proper angle triple (according to the source data) is set: [yaw, pitch, roll], [omega, phi, kappa], [phi, omega, kappa] or [alpha, nu, kappa].
5. Optionally, indicate accuracy values for coordinates and rotation angles.
6. Click OK button. The reference coordinates data will be loaded onto the Reference pane.

**Note**

- If reference coordinates of a marker / camera position for a photo are not specified in the loading file the current value will be kept for them.
- An example of a coordinates data file in the CSV format is given in the next section.
Information on the accuracy of the source coordinates (x, y, z) as well as of the source orientation angles can be loaded with a CSV file as well. Check Load Accuracy option and indicate the number of the column where the accuracy for the data should be read from. It is possible to indicate the same accuracy column for all three coordinates/angles.

**To assign reference coordinates manually**

1. Switch to the View Source mode using View Source button from the Reference pane toolbar. (To open Reference pane use Reference command from the View menu.)
2. On the Reference pane select x/y/z or angle data cells and press F2 button on the keyboard to assign values to corresponding coordinates/angles.
3. Repeat for every marker/camera position (orientation angle) needed to be specified.
4. To remove unnecessary reference coordinates select corresponding items from the list and press Del key.
5. Click Update toolbar button to apply changes and set coordinates.

System of angular elements of exterior orientation([yaw,pitch,roll], [omega, phi, kappa] or [alpha, nu, kappa]) can be switched in the Reference Settings dialog. Do not forget to click OK button in the Reference Settings dialog to apply the changes.

Additionally, it is possible to indicate accuracy data for the coordinates / orientation angles. Select Set Accuracy... command from the context menu of an image on the Reference pane and input accuracy data both for position (i.e. x,y,z coordinates) and orientation (i.e. [yaw, pitch, roll], [omega, phi, kappa], [phi,omega,kappa] or [alpha, nu, kappa] angles) data. It is possible to select several cameras and apply Set Accuracy... command simultaneously to all of them. Alternatively, you can select Accuracy (m) or Accuracy (deg) text box for a certain camera on the Reference pane and press F2 button on the keyboard to type the text data directly onto the Reference pane. Note that "/" delimiter allows to enter different accuracy data for x, y, z or orientation angles ([yaw, pitch, roll], [omega, phi, kappa], [phi,omega,kappa] or [alpha, nu, kappa]) data respectively.

**To load reference coordinates from GPS EXIF tags**

1. Click Import EXIF button on the Reference pane. (To open Reference pane use Reference command from the View menu.) The reference coordinates data will be loaded into the Reference pane.
2. If the corresponding options in the Advanced tab o the Preferences window are checked on, it is also possible to load camera orientation angles and location/rotation accuracy parameters from XMP extension of the image header. The data will be loaded upon clicking Import EXIF button.

**Camera orientation angles conventions**

Metashape allows to define camera orientation with either [yaw, pitch, roll], [omega, phi, kappa], [phi, omega, kappa] or [alpha, nu, kappa] angles. The more common scenario is to load [yaw, pitch, roll] measurements directly from the airborne IMU system and, hence, default setting in Metashape is to tackle the input values as [yaw, pitch, roll] data.

To provide compatibility with different processing workflows Metashape also supports [omega, phi, kappa] data input. The omega, phi, kappa angles are defined as the angles used in order to rotate the (X,Y,Z) geodetic coordinate system and align it with the image coordinate system.
• Omega is the rotation around the X axis.
• Phi is the rotation around the Y axis.
• Kappa is the rotation around the Z axis.

Yaw, Pitch, Roll definition:
• Yaw is the rotation around the Z axis.
• Pitch is the rotation around the Y axis.
• Roll is the rotation around the X axis.

Alpha, Nu, Kappa definition:
• Alpha is the rotation around the Z axis.
• Nu is the rotation around the X axis.
• Kappa is the rotation around the Y axis.

RTK/PPK camera coordinates data
If the source data includes RTK/PPK measurements, it is important to input accuracy values for all the respective cameras onto the Reference pane. Otherwise default accuracy value (10 m) will be assumed for all camera coordinates in the chunk, hence, the value of the RTK/PPK measurements will efficiently be lost and the processing results will not be referenced with expected accuracy. In case the coordinates input for the cameras are measured for the point where the measuring instrument is mounted (not the camera itself) it is also necessary to input measurement instrument shift with respect to the camera itself on GPS/INS Offset tab of Camera Calibration dialog available from Tools menu.

After reference coordinates have been assigned Metashape automatically estimates coordinates in a local Euclidean system and calculates the referencing errors. To see the results switch to the View Estimated or View Errors modes respectively using View Estimated and View Errors toolbar buttons.

Setting georeferenced coordinate system

To set a georeferenced coordinate system
1. Assign reference coordinates using one of the options described above.
2. Click Settings button on the Reference pane toolbar.
3. In the Reference Settings dialog box select the Coordinate System used to compile reference coordinates data if it has not been set at the previous step.
4. Specify the assumed measurement accuracy in the left-hand side part of the dialog.
5. If the information about GPS system shift with respect to the camera itself is available, it is worth inputting it on GPS/INS Offset tab of Camera Calibration dialog available from Tools menu. See Figure below.
6. Specify the assumed image coordinates accuracy in the corresponding column of the dialog.
7. Specify Capture distance parameters for the datasets where the images are captured with the oblique camera mount (more than 20-30 degrees from the vertical).

8. Click OK button to initialize the coordinate system and estimate geographic coordinates.

Note

- When the coordinate information for the camera locations is present in the Source values tab of the Reference pane and the Capture Distance parameter is not defined, the Reference Pair Preselection will consider only XYZ coordinates for preliminary identification of the overlapping image pairs. For each camera the certain number of closest neighbors will be selected for the image matching operation.

- When the Capture Distance parameter is input and camera orientation angles (yaw, pitch, roll or omega, phi, kappa) are present along with the XYZ camera locations in the Reference pane, then for the neighbors estimation the following points are considered: from the original camera locations the vector is sent according to the orientation angles, the length of the vector is equal to the Capture Distance parameter values. So for each camera the new 3D location is calculated ($X'Y'Z'$) and these new points are used for the neighbors estimation.

- If camera orientation angles are not loaded to the Source values tab or Reference preselection is not enabled in the Align Photos dialog, the Capture Distance parameter will be ignored.

**GPS/INS Offset**

Rotation angles for the camera coordinates in Metashape are defined around the following axes: yaw axis runs from top to bottom, pitch axis runs from left to right wing of the drone, roll axis runs from tail to nose.
of the drone. Zero values of the rotation angle triple define the following camera position aboard: camera looks down to the ground, frames are taken in landscape orientation, and horizontal axis of the frame is perpendicular to the central (tail-nose) axis of the drone. If the camera is fixed in a different position, respective yaw, pitch, roll values should be input on GPS/INS Offset tab of Camera Calibration dialog. The signs of the angles are defined according to the right-hand rule. See Figure below.

Note

- Step 5 can be safely skipped if you are using standard GPS system (not that of superhigh precision).

In Select Coordinate System dialog it is possible to ease searching for the required georeferencing system using Filter option. Enter respective EPSG code (e.g. EPSG::4302) to filter the systems.

Coordinate system editor

If the target coordinate system is not on the list, it is possible to set its parameters manually. In Select Coordinate System dialog choose any coordinate system and click Edit button. (Obviously, it is optimal to select a coordinate system which parameters are the most similar ones to the target coordinate system.) Enter the proper name for the system to be shown on the list and edit all the parameters according to the coordinate system definition.

Configurable datum transformation

If the project coordinate system should be converted to WGS84, Datum Transformation Settings dialog is aimed at controlling proper parameters for the conversion. The dialog can be accessed via Settings button next to Coordinate System selection field in the Reference Settings dialog.
Using different vertical datums

On default Metashape requires all the source altitude values for both cameras and markers to be input as values measured above the ellipsoid. However, Metashape allows for the different geoid models utilization as well. Metashape installation package includes only EGM96 geoid model, but additional geoid models can be downloaded from Agisoft’s website if they are required by the coordinate system selected in the Reference pane settings dialog. Downloaded geoid model from the supported list should be copied to \geoids\ folder in Metashape installation directory before using the corresponding coordinate system from GUI.

Please refer to the following web-page to review the list of supported geoid models: http://www.agisoft.com/downloads/geoids/.

Additional features of the Reference pane

To view the estimated geographic coordinates, reference errors and variance switch between the View Estimated, View Errors and View Variance modes respectively using View Estimated, View Errors and View Variance toolbar buttons. A click on the column name on the Reference pane sorts the markers and cameras by the data in the column. At this point you can review the errors and decide whether additional refinement of marker locations is required (in case of marker based referencing), or if certain reference points should be excluded.

To save the errors and/or estimated coordinates use Export toolbar button on the Reference pane.

To reset a chunk georeferencing, use Reset Transform command from the chunk context menu on the Workspace pane. [R] indicator of a chunk being georeferenced will be removed from the chunk name.

Note

- Unchecked reference points on the Reference pane are not used for georeferencing and optimization. Use context menu to check/uncheck selected items.
- After adjusting marker locations on the photos, the coordinate system will not be updated automatically. It should be updated manually using Update toolbar button on the Reference pane.
- Metashape allows to convert the estimated geographic coordinates into a different coordinate system. To calculate the coordinates of the camera positions and/or markers in a different coordinate system use Convert toolbar button on the Reference pane.

Example of a reference coordinates file in CSV format (*.txt)

The reference coordinates can be loaded onto the Reference pane using character separated text file format. Each reference point is specified in this file on a separate line. Sample reference coordinates file is provided below:
# Reference

<table>
<thead>
<tr>
<th>&lt;label&gt;</th>
<th>&lt;longitude&gt;</th>
<th>&lt;latitude&gt;</th>
<th>&lt;height&gt;</th>
<th>&lt;yaw&gt;</th>
<th>&lt;pitch&gt;</th>
<th>&lt;roll&gt;</th>
</tr>
</thead>
<tbody>
<tr>
<td>IMG_01.JPG</td>
<td>40.165011</td>
<td>48.103654</td>
<td>433.54</td>
<td>15.54</td>
<td>0.39</td>
<td>0.87</td>
</tr>
<tr>
<td>IMG_02.JPG</td>
<td>40.165551</td>
<td>48.103654</td>
<td>434.72</td>
<td>15.73</td>
<td>0.38</td>
<td>1.21</td>
</tr>
<tr>
<td>IMG_03.JPG</td>
<td>40.166096</td>
<td>48.103640</td>
<td>435.63</td>
<td>15.67</td>
<td>0.24</td>
<td>1.04</td>
</tr>
</tbody>
</table>

Individual entries on each line should be separated with a tab (space, semicolon, comma, etc) character. All lines starting with # character are treated as comments.

Records from the coordinate file are matched to the corresponding cameras or markers basing on the label field. Camera coordinates labels should match the file name of the corresponding photo including extension. Marker coordinates labels should match the labels of the corresponding markers in the project file. All labels are case insensitive.

Metashape has the ability to use degrees, minutes, seconds in a CSV file. An example entry:

```
IMG00001.jpg,19°39'59.99"E,60° 20'0.05"N,100.073997
```

or "colon" delimiter:

```
IMG00002.jpg,19:39:59.99E,60:20:0.05N,100.073997
```

- **Note**
  - Character separated reference coordinates format does not include specification of the type of coordinate system used. The kind of coordinate system used should be selected separately in the Reference Settings dialog.
  - Metashape requires Z value to be indicating the height above the ellipsoid (or above geoid, if corresponding compound coordinate system is selected in the Reference pane settings dialog).

## Optimization

### Optimization of camera alignment

Optimize Cameras command performs a full bundle adjustment procedure on the aligned photogrammetric block, simultaneously refining exterior and interior camera orientation parameters and triangulated tie point coordinates. Adjustment is performed based on all available measurements and corresponding accuracies, including image projections of tie points and markers, GPS coordinates of image centers, GCP coordinates, scale bar distances, etc.

- **Note**
  - If markers are used for the optimization process, we recommend distributing the control points evenly over the survey object. It is also necessary that the markers are not located on one straight line.
To ensure maximum geometric accuracy of processing results, it is important to always optimize cameras after adding or editing measured values and/or their accuracies, e.g. loading GPS camera coordinates, adding GCPs, changing accuracy settings.

![Note]

- By default optimization adjusts both exterior and interior camera orientation parameters. When working with a pre-calibrated camera, it is possible to load available calibration in the Camera Calibration dialog and set its parameters as fixed. Fixed parameters will not be adjusted during optimization step.

To optimize camera alignment

1. Set the marker and/or camera coordinates to be used for optimization (if not done yet).

2. Click **Settings** toolbar button on the Reference pane and set the coordinate system (if not done yet).

3. In the Reference pane Settings dialog box specify the assumed accuracy of measured values as well as the assumed accuracy of marker projections on the source photos.

4. Click **OK** button.

5. Indicate relative GPS device and/or INS to camera coordinates (if info is available) on GPS/INS Offset tab of Camera Calibration dialog available from Tools menu.

6. Check Adjust GPS/INS offset box.

7. Click **OK** button.

8. Click **Optimize** toolbar button on the Reference pane.

9. In Optimize Camera Alignment dialog box check additional camera parameters to be optimized.

10. Click **OK** button to start optimization.

![Note]

- Step 5 can be safely skipped if you are using standard GPS (not that of extremely high precision).

- Using RTK / PPK camera coordinates data will also provide more accurate results. More details about using RTK / PPK data can be found in Setting coordinate system section.

- The optimization procedure discards active depth maps, dense cloud and mesh model from the chunk. It is recommended to rebuild these objects after performing the optimization.

- The optimization process can improve the results of alignment and reduce the errors.

**Optimize Camera Alignment parameters**
Fit additional corrections
With this option enabled Metashape estimates additional coefficients that are necessary to achieve better accuracy. There are different corrections which allows to compensate the distortions which cannot be fit by the ideal Brown's model used (see Appendix C, Camera models section). This option may be helpful for the datasets acquired with DJI P4 RTK drone, when no GCPs are used.

Adaptive camera model fitting
This option enables automatic selection of camera parameters to be included into adjustment based on their reliability estimates. Read more about in Aligning photos section.

Estimate tie point covariance
The function allows to estimate the covariance values of the tie point.

Image coordinates accuracy for markers indicates how precisely the markers were placed by the user or adjusted by the user after being automatically placed by the program.

Capture distance parameter is used to make reference preselection mode of alignment procedure work effectively for oblique imagery. See Aligning photos for details.

Camera, marker and scale bar accuracy can be set per item (i.d. per camera/marker/scale bar) using Accuracy column on the Reference pane. Accuracy values can be typed in on the pane per item or for a group of selected items. Alternatively accuracy values can be uploaded along with camera/marker data as a text file (see Assigning reference coordinates subsection of Setting coordinate system). Additionally, different accuracy per coordinate can be indicated using "f" as a separator between values in the Accuracy column.

GPS/INS offset values input by the user can also be adjusted by Metashape with respect to measurement accuracy that may be indicated on the GPS/INS tab of Camera Calibration dialog. Uncheck Adjust GPS/INS offset box to allow for adjustment procedure.
Generally it is reasonable to run optimization procedure based on markers data only. It is due to the fact that GCPs coordinates are measured with significantly higher accuracy compared to GPS data that indicates camera positions. Thus, markers data are sure to give more precise optimization results. Moreover, quite often GCP and camera coordinates are measured in different coordinate systems, that also prevents from using both cameras and markers data in optimization simultaneously.

The results of the optimization procedure can be evaluated with the help of error information on the Reference pane. In addition, distortion plot can be inspected along with mean residuals visualized per calibration group. This data is available from Camera Calibration dialog (Tools menu), from context menu of a camera group - Distortion Plot... command. Note that residuals are averaged per cell of an image and then across all the images in a camera group. Scale reference under the plot indicates the scale of the distortions/residuals. Read more in What do the errors in the Reference pane mean? section.

In case optimization results does not seem to be satisfactory, you can try recalculating with lower values of accuracy parameters, i.e. assuming ground control measurements to be more accurate.

**Covariance matrix**

If additional analyses is required, extra option **Estimate tie point covariance** can be selected on running the Optimization procedure. As a result, Metashape will calculate covariance matrix for the bundle adjustment calculations. Covariance matrix captures the uncertainty of the transformation. Covariance matrix diagonal elements are variances, $\sigma_i^2$; the positive square root of the variance, $\sigma_i$, is called the standard deviation. Standard deviation values for the camera position coordinates and rotation angles can be inspected on the Reference pane - View Variance tab. Covariance matrix off-diagonal elements are covariances, $\sigma_{ij}$. The value of each covariance reflects the degree of correlation between the corresponding parameters. Calculated covariance values for the tie points can be inspected in the Model view using Point Cloud Covariance command available from View Mode submenu of Model menu. Vector associated with each tie point indicates the direction and value of the largest error for the tie point estimated position (large semi-axis of the error ellipsoid determined by the covariance values). The color code is aimed to help to perceive the general distribution of the errors across the tie point cloud at a glance.

**Scale bar based optimization**

Scale bar is program representation of any known distance within the scene. It can be a standard ruler or a specially prepared bar of a known length. Scale bar is a handy tool to add supportive reference data to your project. They can prove to be useful when there is no way to locate ground control points all over the scene. Scale bars allow to save field work time, since it is significantly easier to place several scale bars with precisely known length, than to measure coordinates of a few markers using special equipment. In addition, Metashape allows to place scale bar instances between cameras, thus making it possible to avoid not only marker but ruler placement within the scene as well. Surely, scale bar based information will not be enough to set a coordinate system, however, the information can be successfully used while optimizing the results of photo alignment. It will also be enough to perform measurements in Metashape software. See Performing measurements on 3D model.

**To add a scale bar between markers**

1. Place markers at the start and end points of the bar. For information on marker placement please refer to the Setting coordinate system section of the manual.

2. Select both markers on the Reference pane using Ctrl button.

3. Select Create Scale Bar command form the Model view context menu. The scale bar will be created and an instant added to the Scale Bar list on the Reference pane.
4. Switch to the View Source mode using the Reference pane toolbar button.

5. Double click on the Distance (m) box next to the newly created scale bar name and enter the known length of the bar in meters.

**To add a scale bar between cameras**

1. Select the two cameras on the Workspace or Reference pane using Ctrl button. Alternatively, the cameras can be selected in the Model view window using selecting tools from the toolbar.

2. Select Create Scale Bar command from the context menu. The scale bar will be created and an instant added to the Scale Bar list on the Reference pane.

3. Switch to the View Source mode using the Reference pane toolbar button.

4. Double click on the Distance (m) box next to the newly created scale bar name and enter the known length of the bar in meters.

**To run scale bar based optimization**

1. On the Reference pane check all scale bars to be used in optimization procedure.

2. Click Settings toolbar button on the Reference pane. In the Reference pane Settings dialog box specify the assumed accuracy of scale bars measurements.

3. Click OK button.

4. Click Optimize toolbar button. In Optimize Camera Alignment dialog box check additional camera parameters to be optimized if needed. Click OK button to start optimization.

After the optimization is complete, cameras and markers estimated coordinates will be updated as well as all the georeferencing errors. To analyze optimization results switch to the View Estimated mode using the Reference pane toolbar button. In scale bar section of the Reference pane estimated scale bar distance will be displayed.

**To delete a scale bar**

1. Select the scale bar to be deleted on the Reference pane.

2. Right-click on it and chose Remove Scale Bars command from the context menu.

3. Click OK for the selected scale bar to be deleted.

**What do the errors in the Reference pane mean?**

To analyze errors switch to the View Errors mode using the Reference pane toolbar button.

**Cameras section**

1. Error (m) - residual error per coordinate or in 3D space. That is distance between the input (source) and estimated positions of the camera.
Referencing

2. Error (deg) - residual error per orientation angle or in 3D space (that is root mean square error calculated over all three orientation angles).

3. Error (pix) - root mean square reprojection error calculated over all valid tie points detected on the photo.

4. Total error - total error is calculated as root mean square for all the values in the corresponding column.

Reprojection error is the distance between the point on the image where a reconstructed 3D point can be projected and the original projection of that 3D point detected on the photo and used as a basis for the 3D point reconstruction procedure.

Markers section

1. Error (m) - residual error per coordinate or in 3D space. That is distance between the input (source) and estimated positions of the marker.

2. Error (pix) - root mean square reprojection error for the marker calculated over all photos where marker is visible.

3. Total error (Control points and Check points) - total error is calculated as root mean square for all the values in the corresponding column.

If the total reprojection error for some marker seems to be too large, it is recommended to inspect reprojection errors for the marker on individual photos. The information is available with Show Info command from the marker context menu on the Reference pane.

In Metashape estimated check point coordinates displayed in the Reference pane (as well as the error values) are calculated based on minimization of the reprojection error only, without taking into account measured check point coordinates in 3D-space. So they do not correspond to adjusted coordinates from the bundle adjustment step, and are calculated solely from weighted image measurements.

On the other hand, estimated coordinates of the control points correspond to the adjusted values, that is, they are calculated taking into account both reprojection error and measured object space coordinates. This approach allows for better detection of the measurement errors.

If you are interested in the difference between measured (source) and triangulated (estimated) control point coordinates only, you can temporary uncheck the corresponding entry in the Reference pane (thus making it a check point) and observe the values in the Errors tab. Note that Update button shouldn't be pressed after conversion of the control point to the check point, otherwise the estimated values would be recalculated with the given reference point excluded from the computation.

Scale Bars section

1. Error (m) - residual error per coordinate or in 3D space. That is difference between the input (source) scale bar length and the measured distance between two cameras or markers representing start and end points of the scale bar.

2. Total error (Control scale bars and Check scale bars) - total error is calculated as root mean square for all the values in the corresponding column.

Working with coded and non-coded targets

Coded and non-coded targets are specially prepared, yet quite simple, real world markers that can add up to successful 3D model reconstruction of a scene. Targets are artificial markers placed in the scene to
provide manual image correspondences in cases where automatic matching fails. Coded and non-coded targets can mark object point to be used for georeferencing. In the figure of coded targets, their identifier is recorded, which allows to automatically and accurately compare their projections of different images. The difference between coded and non-coded targets is that while a non-coded target looks like an ordinary full circle or a figure (circle / rectangular) with 4 segments, the coded target has a ring parted in black and white segments around the central full circle.

**Coded targets advantages and limitations**

Coded targets (CTs) can be used as markers to define local coordinate system and scale of the model or as true matches to improve photo alignment procedure. Metashape functionality includes automatic detection and matching of CTs on source photos, which allows to benefit from marker implementation in the project while saving time on manual marker placement. Moreover, automatic CTs detection and marker placement is more precise then manual marker placement.

Metashape supports four types of circle CTs: 12 bit, 14 bit, 16 bit and 20 bit. While 12 bit pattern is considered to be decoded more precisely, whereas 14 bit, 16 bit and 20 bit patterns allow for a greater number of CTs to be used within the same project.

To be detected successfully CTs must take up a significant number of pixels on the original photos. This leads to a natural limitation of CTs implementation: while they generally prove to be useful in close-range imagery projects, aerial photography projects will demand too huge CTs to be placed on the ground, for the CTs to be detected correctly.

**Coded targets in workflow**

Sets of all patterns of CTs supported by Metashape can be generated by the program itself.

**To create a printable PDF with coded targets**

1. Select *Print Markers...* command from the *Tools* menu.
2. Specify the CTs type and desired print parameters in *Print Markers* dialog.
3. Click *OK*.

Once generated, the pattern set can be printed and the CTs can be placed over the scene to be shot and reconstructed.

When the images with CTs seen on them are uploaded to the program, Metashape can detect and match the CTs automatically.

**To detect coded targets on source images**

1. Select *Detect Markers...* command from the *Tools* menu.
2. Specify parameters of detector in *Detect Markers* dialog according to the CTs type.
3. Click *OK*.

Metashape will detect and match CTs and add corresponding markers to the *Reference* pane.

CTs generated with Metashape software contain even number of sectors. However, previous versions of Metashape software had no restriction of the kind. Thus, if the project to be processed contains CTs from
previous versions of Metashape software, it is required to disable parity check in order to make the detector work.

**Non-coded targets implementation**

Non-coded targets can also be automatically detected by Metashape (see *Detect Markers* dialog). However, for non-coded targets to be matched automatically, it is necessary to run align photos procedure first.

Non-coded targets.

Non-coded targets are more appropriate for aerial surveying projects due to the simplicity of the pattern to be printed on a large scale.

When non-coded targets are detected Metashape allows automatic matching of detected non-coded targets with referencing coordinates imported from file. To do that, when importing referencing coordinates check the **Ignore labels** box in the *Import CSV* dialog. Metashape will try to match non-coded targets markers with imported referencing coordinates markers, in case of success non-coded targets markers will have corresponding coordinates. In case automatic matching does not work or works with errors, manual assignment of an identifier is required if some referencing coordinates are to be imported from a file correctly.
Chapter 5. Measurements

Performing measurements on 3D model

Metashape supports measuring of distances on the model, as well as of surface area and volume of the reconstructed 3D model. All the instructions of this section are applicable for working in the Model view of the program window, both for analysis of Dense Point Cloud or of Mesh data. When working in the Model view, all measurements are performed in 3D space, unlike measurements in Ortho view, which are planar ones.

Distance measurement

Metashape enables measurements of distances between the points of the reconstructed 3D scene. Obviously, model coordinate system must be initialized before the distance measurements can be performed. Alternatively, the model can be scaled based on known distance (scale bar) information to become suitable for measurements. For instructions on setting coordinate system please refer to the Setting coordinate system section of the manual. Scale bar concept is described in the Optimization section.

To measure distance

1. Select Ruler instrument from the Toolbar of the Model view.
2. Click on the point of the model where the measurement should be started from.
3. Upon the second click on the model the distance between the indicated points will be shown right in the Model view.
4. The distance can be measured along the polyline drawn with the Ruler.
5. To complete the measurement and to proceed to a new one, please press Escape button on the keyboard. The result of the measurement will be shown on the Console pane.

Shape drawing is enabled in Model view as well. See Shapes section of the manual for information on shape drawing. Measure command available from the context menu of a selected shape allows to learn the coordinates of the vertices as well as the perimeter of the shape.

To measure several distances between pairs of points and automatically keep the resulting data, markers can be used.

To measure distance between two markers

1. Place the markers in the scene at the targeted locations. For information on marker placement please refer to the Setting coordinate system section of the manual.
2. Select both markers to be used for distance measurements on the Reference pane using Ctrl button.
3. Select Create Scale Bar command form the 3D view context menu. The scale bar will be created and an instant added to the Scale Bar list on the Reference pane.
4. Switch to the estimated values mode using View Estimated button from the Reference pane toolbar.
5. The estimated distance for the newly created scale bar equals to the distance that should have been measured.

**To measure distance between cameras**

1. Select the two cameras on the *Workspace* or *Reference* pane using Ctrl button. Alternatively, the cameras can be selected in the *Model* view window using selecting tools from the Toolbar.

2. Select ✡️ *Create Scale Bar* command from the context menu. The scale bar will be created and an instant added to the *Scale Bar* list on the *Reference* pane.

3. Switch to the estimated values mode using ✡️ *View Estimated* button from the *Reference* pane toolbar.

4. The estimated distance for the newly created scale bar equals to the distance that should have been measured.

**Note**

- Please note that the scale bar used for distance measurements must be unchecked on the *Reference* pane.
- The distance values measured by Metashape are displayed in meters.

**Shape-based measurements**

**Polyline and Polygon measurements**

1. Indicate a line to make a cut of the model using ✡️ *Draw Polyline* ✡️ *Draw Polygon* tool from the *Model* view.

2. Double click on the last point to indicate the end of a polyline.

3. Right button click on the polyline/polygon and select ✡️ *Measure...* command from the context menu.

4. In the *Measure Shape* dialog displayed coordinates points, perimeter and coordinate system.

**Point measurement**

1. Select *Point measurement* from the Toolbar of the *Model* view.

2. Right button click on the point and select *Measure...* command from the context menu.

3. In the *Measure Shape* dialog displayed coordinate point and coordinate system.

**Surface area and volume measurement**

Surface area or volume measurements of the reconstructed 3D model can be performed only after the scale or coordinate system of the scene is defined. For instructions on setting coordinate system please refer to the *Setting coordinate system* section of the manual.

**To measure surface area and volume**

1. Select *Measure Area and Volume...* command from the *Tools* menu.
Measurements

2. The whole model surface area and volume will be displayed in the Measure Area and Volume dialog box. Surface area is measured in square meters, while mesh volume is measured in cubic meters.

Volume measurement can be performed only for the models with closed geometry. If there are any holes in the model surface Metashape will report zero volume. Existing holes in the mesh surface can be filled in before performing volume measurements using Close Holes... command from the Tools menu.

Performing measurements on DEM

Metashape is capable of DEM-based point, distance, area, and volume measurements as well as of generating cross-sections for a part of the scene selected by the user. Additionally, contour lines can be calculated for the model and depicted either over DEM or Orthomosaic in Ortho view within Metashape environment. Measurements on the DEM are controlled with shapes: points, polylines and polygons. For information about how to create and work with shapes please refer to Shapes section of the manual.

Point measurement

Ortho view allows to measure coordinates of any point on the reconstructed model. X and Y coordinates of the point indicated with the cursor as well as height of the point above the vertical datum selected by the user are shown in the bottom right corner of the Ortho view.

Distance measurement

To measure distance with a Ruler

1. Select Ruler instrument from the Toolbar of the Ortho view.
2. Click on the point of the DEM where the measurement should be started from.
3. Upon the second click on the DEM the distance between the indicated points will be shown right in the Ortho view.
4. The distance can be measured along the polyline drawn with the Ruler.
5. To complete the measurement and to proceed to a new one, please press Escape button on the keyboard. The result of the measurement will be shown on the Console pane.

To measure distance with shapes

1. Connect the points of interest with a polyline using Draw Polyline tool from the Ortho view toolbar.
2. Double click on the last point to indicate the end of a polyline.
3. Right button click on the polyline and select Measure... command from the context menu.
4. In the Measure Shape dialog inspect the results. Perimeter value equals to the distance that should have been measured.

In addition to polyline length value (see perimeter value in the Measure Shape), coordinates of the vertices of the polyline are shown on the Planar tab of the Measure Shape dialog.
Measurements

Note

• Measure option is available from the context menu of a selected polyline. To select a polyline, double-click on it. A selected polyline is colored in red.

Area and volume measurement

To measure area and volume

1. Draw a polygon on the DEM using \textit{Draw Polygon} instrument to indicate the area to be measured.

2. Right button click on the polygon and select \textit{Measure...} command from the context menu.

3. In the \textit{Measure Shape} dialog inspect the results: see area value on the \textit{Planar} tab and volume values on the \textit{Volume} tab.

Metashape allows to measure volume above best fit / mean level / custom level planes. Best fit and mean level planes are calculated based on the drawn polygon vertices. Volume measured against custom level plane allows to trace volume changes for the same area in the course of time.

Note

• Measure option is available from the context menu of a selected polygon. To select a polygon, double-click on it. A selected polygon is colored in red.

Cross sections and contour lines

Metashape enables to calculate cross sections, using shapes to indicate the plane(s) for a cut(s), the cut being made with a plane parallel to Z axis. For a polyline/polygon the program will calculate profiles along all the edges starting from the first drawn side.

To calculate cross section

1. Indicate a line to make a cut of the model using \textit{Draw Polyline} / \textit{Draw Polygon} tool from the \textit{Ortho} view toolbar.

2. Double click on the last point to indicate the end of a polyline.

3. Right button click on the polyline/polygon and select \textit{Measure...} command from the context menu.

4. In the \textit{Measure Shape} dialog inspect the results on the \textit{Profile} tab of the dialog.

\textit{Generate Contours...} command is available either from DEM label context menu on the \textit{Workspace} pane or from the \textit{Tools} menu.

To generate contours

1. Select \textit{Generate Contours...} command from \textit{Tools} menu.

2. In the \textit{Generate Contours} dialog select DEM as the source data for calculation.

3. Set values for Minimal altitude, Maximal altitude parameters as well as the Interval for the contours. All the values should be indicated in meters.
4. Click **OK** button once done.

5. The progress dialog box will appear displaying the current processing status. To cancel processing click **Cancel** button.

6. When the procedure is finished, a shape layer with "contours" label will be added to the project file structure shown on the *Workspace* pane.

Contour lines can be exported using *Export Contours* command from the contour lines label context menu on the *Workspace* pane. Alternatively the command is available from the *File* menu. In the *Export Contour Lines* dialog it is necessary to select the type of the contour lines to be exported. A shape file can store the lines of the same type only: either polygons or polylines.

### Transform DEM

Metashape supports transformation of the digital elevation models. Different DEMs can be subtracted one from another for the changes observation purposes.

"Transform DEM“ dialog

**To transform DEM**

1. Select DEM from which you want to transform on the *Workspace* pane.

2. Select *Transform DEM...* command from *Tools* menu.

3. In the *Transform DEM...* dialog select the check *Calculation difference* box and select the file from the drop-down list for calculation.

4. Press **OK** button to calculate transform DEM.

5. In the dialog box click *Yes* button in order to create a new DEM instance with the calculation result. If *No* button is pressed, the result will overwrite the active DEM instance contents.
6. The progress dialog box will appear displaying the current processing status. To cancel processing click *Cancel* button.

7. When the procedure is finished, a layer with transform DEM label will be added to the project file structure shown on the *Workspace* pane.

## Vegetation indices calculation

### Multispectral cameras

Metashape enables to calculate NDVI and other vegetation indices based on the multispectral imagery input. Vegetation index formula can be set by the user, thus allowing for great flexibility in data analysis. Calculated data can be exported as a grid of floating point index values calculated per pixel of orthomosaic or as an orthomosaic in pseudocolors according to a palette set by the user. In case several indices are calculated for the same orthomosaic, the results can be exported as a multichannel orthomosaic, one channel per index. Furthermore, values of 3 different vegetation indices can be mixed to represent combined results as a false color "RGB" image.

### Calibrate Reflectance

In Metashape you can execute the reflectance calibration of multispectral image data acquired using Parrot Sequoia or MicaSense RedEdge cameras. Images from Parrot Sequoia and MicaSense RedEdge can be loaded at once for all bands. If the images are stored in several folders, the same operation should be repeated for each folder. Metashape can automatically sort out those calibration images to the special camera folder in the *Workspace* pane if the image meta-data says that the images are for calibration. The images will be disabled automatically (not to be used in actual processing). If there is no such information in the image meta-data, the calibration images will be detected automatically in calibrate reflectance.

> **Note**

- Please remember to add reflectance calibration images.

1. Choose *Calibrate Reflectance* from the *Tools* menu.

2. Press *Locate Panels* button. As a result the images with the panel will be moved to the separate folder and the masks would be applied to cover everything on the images except the panel itself. If you are using the panel for the first time, and its calibration is not added to Metashape internal database yet, you will be prompted to load calibration from CSV file.

3. If you don't have a CSV file with calibration information, you can enter calibration values manually. It can be done manually in *Calibrate Reflectance* dialog or using *Select Panel...* button. In the *Select Reflectance Panel* dialog it is possible to: load reflectance information from a CSV file; save current table (wavelength / reflectance factor); edit the name of a panel in the database (the name is used in *Calibrate Reflectance* dialog); remove the panel from the database.

4. Check on *Use reflectance panel* and *Use sun sensor* options in the *Calibrate Reflectance* dialog to perform calibration based on panel data and/or image meta information.

5. Click *OK* to start calibration process.

### To calculate a vegetation index

1. Open orthomosaic in the *Ortho* tab double-clicking on the orthomosaic label on the *Workspace* pane.
2. Open Raster Transform tool using Raster Transform button from the Ortho view toolbar.

3. On the left-hand side of the Transform tab of the Raster Calculator dialog all the bands of the input images are listed. Set a vegetation index expression on the Output Bands side of the tab using keyboard input and operator buttons of the raster calculator if necessary. If the expression is valid, the line will be marked with sign.

4. You can set several vegetation index expressions to be calculated. Use buttons to add/delete lines in the list of output bands.

5. Click OK button to have the index (or indices) calculated. The result - orthomosaic with vegetation index (or indices) information, each index being stored in a separate channel, can be exported with Export orthomosaic command from the File menu. For guidance on the export procedure, please refer to NDVI data export section of the manual.

6. Alternatively to Step 5, if you would like to have the index visualized in Ortho view of Metashape window for inspection, follow Steps 6-12. Check Enable transform box and switch to the Palette tab of the Raster Calculator dialog.

7. Select output band in Use band field on the Palette tab.

8. Click Update button to have the histogram of the index values shown on the left-hand side of the Palette tab.

9. Select the range of meaningful index values either manually on the histogram or apply automatically calculated range with the Auto button at the bottom of the tab.

10. Select palette preset from the drop-down list on the right-hand side of the Palette tab.

11. Click Apply button. Once the operation is completed - all the vegetation indices are calculated, the index values stored in the selected output band (indices calculated according to the selected output band expression set on the Transform tab of the Raster Calculator) will be shown in the Ortho view, index values being visualized with pseudocolors according to the palette set in the Raster Calculator dialog.

12. You can either continue your work in Raster Calculator or click OK button to close the dialog.

Palette defines the color for each index value to be shown with. Metashape offers several standard palette presets on the Palette tab of the Raster Calculator dialog. A preset (Heat, NDVI, Gray scale) can be chosen from the drop-down list on the Palette tab of the Raster Calculator dialog. Alternatively, the user can upload the palette from a Surfer Color Spectrum (*.clr) file, preliminary prepared in an external tool.

The palette can also be edited within Metashape environment using Add Color and Remove Color buttons on the Palette tab of the Raster Calculator dialog. For each new line added to the palette a certain index value should be typed in. Double click on the newly added line to type the value in. A customized palette can be saved for future projects using Export Palette button on the Palette tab of the Raster Calculator dialog.

The range of meaningful index values can be manually adjusted on the left-hand side of the Palette tab or set automatically with the Auto button at the bottom of the tab. Interpolate colors option can be checked to introduce intermediate colors to the output image.
False color value on the drop-down list of the palette presets allows to visualize combined results of particular 3 vegetation indices tackled as false RGB colors.

**Note**

- If you change the index expression for selected output band on the Transform tab, do not forget to adjust Palette settings for visualization purposes: click Update button on the Palette tab to have the histogram of the index values updated, set the range of the meaningful values, chose the proper color palette.

- If you would like to inspect values of a different vegetation index, not the one already shown, you need to set the corresponding formula in the selected band of the Output Band list on the Transform tab of the Raster Calculator dialog.

- If you would like to see original multispectral orthomosaic, with no index calculation applied, uncheck Enable transform option on the Transform tab of the Raster Calculator dialog and click Apply/OK button. If the input images have three channels marked as R, G, B, then the orthomosaic will be visualized as an RGB image (or false RGB). Otherwise, the spectral data from the first channel will be visualized in gray scale.

### Prescription Map

The prescription map is generated based on the orthomosaic with calculated index. Select Generate Prescription Map command on the Orthomosaic submenu from the Tools menu.

In Metashape Prescription maps are built according to the following algorithm:

Specify the area along with the boundary vector layer (if there are no vector layers, orthomosaic is used in its entirety). The selected area will be transformed if there is an active raster transformation rule (Raster transform). For the resulting raster, a histogram of the values of the first transformed channel is built and this histogram is divided into clusters.

When using the Jenks natural breaks clustering method, the splitting occurs automatically.

When using the Equal intervals clustering method, the histogram is split into equal intervals in the interval from the min index value to the max index value. In this case, index values grater than the maximum are assigned to the maximum class, and less than the minimum - to the minimum.

Then a grid with a given step is applied to the raster. The direction of the grid corresponds to the specified azimuth. The index values in the grid cell are averaged and assigned to the cluster based on the histogram partition.

After this step, the cells that fall into the same cluster are combined and for each cluster, its borders are built and written into a vector layer named Prescription. The resulting layer contains several groups of polygons (MultiPolygon) corresponding to the clusters. The attributes of each group contain the average value of the index for the given cluster (zonal_mean) and the ordinal number of the cluster (cluster_id), starting from 1.

The following parameters can be adjusted:

**Boundary shape layer**
Layer with polygon for which the Prescription map will be generated (if there are no shape layer, the whole orthomosaic will be used).

**Cell size (m)**
Setting cell size in meters.
Measurements

**Grid azimuth (deg)**
Setting azimuth, which will correspond to the direction of the grid.

**Clustering method**
Choose clustering method (Junks natural breaks or Equal intervals).

**Cluster count**
Setting cluster count.

**Min index value**
Setting min index value.

**Max index value**
Setting max index value.

**Modified visible range cameras**

Modified visible range cameras provide data in the form of three channel imagery, but those channels do not contain standard R, G, B spectrum range information due to some physical manipulation done on the sensor. For example, a Colored Infrared (CIR) camera by MAVinci records Red+NIR data in the first channel, Green+NIR data in the second channel, and NIR data in the third one.

Modified visible range cameras are used for vegetation monitoring along with multispectral cameras. To calculate vegetation indices with Metashape the data captured with a modified camera should be calibrated first. This means we need to get pure R, G, NIR values to apply vegetation index formula. To perform the calibration, one needs calibration matrix data. In this context, a calibration matrix is a matrix of linear transformation of source light intensity values in each channel into absolute values of intensity.

In case of CIR camera by MAVinci, calibration matrix can be calculated based on the histograms for the following relations: NIR/R, NIR/G. Calibration matrix spectrum values will be equal to the values of the cut offs \((k_R, k_G)\) of the corresponding histograms: \(C = \{(k_R, 0, -1), (0, k_G, -1), (0, 0, 1)\}\). Then the vector of the absolute intensity values for R, G, NIR spectrum bands, scaled according to NIR intensity value, can be calculated as \(X_1 = C \times X_0\), where \(C [3x3]\)- CIR calibration matrix, \(X_0 [3x1]\)- vector of the source values of the intensity for each band.

Metashape offers dialog to manually input values of the calibration matrix - see Color Matrix section of the CIR Calibration tab in the Raster Calculator dialog. (The tab is available for 3 bands imagery only. If the project deals with multispectral imagery, there is no need to calibrate the data.) One can either print in the values, or select the values with sliders on the histograms. For a CIR camera by MAVinci, calibration matrix values can be set automatically with the Auto button.

Once the calibration matrix values are set, click Apply button for Metashape to perform the calibration. After that you can proceed to Transform and Palette tabs of the Raster Calculator to calculate vegetation indices as described in the section above. Metashape will use calibrated values as Input Bands on the Transform tab.

**Index based contour lines**

Metashape enables to calculate contour lines based on the calculated index values.

**To calculate contour lines based on vegetation index data**

1. Select Generate Contours... command from the orthomosaic icon context menu on the Workspace pane, while index data is shown in the Ortho view.

2. Select Orthomosaic as the source for the contours calculation.
3. Adjust the min/max value and the interval parameters for the task.

4. Press OK button to calculate index values.

5. The progress dialog box will appear displaying the current processing status. To cancel processing click Cancel button.

6. When the procedure is finished, a shape layer with "contours" label will be added to the project file structure shown on the Workspace pane. The contour lines will be shown over the index data on the Ortho tab.

### Powerlines detection

Metashape supports powerlines detection. The algorithm uses aligned images to detect powerlines. Detected powerlines will be saved as shapes (3D polylines) in one or more shape layers. Read more about shape properties in Shapes section.

**Note**

- The shape layer with the powerlines can be used together with the Plan Mission tool to indicate the danger zone for a drone flight.

### Detect Powerlines

1. Select the Detect Powerlines command from the Tools menu.

2. Choose parameters in Detect Powerlines dialog box.

3. The progress dialog box will appear displaying the current processing status. To cancel processing click Cancel button.

### Detect Powerlines parameters

!["Detect Powerlines" dialog]

**Use model for visibility checks**

Helps to reconstruct more powerlines in scenes with difficult geometry where wires are occluded by the model in images.

**Min altitude from DEM (m)**

To exclude road marking or, for example, fences, we recommend setting this parameter, which requires to generate DEM as an additional preliminary step.
Number of vertices per line
During drawing powerlines, a large number of vertices can be created in the line. It is possible to limit the number of vertices by specifying the desired maximum number of vertices per line. The value "0" can be set to avoid the number of vertices to be limited.

Stereoscopic measurements and vectorization
Metashape supports performing measurements and vectorization in stereo mode on stereo pairs (overlapping photos). In Metashape Hardware stereo is supported only for systems (graphics cards) that support the technology Quad Buffered Stereo.

Before starting to use stereo mode the parameters of Stereoscopic Display Mode for the current hardware needs to be adjusted in the General tab of Preferences dialog available from Tools menu. Metashape supports simply anaglyph display mode (for red/blue glasses) as well as hardware stereo mode that assumes polarization glasses and professional grade hardware (GPU that supports quad-buffer stereo and 3D monitor). The parameters of the 3D controller can be adjusted on the Navigation tab available in the Preferences dialog window.

For example, if you use Stealth3DMouse controller, you need to install virtual com port to enable this type of controller selection on the Navigation tab available in the Preferences dialog window. If 3D controller cannot be configured on the Navigation tab, please follow the steps below:

• check the USB Serial Comport in the Ports section of Device manager dialog;

• open Port Settings tab of Properties dialog window, then click on Advanced tab. In the Advanced Settings dialog switch the COM port number to COM3;

• restart the computer;

• in Metashape open Preferences dialog window from Tools menu and in the Navigation tab you should be able to select COM3 port then for the Stealth3DMous device.

Working with stereo pairs in Metashape is performed in Model view pane with Top predefined view set up.

Setting up stereo mode
1. Align photos. (For more information about photo alignment refer to Aligning photos section)
2. Switch to Model view pane.
3. Select Top command from Predefined Views submenu of Model menu.
4. Select Stereo mode view command from the View Mode submenu of the Model menu.
5. Turn on stereo pair overlay by clicking Show Images toolbar button.

Navigation
1. Navigate through overlaying stereo pair with right mouse button pressed.
2. To control 3D cursor depth, navigate with the right mouse button and Shift key pressed. When using the 3D controller, height change is performed with the help of a special wheel.

Stereo pair selection
1. Right button click on the area of interest on the model and select Filter by point command.
2. In the *Photos* pane select both images of a stereo pair, right click on the selection and choose *Look Through* command.

3. To avoid switching between stereo pairs while navigating through model, lock current overlaying stereo pair by clicking *Lock Image* toolbar button.

4. In case you need to select another stereo pair, repeat step two.

**Measurements and vectorization**

**Note**

- The *Snapping* tool in Metashape will help you to do vectorization. The following snapping types are available: Axis, Vertex and Edge. To use snapping mode, click *Axis Snap, Vertex Snap, Edge Snap* on the toolbar and press *Shift* button when you start drawing shapes.

1. To measure distance click *Ruler* toolbar button, hold right mouse button and left click on the first point, than move 3D cursor to the next point and left click on it.

2. To draw point, click *Draw Point* toolbar button and left click on the point of your interest.

3. To draw polyline click *Draw Polyline* toolbar button, left click on the first point, than move 3D cursor to the next point, and left click on it. Perform double left click to finish the polyline.

4. To draw polygon click *Draw Polygon* toolbar button, left click on the first point, than move 3D cursor to the next point, and left click on it. Perform double left click to finish the polygon.
Chapter 6. Editing

Using masks

Overview

Masks are used in Metashape to specify the areas on the photos which can otherwise be confusing to the program or lead to incorrect reconstruction results. Masks can be applied at the following stages of processing:

• Matching of the images
• Building Depth Maps
• Building Mesh from the depth maps source with the strict volumetric masks option applied
• Building Texture
• Building Tiled Model
• Building Orthomosaic

Alignment of the photos

Masked areas can be excluded during feature point detection. Thus, the objects on the masked parts of the photos are not taken into account while estimating camera positions. This is important in the setups, where the object of interest is not static with respect to the scene, like when using a turn table to capture the photos.

Masking may be also useful when the object of interest occupies only a small part of the photo. In this case a small number of useful matches can be filtered out mistakenly as a noise among a much greater number of matches between background objects.
**Building dense point cloud**

While building dense point cloud, masked areas are not used in the depth maps computation process. Masking can be used to reduce the resulting dense cloud complexity, by eliminating the areas on the photos that are not of interest.

Masked areas are always excluded from processing during dense point cloud and texture generation stages, including Tiled Model generation process.

Let's take for instance a set of photos of some object. Along with an object itself on each photo some background areas are present. These areas may be useful for more precise camera positioning, so it is better to use them while aligning the photos. However, impact of these areas at the building dense point cloud is exactly opposite: the resulting model will contain object of interest and its background. Background geometry will "consume" some part of mesh polygons that could be otherwise used for modeling the main object.

Setting the masks for such background areas allows to avoid this problem and increases the precision and quality of geometry reconstruction.

**Building texture atlas**

During texture atlas generation (for single mesh model and tiled model), masked areas on the photos are not used for texturing. Masking areas on the photos that are occluded by outliers or obstacles helps to prevent the "ghosting" effect on the resulting texture atlas.

---

**Loading masks**

Masks can be loaded from external sources, as well as generated automatically from background images if such data is available. Metashape supports loading masks from the following sources:

- From alpha channel of the source photos.
- From separate images.
- Generated from background photos based on background differencing technique.
- Based on reconstructed 3D model.

**To import masks**

1. Select *Import Masks...* command from the *File* menu.
2. In the *Import Mask* dialog select suitable parameters. Click *OK* button when done.
3. When generating masks from separate or background images, the folder selection dialog will appear. Browse to the folder containing corresponding images and select it.
4. The progress dialog box will appear displaying the current processing status. To cancel processing click *Cancel* button.
The following parameters can be specified during mask import:

**Method**
Specifies the source of the mask data.
- **From Alpha** - load masks from alpha channel of the source photos.
- **From File** - load masks from separate images.
- **From Background** - generate masks from background photos.
- **From Model** - generate masks based on reconstructed model.

**Operation**
Specifies the action to be done in case a second mask is imported for the photo.
- **Replacement** - new mask will be loaded and stored instead of the original one.
- **Union** - two masks will be united and stored.
- **Intersection** - the intersection of the two masks will be stored as a new mask for the photo.
- **Difference** - only the difference between two masks will be stored as a new mask for the photo.

**Filename template (not used in From alpha mode)**
Specifies the file name template used to generate mask file names. This template can contain special tokens, that will be substituted by corresponding data for each photo being processed. The following tokens are supported:

- `{filename}` - file name of the source photo without extension.
- `{fileext}` - extension of the source photo.
- `{camera}` - camera label.
- `{frame}` - frame number.
- `{filenum}` - sequential number of the mask being imported.
For example, `{filename}_mask.png` template can be used if masks are available in PNG format and have a `_mask` suffix.

**Tolerance (From Background method only)**
Specifies the tolerance threshold used for background differencing. Tolerance value should be set according to the color separation between foreground and background pixels. For larger separation higher tolerance values can be used.

**Apply to**
Specifies whether masks should be imported for the currently opened photo, active chunk or entire Workspace.

- **All cameras** - load masks for active chunk.
- **Entire workspace** - load masks for all chunks in the project.
- **Selected cameras** - load mask for the currently checked cameras (if any).
- **Current photo** - load mask for the currently opened photo (if any).

**Generate masks**

The *Generate masks* tool allows to create masks from the mesh model. Due to the nature of the shooting, not the whole object may be placed in focus, which will lead to blurred areas in the pictures. The texture will be more blurry than possible if built texture uses the images data from defocus areas. The tool allows to exclude such areas prior to the texture blending procedure by applying the masks automatically to out of focus areas.

**To generate mask**

1. Select *Generate Masks* command from the *Mesh* submenu from the *Tools* menu.
2. In the *Generate Masks* dialog select suitable parameters. Click *OK* button when done.
3. The progress dialog box will appear displaying the current processing status. To cancel processing click *Cancel* button.
"Generate Masks" dialog

The following parameters can be specified in Generate Masks dialog:

**Operation**
Specifies the action to be done in case a second mask is imported for the photo.

- **Replacement** - new mask will be loaded and stored instead of the original one.
- **Union** - two masks will be united and stored.
- **Intersection** - the intersection of the two masks will be stored as a new mask for the photo.
- **Difference** - only the difference between two masks will be stored as a new mask for the photo.

**Mask defocus areas**
Enabled applying masks to the areas that are out of focus based on the depth information of each point.

**Fix coverage (for Replace and Union operations only)**
Allows to avoid blind spots on the model surface when generating masks.

**Blur threshold**
Allowed blur radius on a photo in pix. By default, recommend using 2 or 3 pix, but take into account your area of blurring in the images. The parameter is available if only enabled - Mask defocus areas.

**Apply to**
Specifies whether masks should be created for the currently opened photo, active chunk or entire Workspace.

- **All cameras** - generate masks for active chunk.
- **Entire workspace** - generate masks for all chunks in the project.
- **Selected cameras** - generate mask for the currently checked cameras (if any).
- **Current photo** - generate mask for the currently opened photo (if any).

**Editing masks**

Modification of the current mask is performed by adding or subtracting selections. A selection is created with one of the supported selection tools and is not incorporated in the current mask until it is merged with a mask using Add Selection or Subtract Selection operations.

**To edit the mask**

1. Open the photo to be masked by double clicking on its name on the Workspace / Photos pane. The photo will be opened in the main window. The existing mask will be displayed as a shaded region on the photo.

2. Select the desired selection tool and generate a selection.

3. Click on Add Selection toolbar button to add current selection to the mask, or Subtract Selection to subtract the selection from the mask. Invert Selection button allows to invert current selection prior to adding or subtracting it from the mask.

The following tools can be used for creating selections:
**Rectangle selection tool**

Rectangle selection tool is used to select large areas or to clean up the mask after other selection tools were applied.

**Intelligent scissors tool**

Intelligent scissors is used to generate a selection by specifying its boundary. The boundary is formed by selecting a sequence of vertices with a mouse, which are automatically connected with segments. The segments can be formed either by straight lines, or by curved contours snapped to the object boundaries. To enable snapping, hold Ctrl key while selecting the next vertex. To complete the selection, the boundary should be closed by clicking on the first boundary vertex.

**Intelligent paint tool**

Intelligent paint tool is used to "paint" a selection by the mouse, continuously adding small image regions, bounded by object boundaries.

**Magic wand tool**

Magic Wand tool is used to select uniform areas of the image. To make a selection with a Magic Wand tool, click inside the region to be selected.

The range of pixel colors selected by Magic Wand is controlled by the tolerance value. At lower tolerance values the tool selects fewer colors similar to the pixel you click with the Magic Wand tool. Higher value broadens the range of colors selected.

**Note**

- To add new area to the current selection hold the Ctrl key during selection of additional area.
- To subtract a part from the current selection hold the Shift key during selection of the area to be subtracted.
- To reset mask selection on the current photo press Esc key.

A mask can be inverted using Invert Mask command from the Edit menu. The command is active in Photo view only. Alternatively, you can invert masks either for selected cameras or for all cameras in a chunk using Invert Masks... command from a photo context menu on the Photos pane.

The masks are generated individually for each image. If some object should be masked out, it should be masked out on all photos, where that object appears.

### Saving masks

Created masks can be also saved for external editing or storage.

**To export masks**

1. Select Export Masks... command from the File menu.
2. In the Export Mask dialog select suitable parameters. Click OK button when done.
3. Browse to the folder where the masks should be saved and select it.
4. The progress dialog box will appear displaying the current processing status. To cancel processing click Cancel button.
"Export Masks" dialog

The following parameters can be specified during mask export:

**Export masks for**
- Specifies whether masks should be exported for the currently opened photo, active chunk or entire *Workspace*.
  - **Current photo** - save mask for the currently opened photo (if any).
  - **Active chunk** - save masks for active chunk.
  - **Entire workspace** - save masks for all chunks in the project.

**File type**
- Specifies the type of generated files.
  - **Single channel mask image** - generates single channel black and white mask images.
  - **Image with alpha channel** - generates color images from source photos combined with mask data in alpha channel.

**Mask file names**
- Specifies the file name template used to generate mask file names. This template can contain special tokens, that will be substituted by corresponding data for each photo being processed. The following tokens are supported:
  - `{filename}` - file name of the source photo without extension.
  - `{fileext}` - extension of the source photo.
  - `{camera}` - camera label.
  - `{frame}` - frame number.
  - `{filenum}` - sequential number of the mask being exported.

For example, `{filename}_mask.png` template can be used to export masks in PNG format with *_mask* suffix.

**Note**
- When importing/exporting mask for the current photo only, Metashape will prompt for the actual image instead of image folder. *Mask file names* parameter will not be used in this case.

**Editing point cloud**

The following point cloud editing tools are available in Metashape:
- Automatic filtering based on specified criterion (sparse cloud only)
- Automatic filtering based on applied masks (dense cloud only)
- Automatic filtering based on points colors (dense cloud only)
- Automatic filtering by class (dense cloud only)
• Automatic filtering by selection (dense cloud only)
• Automatic filtering by confidence (dense cloud only)
• Reducing number of points in point cloud by setting tie point per photo limit (sparse cloud only)
• Reducing number of dense cloud points by setting up point spacing value
• Colorize dense point cloud
• Sample points operation to create dense point cloud from the mesh or tiled model
• Manual points removal

Note

• Point cloud editing operation can be undone/redone using Undo/Redo command from the Edit menu.

Filtering points based on specified criterion

In some cases it may be useful to find out where the points with high reprojection error are located within the sparse cloud, or remove points representing high amount of noise. Point cloud filtering helps to select such points, which usually are supposed to be removed.

Metashape supports the following criteria for point cloud filtering:

Reprojection error

Maximum reprojection error in normalized units across all images where tie-point was measured.

\[ \text{max}_i \left| \frac{x'_i - x_i}{s_i} \right| \]

where

- \( x'_i \) - point projection according to adjusted orientation parameters on the i-th image in pixels,
- \( x_i \) - measured point projection coordinates on the i-th image in pixels,
- \( s_i \) - image scale at which corresponding projection was measured on the i-th image

High reprojection error usually indicates poor localization accuracy of the corresponding point projections at the point matching step. It is also typical for false matches. Removing such points can improve accuracy of the subsequent optimization step.

Reconstruction uncertainty

Ratio of the largest semi-axis to the smallest semi-axis of the error ellipse of the triangulated 3D point coordinates. The error ellipse corresponds to the uncertainty of the point triangulation alone without taking into account propagation of uncertainties from interior and exterior orientation parameters.

\[ \sqrt{\frac{k_1}{k_3}} \]

where

- \( k_1 \) - largest eigenvalue of the tie-point covariance matrix,
- \( k_3 \) - smallest eigenvalue of the tie-point covariance matrix
High reconstruction uncertainty is typical for points, reconstructed from nearby photos with small baseline. Such points can noticeably deviate from the object surface, introducing noise in the point cloud. While removal of such points should not affect the accuracy of optimization, it may be useful to remove them before building geometry in Point Cloud mode or for better visual appearance of the point cloud.

**Image count**
Number of images where the tie point was measured.

Metashape reconstruct all the points that are visible at least on two photos. However, points that are visible only on two photos are likely to be located with poor accuracy. Image count filtering enables to remove such unreliable points from the cloud.

**Projection Accuracy**
Average image scale at which image coordinates of the tie-point were measured.

\[
\text{sum}_i \frac{s_i}{n}
\]

where

\(s_i\) - image scale at which corresponding projection was measured on the i-th image,

\(n\) - number of images where tie-point was measured

This criterion allows to filter out points which projections were relatively poorer localized due to their bigger size.

**To remove points based on specified criterion**
1. Switch to Point Cloud view mode using Point Cloud toolbar button.
2. Select Gradual Selection... command from the Model menu.
3. In the Gradual Selection dialog box specify the criterion to be used for filtering. Adjust the threshold level using the slider. You can observe how the selection changes while dragging the slider. Click OK button to finalize the selection.
4. To remove selected points use Delete Selection command from the Edit menu or click Delete Selection toolbar button (or simply press Del button on the keyboard).

**Filtering points based on applied masks**

**To remove points based on applied masks**
1. Switch to Dense Cloud view mode using Dense Cloud toolbar button.
2. Choose Select Masked Points... command from the Dense Cloud submenu of the Tools menu.
3. In the Select Masked Points dialog box indicate the photos whose masks to be taken into account. Adjust the edge softness level using the slider. Click OK button to run the selection procedure.
4. To remove selected points use Delete Selection command from the Edit menu or click Delete Selection toolbar button (or simply press Del button on the keyboard).
Filtering points based on points colors

To remove points based on points colors

1. Switch to Dense Cloud view mode using Dense Cloud toolbar button.

2. Choose Select Points by Color... command from the Dense Cloud submenu of the Tools menu.

3. In the Select Points by Color dialog box the color to be used as the criterion. Adjust the tolerance level using the slider. Click OK button to run the selection procedure.

4. To remove selected points use Delete Selection command from the Edit menu or click Delete Selection toolbar button (or simply press Del button on the keyboard).

Filtering points by class

To select objects of the same type in Dense Cloud, you can filter by class. Classification is performed automatically, you should choose only the class interested.

Filter by class

1. Switch to Dense Cloud view mode using Dense Cloud toolbar button.

2. Choose Filter By Class... command from the Dense Cloud submenu of the Tools menu.

3. In the Select Point Classes dialog box choose classes to be used as the filter. Click OK button to run the selection procedure.

4. The result of the filtering will be shown in the Model view.

5. Select Reset filter command from the Dense Cloud submenu of the Tools menu to cancel filtering by classes.

Filtering points by selection

Filter by selection

1. Switch to Dense Cloud view mode using Dense Cloud toolbar button.

2. Select points to be filter Rectangle Selection, Circle Selection or Free-Form Selection tools.

3. Choose Filter By Selection... command from the Dense Cloud submenu of the Tools menu.

4. The result of the filtering will be shown in the Model view.

5. Select Reset filter command from the Dense Cloud submenu of the Tools menu to cancel filtering by classes.

Filtering points by confidence

Metashape supports dense point cloud filtering by confidence value. To perform such filtering Calculate point confidence option should be enabled in the Build Dense Cloud dialog before the dense point cloud of interest is generated.
Filter by confidence

1. Switch to Dense Cloud view mode using Dense Cloud Confidence toolbar button.
2. Choose Filter by Confidence... command from the Dense Cloud submenu of the Tools menu.
3. In the Select Confidence Range dialog box choose min and max value to be used as the filter. The values define the number of depth maps involved in the point generation.
4. Click OK button to run the selection procedure.
5. The result of the filtering will be shown in the Model view.
6. Select Reset filter command from the Dense Cloud submenu of the Tools menu to cancel filtering by confidence.

Tie point per photo limit

Tie point limit parameter could be adjusted before Align photos procedure. The number indicates the upper limit for matching points for every image. Using zero value doesn't apply any tie-point filtering.

The number of tie points can also be reduced after the alignment process with Tie Points - Thin Point Cloud command available from Tools menu. As a results sparse point cloud will be thinned, yet the alignment will be kept unchanged.

Filter dense cloud

In Metashape it is possible to reduce the number of the dense cloud points by setting the point spacing parameter manually which defines the regular grid step.

To filter dense point cloud

1. Select Filter dense cloud command from the Dense Cloud submenu of the Tools menu.
2. In the Filter Dense Cloud dialog box specify Point spacing in meters to be used.
3. Click OK button to run the selection procedure.
4. The progress dialog box will appear displaying the current processing status. To cancel processing click Cancel button.

Note

• In the confirmation dialog box click Yes button if a new dense cloud instance with result calculation should be created in the active chunk. If No button is pressed the dense cloud filtering result will overwrite the active dense point cloud instance.

Colorize Dense Cloud

Metashape supports the option to colorize dense point clouds with the colors from the images or orthomosaic.

To colorize dense cloud

1. Select an active Dense Cloud in the Workspace pane.
2. Choose Colorize Dense Cloud... command from the Dense Cloud submenu of the Tools menu.
3. In the Colorize Dense Cloud dialog box select Source data from Orthomosaic or Images option.

4. Click on the OK button to start the procedure. The progress dialog box will appear displaying the current processing status.

**Sample points**

*Sample points* tool creates a dense point cloud based on a Mesh or Tiled model.

**To create the dense point cloud from the polygonal surface**

1. Select Sample Points command from the Dense Cloud submenu of the Tools menu.

2. In the Sample Points dialog select the source polygonal surface type (mesh or tiled model) and desired point spacing value. Target point count based on the input parameters will be displayed in Estimated points field.

3. Click on the OK button to start the procedure. The progress dialog box will appear displaying the current processing status. To cancel processing click Cancel button.

The following parameters can be specified in Sample points dialog:

**Source data**

Specifies the source polygonal surface for the dense point cloud generation (Mesh or Tiled model).

**Points spacing**

Specifies the desired distance between points of the dense cloud to be generated.

**Estimated points**

Defines the expected number of points to be generated.

**Manual points removal**

Incorrect points can be also removed manually.

**To remove points from a point cloud manually**

1. Switch to Sparse Cloud view mode using Point Cloud toolbar button or to Dense Cloud view mode using Dense Cloud toolbar button.

2. Select points to be removed using Rectangle Selection, Circle Selection or Free-Form Selection tools. To add new points to the current selection hold the Ctrl key during selection of additional points. To remove some points from the current selection hold the Shift key during selection of points to be removed.

3. To delete selected points click the Delete Selection toolbar button or select Delete Selection command from the Edit menu. To crop selection to the selected points click the Crop Selection toolbar button or select Crop Selection command from the Edit menu.

**Classifying dense point cloud**

Metashape allows not only to generate and visualize dense point cloud but also to classify the points within it. There are two options: automatic division of all the points into two classes - ground points and the rest,
and manual selection of a group of points to be placed in a certain class from the standard list known for LIDAR data. Dense cloud points classification opens way to customize Build Mesh step: you can choose what type of objects within the scene you would like to be reconstructed and indicate the corresponding point class as a source data for mesh generation. For example, if you build mesh or DEM based on ground points only, it will be possible to export DTM (as opposed to DSM) at the next step.

**Automatic classification of ground points**

For the user to avoid extra manual work Metashape offers feature for automatic detection of ground points.

**To classify ground points automatically**

1. Select *Classify Ground Points...* command from the *Dense Cloud* submenu of the *Tools* menu.
2. In the *Classify Ground Points* dialog box select the parameters for the classification procedure.
3. Click *OK* button to run the classification procedure.

Automatic classification procedure consists of two steps. At the first step the dense cloud is divided into cells of a certain size. In each cell the lowest point is detected. Triangulation of these points gives the first approximation of the terrain model.

Additionally, at this step Metashape filters out some noise points to be handled as Low Points class.

At the second step new point is added to the ground class, providing that it satisfies two conditions: it lies within a certain distance from the terrain model and that the angle between terrain model and the line to connect this new point with a point from a ground class is less than a certain angle. The second step is repeated while there still are points to be checked.

"Classify Ground Points" dialog

The following parameters control automatic ground points classification procedure

**Max angle (deg)**

Determines one of the conditions to be checked while testing a point as a ground one, i.e. sets limitation for an angle between terrain model and the line to connect the point in question with a point from a
ground class. For nearly flat terrain it is recommended to use default value of 15 deg for the parameter. It is reasonable to set a higher value, if the terrain contains steep slopes.

**Max distance (m)**
Determines one of the conditions to be checked while testing a point as a ground one, i.e. sets limitation for a distance between the point in question and terrain model. In fact, this parameter determines the assumption for the maximum variation of the ground elevation at a time.

**Cell size (m)**
Determines the size of the cells for point cloud to be divided into as a preparatory step in ground points classification procedure. Cell size should be indicated with respect to the size of the largest area within the scene that does not contain any ground points, e.g. building or dense forest.

**Erosion radius (m)**
Determines the indentation (in meters) from unclassified points to create an additional area from the object, it is useful when classifying houses and trees to exclude the remaining "stumps" when building DTM.

**Automatic dense cloud multi-class classification**

Metashape allows for semantic classification of dense point clouds to solve the task of higher-level interpretation of the reconstructed data. Using the machine learning techniques Metashape enables automatic dense cloud classification to any combination of the following classes: Ground, High Vegetation, Building, Road, Car and Man-made.

**To start the automatic multi-class classification**

1. Select *Classify Points...* command from the *Dense Cloud* submenu of the *Tools* menu.
2. In the *Classify Points* dialog box select the source point class for the classification procedure in the "From" field.
3. Select the target classes from the list in "To" field.
4. Define *Confidence* parameter in 0 - 1 range. Higher value of the parameter means that the point which class cannot be reliably assigned, will remain unclassified.
5. Click *OK* button to run the classification procedure.
"Classify Points" dialog

Note

- If you are not satisfied with the automatic multi-class classification results or would like to contribute and improve the classificator, please send the manually labeled point clouds according to the guidelines published on the following page to support@agisoft.com: http://www.agisoft.com/support/tips-tricks/

Manual classification of dense point cloud

Metashape allows to associate all the points within the dense cloud with a certain standard class (see LIDAR data classification). This provides possibility to diversify export of the processing results with respect to different types of objects within the scene, e. g. DTM for ground, mesh for buildings and point cloud for vegetation.

To assign a class to a group of points

1. Switch to Dense Cloud view mode using using Dense Cloud toolbar button.

2. Select points to be placed to a certain class using Rectangle Selection, Circle Selection or Free-Form Selection tools. To add new points to the current selection hold the Ctrl key during selection of additional points. To remove some points from the current selection hold the Shift key during selection of points to be removed.

3. Select Assign Class... command from the Dense Cloud submenu of the Tools menu.

4. In the Assign Class dialog box select the source point data for the classification procedure and the targeted class to be assigned to the selected points. Click OK button to run classification procedure.

Dense point cloud classification can be reset with Reset Classification command from Tools - Dense Cloud menu.

Editing model geometry

The following mesh editing tools are available in Metashape:

- Decimation tool
- Photoconsistent mesh refinement tool
- Close holes tool
- Smooth tool
- Colorize vertices
- Automatic filtering based on specified criterion
- Manual polygon removal
- Fixing mesh topology
More complex editing can be done in the external 3D editing tools. Metashape allows to export mesh and then import it back for this purpose.

**Note**

- For polygon removal operations such as manual removal and connected component filtering it is possible to undo the last mesh editing operation. There are *Undo/Redo* commands in the *Edit* menu.

- Please note that *Undo/Redo* commands are not supported for mesh decimation and this operation cannot be undone.

**Decimation tool**

Decimation is a tool used to decrease the geometric resolution of the model by replacing high resolution mesh with a lower resolution one, which is still capable of representing the object geometry with high accuracy. Metashape tends to produce 3D models with excessive geometry resolution, so mesh decimation is usually a desirable step after geometry computation.

Highly detailed models may contain hundreds of thousands of polygons. While it is acceptable to work with such a complex models in 3D editor tools, in most conventional tools like Adobe Reader or Google Earth high complexity of 3D models may noticeably decrease application performance. High complexity also results in longer time required to build texture and to export model in PDF file format.

In some cases it is desirable to keep as much geometry details as possible like it is needed for scientific and archive purposes. However, if there are no special requirements it is recommended to decimate the model down to 100 000 - 200 000 polygons for exporting in PDF, and to 100 000 or even less for displaying in Google Earth and alike tools.

**To decimate 3D model**

1. Select *Decimate Mesh...* command from the *Tools* menu.
2. In the *Decimate Mesh* dialog box specify the target number of polygons, which should remain in the final model. Click on the *OK* button to start decimation.
3. The progress dialog box will appear displaying the current processing status. To cancel processing click on the *Cancel* button.

**Note**

- Texture atlas is discarded during decimation process. You will have to rebuild texture atlas after decimation is complete.

**Photoconsistent mesh refinement tool**

Metashape allows to refine already reconstructed mesh with respect to camera photos. This is iterative process that can further recover details on surface. For example it can recover basrelief or ditch.

**To refine mesh**

1. Check the model - it will be refined with respect to camera photos. You can duplicate it with right click on the model and selecting *Duplicate...* to refine the copy of model.
2. Select *Refine Mesh...* command from the *Tools* menu.

3. In the *Refine Mesh...* dialog box specify the target quality of refinement, number of iterations and smoothness. Click on the *OK* button to start refinement.

4. The progress dialog box will appear displaying the current processing status. To cancel processing click on the *Cancel* button.

**Refinement parameters**

**Quality**
Specifies the desired refinement quality. Higher quality settings can be used to obtain more detailed and accurate geometry, but they require longer time for processing. Interpretation of the quality parameters here is similar to that of accuracy settings given in *Building dense point cloud* section.

**Iterations**
Number of refinement iterations. In some cases additional iterations are able to recover more details, but it will lead to proportional slow down.

**Smoothness**
Smaller smoothness parameter leads to better features recovering but also it can increase noise. Bigger smoothness parameter leads to better noise suppression, but can smooth out features too. Changing smoothness value can help to balance between noise suppression and features recovering.

**Colorize model vertices**

In Metashape the mesh model vertices can be colorized using images, sparse / dense cloud points colors or orthomosaic data.

**To colorize model vertices**

1. Select *Colorize Vertices* command in *Mesh* submenu from the *Tools* menu.
2. In the *Colorize Model* dialog box select source data for the operation.
3. Click on the *OK* button to start the procedure.
4. The progress dialog box will appear displaying the current processing status. To cancel processing click on the *Cancel* button.

**Close holes tool**

Close Holes tool provides possibility to repair your model if the reconstruction procedure resulted in a mesh with several holes, due to insufficient image overlap for example.

Some tasks require a continuous surface disregarding the fact of information shortage. It is necessary to generate a close model, for instance, to fulfill volume measurement task with Metashape.

Close holes tool enables to close void areas on the model substituting photogrammetric reconstruction with extrapolation data. It is possible to control an acceptable level of accuracy indicating the maximum size of a hole to be covered with extrapolated data.

**To close holes in a 3D model**

1. Select *Close Holes...* command in *Mesh* submenu from the *Tools* menu.
2. In the Close Holes dialog box indicate the maximum size of a hole to be covered with the slider.
3. Click on the OK button to start the procedure.
4. The progress dialog box will appear displaying the current processing status. To cancel processing click on the Cancel button.

**Note**
- The slider allows to set the size of a hole in relation to the size of the whole model surface.

### Smooth tool

The Smooth tool allows you to make the model smoother and remove irregularities on the surface. Some tasks require a sleek surface disregarding of details or real object more smooth than mesh in Metashape. You can apply the tool to the entire mesh or only to the selected area.

**Note**
- To apply smoothing to a specific area, you must first select it and then apply the tool.

**To smooth mesh**
1. Select Smooth mesh... command in Mesh submenu of Tools menu.
2. In the Smooth mesh dialog box set the Strength parameter using slider. You can also enable check box Apply to selected faces.
3. Click OK when done. To cancel processing click Cancel button.

**Note**
- Fix borders option can be applied to the models with the open edges, it allows to preserve the position of the mesh vertices along the open edges when using smoothing.

### Polygon filtering on specified criterion

In some cases reconstructed geometry may contain the cloud of small isolated mesh fragments surrounding the "main" model or big unwanted polygons. Mesh filtering based on different criteria helps to select polygons, which usually are supposed to be removed.

Metashape supports the following criteria for face filtering:

**Connected component size**
This filtering criteria allows to select isolated fragments with a certain number of polygons. The number of polygons in all isolated components to be selected is set with a slider and is indicated in relation to the number of polygons in the whole model. The components are ranged in size, so that the selection proceeds from the smallest component to the largest one.

**Polygon size**
This filtering criteria allows to select polygons up to a certain size. The size of the polygons to be selected is set with a slider and is indicated in relation to the size of the whole model. This function can be useful, for example, in case the geometry was reconstructed with the extrapolation and there is a need to remove extra polygons automatically added by Metashape to fill the gaps; these polygons are often of a larger size than the rest.
To remove small isolated mesh fragments

1. Select *Gradual Selection*... command from the *Model* menu.
2. In the *Gradual Selection* dialog box select *Connected component size* criterion.
3. Select the size of isolated components to be removed using the slider. Size of the largest component is taken for 100%. You can observe how the selection changes while dragging the slider. Click *OK* button to finalize the selection.
4. To remove the selected components use *Delete Selection* command from the *Edit* menu or click *Delete Selection* toolbar button (or simply press *Del* button on the keyboard).

To remove large polygons

1. Select *Gradual Selection*... command from the *Model* menu.
2. In the *Gradual Selection* dialog box select *Polygon size* criterion.
3. Select the size of polygons to be removed using the slider. Size of the largest polygon is taken for 100%. You can observe how the selection changes while dragging the slider. Click *OK* button to finalize the selection.
4. To remove the selected components use *Delete Selection* command from the *Edit* menu or click *Delete Selection* toolbar button (or simply press *Del* button on the keyboard).

Note that Metashape always selects the fragments starting from the smallest ones. If the model contains only one component the selection will be empty.

**Manual face removal**

Unnecessary and excessive sections of model geometry can be also removed manually.

To remove part of the mesh polygons manually

1. Select rectangle, circle or free-form selection tool using *Rectangle Selection*, *Circle Selection* or *Free-Form Selection* toolbar buttons.
2. Make the selection using the mouse. To add new polygons to the current selection hold the *Ctrl* key during selection of additional polygons. To remove some polygons from the current selection hold the *Shift* key during selection of polygons to be excluded.
3. To delete selected polygons click the *Delete Selection* toolbar button or use *Delete Selection* command from the *Edit* menu. To crop selection to the selected polygons click the *Crop Selection* toolbar button or use *Crop Selection* command from the *Edit* menu.

To grow or shrink current selection

1. To grow current selection press *PageUp* key in the selection mode. To grow selection by even a larger amount, press *PageUp* while holding *Shift* key pressed.
2. To shrink current selection press *PageDown* key in the selection mode. To shrink selection by even a larger amount, press *PageDown* while holding *Shift* key pressed.
Fixing mesh topology

Metashape is capable of basic mesh topology fixing.

To fix mesh topology

1. Select View Mesh Statistics... command from the Tools menu.

2. In the Mesh Statistics dialog box you can inspect mesh parameters. If there are any topological problems, Fix Topology button will be active and can be clicked to solve the problems.

3. The progress dialog box will appear displaying the current processing status. To cancel processing click on the Cancel button.

Editing mesh in the external program

To export mesh for editing in the external program

1. Select Export Model... command from the File menu.

2. In the Save As dialog box, specify the desired mesh format in the Save as type combo box. Select the file name to be used for the model and click Save button.

3. In the opened dialog box specify additional parameters specific to the selected file format. Click OK button when done.

To import edited mesh

1. Select Import Mesh... command from the File menu.

2. In the Open dialog box, browse to the file with the edited model and click Open.

Note

- Metashape supports loading models in Wavefront OBJ, 3DS, STL, COLLADA, Stanford PLY, Autodesk FBX, Autodesk DXF, OpenCTM and U3D file formats only. Please make sure to select one of these file formats when exporting model from the external 3D editor.

- Please be aware that it is important to keep reference information for the model if any.

Shapes

Shapes are used to indicate boundaries either for export or for measurement procedures. Shapes can be drawn over DEM or Orthomosaic as well as over model using buttons from the Ortho/Model view toolbar. Alternatively, shapes can be loaded from external files (SHP, KML, KMZ, DXF, GeoJSON formats are supported) using Import Shapes... command of Import... submenu available from the File menu. Shapes created in Metashape can be exported using Export Shapes... command of Export... submenu available from the File menu.

To draw a shape on DEM/Orthomosaic/Model

1. Open DEM/orthomosaic in Ortho view double clicking on DEM/orthomosaic label in the Workspace pane. Alternatively, model in Model view.
2. Select $\text{Draw Point} / \text{Draw Polyline} / \text{Draw Polygon}$ instrument from the toolbar.

3. Draw a point/polyline/polygon on the DEM/orthomosaic/model with a cursor. By default the shape vertex will be put on the available surface, however, in Metashape it is possible to draw the shapes on a given plane (for example, at a certain height). To set up the drawing plane, select polyline or polygon shape with three or more vertices or three markers placed in 3D. Then right click on the selection and choose Set Drawing Plane command from the context menu. To reset Drawing Plane select the corresponding command from the context menu.

4. Double click on the last point to indicate the end of a polyline. To complete a polygon, place the end point over the starting one.

5. Once the shape is drawn, a shape label will be added to the chunk data structure on the Workspace pane. All shapes drawn on the same model (and on the corresponding DEM and orthomosaic) will be shown under the same label on the Workspace pane.

6. The program will switch to a navigation mode once a shape is completed.

Drawing shapes in 3D (on the model) solves issues with building basements and other features which are not visible on the orthomosaic. However, drawing on a model might not be accurate enough. For this case Metashape offers possibility to draw a shape on source photos and automatically reconstruct it in 3D.

**To automatically reconstruct a shape in 3D**

1. Enable Attach markers option available in Markers submenu of Tools menu.

2. Open a photo in Photo view double clicking on the photo thumbnail in the Photo pane.

3. Select $\text{Draw Point} / \text{Draw Polyline} / \text{Draw Polygon}$ instrument from the toolbar.

4. Draw a point/polyline/polygon on the photo with a cursor.

5. Double click on the last point to indicate the end of a polyline. To complete a polygon, place the end point over the starting one. All the vertices will be indicated with markers.

6. Switch to Model view to see that the shape has been reconstructed in 3D automatically.

7. To refine the position of the shape, filter photos by shape using the corresponding command from the shape context menu. The shape must be selected - to select a shape double click on it.

8. Inspect all the relevant photos to refine markers-vertices positions where necessary. The position of the shape in 3D will automatically be refined.

After a shape has been drawn, it can be edited using Insert Vertex / Delete Vertex commands from the context menu. Delete Vertex command is active only for a vertex context menu. To get access to the vertex context menu, select the shape with a double click first, and then select the vertex with a double click on it. To change position of a vertex, drag and drop it to a selected position with the cursor. Positions of the markers-vertices cannot be changed in the Model view.

Shapes allow to measure distances both on DEM and 3D model and to measure coordinates, surface areas and volumes on 3D model. Please refer to Performing measurements on 3D model, Performing measurements on DEM sections of the Manual for details.

Shapes added to the particular chunk of the project can be organized into layers. The first layer is generated automatically on creation of the first shape and is placed into the Shapes folder on the project tree. This
layer is meant to serve as a background thus named No Layer. It is originally set as default one to store all the shapes.

To create a new layer use Create Shape Layer command from the context menu of the Shape folder on the Workspace pane. A layer can be set as default one using Set as default command from the context menu of the layer name on the Workspace pane. A newly created layer can be renamed with a relevant command from the context menu.

Export Layers... command from the context menu of a layer allows to save shapes from the layer in one of the supported export formats available: SHP, DXF, KML, KMZ, GeoJSON.

A shape can be labeled and saved to a certain layer using Properties... command from the context menu of the shape in the Model/Ortho view.

Shape properties

The style of the shape layer can be defined in Metashape. It is possible to assign the label, border color, fill color and fill style (for polygons) and transparency for the layer. Attribute table customization is available from the shape properties dialog for each shape, where an attribute and its value can be specified.

Note

- Polygon fill style is applied only in Ortho view mode.

To set properties for a shape

1. Right-clink on the selected shape in the Model, Ortho or Photo view mode.
2. Select Properties... command from the context menu.
3. Assign the shape to an existing layer from the list or create a new one by clicking on Add Layer button.
4. Populate the attribute table for the shape.
5. Click OK if to complete the settings.

It is possible to modify the style of the shape layer in the Metashape from the shape Properties pane. To open the Properties pane, select Properties command from the View menu. Properties (Label, Description and Layer) for the selected shape will appear in this pane. To customize the layer style for this shape, double click on the Layer line and click on the Edit layer button. Parameters can be modified in the opened Shape layer properties dialog.

Orthomosaic seamlines editing

Metashape software offers various blending options at orthomosaic generation step for the user to adjust processing to their data and task. However, in some projects moving objects can cause artefacts which interfere with visual quality of the orthomosaic. The same problem may result from oblique aerial imagery processing if the area of interest contains high buildings or if the user has captured facade from too oblique positions. To eliminate mentioned artefacts Metashape offers seamline editing tool. The functionality allows to choose manually the image or images to texture the indicated part of the orthomosaic from. Thus, the final orthomosaic can be improved visually according to the user's expectations.

Automatic seamlines can be turned on for inspection in the Ortho view with pressing the Show Seamlines button from the Ortho view toolbar.
To edit orthomosaic seamlines

1. Draw a polygon on the orthomosaic using \(\text{Draw Polygon}\) instrument to indicate the area to be retextured.

2. Select \(\text{Assign Images...}\) command from the context menu of the selected polygon.

3. In the \(\text{Assign Images}\) dialog box select the image to texture the area inside the polygon from. Orthomosaic preview on the \(\text{Ortho}\) tab allows to evaluate the results of the selection. Click \(\text{OK}\) button to finalize the image selection process.

4. Click \(\text{Update Orthomosaic}\) button from the \(\text{Ortho}\) view toolbar to apply the changes.

Assign Images dialog allows to activate multiple selection option. If the \(\text{Allow multiple selection}\) option is checked, it is possible to assign several images to texture the area inside the polygon from. However, in this case there is no possibility to preview the resulting orthomosaic. It is necessary to click \(\text{Update Orthomosaic}\) button from the \(\text{Ortho}\) view toolbar to apply the changes and see the results. Until the changes are applied, the area of interest will be marked with a net of blue color to indicate that some edits are waiting for enforcement. Blending method selected at build orthomosaic step will be implemented at orthomosaic editing step.

Assign Images dialog, alternatively, allows to exclude selected images from texturing the area of interest. Check \(\text{Exclude selected images}\) option to follow this way. Please note that in this case preview illustrates the image to be excluded, i.e. the results one should expect after applying the changes are not shown. Click \(\text{Update Orthomosaic}\) button from the \(\text{Ortho}\) view toolbar to apply the changes.

If the Assign image operation should be repeated several times, it is recommended to use \(\text{Draw Patch}\) tool available from the \(\text{Ortho}\) menu or with a corresponding \(\text{Toolbar}\) button of the \(\text{Ortho}\) view menu. In this case it will still be required to draw polygons as in the procedure above, but the best fit image will be assigned automatically, being selected with respect to the first drawn vertex of the patch.

Editing textures

Remove lighting

Metashape can delight texture automatically. Generally, removing shadows and recovering lighting-neutral color while preserving texture features is impossible - at least because of ambiguity between dark texture produced by shadows on surface and dark texture produced by dark regions of the surface. But in practice in many cases heuristics based on some assumptions can provide good results.

Texture delighting tool smooths out dark and light sides of object model and can additionally light up surface areas that were found to be too dark with respect to ambient occlusion map.

1. Open project with textured model. In case the external model should be delit, the empty project or new chunk can be created, add new chunk selecting \(\text{Add Chunk}\) command from the \(\text{Workspace}\) context menu and then import textured mesh using \(\text{Import Model}\) command in the \(\text{Import}\) submenu of \(\text{File}\) menu.

2. Duplicate model. To be able to compare delighted texture with the original one afterwards, you should preliminary duplicate the model and then delight only the second one. To duplicate the model, right click on Workspace \(3D\ Model\) and select \(\text{Duplicate}\).
3. Select *Remove lighting* command from the *Mesh* submenu of the *Tools* menu.

In the *Remove lighting* dialog box select the kind of parameters to be performed. Options include: color mode, presets and ambient occlusion. Click *OK* button when done.

**Color mode**

You can use two types color mode: Single color and Multi color. Use Single color if the model is homogeneous and use Multi color if scene presents a combination of the colors.

**Presets**

Preset configures advanced parameters for some special cases.

**Aggressive (for rocks)**

Preset, it is adjusted for delighting of rocks, but still sometimes can lead to artefacts.

**Ambient occlusion map**

Optionally, you can load into Metashape ambient occlusion texture map and the tool will try to recover ambient occlusion dark areas on the model.

### Resize texture

Metashape supports texture resizing. Select *Resize texture* command from the Mesh submenu in the *Tools* menu to change the size of the texture.

In the *Resize texture* dialog box set the diffuse map size in pix. Click *OK* button when done.

**Diffuse map size (pix)**

You can set the parameters for resizing texture in order to upscale or downscale it.
Chapter 7. Automation

Using chunks

When working with typical data sets, automation of general processing workflow allows to perform routine operations efficiently. Metashape allows to assign several processing steps to be run one by one without user intervention thanks to Batch Processing feature. Manual user intervention can be minimized even further due to 'multiple chunk project' concept, each chunk to include one typical data set. For a project with several chunks of the same nature, common operations available in Batch Processing dialog are applied to each selected chunk individually, thus allowing to set several data sets for automatic processing following predefined workflow pattern.

In addition, multiple chunk project could be useful when it turns out to be hard or even impossible to generate a 3D model of the whole scene in one go. This could happen, for instance, if the total amount of photographs is too large to be processed at a time. To overcome this difficulty Metashape offers a possibility to split the set of photos into several separate chunks within the same project. Alignment of photos, building dense point cloud, building mesh, and forming texture atlas operations can be performed for each chunk separately and then resulting 3D models can be combined together.

Working with chunks is not more difficult than using Metashape following the general workflow. In fact, in Metashape always exists at least one active chunk and all the 3D model processing workflow operations are applied to this chunk.

To work with several chunks you need to know how to create chunks and how to combine resulting 3D models from separate chunks into one model.

Creating a chunk

To create new chunk click on the Add Chunk toolbar button on the Workspace pane or select Add Chunk command from the Workspace context menu (available by right-clicking on the root element on the Workspace pane).

After the chunk is created you may load photos in it, align them, generate dense point cloud, generate mesh surface model, build texture atlas, export the models at any stage and so on. The models in the chunks are not linked with each other.

The list of all the chunks created in the current project is displayed in the Workspace pane along with flags reflecting their status.

The following flags can appear next to the chunk name:

R (Referenced)
Indicates that 3D model in the chunk was referenced. Also will appear when two or more chunks are aligned with each other. See information on how to reference the model in Setting coordinate system.

S (Scaled)
Indicates that 3D model in the chunk was scaled based on scale bars information only, with no reference coordinates data being present. See information on scale bar placement in Optimization section.

T (Transformed)
Indicates that 3D model has been modified manually with at least one of the following instruments: Rotate object, Move object or Scale object.
To move photos from one chunk to another simply select them in the list of photos on the Workspace pane, and then drag and drop to the target chunk.

**Note**
- Chunk can contain several instances of the same object (point clouds, 3D model, etc).

## Working with chunks

All operations within the chunk are carried out following the common workflow: loading photographs, aligning them, generating dense point cloud, building mesh, building texture atlas, exporting 3D model and so on.

Note that all these operations are applied to the active chunk. When a new chunk is created it is activated automatically. Save project operation saves the content of all chunks. To save selected chunks as a separate project use *Save Chunks* command from the chunk context menu.

### To set another chunk as active

1. Right-click on the chunk title on the Workspace pane.
2. Select *Set Active* command from the context menu.

### To remove chunk

1. Right-click on the chunk title on the Workspace pane.
2. Select *Remove Chunks* command from the context menu.

To rearrange the order of chunks in the Workspace pane simply drag and drop the chunks in the pane.

## Aligning chunks

After the "partial" 3D models are built in several chunks they can be merged together. Before merging chunks they need to be aligned.

### To align separate chunks

1. Select *Align Chunks* command from the Workflow menu.
2. In the *Align Chunks* dialog box select chunks to be aligned, indicate reference chunk with a double-click. Set desired alignment options. Click *OK* button when done.
3. The progress dialog box will appear displaying the current processing status. To cancel processing click the *Cancel* button.

## Aligning chunks parameters
"Align Chunks" dialog

The following parameters control the chunks alignment procedure and can be modified in the Align Chunks dialog box:

**Method**
Defines the chunks alignment method. **Point based** method aligns chunks by matching photos across all the chunks. **Marker based** method uses markers as common points for different chunks. The details on using markers are available in the Setting coordinate system section. **Camera based** method is used to align chunks based on estimated camera locations. Corresponding cameras should have the same label.

**Accuracy (Point based alignment only)**
Higher accuracy setting helps to obtain more accurate chunk alignment results. Lower accuracy setting can be used to get the rough chunk alignment in the shorter time.

**Point limit (Point based alignment only)**
The number indicates upper limit of feature points on every image to be taken into account during **Point based** chunks alignment.

**Fix scale**
Option is to be enabled in case the scales of the models in different chunks were set precisely and should be left unchanged during chunks alignment process.

**Preselect image pairs (Point based alignment only)**
The alignment process of many chunks may take a long time. A significant portion of this time is spent for matching of detected features across the photos. Image pair preselection option can speed up this process by selection of a subset of image pairs to be matched.
Apply mask to (Point based alignment only)
If **apply mask to key points** option is selected, areas previously masked on the photos are excluded from feature detection procedure. **Apply mask to tie points** option means that certain tie points are excluded from alignment procedure. Effectively this implies that if some area is masked at least on a single photo, relevant key points on the rest of the photos picturing the same area will be also ignored during alignment procedure (a tie point is a set of key points which have been matched as projections of the same 3D point on different images). This can be useful to be able to suppress background in turntable shooting scenario with only one mask. For additional information on the usage of masks please refer to the [Using masks] section.

### Note
- Chunk alignment can be performed only for chunks containing aligned photos.
- There is no need to perform chunk alignment for georeferenced chunks, as they are already in the same coordinate frame.

### Merging chunks

After alignment is complete the separate chunks can be merged into a single chunk.

### Note
- We recommend processing all the images in a single chunk to provide better accuracy and quality of the final results than the chunking method (separate processing of the sub-sets of the complete photos set and merging them).

**To merge chunks**

1. Select *Merge Chunks* command from the *Workflow* menu.
2. In the *Merge Chunks* dialog box select chunks to be merged and the desired merging options. Click *OK* button when done.
3. Metashape will merge the separate chunks into one. The merged chunk will be displayed in the project content list on *Workspace* pane.

### Merge chunks parameters
The following parameters control the chunks merging procedure and can be modified in the *Merge Chunks* dialog box:

**Merge dense clouds**
Defines if dense clouds from the selected chunks are combined.

**Merge models**
Defines if models from the selected chunks are combined.

**Merge DEMs**
Defines if DEMs from the selected chunks are combined.

**Merge depth maps**
Defines if depth maps from the selected chunks are combined.

**Merge tie points**
Defines if the projections of the tie points for corresponding features should be merged. Since tie points merging operation assumes re-matching of the features from different chunks, the operation may be time consuming. Thus it is recommended to disable tie points merging, unless it is required by the task specifics.

**Merge markers**
Defines if markers from the selected chunks are merged (only markers with the same labels would be merged).

**Merge orthomosaics**
Defines if orthomosaics from the selected chunks are combined.

Chunks merging result (i.e. photos, point clouds and geometry) will be stored in the new chunk and it may be treated as an ordinary chunk (e.g. the model can be textured and/or exported).

**Note**
- Dense cloud and model merging operations will be applied only to the active items. Disabled (inactive) items will not be transferred to the merged chunk.
Batch processing

Metashape allows to perform general workflow operations with multiple chunks automatically. It is useful when dealing with a large number of chunks to be processed.

Batch processing can be applied to all chunks in the Workspace, to unprocessed chunks only, or to the chunks selected by the user. Each operation chosen in the Batch processing dialog will be applied to every selected chunk before processing will move on to the next step.

<table>
<thead>
<tr>
<th>Align Photos</th>
<th>Align/Merge Chunks</th>
<th>Save/Load Project</th>
</tr>
</thead>
<tbody>
<tr>
<td>Optimize Alignment</td>
<td>Decimate Mesh</td>
<td>Export/Import Cameras</td>
</tr>
<tr>
<td>Build Dense Cloud</td>
<td>Smooth Model</td>
<td>Export Points</td>
</tr>
<tr>
<td>Build Mesh</td>
<td>Close Holes</td>
<td>Export Model</td>
</tr>
<tr>
<td>Build Texture</td>
<td>Calibrate Colors</td>
<td>Export Texture</td>
</tr>
<tr>
<td>Build Tiled Model</td>
<td>Remove Lighting</td>
<td>Export Tiled Model</td>
</tr>
<tr>
<td>Build DEM</td>
<td>Classify Points / Ground Points</td>
<td>Export DEM</td>
</tr>
<tr>
<td>Build Orthomosaic</td>
<td>Import Shapes</td>
<td>Export Orthomosaic</td>
</tr>
<tr>
<td>Refine Mesh</td>
<td>Import Masks</td>
<td>Reset Region</td>
</tr>
<tr>
<td>Sample Points</td>
<td>Generate Masks</td>
<td>Convert Images</td>
</tr>
<tr>
<td>Detect Markers</td>
<td>Detect Fiducials</td>
<td>Run Script</td>
</tr>
<tr>
<td>Generate Report</td>
<td>Colorize Dense Cloud / Model</td>
<td></td>
</tr>
</tbody>
</table>

To start batch processing

1. Select Batch Process... command from the Workflow menu.
2. Click Add to add the desired processing stages.
3. In the Add Job dialog select the kind of operation to be performed, the list of chunks it should be applied to, and desired processing parameters. Click OK button when done.
4. Repeat the previous steps to add other processing steps as required.
5. Arrange jobs by clicking Up and Down arrows at the right of the Batch Process... dialog box.
6. Click OK button to start processing.
7. The progress dialog box will appear displaying the list and status of batch jobs and current operation progress. To cancel processing click the Cancel button.
When the batch process includes import/export features that are applied to multiple chunks it is reasonable to use the following templates in the Path field of the import/export jobs:

- `{filename}` - filename (without extension),
- `{fileext}` - file extension,
- `{camera}` - camera label,
- `{frame}` - frame index,
- `{chunklabel}` - chunk label,
- `{imagefolder}` - folder containing images of an active chunk,
- `{projectfolder}` - path to the folder containing current project,
- `{projectname}` - current project filename,
- `{projectpath}` - absolute path to the current project.

The list of tasks for batch processing can be exported to XML structured file using the Save button in the Batch processing dialog and imported in a different project using the Open button.

**4D processing**

**Overview**

Metashape supports reconstruction of dynamic scenes captured by a set of statically mounted synchronized cameras. For this purpose multiple image frames captured at different time moments can be loaded for
each camera location, forming a multiframe chunk. In fact normal chunks capturing a static scene are multiframe chunks with only a single frame loaded. Navigation through the frame sequence is performed using *Timeline* pane.

Although a separate static chunk can be used to process photos for each time moment, aggregate multiframe chunks implementation has several advantages:

- Coordinate systems for individual frames are guaranteed to match. There is no need to align chunks to each other after processing.
- Each processing step can be applied to the entire sequence, with a user selectable frame range. There is no need to use batch processing, which simplifies the workflow.
- Accuracy of photo alignment is better due to the joint processing of photos from the entire sequence.
- Markers can be tracked automatically through the sequence.
- Intuitive interface makes navigation through the sequence pretty simple and fast.

Multiframe chunks can be also efficient (with some limitations) for processing of disordered photo sets of the same object or even different objects, provided that cameras remain static throughout the sequence.

**Managing multiframe chunks**

Multiframe layout is formed at the moment of adding photos to the chunk. It will reflect the data layout used to store image files. Therefore it is necessary to organize files on the disk appropriately in advance. The following data layouts can be used with Metashape:

a. All frames from corresponding camera are contained in a separate subfolder. The number of subfolders is equal to the number of cameras.

b. Corresponding frames from all cameras are contained in a separate subfolder. The number of subfolders is equal to the number of frames.

c. All frames from corresponding camera are contained in a separate multilayer image. The number of multilayer images is equal to the number of cameras.

d. Corresponding frames from all cameras are contained in a separate multilayer image. The number of multilayer images is equal to the number of frames.

Once the data is properly organized, it can be loaded into Metashape to form a multiframe chunk. The exact procedure will depend on whether the multifolder layout (variants a and b) or multilayer (variants c and d) layout is used.

**To create a chunk from multifolder layout**

1. Select *Add Folder...* command from the *Workflow* menu.
2. In the *Add Folder* dialog box browse to the parent folder containing subfolders with images. Then click *Select Folder* button.
3. In the *Add Photos* dialog select *Dynamic scene (4D)* data layout. For layout a) above select *Create camera from each subfolder*. For layout b) select *Create frame from each subfolder*.
4. Created multiframe chunk will appear on the *Workspace* pane.
To create a chunk from multilayer images

1. Select Add Photos... command from the Workflow menu or click Add Photos toolbar button.

2. In the Add Photos dialog box browse to the folder containing multilayer images and select files to be processed. Then click Open button.

3. In the Add Photos dialog select the suitable data layout. For layout c) above select Create camera from each multilayer file. For layout d) select Create frame from each multilayer file.

4. Created multiframe chunk will appear on the Workspace pane.

It is recommended to inspect the loaded frame sequence for errors. This can be done by scrolling the frame selector in the Timeline pane and inspecting thumbnails in the Photos pane during scrolling.

In case each frame should be processed completely separately, it is possible to split them using Split frames... command from the chunk context menu.

Frames can be added from one chunk to another. To do that right-click on the chunk's label in the Workspace pane and select Add > Add frames command. In the Add Frames dialog select chunk where from the frames will be added and click OK button.

After multiframe chunk is created, it can be processed in the same way as normal chunks. For multiframe chunks additional processing parameters allowing to select the range of frames to be processed will be provided where appropriate.

Tracking markers

Metashape allows to automatically track marker projections through the frames sequence, provided that object position doesn't change significantly between frames. This greatly simplifies the task of labeling of a moving point if the number of frames is large.

To track markers through the frame sequence

1. Scroll frame selector in the Timeline pane to the 1st frame. Add markers for the 1st frame as described in the Setting coordinate system section.

2. Select Track Markers... command from the Markers submenu of the Tools menu.

3. Adjust the starting and ending frame indices if necessary. Default values correspond to tracking from the current frame to the end of sequence. Click OK button to start tracking.

4. Check tracked marker locations. Automatically tracked markers will be indicated with icons. In case of a placement error at some frame, adjust the wrong marker location within the frame where the failure occurred. Once the marker location is refined by user, the marker icon will change to

5. Restart tracking from that frame using Track Markers... command again.

Note

- If the ending frame index is smaller than the starting index, tracking will be performed in the backwards direction.
• Automatic marker tracking is likely to fail in case when structured light is used to add texture details to the object surface, as the light pattern will not be static with respect to the moving object surface.

Python scripting

Python scripting in Metashape

Metashape supports Python API, using Python 3.8 as a scripting engine.

Python commands and scripts can be executed in Metashape through one of the following options:

1. Metashape Console pane can serve as Python rich console.

2. Click Run Script button on Console pane toolbar or use Run Script... command from the Tools menu to run a Python script.

From command-line using -r argument.

On Windows:
metashape.exe -r <scriptname.py>

On Linux:
./metashape.sh -r <scriptname.py>

On macOS:
./MetashapePro.app/Contents/MacOS/MetashapePro -r <scriptname.py>

From autorun folder.

for Windows: C:/Users/<user>/AppData/Local/Agisoft/Metashape Pro/scripts/

for Linux: /home/<user>/local/share/Agisoft/Metashape Pro/scripts/

for macOS: /Users/<user>/Library/Application Support/Agisoft/Metashape Pro/scripts/

on any OS (for all users): <installation folder>/scripts/

For details on Metashape functionality accessible through Python scripts please refer to Python API Reference document available on Agisoft official website (http://www.agisoft.com/downloads/user-manuals/).

The collection of the sample Python scripts is available on Agisoft GitHub repository: https://github.com/agisoft-llc/metashape-scripts.

Stand-alone Python module

Metashape can be used as Python 3 package for stand-alone Python module development.

To configure development environment

1. Download Metashape Python 3 module for your platform from Agisoft web-site: https://www.agisoft.com/downloads/installer/
2. Install Metashape Python 3 module
3. Import Metashape Python 3 module and start development: `import Metashape`

**Java API**

Metashape Java API allows to integrate photogrammetric processing engine into applications developed using Java programming language. It comes in the form of software library and need to be downloaded separately from Downloads section of Agisoft website.

**To configure development environment**

2. Unpack downloaded archive and copy libs and jniLibs folders to your project directory.
3. Add jars from the libs folder to your classpath.

⚠️ **Important**

Java garbage collection system may not release memory associated with Metashape objects in a timely manner as it doesn't know memory consumption of underlying native objects. To prevent excessive memory consumption it is highly recommended to call `delete()` method manually for each object obtained using Metashape Java API when it is no longer needed.

For details on Metashape Java API functionality please refer to the included javadoc package. Also please take a look at examples available in the samples directory to get started.
Chapter 8. Distributed processing

Local network processing

Overview

Agisoft Metashape can be configured to run on a computer cluster where processing is distributed on several computer nodes connected to a local network. In such configuration multiple Metashape instances running on different processing nodes can work on the same task in parallel, effectively reducing the total processing time needed.

Processing tasks are divided between the nodes on a chunk by chunk or frame by frame basis (when possible). In addition a more fine grained distribution can be optionally enabled for image matching and alignment, generation of dense point clouds, tiled models, DEMs and orthomosaics, as well as mesh generation from depth maps, in which case processing of individual chunks/frames will be further subdivided between several processing nodes.

Communication between processing nodes, server and clients is performed using TCP connections. In addition, shared network storage accessible for all processing nodes and clients is used for storing the source data and intermediate processing results.

Cluster components

Server

The server node coordinates operation of all processing nodes, maintaining a task queue for all projects scheduled for processing. The clients can connect to the server to start new processing tasks or monitor progress of existing ones.
Distributed processing

The server itself doesn't perform any processing and can easily run on slow hardware. The server component is critical for operation of the cluster, and is not fault tolerant. Measures should be taken to ensure continuous operation of the server node.

The server node accepts TCP connections from processing nodes and clients. Additional slave servers can be connected to the master server to perform replication of processing queue for additional fault tolerance in critical environments.

Processing nodes

Processing nodes perform actual calculations, and thus need to be run on fast hardware. Each processing node connects to the server on startup and waits for a task to be assigned. Once the task is available, the node starts processing, informing the server about the progress. When processing is finished, the results are stored on shared network storage, and the server is informed about completion. Then a node switches to the next task when it becomes available.

Processing nodes can be added or removed from the cluster as needed. Abnormal shutdown of processing node doesn't cause cluster failure in most cases. Nevertheless, it is highly recommended to stop particular nodes using Agisoft Network Monitor before disconnecting them from the cluster.

Clients

Clients can connect to the server node to control cluster operation or to monitor its status. New tasks can be submitted for processing using Agisoft Metashape software configured as a network client, while cluster monitoring is performed using Agisoft Network Monitor. Multiple clients can be connected to the server node simultaneously.

Cluster setup

Before proceeding to the following steps please make sure that shared network storage is accessible from all processing and client nodes using the same absolute path. It should be either mounted to the same folder on all nodes (Linux), or should have the same UNC network path (Windows). In case such configuration is not possible (for example in mixed Windows/Linux cluster), a path prefix can be specified on each node to compensate for the differences.

Starting server

It is recommended to configure server with a static IP address, not dynamically assigned one. This IP address will be needed for each processing node and client.

The server process can be started by executing Metashape with the following command line arguments:

```
metashape --server --host <ip>[:port]
```

--server parameter specifies that Metashape should be started in a server mode.

--host <hostname>[:port] parameter specifies the network interface to be used for communication with clients and processing nodes. In case port value is omitted, the default port 5840 is used. The host parameter can be specified multiple time, in which case the server will listen for connections on multiple interfaces.

--master <hostname>[:port] parameter switches the server to slave mode and starts replication of the specified master server. In case port value is omitted, the default port 5840 is used.

Example:
metashape --server --host 10.0.1.1

In this case Metashape will use 10.0.1.1 interface for both clients and processing nodes with default port value.

Starting network nodes

The processing node can be started by executing Metashape with the following command line arguments:

metashape --node --host <ip>[<port>] [--root prefix]

--node parameter specifies that Metashape should be started as a processing node.

--host <hostname>[<port>] parameter specifies IP of the server to connect. In case port value is omitted, the default port 5840 is used. The host parameter can be specified multiple times, in which case the node will automatically connect to the next server in the list if the previous one becomes unavailable. This is useful when using slave servers.

--root <path> parameter can be used to specify network storage mount point or prefix path in case it is not the same across network.

--priority <priority> parameter can be used to specify the priority of the node. Higher number means higher priority.

--capability {cpu, gpu, any} parameter can be used to specify whether the node should work on CPU-only tasks, GPU-supported tasks only or will receive any tasks.

--gpu_mask <mask> parameter set GPU device mask for GPU-supported tasks.

--cpu_enable {0,1} parameter can be used to enable or disable CPU during the GPU-supported tasks.

--absolute_paths {0,1} parameter can be used to set the absolute paths option.

--timestamp parameter can be used to append timestamps to the output messages.

--auto-submit parameter can be used to enable automatic crash report submission.

--email <address> parameter specifies email address to be included in the crash reports.

--comment <text> parameter specifies optional comment to be included in the crash reports.

Example:

metashape --node --host 10.0.1.1 --root /mnt/datasets

This command will start processing node using 10.0.1.1 as a server IP with default port 5840.

Checking cluster status

Start Agisoft Network Monitor application. In the host name field enter server IP used for client connections (10.0.1.1 in our example). Modify port values in case non-default port was specified. Click Connect button when done.

A list of available network nodes currently connected to the server will be displayed in the bottom part of the window. Please make sure that all started processing nodes are listed. Agisoft Network Monitor for each node allows to modify the node priority, capability, CPU enable flag, GPU mask and to pause/resume...
the node. The priority for the tasks can be also altered and tasks themselves can be paused, resumed and aborted via Agisoft Network Monitor.

The top part lists tasks currently being processed (finished tasks are removed from the list as soon as they are completed). The task list will be empty if no processing was started yet.

**Starting network processing**

1. Configure Agisoft Metashape for network processing.

   Start Agisoft Metashape on any computer connected to the cluster network.

   Open *Preferences* dialog using *Preferences...* command from the *Tools* menu. On the *Network* tab make sure Enable network processing option is turned on, and specify the server IP used for client connection in the Host name field. In case non-default port was configured on a server, modify the port value accordingly.

   In case you are going to process a few single-frame chunks with large number of photos, please make sure that *Enable fine-level task subdivision* option is turned on in the *Advanced* tab of *Preferences* dialog. The subdivision will be automatically applied when possible to all the supported operations (Match Photos, Align Cameras, Build Depth Maps, Build Mesh from Depth Maps, Build Dense Cloud, Build Tiled Model, Build DEM, Build Orthomosaic, Classify Points). In case you are going to process a large number of small chunks, or chunks with large number of frames, fine-level task subdivision can be disabled, therefore each chunk or frame will be processed on the single node only without any further internal distribution applied.

   Press *OK* button when done.

2. Prepare project for network processing.

   Open the project file to be processed. Make sure that the project is saved in Metashape Project (*.psx) format. Processing of projects in Metashape Archive (*.psz) format is not supported in network mode.

   🟠 **Important**
   
   Please make sure that source images are located on shared network storage and not on a local hard drive. Otherwise processing nodes will be unable to load them.

3. Start processing.

   Start processing using corresponding command from the *Workflow* menu, or using *Batch Process* command to execute a command sequence. A network progress dialog should appear displaying current progress.

4. Wait for processing to complete.

   You can disconnect from the server at any time using *Disconnect* button in the *Network Progress* dialog in case you need to work on other projects. Processing will continue in the background.

   To see processing status after you have disconnected from the server simply open corresponding .psx project on the network storage. Alternatively you can use Agisoft Network Monitor to see processing status for all projects being processed.

5. Inspect processing results.

   After processing is finished, click *Close* button to close *Network Progress* dialog. The project with processing results will be displayed in Metashape window.
Cluster administration

Adding processing nodes

New processing nodes can be added by starting Agisoft Metashape on additional computers in the network node mode, as outlined in the Starting network nodes section above.

Removing processing nodes

Aborting or disconnecting processing node during cluster operation is not absolutely safe, and can lead to project corruption if performed during final project update at the end of processing. Although the chances of this situation are relatively low, we strongly recommend against such approach. To safely disconnect processing node from the cluster you need to stop processing on this node using Agisoft Network Monitor first.

1. Start Agisoft Network Monitor. Make sure the server IP is properly configured in the host name field and click Connect button.

2. In the bottom list of network nodes identify the node to be removed. From the node menu select Pause command to stop the node after it finishes current job, or Stop command to abort processing immediately.

3. Wait until the Batch # and Progress items for a selected node become empty. This indicates that the node has finished processing. The status of the node should be Paused.

4. Now you can safely disconnect the node by aborting Metashape process.

Using server replication

In case of abnormal termination of the server node processing queue will be lost, and all incomplete tasks will need to be restarted from the beginning. To avoid such problem it is possible to set up one or more slave servers, that will be automatically synchronized with a master server. In case of a master server failure, it will be possible to resume processing by switching to the one of the available slave servers.

Here is an example setup of a cluster with a server replication:

```
metashape --server --host 10.0.1.1
metashape --server --host 10.0.2.1 --master 10.0.1.1
metashape --node --host 10.0.1.1 --host 10.0.2.1 --root /mnt/datasets
```

These commands will start a master server at 10.0.1.1 interface and a slave server on 10.0.2.1 interface. In addition a node will be configured to look for an active master server at 10.0.1.1 and 10.0.2.1 addresses. In case of a master server failure the node will automatically reconnect to another master server.

Important

- In case of a master server failure, slave servers will not switch to a master state automatically. An operator will need to switch one of the slave servers to a master state manually using Reset Master Server command from the Agisoft Network Monitor File menu and connect remaining slave servers to a new master. In the unattended environment this can be automated using a Python or Java API.
Distributed processing

• Before switching to a new master server please make sure that original master server is disabled and will not be unexpectedly restored (due to a temporary network failure for example). Simultaneous operation of two master servers will result in inconsistent project state and further processing will fail.

Installing server and nodes as a Windows service

It is possible to configure server and nodes to run as a service on Windows. In this log in.

The following command line parameters are used to manage Windows service settings:

--service {install,remove,start,stop} parameter can be used to configure Windows service.

--service-name <name> optional parameter for Windows service name. Required when multiple services needs to be installed on the same computer.

Examples:

metashape --service install --node --host 10.0.1.1 --root /mnt/datasets
metashape --service install --server --host 10.0.1.1
metashape --service start
metashape --service stop
metashape --service remove

☑️  Note

• These commands must be executed from Administrators Command Prompt as they require elevated privileges.

Cloud processing

Overview

Agisoft Metashape presents cloud processing option integrated into the application user interface for those who are interested in high quality outputs for big datasets, without need to invest into hardware infrastructure.

Starting cloud processing

Cloud processing option is only accessible for those Metashape license owners who have registered on Agisoft Cloud page: https://cloud.agisoft.com/. Personal account page provides information about current subscription plan, storage space and processing hours available, projects published in the cloud, invoices and personal data. Having completed the registration and having chosen the appropriate payment plan, one should input Agisoft Cloud account credentials to the Network tab of Preferences dialog in Metashape application.

Setting up cloud processing in Metashape

1. Select Preferences command from the Tools menu.
Distributed processing

2. Input your Agisoft account credentials to the Network tab in Preferences dialog.

3. Check the box for Enable cloud processing option to turn it on. Check that Enable network processing option is turned off.

4. Click OK button when done.

Once the cloud processing option is enabled, each time the processing operation is run in Metashape a confirmation dialog will appear, asking if the operation should be executed locally or in the cloud. If the cloud processing option is selected in the dialog, the project data and related source imagery will be uploaded/synchronized with the data in your personal Agisoft Cloud account. To monitor the status of the project, you can use Project tab on the personal account page.

Do not disable Internet connection nor shut down the computer when uploading process is in progress. You can disconnect, however, once the processing has been started according to the indication in the program interface and in the web interface of your personal account.

Next time you open a local project for which a processing operation in Agisoft Cloud is finished the updated project files will be downloaded from the cloud and synchronized with your local project copy.

Download project from the cloud

To download project from the cloud

1. Select Download Project... command from the Cloud submenu of the File menu.

2. Select the project to be downloaded from the list.

3. Click OK to start the download process.

Visualize project results

To make cloud project available for visualization in web interface, it is necessary to publish it, first. Publication is a process of preparing processing results for 3D visualization in web interface. The publication is only available for georeferenced PSX projects. Each publication takes up storage space.

When processing a new project in Agisoft Cloud for the first time, you may check Publish results option in the Schedule processing in the cloud Metashape dialog. If Publish results option is checked on during the first processing of the current project in Agisoft Cloud, results of further processing iterations for the same project will be published automatically.

Furthermore, it is possible to publish project via Agisoft Cloud web interface.

When the project is published, use View button to inspect project results.

To unpublish the project (i.e. disable the possibility to view the project processing results online) use Unpublish button on the projects page of your personal account. The Unpublish button is available when the project is selected from the list.

Upload project into the cloud

If the cloud processing option is enabled and properly configured (valid email and password are input to the Network tab of Preferences dialog) in Metashape, each time the processing operation in run in Agisoft Cloud, a synchronization procedure will be started and the source imagery together with the project file directory will be uploaded to your Agisoft Cloud account.
Optionally, it is possible to upload project to Agisoft Cloud from Metashape user interface manually, without running any processing operation.

**To upload project into the cloud**

1. Select Upload Project... command from Cloud submenu of the File menu.
2. Click Yes button to confirm the operation and start the upload process.

**Download photos from the cloud**

**To download photos from the cloud**

1. In Metashape user interface open the project which the photos should be downloaded for.
2. Select Download Photos... command from the Cloud submenu of the File menu.
3. In the Download Photos dialog specify the target folder for the images and select the images to be downloaded from the list.
4. Click OK to start the download process.

**Note**

- Cloud processing is supported only for projects saved in Metashape Project (*.psx) format.
- All the files related to a certain project can be removed to free the disk space available for the subscription plan from your personal account in Agisoft Cloud web interface.
- Some operations do not support processing in the cloud (for example, no of the export operations are supported). If the Batch Process task sent to the Cloud includes such operations, the warning message will be displayed and the batch processing task list should be adjusted before sending it to the Agisoft Cloud again.

**Share cloud project**

In Agisoft Cloud the following project sharing methods are available: share a project with a link and share a project via email. Each project by default is in private mode. When private mode is activated, only the owner of the project has access to view project visualization in the web interface and download it via Metashape desktop application.

**To share project with a link**

1. Click on the Share button on the project visualization page or select Share option in the project menu on My Projects page.
2. In the Share pop-up window select Anyone with the link can view option from the dropdown menu, copy the link and close the pop-up window.

When share with a link option is activated, each person who has the link will be able to view project visualization in web interface without need to create an account on Agisoft Cloud.

In case it is needed to securely share the project with a person or a number of people, it is possible to share published or unpublished projects by including someone's email into the sharing list. When share via email...
option is activated, invited users will have access to view the project visualization in web interface and download its copy via Metashape desktop application.

**To securely share project via email**

1. Click the *Share* button on the project visualization page or select *Share* option in the project menu on *My Projects* page.

2. In the *Share* pop-up window select *Invited people can view and download* option from the dropdown menu, insert email of the person who you want to grant the access to the project to and click the *Invite* button. Then close the pop-up window.

**Note**

- Those who have an account on Agisoft Cloud will be notified by email and granted the access to view the project visualization in web interface and download its copy via Metashape desktop application.

- Those who have no account on Agisoft Cloud will be invited via email to create an account to be able to view the project visualization in web interface and download its copy via Metashape desktop application.

**To turn off sharing and switch the project to the private mode**

1. Click *Share* button on the project visualization page or select *Share* option in the project menu on *My Projects* page.

2. In the *Share* pop-up window select *Turn off sharing* option in the project menu on *My Projects* page.

**To close the access to the project to a certain person**

1. Click the *Share* button on the project visualization page or select *Share* option in the project menu on *My Projects* page.

2. Delete email of a person who you want the access to the project be closed to by clicking the *Delete* button represented as a cross mark. Then close the pop-up window.
Appendix A. Graphical user interface

Application window

General view

Model view

Model view tab is used for displaying 3D data as well as for mesh and point cloud editing. The view of the model depends on the current processing stage and is also controlled by mode selection buttons on the Metashape toolbar.

Model can be shown as a dense cloud, with class indication or without, or as a mesh in shaded, solid, wireframe or textured mode. Along with the model the results of photo alignment can be displayed. These include sparse point cloud and camera positions visualized data. Additionally tiled textured model can be displayed and navigated in the model view.

Metashape supports the following tools for navigation in the 3D view:

<table>
<thead>
<tr>
<th>Tool</th>
<th>Keyboard modifier</th>
</tr>
</thead>
<tbody>
<tr>
<td>Rotation Tool</td>
<td>Default</td>
</tr>
</tbody>
</table>
Graphical user interface

<table>
<thead>
<tr>
<th>Tool</th>
<th>Keyboard modifier</th>
</tr>
</thead>
<tbody>
<tr>
<td>Pan Tool</td>
<td>Ctrl key pressed</td>
</tr>
<tr>
<td>Zooming Tool</td>
<td>Shift key pressed</td>
</tr>
</tbody>
</table>

All navigation tools are accessible in the navigation mode only. To enter the navigation mode click the

*Navigation* toolbar button.

Metashape offers two different navigation modes: Object navigation and Terrain navigation. Switching
between the navigation modes can be performed from the *Navigation Mode* submenu of the *View* menu.
Object navigation mode allows for 3-axis rotation control, while Terrain navigation mode restricts control
to 2-axis rotation only, z-axis being kept vertical all the time.

In Object navigation mode the rotation with mouse can be performed while left mouse button is pressed,
whereas holding right mouse button allows for model tilt. In Terrain navigation mode mouse buttons
functionality is inverted and left button is responsible for tilt, whereas right button for rotation.

**Note**

- Zooming into the model can be also controlled by the mouse wheel.

**Ortho view**

*Ortho* view is used for the display of 2D processing results data: digital elevation model, full resolution
orthomosaic, raster transformed orthomosaic as well as shapes data. Switching between DEM and
orthomosaic can be performed using the corresponding button on the toolbar or by double-clicking on the
respective icon on the *Workspace* pane, providing that both products have been generated.

Orthomosaic can be displayed in the original colors or in colors according to the palette set for vegetation
index values visualization.

Additional instruments allow to draw points, polylines and polygons on the orthomosaic and/or digital
elevation model to perform point, linear, profile and volume measurements. Also polygonal shapes are
allowed to be set up as inner or outer boundaries, that will be used for the definition of the area to be
exported. Using polygonal shapes allows to create custom seamlines on the orthomosaic, which can be
useful for some projects enabling to eliminate blending artefacts.

Switching to *Ortho* view mode changes the contents of the Toolbar, presenting related instruments and
hiding irrelevant buttons.

**Photo view**

Photo view tab is used for displaying individual images as well as corresponding depth maps in semi-
transparent representation, markers, shapes and masks on them.

In the Photo view tab it is allowed to create markers, refine their projections, draw shapes and adjust
positions of shape vertices and to draw masks on the images. Additionally in Photo view tab it is possible
to display the residuals for the tie points and markers providing that the corresponding camera is aligned.

Photo view is visible only if any image is opened. To open an image in Photo view mode double-click on
the label of the corresponding camera on the *Workspace, Reference or Photos* pane.

For multicamera systems which have several sensors assigned to the same layer Photo view tab will be
vertically split into corresponding number of sub-frames.
Switching to Photo view mode changes the contents of the Toolbar, presenting related instruments and hiding irrelevant buttons.

**Workspace pane**

On the **Workspace** pane all elements comprising the current project are displayed. These elements can include:

- List of chunks in the project
- List of cameras and camera groups in each chunk
- List of markers and marker groups in each chunk
- List of scale bars and scale bar groups in each chunk
- List of shape layers in each chunk
- Tie points in each chunk
- Components in each chunk
- Depth maps in each chunk
- Dense point clouds in each chunk
- 3D models in each chunk
- Tiled models in each chunk
- Digital elevation models in each chunk
- Orthomosaics in each chunk
- Camera tracks in each chunk

Buttons located on the Workspace pane toolbar allow to:

- Add chunk
- Add photos
- Add marker
- Create scale bar
- Enable or disable certain cameras or chunks for processing at further stages.
- Remove items

Each element in the list is linked with the context menu providing quick access to some common operations.

**Photos pane**

*Photos* pane displays the list of photos / masks / depth maps in the active chunk in the form of thumbnails.
Buttons located on the Photos pane toolbar allow to:

• Enable / disable certain cameras
• Remove cameras
• Rotate selected photos clockwise / counterclockwise (for display purposes only)
• Reset current photo filtering option
• Switch between images / masks / depth maps thumbnails
• Increase / decrease icons’ size or display detailed information on photos including EXIF data

**Console pane**

*Console* pane is used for:

• Displaying auxiliary information
• Displaying error messages
• Python commands input

Buttons located on the Console pane toolbar allow:

• Save log (in HTML, XHTML or Plain Text format)
• Clear log
• Execute Python script

**Reference pane**

*Reference* pane is designed for:

• Displaying and editing camera and / or marker coordinates
• Displaying and editing scale bars lengths
• Displaying and editing camera orientation angles
• Displaying estimation errors
• Displaying and editing accuracy parameters for camera/marker coordinates, camera angles and scale bar lengths

Buttons located on the pane toolbar allow:

• Import / export reference coordinates
• Convert reference coordinates from one system to the other
• Optimize camera alignment and update data
• Switch between source coordinates, estimated coordinates and errors views
• Specify the coordinate system and measurement accuracy to be assumed through Settings dialog
Shape Properties pane

*Properties* pane is designed for:

- Displaying and editing labels for selected shapes
- Displaying and editing description for selected shapes
- Displaying and editing existing attribute values for selected shapes
- Adding new attributes for the selected shape
- Assigning shape layer to the selected shapes
- Editing label and style for shape layer assigned to the selected shapes

Buttons located on the pane toolbar allow:

- Add attribute
- Remove attribute

Jobs pane

*Jobs* pane is designed for:

- Monitoring the processing status for active and background projects
- Organizing the background processing queue
- Switching between the projects

Buttons located on the pane toolbar allow:

- Start / pause / cancel the selected tasks
- Change the order of the tasks in the processing queue
- Clear the processing tasks history

Note

- You can switch between projects by right-clicking on the project name.

Timeline pane

*Timeline* pane is designed for:

- Working with multi-frame chunks

Buttons located on the pane toolbar allow:

- Add / remove frames from chunk
- Play / stop frame sequence
• Adjust frame rate through Settings dialog

**Animation pane**

*Animation* pane is designed for:

• Creating a new camera track from pre-sets (Horizontal, Vertical) with the given number of the keyframes
• Loading camera track from external file in supported formats (Autodesk FBX, Camera Path)
• Exporting camera track
• Playing the viewpoint camera movement according to the track
• Rendering the frame sequence to the form of the separate images for the keyframes
• Rendering the frame sequence to the form of the video file
• Appending current viewpoint to the camera track
• Removing keyframes from the camera track
• Changing the selected keyframes positions in current camera track sequence
• Setting the camera track parameters (label, duration, field of view, loop camera track)

Buttons located on the pane toolbar allow:

• Create new track
• Load camera track
• Save camera track
• Start / stop the animation according to the camera track
• Capture video file
• Append current viewpoint to the active camera track
• Remove selected keyframes from the active camera track
• Move selected keyframes up
• Move selected keyframes down
• Update selected keyframe to the current viewpoint
• Change camera track settings

⚠️ **Note**

• To open any pane select a corresponding command from the View menu.
• To display the track path, select *Show animation* in *Show/Hide items* submenu from the Model menu.
Graphical user interface

- You can adjust the position of the viewpoint in Model view by dragging the left mouse button to display it visually.

Menu commands

File Menu

- New
  Creates an empty Metashape project.

- Open...
  Opens Metashape project file.

- Append...
  Appends existing Metashape project file to the current one.

- Save
  Saves Metashape project file.

- Save As...
  Saves Metashape project file with a new name.

- Upload Project...
  Uploads current project to Agisoft Cloud.

- Download Project...
  Downloads project from the list of the projects currently available in Agisoft Cloud.

- Download Photos...
  Downloads images from Agisoft Cloud for the current project.

- Export Points...
  Saves sparse / dense point cloud.

- Export Model...
  Saves 3D model.

- Export Tiled Model...
  Saves a tiled model as hierarchical tiles.

- Export Orthomosaic...
  Exports generated orthomosaic.

- Export DEM...
  Exports generated digital elevation model.

- Generate Report...
  Generates Agisoft Metashape processing report in PDF and HTML formats.

- Export Cameras...
  Exports camera positions, orientation data and tie points measurements.

- Export Markers...
  Exports marker projections / estimated marker locations.

- Export Reference
  Exports reference.

- Export Masks...
  Exports masks.

- Export Shapes...
  Exports shapes from the selected layers.

- Export Texture...
  Exports model texture.

- Export Panorama...
  Exports spherical panorama for camera stations.

- Export Orthophotos...
  Exports orthorectified images corresponding to individual cameras.

- Convert Images...
  Exports the images corresponding to the original camera with distortion or color correction applied.
File Menu

Render Photos... Generates lenticular images for the current scene.
Import Cameras... Imports camera positions and orientation data.
Import Markers... Imports marker projections.
Import Reference Imports reference data.
Import Masks... Imports masks or creates mask from model or background.
Import Shapes... Imports shapes to be used for editing or measurements.
Import Points... Imports points in a form of the dense point cloud.
Import Model... Imports polygonal mesh model.
Import Texture... Imports texture and applies it to the current model.
Import Tiled Model... Imports tiled model.
Import DEM... Imports digital elevation model.
Import Orthomosaic... Imports orthomosaic.
Import Laser Scans Imports laser scans data.
Import Video... Imports video in a form of frame sequence and saves the extracted frames as images.
Upload Data... Uploads generated products (points, textured mesh models, tiled models, orthomosaics or digital elevation models) to one of the supported websites.
Exit Closes the application window.

Edit Menu

Undo Undo the last editing operation.
Redo Redo the previously undone editing operation.
Snap type Enable or disable snap type (Axis, Vertex, Edge, 2D snap).
Add selection Adds current selection to the mask.
Subtract selection Subtracts current selection from the mask.
Invert Selection Inverts current selection for the photo.
Invert Selection Inverts current selection of faces / points / cameras.
Grow Selection Grows current selection of mesh faces.
Shrink Selection Shrinks current selection of mesh faces.
### Edit Menu

- **Delete Selection**: Removes selected faces from the mesh or selected points from the point cloud.
- **Crop Selection**: Crops selected faces / points.
- **Invert Mask**: Inverts mask for the current photo.
- **Reset mask**: Resets mask for the current photo.
- **Rotate right**: Rotates the photo clockwise.
- **Rotate left**: Rotates the photo counterclockwise.

### View Menu

- **Zoom In**: Increases magnification in the active view mode.
- **Zoom Out**: Decreases magnification in the active view mode.
- **Reset View**: Resets the viewport to display the complete model or photo.
- **Capture view**: Saves screenshot of current view of the project (Model/Ortho/Photo).
- **Workspace**: Shows or hides Workspace pane.
- **Timeline**: Shows or hides Timeline pane.
- **Animation**: Shows or hides Animation pane.
- **Reference**: Shows or hides Reference pane.
- **Properties**: Shows or hides shape Properties pane.
- **Photos**: Shows or hides Photos pane.
- **Console**: Shows or hides Console pane.
- **Jobs**: Shows or hides Jobs pane.
- **Toolbar**: Shows or hides Toolbar.
- **Full Screen**: Switches to or from Full Screen mode.

### Workflow Menu

- **Add Photos...**: Loads additional photos to be processed by Metashape.
- **Add Folder...**: Loads additional photos from folders to be processed by Metashape.
- **Align Photos...**: Estimates camera positions and sparse point cloud.
- **Build Dense Cloud...**: Generates dense point cloud.
- **Build Mesh...**: Generates polygonal mesh model.
**Workflow Menu**

- **Build Texture...**  
  Generates texture map for the mesh model.
- **Build Tiled Model...**  
  Generates tiled textured model.
- **Build DEM...**  
  Generates digital elevation model.
- **Build Orthomosaic...**  
  Generates orthomosaic.
- **Align Chunks...**  
  Aligns multiple chunks.
- **Merge Chunks...**  
  Merges multiple chunks into the single chunk.
- **Batch Process...**  
  Opens Batch Process dialog box.

**Model Menu**

- **Navigation**  
  Switches to navigation mode.
- **Rectangle Selection**  
  Rectangle selection tool for the elements of the Model view.
- **Circle Selection**  
  Circle selection tool for the elements of the Model view.
- **Free-form Selection**  
  Free-form selection tool for the elements of the Model view.
- **Gradual selection...**  
  Selects faces / points based on the specified criterion.
- **Draw Point**  
  Switches to the 3D point drawing tool.
- **Draw Polyline**  
  Switches to the 3D polyline drawing tool.
- **Draw Polygon**  
  Switches to the 3D polygon drawing tool.
- **Ruler**  
  Switches to 3D coordinate and linear distance measurement tool.
- **Move Object**  
  Switches to object movement tool.
- **Rotate Object**  
  Switches to object rotation tool.
- **Scale Object**  
  Switches to object scaling tool.
- **Reset Transform**  
  Resets the transformations applied to the object.
- **Move Region**  
  Switches to volume movement tool.
- **Rotate Region**  
  Switches to volume rotation tool.
- **Resize Region**  
  Switches to volume resize tool.
- **Reset Region**  
  Resets the transformations applied to the volume to default.
- **Show Basemap**  
  Displays or hides Basemap.
Graphical user interface

Model Menu

Show Cameras
Displays or hides camera positions estimated during image alignment.

Show Thumbnails
Displays or hides image thumbnails in the camera placeholders.

Show Shapes
Displays or hides shapes.

Show Markers
Displays or hides marker positions.

Show Labels
Displays or hides item labels.

Show Images
Switches stereographic image overlay mode on/off.

Lock Image
Locks current image in stereographic image overlay mode.

Show Region
Displays or hides region selector.

Show Animation
Displays or hides animation track.

Show Trackball
Displays or hides the trackball.

Show Info
Displays or hides the auxiliary on-screen information.

Show Grid
Displays or hides the grid.

Show Aligned Chunks
Displays all enabled aligned chunks in project workspace.

Show All
Displays all elements at the same time.

Hide All
Hides all elements.

Point Cloud
Displays sparse point cloud reconstructed during photo alignment.

Point Cloud Variance
Displays sparse point cloud colored by variance.

Dense Cloud
Displays dense point cloud.

Dense Cloud Confidence
Displays dense point cloud colored according to the confidence values.

Dense Cloud Classes
Displays dense point cloud colored according to the point classes.

Model Shaded
Displays 3D model in the shaded mode with vertices colored with interpolated colors.

Model Solid
Displays 3D model in the solid mode.

Model Wireframe
Displays 3D model in the wireframe mode.

Model Textured
Displays 3D model in the textured mode.

Model Confidence
Displays 3D model with vertices colored according to the confidence values.
Graphical user interface

Model Menu

- Tiled Model Textured: Displays tiled model with applied texture.
- Tiled Model Solid: Displays tiled model without texture in the solid model.
- Tiled Model Wireframe: Displays tiled model in the wireframe mode.
- Perspective/Orthographic: Switches visualization view between Perspective and Orthographic.
- Stereo Mode: Enables or disables stereo view mode according to the parameters specified in Preferences dialog.
- Predefined views: Switches viewport to one of the predefined views.
- Navigation Mode: Switches between Object and Terrain navigation modes for the Model view window. Object navigation mode allows for 3-axis rotation control, while Terrain navigation mode restricts control to 2-axis rotation only, z-axis being kept vertical all the time.

Photo Menu

- Navigation: Switches to navigation mode.
- Rectangle Selection: Rectangle selection tool.
- Intelligent Scissors: Intelligent Scissors selection tool.
- Intelligent Paint: Intelligent Paint selection tool.
- Draw Point: Switches to the 3D point drawing tool.
- Draw Polyline: Switches to the 3D polyline drawing tool.
- Draw Polygon: Switches to the 3D polygon drawing tool.
- Ruler: Switches to 3D coordinate and linear distance measurement tool.
- Open Next Photo: Opens next photo from the list in the Photos pane.
- Open Previous Photo: Opens previous photo from the list in the Photos pane.
- Go To Next Marker: Zooms to the next marker projection on the opened photo.
- Go To Previous Marker: Zooms to the previous marker projection on the opened photo.
- Show Masks: Turns mask shading on or off.
- Show Depth Maps: Displays or hides the depth maps overlay.
- Show Intensity: Displays or hides intensity map overlay for the laser scans.
Graphical user interface

**Photo Menu**

- **Show Shapes**: Displays or hides shapes.
- **Show Markers**: Displays or hides markers.
- **Show Marker Residuals**: Displays or hides the residuals of each marker.
- **Show Labels**: Displays or hides item labels.
- **Show Points**: Displays or hides tie point projections used for the camera alignment.
- **Show Point Residuals**: Displays or hides the residuals of each point.
- **Show All**: Displays all elements at the same time.
- **Hide All**: Hides all elements.

**Ortho Menu**

- **Navigation**: Switches to navigation mode.
- **Rectangle Selection**: Rectangle selection tool for the elements of the Ortho view.
- **Circle Selection**: Circle selection tool for the elements of the Ortho view.
- **Free-form Selection**: Free-form selection tool for the elements of the Ortho view.
- **Draw Point**: Switches to the 2D point drawing tool.
- **Draw Polyline**: Switches to the 2D polyline drawing tool.
- **Draw Polygon**: Switches to the 2D polygon drawing tool.
- **Draw Patch**: Switches to the patch drawing tool.
- **Ruler**: Switches to coordinate and linear distance measurement tool.
- **Show Basemap**: Displays or hides basemap (map and satellite).
- **Show Seamlines**: Displays or hides orthomosaic seamlines.
- **Show Cameras**: Displays or hides camera positions according to the estimated location for aligned cameras or reference coordinates for not aligned cameras.
- **Show Markers**: Displays or hides marker positions.
- **Show Shapes**: Displays or hides shapes.
- **Show Labels**: Displays or hides item labels.
- **Show All**: Displays all elements at the same time.
- **Hide All**: Hides all elements.
Graphical user interface

**Ortho Menu**

- **DEM**
  Switches to the digital elevation model display mode.
- **Orthomosaic**
  Switches to the orthomosaic display mode.
- **Hillshading**
  Enables or disables hillshading mode of digital elevation mode visualization.

**Tools Menu**

- **Detect Markers...**
  Creates markers from coded targets on photos.
- **Detect Fiducials...**
  Detects fiducial marks on the images.
- **Print Markers...**
  Generates printable PDF file with coded targets.
- **Track Markers...**
  Tracks marker locations across the frame sequence.
- **Attach Markers**
  Enables or disables the mode where every newly drawn shape has markers attached to its vertices.
- **Refine Markers**
  Enables or disables automatic marker projection refinement based on the image content.
- **Build Point Cloud...**
  Builds sparse point cloud based on the estimated camera parameters available.
- **Thin Point Cloud...**
  Thins sparse point cloud by reducing the number of projections on the individual photos to the given limit.
- **View Matches...**
  Displays View Matches dialog for visual representation of the common tie points between the image pairs.
- **Filter Dense Cloud...**
  Decimates the dense point cloud according to the user-defined point spacing distance.
- **Colorize Dense Cloud...**
  Applies colors to the dense cloud points basing on source images or orthomosaic.
- **Invert Point Normals...**
  Inverts normals for the selected points of the dense cloud.
- **Classify Ground Points...**
  Classifies dense point cloud based on the user defined settings.
- **Classify Points...**
  Automatically classifies dense point cloud to the supported classes.
- **Assign Class...**
  Assigns class to the selected points.
- **Reset Classification...**
  Resets assigned classes for the selected point classes.
- **Select Points by Masks...**
  Selects dense cloud points according to the masks of the selected images.
- **Select Points by Color...**
  Selects dense cloud points according to the color and tolerance.
- **Select Points by Shapes...**
  Selects dense cloud points according to the selected shapes.
Tools Menu

Filter By Class
Filters the points in the dense cloud according to the selected classes.

Filter By Confidence
Filters the points in the dense cloud according to the calculated confidence value.

Filter By Selection
Filters the points in the dense cloud according to the selected points.

Reset Filter
Resets all applied dense cloud filters.

Compact Dense Cloud...
Permanently removes all deleted points from the dense cloud.

Restore Dense Cloud...
Restores all deleted points of the dense cloud that were once marked as removed.

Update Dense Cloud...
Updates statistics of the dense cloud, including point numbers and assigned classes.

Refine Mesh...
Starts photoconsistent mesh refinement operation.

Decimate Mesh...
Decimates mesh to the target face count.

Smooth Mesh...
Smoothes mesh.

Close Holes...
Closes holes on the model surface.

Colorize Vertices...
Applies colors to the mesh vertices basing on source images, orthomosaic or point cloud.

Resize texture...
Starts resize texture operation for mesh.

Remove Lighting...
Starts the delighting operation for mesh texture.

View Mesh Statistics...
Collects and displays mesh statistics.

View Mesh UVs...
Displays mesh UV mapping.

Measure Area and Volume...
Displays surface area and volume of the polygonal model.

Filter By Selection
Filters the faces of the polygonal model according to the selected points.

Reset Filter
Resets all applied mesh filters.

Transform DEM...
Displays digital elevation model transformation dialog.

Update Orthomosaic
Applies all the manual edits to the orthomosaic.

Reset Orthomosaic
Resets all applied edits to default orthomosaic stitching.

Remove Orthophotos
Removes individually orthorectified images from the project contents.

Generate Seamlines
Creates the shape layer with the polygonal shapes as copies of the orthomosaic patches.
### Tools Menu

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Generate Prescription Map</td>
<td>Creates the shape layer with the prescription map information based on the orthomosaic index.</td>
</tr>
<tr>
<td>Calibrate Lens...</td>
<td>Displays lens calibration dialog.</td>
</tr>
<tr>
<td>Show Chessboard...</td>
<td>Displays the calibration board on screen.</td>
</tr>
<tr>
<td>Camera Calibration...</td>
<td>Displays camera calibration dialog box.</td>
</tr>
<tr>
<td>Optimize Cameras...</td>
<td>Starts the optimization of exterior and interior parameters of the aligned cameras.</td>
</tr>
<tr>
<td>Calibrate Reflectance...</td>
<td>Displays reflectance calibration dialog for precise radiometric calibration of multispectral data based on reflectance panel and sun sensor data.</td>
</tr>
<tr>
<td>Calibrate Colors...</td>
<td>Displays the color correction dialog for the brightness and white balance compensation of the images.</td>
</tr>
<tr>
<td>Set Primary Channel...</td>
<td>Displays the primary channel selection dialog.</td>
</tr>
<tr>
<td>Set Brightness...</td>
<td>Adjusts image brightness and contrast for more convenient display.</td>
</tr>
<tr>
<td>Set Raster Transform...</td>
<td>Displays Raster Calculator dialog for NDVI and other vegetation indices calculation.</td>
</tr>
<tr>
<td>Generate Contours...</td>
<td>Generates contours based on DEM according to the elevation levels or based on Orthomosaic according to the vegetation index values.</td>
</tr>
<tr>
<td>Plan Mission...</td>
<td>Creates mission plan based on available mesh model.</td>
</tr>
<tr>
<td>Reduce Overlap...</td>
<td>Reduces the number of enabled cameras in the active project to optimize the coverage in case of excessive overlap.</td>
</tr>
<tr>
<td>Detect Powerlines</td>
<td>Starts image based powerlines detection operation.</td>
</tr>
<tr>
<td>Survey Statistics...</td>
<td>Displays the survey statistics dialog in a form of interactive report.</td>
</tr>
<tr>
<td>Run Script...</td>
<td>Displays Run Script dialog box for Python script execution.</td>
</tr>
<tr>
<td>Preferences...</td>
<td>Displays preferences dialog box.</td>
</tr>
</tbody>
</table>

### Help Menu

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Contents</td>
<td>Displays help contents.</td>
</tr>
<tr>
<td>Check for Updates</td>
<td>Checks if Metashape update is available for download.</td>
</tr>
<tr>
<td>Activate Product</td>
<td>Displays the activation dialog for activation / deactivation of the product using the activation key or borrowing / returning borrowed floating license to the license server.</td>
</tr>
</tbody>
</table>
Help Menu

About Metashape... Displays program information, version number and copyright.

Toolbar buttons

General commands

New Creates a new Metashape project file.
Open Opens a Metashape project file.
Save Saves a Metashape project file.

3D view commands

Undo Undo the last editing operation.
Redo Redo the previously undone editing operation.
Rectangle Selection Rectangle selection tool.
Circle Selection Circle selection tool.
Free-Form Selection Free-form selection tool.
Reset Selection Resets current selection.
Move region Volume translation tool.
Resize region Volume resize tool.
Rotate Region Volume rotation tool.
Reset Region Resets region according to the actual point cloud.
Move Object Model translation tool.
Rotate Object Model rotation tool.
Scale Object Model resize tool.
Reset Transform Resets all transformations applied to the model.

Draw Point Switches to the 3D point drawing tool.
Draw Polyline Switches to the 3D polyline drawing tool.
Draw Polygon Switches to the 3D polygon drawing tool.
Ruler 3D coordinate and linear distance measurement tool.
Delete Selection Removes selected faces / points.
Graphical user interface

3D view commands

Crop Selection
Crops selected faces / points.

3D view settings

Zoom In
Increases magnification.

Zoom Out
Decreases magnification.

Reset View
Resets model view.

Point Cloud
Displays sparse point cloud reconstructed during image alignment.

Point Cloud Variance
Displays sparse point cloud colored by variance.

Dense Cloud
Displays dense point cloud model.

Dense Cloud Confidence
Displays dense point cloud colored according to the confidence values.

Dense Cloud Classes
Displays dense point cloud colored according to the point classes.

Model Shaded
Displays 3D model in the shaded mode with vertices colored with interpolated colors.

Model Solid
Displays 3D model in the solid mode.

Model Wireframe
Displays 3D model in the wireframe mode.

Model Textured
Displays 3D model with vertices colored according to the confidence values.

Diffuse Map
Displays diffuse map for the textured mode.

Normal Map
Displays normal map for the textured mode.

Occlusion Map
Displays occlusion map the textured mode.

Tiled Model Textured
Displays tiled model with the applied texture.

Tiled Model Solid
Displays tiled model in the solid mode.

Tiled Model Wireframe
Displays tiled model in the wireframe mode.

Show Basemap
Displays or hides basemap.

Show Cameras
Displays or hides camera positions, reconstructed during image alignment.

Show Thumbnails
Displays or hides image thumbnails in the camera placeholders.

Show Shapes
Displays or hides 3D shapes.

Show Markers
Displays or hides positions of markers placed on the model.
### Graphical user interface

#### 3D view settings
- **Show Images**: Displays or hides stereographic image overlay.
- **Lock Images**: Locks current image in stereographic image overlay mode.
- **Show Aligned Chunks**: Displays or hides enabled aligned chunks.

#### Photo view commands
- **Undo**: Undoes the last mask editing operation.
- **Redo**: Redoes the previously undone mask editing operation.
- **Navigation**: Switches to the navigation mode.
- **Rectangle Selection**: Rectangle selection tool.
- **Intelligent Scissors**: Intelligent scissors tool.
- **Intelligent Paint**: Intelligent paint tool.
- **Magic Wand**: Magic wand tool.
- **Magic Wand Options**: Changing the parameters of the magic wand.
- **Reset Selection**: Resets current selection.
- **Draw Point**: Switches to the 3D point drawing tool.
- **Draw Polyline**: Switches to the 3D polyline drawing tool.
- **Draw Polygon**: Switches to the 3D polygon drawing tool.
- **Ruler**: 3D coordinate and linear distance measurement tool.
- **Add Selection**: Adds current selection to the mask.
- **Subtract Selection**: Subtracts current selection from the mask.
- **Invert Selection**: Inverts current selection.
- **Set Brightness**: Adjusts image brightness and contrast for more convenient display.
- **Rotate Right**: Rotates the image clockwise.
- **Rotate Left**: Rotates the image counterclockwise.
- **Zoom In**: Increases magnification.
- **Zoom Out**: Decreases magnification.
- **Reset View**: Resets the viewport to display the whole image.
- **Show Masks**: Enables or disables the mask shading overlay.
**Photo view commands**

- Show Depth Maps: Enables or disables the depth map overlay of the selected level.
- Show Intensity: Displays or hides intensity map overlay for laser scans.
- Show Shapes: Displays or hides shapes on the current image.
- Show Markers: Displays or hides marker projections.
- Show Marker Residuals: Displays or hides residuals related to marker projections.
- Show Points: Displays or hides tie point projections.
- Show Point Residuals: Displays or hides residuals related to tie point projections.

**Ortho view commands**

- Navigation: Switches to the navigation mode.
- Rectangle Selection: Rectangle selection tool.
- Circle Selection: Circle selection tool.
- Reset Selection: Resets current selection.
- Draw Point: Switches to the point drawing tool.
- Draw Polyline: Switches to the polyline drawing tool.
- Draw Polygon: Switches to the polygon drawing tool.
- Draw Patch: Switches to the patch drawing tool.
- Ruler: 2D linear distance measurement tool.
- DEM: Switches to the digital elevation model display mode.
- Hillshading: Enables or disables hillshading mode of digital elevation mode visualization.
- Orthomosaic: Switches to the orthomosaic display mode.
- Set Brightness: Adjusts image brightness and contrast for more convenient display.
- Set Raster Transform: Displays Raster Calculator dialog for NDVI and other vegetation indices calculation.
- Update Orthomosaic: Applies all the manual edits to the orthomosaic.
- Zoom In: Increases the magnification of the image in the Ortho view.
Graphical user interface

**Ortho view commands**

- **Zoom Out**
  - Decreases the magnification of the image in the Ortho view.

- **Reset View**
  - Resets the viewport to display the complete orthomosaic or DEM.

- **Show Basemap**
  - Displays or hides basemap in a form of satellite or vector map.

- **Show Seamlines**
  - Displays or hides orthomosaic seamlines.

- **Show Cameras**
  - Displays or hides camera positions according to the estimated location for aligned cameras or reference coordinates for not aligned cameras.

- **Show Markers**
  - Displays or hides marker positions.

- **Show Shapes**
  - Displays or hides shapes.

**Hot keys**

For convenient operation in the Metashape it is possible to use Hot keys. Below is a list of default hot keys that can be customized in the *Preferences* dialog. Select the *Customize* button at the *Shortcuts* menu item.

**General**

- **Create new project** Ctrl + N
- **Save project** Ctrl + S
- **Open project** Ctrl + O
- **Run Script** Ctrl + R
- **Full Screen** F11

**Model View**

- **Undo (only for Delete, Assign Class / Classify Ground Points, Masking and Close Holes operations)** Ctrl + Z
- **Redo (only for Delete, Assign Class / Classify Ground Points, Masking and Close Holes operations)** Ctrl + Y
- **Switch between navigation and any other previously selected mode** Space
- **Zoom In** Ctrl + +
- **Zoom Out** Ctrl + -
- **Reset view** 0
- **Switch to stereoview mode** 9
- **Switch between orthographic and perspective view modes** 5
- **Change the angle for perspective view** Ctrl + mouse wheel
### Graphical user interface

**Assign dense cloud class (only if some points are selected)**

<table>
<thead>
<tr>
<th>Command</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ctrl + Shift + C</td>
<td></td>
</tr>
</tbody>
</table>

**Predefined Views**

<table>
<thead>
<tr>
<th>View</th>
<th>Key Combination</th>
</tr>
</thead>
<tbody>
<tr>
<td>Top</td>
<td>7</td>
</tr>
<tr>
<td>Bottom</td>
<td>Ctrl + 7</td>
</tr>
<tr>
<td>Right</td>
<td>3</td>
</tr>
<tr>
<td>Left</td>
<td>Ctrl + 3</td>
</tr>
<tr>
<td>Front</td>
<td>1</td>
</tr>
<tr>
<td>Back</td>
<td>Ctrl + 1</td>
</tr>
</tbody>
</table>

**Rotate View**

<table>
<thead>
<tr>
<th>Rotate</th>
<th>Key Combination</th>
</tr>
</thead>
<tbody>
<tr>
<td>Rotate Up</td>
<td>8</td>
</tr>
<tr>
<td>Rotate Down</td>
<td>2</td>
</tr>
<tr>
<td>Rotate Left</td>
<td>4</td>
</tr>
<tr>
<td>Rotate Right</td>
<td>6</td>
</tr>
</tbody>
</table>

**Photo View**

<table>
<thead>
<tr>
<th>Action</th>
<th>Key Combination</th>
</tr>
</thead>
<tbody>
<tr>
<td>Next photo (according to Photos pane order)</td>
<td>Page Up</td>
</tr>
<tr>
<td>Previous photo (according to Photos pane order)</td>
<td>Page Down</td>
</tr>
<tr>
<td>Go to the next marker on the same photo</td>
<td>Tab</td>
</tr>
<tr>
<td>Go to the previous marker on the same photo</td>
<td>Shift + Tab</td>
</tr>
<tr>
<td>Navigation mode</td>
<td>V</td>
</tr>
</tbody>
</table>

**Selection Tools**

<table>
<thead>
<tr>
<th>Tool</th>
<th>Key Combination</th>
</tr>
</thead>
<tbody>
<tr>
<td>Rectangle selection</td>
<td>M</td>
</tr>
<tr>
<td>Intelligent scissors</td>
<td>L</td>
</tr>
<tr>
<td>Intelligent paint</td>
<td>P</td>
</tr>
<tr>
<td>Magic wand</td>
<td>W</td>
</tr>
<tr>
<td>Add selection</td>
<td>Ctrl + Shift + A</td>
</tr>
<tr>
<td>Subtract selection</td>
<td>Ctrl + Shift + S</td>
</tr>
<tr>
<td>Invert selection</td>
<td>Ctrl + Shift + I</td>
</tr>
</tbody>
</table>
Appendix B. Supported formats

Images

**Input formats**
- JPG
- TIFF
- PNG
- BMP
- OpenEXR
- JPEG 2000
- TARGA
- Digital Negative (DNG)
- Portable Bit Map (PGM, PPM)
- Multi-Picture Object (MPO)
- Norpix Sequence (SEQ)
- AscTec Thermal Images (ARA)

**Undistort formats**
- JPG
- TIFF
- PNG
- BMP
- OpenEXR
- JPEG 2000

Camera calibration

**Import formats**
- Agisoft Camera Calibration (*.xml)
- Australis Camera Parameters (*.txt)
- Australis v.7 Camera Parameters (*.txt)
- PhotoModeler Camera Calibration (*.ini)
- 3DM CalibCam Camera Parameters (*.txt)
- CalCam Camera Calibration (*.cal)
- Inpho Camera Calibration (*.txt)
- USGS Camera Calibration (*.txt)
- Pix4D Camera Calibration (*.cam)
- OpenCV Camera Calibration (*.xml)
- Photomod Camera Calibration (*.x-cam)
- Z/I Distortion Grid (*.dat)

**Export formats**
- Agisoft Camera Calibration (*.xml)
- Australis Camera Parameters (*.txt)
- Australis v.7 Camera Parameters (*.txt)
- PhotoModeler Camera Calibration (*.ini)
- 3DM CalibCam Camera Parameters (*.txt)
- CalCam Camera Calibration (*.cal)
- Inpho Camera Calibration (*.txt)
- USGS Camera Calibration (*.txt)
- Pix4D Camera Calibration (*.cam)
- OpenCV Camera Calibration (*.xml)
- Photomod Camera Calibration (*.x-cam)
- Z/I Distortion Grid (*.dat)

Camera flight log

**Input format**
- Agisoft XML (*.xml)
- Character-separated values (*.txt, *.csv)
- EXIF meta data

**Estimated positions**
- Agisoft XML (*.xml)
- Character-separated values (*.txt)
### Supported formats

<table>
<thead>
<tr>
<th><strong>Supported formats</strong></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Input format</strong></td>
<td><strong>Estimated positions</strong></td>
</tr>
<tr>
<td>MAVinci CSV (*.csv)</td>
<td></td>
</tr>
<tr>
<td>APM/PixHawk Log (*.log)</td>
<td></td>
</tr>
<tr>
<td>C-Astral Bramor log (*.log)</td>
<td></td>
</tr>
<tr>
<td>TopoAxis telemetry (*.tel)</td>
<td></td>
</tr>
</tbody>
</table>

### GCP locations

<table>
<thead>
<tr>
<th><strong>Input format</strong></th>
<th><strong>Estimated positions</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>Character-separated values (*.txt, *.csv)</td>
<td>Character-separated values (*.txt)</td>
</tr>
<tr>
<td>Agisoft XML (*.xml)</td>
<td>Agisoft XML (*.xml)</td>
</tr>
</tbody>
</table>

### Interior and exterior camera orientation parameters

<table>
<thead>
<tr>
<th><strong>Import camera positions</strong></th>
<th><strong>Export camera positions</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>Agisoft XML (*.xml)</td>
<td>Agisoft XML (*.xml)</td>
</tr>
<tr>
<td>Autodesk FBX (*.fbx)</td>
<td>Autodesk FBX (*.fbx)</td>
</tr>
<tr>
<td>Alembic (*.abc)</td>
<td>Alembic (*.abc)</td>
</tr>
<tr>
<td>Realviz RZML (*.rzml)</td>
<td>Realviz RZML (*.rzml)</td>
</tr>
<tr>
<td>Bundler (*.out)</td>
<td>Bundler (*.out)</td>
</tr>
<tr>
<td>Inpho Project File (*.prj)</td>
<td>Inpho Project File (*.prj)</td>
</tr>
<tr>
<td>BINGO (*.dat)</td>
<td>BINGO Project (*.dat)</td>
</tr>
<tr>
<td>Blocks Exchange (*.xml)</td>
<td>Blocks Exchange (*.xml)</td>
</tr>
<tr>
<td>N-View Match (*.nvm)</td>
<td>N-View Match (*.nvm)</td>
</tr>
<tr>
<td>PATB Camera Orientation (*.ori)</td>
<td>PATB Project (*.pro)</td>
</tr>
<tr>
<td>VisionMap Detailed Report (*.txt)</td>
<td>Boujou (*.txt)</td>
</tr>
<tr>
<td></td>
<td>CHAN files (*.chan)</td>
</tr>
<tr>
<td></td>
<td>ORIMA (*.txt)</td>
</tr>
<tr>
<td></td>
<td>AeroSys Exterior Orientation (*.orn)</td>
</tr>
<tr>
<td></td>
<td>Summit Evolution Project (*.smtxml)</td>
</tr>
<tr>
<td></td>
<td>Omega Phi Kappa (*.txt)</td>
</tr>
</tbody>
</table>

### Tie points

<table>
<thead>
<tr>
<th><strong>Import tie points</strong></th>
<th><strong>Export tie points</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>Bundler (*.out)</td>
<td>Bundler (*.out)</td>
</tr>
<tr>
<td>BINGO (*.dat)</td>
<td>BINGO (*.dat)</td>
</tr>
<tr>
<td>ORIMA (*.txt)</td>
<td>ORIMA (*.txt)</td>
</tr>
<tr>
<td>PATB (*.ptb)</td>
<td>PATB (*.ptb)</td>
</tr>
<tr>
<td>Summit Evolution Project (*.smtxml)</td>
<td>Summit Evolution Project (*.smtxml)</td>
</tr>
</tbody>
</table>
Supported formats

### Import tie points
- Blocks Exchange (*.xml)

### Export tie points
- Blocks Exchange (*.xml)

## Sparse/dense point cloud

### Import formats
- Wavefront OBJ (*.obj)
- Stanford PLY (*.ply)
- ASCII PTS (*.pts)
- ASPRS LAS (*.las)
- LAZ (*.laz)
- ASTM E57 (*.e57)
- Point Cloud Data (*.pcd)
- PTX format (*.ptx)

### Export formats
- Wavefront OBJ (*.obj)
- Stanford PLY (*.ply)
- ASCII PTS (*.pts)
- ASPRS LAS (*.las)
- LAZ (*.laz)
- ASTM E57 (*.e57)
- Point Cloud Data (*.pcd)
- XYZ Point Cloud (*.txt)
- Cesium 3D Tiles (*.zip)
- Scene Layer Package (*.slpk)
- Universal 3D (*.u3d)
- Autodesk DXF (*.dxf)
- potree (*.zip)
- Agisoft OC3 (*.oc3)
- Topcon CL3 (*.cl3)
- Adobe 3D PDF (*.pdf)

## Mesh model

### Import mesh
- Wavefront OBJ (*.obj)
- 3DS models (*.3ds)
- COLLADA (*.dae)
- Stanford PLY (*.ply)
- Alembic (*.abc)
- STL models (*.stl)
- OpenCTM models (*.ctm)
- Universal 3D models (*.u3d)
- Autodesk FBX (*.fbx)
- Autodesk DXF (*.dxf)

### Export mesh
- Wavefront OBJ (*.obj)
- 3DS models (*.3ds)
- COLLADA (*.dae)
- Stanford PLY (*.ply)
- Alembic (*.abc)
- STL models (*.stl)
- VRML models (*.wrl)
- Universal 3D models (*.u3d)
- Autodesk FBX (*.fbx)
- Autodesk DXF Polyline (*.dxf)
- Autodesk DXF 3DFace (*.dxf)
- Binary glTF (*.glb)
- X3D models (*.x3d)
- OpenSceneGraph (*.osg)
- Google Earth KMZ (*.kmz)
Supported formats

**Import mesh**
- LandXML (*.xml)
- Adobe PDF (*.pdf)

**Export mesh**
- LandXML (*.xml)
- Adobe PDF (*.pdf)

**Texture maps**

**Import texture**
- JPG
- TIFF
- PNG
- BMP
- TARGA
- JPEG 2000
- OpenEXR
- Portable Bit Map
- Digital negative
- Multi-Picture Object
- Norpix Sequence File
- AscTec Thermal Images

**Export texture**
- JPG
- TIFF
- PNG
- BMP
- TARGA
- JPEG 2000
- OpenEXR

**Orthomosaic**

**Import orthomosaic**
- GeoTIFF Raster Data (*.tif)
- GeoPackage (*.gpkg)
- Google Earth KML/KMZ (*.kmz)
- MBTiles (*.mbtiles)
- Tiled Map Service Tiles (*.zip)

**Export orthomosaic**
- GeoTIFF Raster Data (*.tif)
- GeoPackage (*.gpkg)
- Google Earth KML/KMZ (*.kmz)
- MBTiles (*.mbtiles)
- Tiled Map Service Tiles (*.zip)
- Google Map Tiles (*.zip)
- World Wind Tiles (*.zip)
- JPG
- JPEG 2000 (.jp2)
- PNG
- BMP

**Digital elevation model (DSM/DTM)**

**Import DEM**
- GeoTIFF elevation (*.tif)

**Export DEM**
- GeoTIFF elevation (*.tif)
- Arc/Info ASCII Grid (*.asc)
- Band interleaved file format (*.bil)
Supported formats

**Import DEM**
- XYZ (*.xyz)
- GeoPackage (*.gpkg)
- Sputnik KMZ (*.kmz)
- Google Map Tiles (*.zip)
- MBTiles (*.mbtiles)
- World Wind Tiles (*.zip)
- Tile Map Service Tiles (*.zip)

**Export DEM**
- XYZ (*.xyz)
- GeoPackage (*.gpkg)
- Sputnik KMZ (*.kmz)
- Google Map Tiles (*.zip)
- MBTiles (*.mbtiles)
- World Wind Tiles (*.zip)
- Tile Map Service Tiles (*.zip)

**Tiled models**

**Import tiled model**
- Agisoft Tiled Model (*.tls)

**Export tiled model**
- Agisoft Tiled Model (*.tls)
- Agisoft Tile Archive (*.zip)
- Cesium 3D Tiles (*.zip)
- Scene Layer Package (*.slpk)
- PhotoMesh Layer (*.zip)
- OpenSceneGraph Binary (*.zip)
- OpenSceneGraph Text (*.zip)

**Laser Scans**

**Import laser scans**
- ASTM E57 (*.e57)
- PTX (*.ptx)
- Dynamic Depth images (*.jpg, *.jpeg)

**Shapes and contours**

**Import shapes**
- Shape Files (*.shp)
- DXF Files (*.dxf)
- KML files (*.kml)
- KMZ files (*.kmz)
- GeoJSON files (*.geojson)
- GeoPackage files (*.gpkg)
- Survey Points (*.txt)

**Export shapes/contours**
- Shape Files (*.shp)
- DXF Files (*.dxf)
- KML Files (*.kml)
- KMZ Files (*.kmz)
- GeoJSON files (*.geojson)
- GeoPackage files (*.gpkg)
- Survey Points (*.txt)

**Video**

**Import video**
- AVI (*.avi)

**Export video**
- AVI (*.avi)
<table>
<thead>
<tr>
<th>Supported formats</th>
</tr>
</thead>
</table>

**Import video**
- Flash video (*.flv)
- MOV (*.mov)
- MPEG-4 (*.mp4)
- WMV (*.wmv)

**Export video**
Appendix C. Camera models

Agisoft Metashape supports several parametric lens distortion models. Specific model which approximates best a real distortion field must be selected before processing. All models assume a central projection camera. Non-linear distortions are modeled using Brown’s distortion model.

A camera model specifies the transformation from point coordinates in the local camera coordinate system to the pixel coordinates in the image frame.

The local camera coordinate system has origin at the camera projection center. The Z axis points towards the viewing direction, X axis points to the right, Y axis points down.

The image coordinate system has origin in the middle of the top-left pixel (with coordinates (0.5, 0.5)). The X axis in the image coordinate system points to the right, Y axis points down. Image coordinates are measured in pixels.

\[
\begin{align*}
(X, Y, Z) & \quad \text{point coordinates in the local camera coordinate system,} \\
(u, v) & \quad \text{projected point coordinates in the image coordinate system (in pixels),} \\
f & \quad \text{focal length (in pixels),} \\
c_x, c_y & \quad \text{principal point offset (in pixels),}
\end{align*}
\]

Equations used to project a points in the local camera coordinate system to the image plane are provided below for each supported camera model.

The following definitions are used in the equations:

- \((X, Y, Z)\) - point coordinates in the local camera coordinate system,
- \((u, v)\) - projected point coordinates in the image coordinate system (in pixels),
- \(f\) - focal length (in pixels),
- \(c_x, c_y\) - principal point offset (in pixels),
Camera models

$K_1, K_2, K_3, K_4$ - radial distortion coefficients (dimensionless),
$P_1, P_2$ - tangential distortion coefficients (dimensionless),
$B_1, B_2$ - affinity and non-orthogonality (skew) coefficients (in pixels),
w, h - image width and height (in pixels).

**Frame cameras**

$$x = X / Z$$
$$y = Y / Z$$
$$r = \sqrt{x^2 + y^2}$$
$$x' = x(1 + K_1 r^2 + K_2 r^4 + K_3 r^6 + K_4 r^8) + (P_1 (r^2 + 2x^2) + 2P_2 xy)$$
$$y' = y(1 + K_1 r^2 + K_2 r^4 + K_3 r^6 + K_4 r^8) + (P_2 (r^2 + 2y^2) + 2P_1 xy)$$
$$u = w \cdot 0.5 + c_x + x'f + x'B_1 + y'B_2$$
$$v = h \cdot 0.5 + c_y + y'f$$

**Fisheye cameras**

$$x_0 = X / Z$$
$$y_0 = Y / Z$$
$$r_0 = \sqrt{x_0^2 + y_0^2}$$
$$x = x_0 \cdot \tan^{-1} r_0 / r_0$$
$$y = y_0 \cdot \tan^{-1} r_0 / r_0$$
$$r = \sqrt{x^2 + y^2}$$
$$x' = x(1 + K_1 r^2 + K_2 r^4 + K_3 r^6 + K_4 r^8) + (P_1 (r^2 + 2x^2) + 2P_2 xy)$$
$$y' = y(1 + K_1 r^2 + K_2 r^4 + K_3 r^6 + K_4 r^8) + (P_2 (r^2 + 2y^2) + 2P_1 xy)$$
$$u = w \cdot 0.5 + c_x + x'f + x'B_1 + y'B_2$$
$$v = h \cdot 0.5 + c_y + y'f$$

**Spherical cameras (equirectangular projection)**

$$u = w \cdot 0.5 + f \cdot \tan^{-1}(X / Z)$$
$$v = h \cdot 0.5 + f \cdot \tan^{-1}(Y / \sqrt{X^2 + Z^2})$$

where:

$$f = w / (2 \cdot \pi)$$
Note

• Spherical (equirectangular) camera model doesn't support distortions. All distortions should be corrected before loading images in Metashape.

• In case you are capturing panoramas with a rotated frame/fisheye camera, we recommend to process original images in Metashape using camera station function instead of stitching them in external software.

Spherical cameras (cylindrical projection)

\[
u = w * 0.5 + f * \tan^{-1}(X / Z)
\]

\[
v = h * 0.5 + f * Y / \sqrt{X^2 + Z^2}
\]

where:

\[f = w / (2 * \pi)\]

Note

• Spherical (cylindrical) camera model doesn't support distortions. All distortions should be corrected before loading images in Metashape.

• In case you are capturing panoramas with a rotated frame/fisheye camera, we recommend to process original images in Metashape using camera station function instead of stitching them in external software.
Appendix D. What do some error messages in Metashape mean?

In some cases warning or error messages may be displayed after unexpected termination of the processing operation in Metashape. Below is the list of some messages which could be encountered and our comments on the possible origins of the issue together with the recommendations for resolving the problem.

- **Empty extent** - Bounding box is misplaced during Build Tiled Model or Build Orthomosaic operation and doesn't contain any information or all the cameras for the related area are disabled.
- **Empty camera list** - no cameras are pointing to the area of the orthomosaic generation.
- **Empty frame path** - the selected operation (for example, import DEM) requires the project to be saved in PSX format.
- **Empty surface** - Bounding box is misplaced during Build Mesh operation and doesn't contain any information.
- **Index Overflow** - usually such a message is observed when the Arbitrary mesh generation method is used based on a very big dense point cloud. To reduce the number of points you can use Filter Dense Cloud option in the Tools menu or shrink the bounding box to the smaller volume using Resize Region instruments in the Model view mode.
- **Null dense point cloud** - missing dense cloud for the operation based on it (like mesh generation or classification).
- **Null model** - missing mesh model for the operation based on it (like mesh decimation).
- **Null point cloud** - missing sparse cloud for the operation based on it (like mesh generation).
- **Media resource couldn't be resolved** - indicates that some video codecs are missing in the system, so we can suggest to install "K-lite Codec pack" or similar in order to guarantee the Import Video operation. Note that you do not need to install any auxiliary utilities in addition to the codecs themselves.
- **Some photos failed to align** - the message indicates that some images were not aligned as a result of the adjustment process. This may be due to poor image quality or insufficient overlap. We can recommend you try to select images in the Workspace pane and select Align Selected Cameras command from the context menu.
- **Zero resolution** - Bounding box is misplaced prior to the Build Dense Cloud operation and doesn't contain any information (almost no tie points are present in the bounding box and therefore no depth maps can be generated).