# Table of Contents

Overview ........................................................................................................ iv
  How it works ................................................................................................ iv
  About the manual ........................................................................................ iv

1. Installation and Activation ........................................................................ 1
  System requirements ..................................................................................... 1
  GPU acceleration .......................................................................................... 1
  Installation procedure .................................................................................... 2
  Restrictions of the Demo mode ..................................................................... 2
  Activation procedure ..................................................................................... 3

2. Capturing scenarios ...................................................................................... 4
  Equipment ...................................................................................................... 4
  Camera settings ............................................................................................. 4
  Object/scene requirements ............................................................................ 4
  Image preprocessing ....................................................................................... 4
  Capturing scenarios ....................................................................................... 5
  Restrictions ................................................................................................... 6
  Lens calibration ............................................................................................. 6

3. General workflow ........................................................................................ 9
  Preferences settings ...................................................................................... 9
  Loading photos ............................................................................................ 10
  Aligning photos ........................................................................................... 11
  Building dense point cloud ......................................................................... 14
  Building mesh .............................................................................................. 16
  Building model texture ................................................................................ 19
  Saving intermediate results ......................................................................... 21
  Exporting results ......................................................................................... 22

4. Improving camera alignment results .......................................................... 27
  Camera calibration ....................................................................................... 27
  Optimization ................................................................................................. 29

5. Editing .......................................................................................................... 30
  Using masks ................................................................................................ 30
  Editing point cloud ...................................................................................... 34
  Editing model geometry ............................................................................... 36

6. Automation ................................................................................................... 41
  Using chunks ............................................................................................... 41

A. Graphical user interface ............................................................................. 45
  Application window ...................................................................................... 45
  Menu commands ........................................................................................... 48
  Toolbar buttons ............................................................................................ 53
  Hot keys ....................................................................................................... 55

B. Supported formats ....................................................................................... 57
  Images .......................................................................................................... 57
  Camera calibration ....................................................................................... 57
  Interior and exterior camera orientation parameters .................................. 57
  Tie points ...................................................................................................... 58
  Sparse/dense point cloud ............................................................................. 58
  Mesh model ................................................................................................ 59
  Texture ........................................................................................................ 59

C. Camera models ........................................................................................... 60
  Frame cameras ............................................................................................ 60
  Fisheye cameras .......................................................................................... 60
Overview

Agisoft PhotoScan is an advanced image-based 3D modeling solution aimed at creating professional quality 3D content from still images. Based on the latest multi-view 3D reconstruction technology, it operates with arbitrary images and is efficient in both controlled and uncontrolled conditions. Photos can be taken from any position, providing that the object to be reconstructed is visible on at least two photos. Both image alignment and 3D model reconstruction are fully automated.

How it works

Generally the final goal of photographs processing with PhotoScan is to build a textured 3D model. The processing procedure includes four main stages.

1. The first stage is camera alignment. At this stage PhotoScan searches for common points on photographs and matches them, as well as it finds the position of the camera for each picture and refines camera calibration parameters. As a result a sparse point cloud and a set of camera positions are formed.

   The sparse point cloud represents the results of photo alignment and will not be directly used in further processing (except for the sparse point cloud based reconstruction method, that is not recommended). However it can be exported for further usage in external programs. For instance, the sparse point cloud model can be used in a 3D editor as a reference.

   On the contrary, the set of camera positions is required for further 3D surface reconstruction by PhotoScan.

2. The next stage is generating dense point cloud, that is built by PhotoScan based on the estimated camera positions and pictures themselves. Dense point cloud may be edited prior to export or proceeding to the next stage.

3. The third stage is building mesh. PhotoScan reconstructs a 3D polygonal mesh representing the object surface based on the dense or sparse point cloud according to the user’s choice. Generally there are two algorithmic methods available in PhotoScan that can be applied to 3D mesh generation: Height Field - for planar type surfaces, Arbitrary - for any kind of object. The mesh having been built, it may be necessary to edit it. Some corrections, such as mesh decimation, removal of detached components, closing of holes in the mesh, smoothing, etc. can be performed by PhotoScan. For more complex editing you have to engage external 3D editor tools. PhotoScan allows to export mesh, edit it by another software and import it back.

4. After geometry (i.e. mesh) is reconstructed, it can be textured. Several texturing modes are available in PhotoScan, they are described in the corresponding section of this manual.

About the manual

Basically, the sequence of actions described above covers most of the data processing needs. All these operations are carried out automatically according to the parameters set by user. Instructions on how to get through these operations and descriptions of the parameters controlling each step are given in the corresponding sections of the Chapter 3, General workflow chapter of the manual.

In some cases, however, additional actions may be required to get the desired results. Pictures taken using uncommon lenses such as fisheye one may require preliminary calibration of optical system parameters or usage of different calibration model specially implemented for ultra-wide angle lens. PhotoScan enables to reestimate extrinsic and intrinsic camera parameters, optimizing them for a tie point pool.
preliminary filtered by user. Chapter 4, *Improving camera alignment results* covers that part of the software functionality. In some capturing scenarios masking of certain regions of the photos may be required to exclude them from the calculations. Application of masks in PhotoScan processing workflow as well as editing options available are described in Chapter 5, *Editing*. Chapter 6, *Automation* describes opportunities to save up on manual intervention to the processing workflow.

It can take up quite a long time to reconstruct a 3D model. PhotoScan allows to export obtained results and save intermediate data in a form of project files at any stage of the process. If you are not familiar with the concept of projects, its brief description is given at the end of the Chapter 3, *General workflow*.

In the manual you can also find instructions on the PhotoScan installation and activation procedures and basic rules for taking "good" photographs, i.e. pictures that provide most necessary information for 3D reconstruction. For the information refer to Chapter 1, *Installation and Activation* and Chapter 2, *Capturing scenarios*. 
Chapter 1. Installation and Activation

System requirements

Minimal configuration

• Windows XP or later (32 or 64 bit), Mac OS X Mountain Lion or later, Debian/Ubuntu with GLIBC 2.13+ (64 bit)

• Intel Core 2 Duo processor or equivalent

• 4 GB of RAM

Recommended configuration

• Windows 7 SP 1 or later (64 bit), Mac OS X Mountain Lion or later, Debian/Ubuntu with GLIBC 2.13+ (64 bit)

• Intel Core i7 processor

• 16 GB of RAM

The number of photos that can be processed by PhotoScan depends on the available RAM and reconstruction parameters used. Assuming that a single photo resolution is of the order of 10 MPix, 4 GB RAM is sufficient to make a model based on 30 to 50 photos. 16 GB RAM will allow to process up to 300-400 photographs.

GPU acceleration

PhotoScan supports accelerated image matching, depth maps reconstruction and photoconsistent mesh refinement due to the graphics hardware (GPU) exploiting.

NVidia

GeForce GTX 400 series and later with CUDA support.

ATI

Radeon HD 6000 series and later with OpenCL 1.1 support.

PhotoScan is likely to be able to utilize processing power of any CUDA enabled device with compute capability 2.0 and higher or OpenCL 1.1 and higher enabled device with SPIR support for stages specified above, provided that CUDA/OpenCL drivers for the device are properly installed. However, because of the large number of various combinations of video chips, driver versions and operating systems, Agisoft is unable to test and guarantee PhotoScan’s compatibility with every device and on every platform.

The table below lists currently supported devices (on Windows platform only). We will pay particular attention to possible problems with PhotoScan running on these devices.

Table 1.1. Supported Desktop GPUs on Windows platform

<table>
<thead>
<tr>
<th>NVIDIA</th>
<th>AMD</th>
</tr>
</thead>
<tbody>
<tr>
<td>Quadro P6000</td>
<td>FirePro W9100</td>
</tr>
<tr>
<td>Quadro M6000</td>
<td>Radeon R9 390x</td>
</tr>
<tr>
<td>GeForce TITAN X</td>
<td>Radeon R9 290x</td>
</tr>
</tbody>
</table>
Installation and Activation

**NVIDIA**
- GeForce GTX 1080
- GeForce GTX TITAN X
- GeForce GTX 980
- GeForce GTX TITAN
- GeForce GTX 780
- GeForce GTX 680
- GeForce GTX 580
- GeForce GTX 570
- GeForce GTX 560
- GeForce GTX 480

**AMD**
- Radeon HD 7970
- Radeon HD 6970
- Radeon HD 6950
- Radeon HD 6870

Although PhotoScan is supposed to be able to utilize other GPU models and being run under a different operating system, Agisoft does not guarantee that it will work correctly.

### Note

- Use CPU enable flag to allow calculations both on CPU and GPU for GPU-supported tasks. However if two or more GPUs are used it is recommended to disable CPU for stable processing.

- Using GPU acceleration with mobile or integrated graphics video chips is not recommended because of the low performance of such GPUs.


**Installation procedure**

**Installing PhotoScan on Microsoft Windows**

To install PhotoScan on Microsoft Windows simply run the downloaded msi file and follow the instructions.

**Installing PhotoScan on Mac OS X**

Open the downloaded dmg image and drag PhotoScan application bundle to the desired location on your hard drive. Do not run PhotoScan directly from the dmg image to avoid issues related to the license activation.

**Installing PhotoScan on Debian/Ubuntu**

Unpack the downloaded archive with a program distribution kit to the desired location on your hard drive. Start PhotoScan by running photoscan.sh script from the program folder.

**Restrictions of the Demo mode**

Once PhotoScan is downloaded and installed on your computer you can run it either in the Demo mode or in the full function mode. On every start until you enter a serial number it will show a registration
box offering two options: (1) use PhotoScan in the Demo mode or (2) enter a serial number to confirm the purchase. The first choice is set by default, so if you are still exploring PhotoScan click the Continue button and PhotoScan will start in the Demo mode.

The employment of PhotoScan in the Demo mode is not time limited. Several functions, however, are not available in the Demo mode. These functions are the following:

• saving the project;
• all export features, including exporting reconstruction results (you can only view a 3D model on the screen);

To use PhotoScan in the full function mode you have to purchase it. On purchasing you will get the serial number to enter into the registration box on starting PhotoScan. Once the serial number is entered the registration box will not appear again and you will get full access to all functions of the program.

### Activation procedure

#### PhotoScan license activation

PhotoScan software requires license key (a digital code) to be activated. First of all, make sure that you have a valid license key or a trial code at hand.

**To activate PhotoScan**

1. Launch PhotoScan software, previously installed on your machine, and go to Help menu for **Activate product...** command.

2. In Activation dialog insert license key according to the suggested 5 digit blocks structure. Please note that license codes does never include zero digit - only letter “O”.

3. If the license code has been input correctly, then the **OK** button will become active. Click on it to complete the activation procedure. If the button is still grayed out, please make sure that the key you are using is meant for the product you are trying to activate: a license key for the Professional Edition, for example, will not activate the Standard version of the software.
Chapter 2. Capturing scenarios

Photographs suitable for 3D model reconstruction in PhotoScan can be taken by any digital camera (both metric and non-metric), as long as you follow some specific capturing guidelines. This section explains general principles of taking and selecting pictures that provide the most appropriate data for 3D model generation.

IMPORTANT! Make sure you have studied the following rules and read the list of restrictions before you get out for shooting photographs.

Equipment

- Use a digital camera with reasonably high resolution (5 MPix or more).
- Avoid ultra-wide angle and fisheye lenses. The best choice is 50 mm focal length (35 mm film equivalent) lenses. It is recommended to use focal length from 20 to 80 mm interval in 35mm equivalent. If a data set was captured with fisheye lens, appropriate camera sensor type should be selected in PhotoScan Camera Calibration dialog prior to processing.
- Fixed lenses are preferred. If zoom lenses are used - focal length should be set either to maximal or to minimal value during the entire shooting session for more stable results, for intermediate focal lengths separate camera calibration groups should be used.

Camera settings

- Using RAW data losslessly converted to the TIFF files is preferred, since JPG compression may induce unwanted noise to the images.
- Take images at maximal possible resolution.
- ISO should be set to the lowest value, otherwise high ISO values will induce additional noise to images.
- Aperture value should be high enough to result in sufficient focal depth: it is important to capture sharp, not blurred photos.
- Shutter speed should not be too slow, otherwise blur can occur due to slight movements.

Object/scene requirements

- Avoid not textured, shiny, highly reflective or transparent objects.
- If still have to, shoot shiny objects under a cloudy sky.
- Avoid unwanted foregrounds.
- Avoid moving objects within the scene to be reconstructed.
- Avoid absolutely flat objects or scenes.

Image preprocessing

- PhotoScan operates with the original images. So do not crop or geometrically transform, i.e. resize or rotate, the images.
Capturing scenarios

Generally, spending some time planning your shot session might be very useful.

- Number of photos: more than required is better than not enough.

- Number of "blind-zones" should be minimized since PhotoScan is able to reconstruct only geometry visible from at least two cameras.

- Each photo should effectively use the frame size: object of interest should take up the maximum area. In some cases portrait camera orientation should be used.

- Do not try to place full object in the image frame, if some parts are missing it is not a problem providing that these parts appear on other images.

- Good lighting is required to achieve better quality of the results, yet blinks should be avoided. It is recommended to remove sources of light from camera fields of view. Avoid using flash.

The following figures represent advice on appropriate capturing scenarios:
Restrictions

In some cases it might be very difficult or even impossible to build a correct 3D model from a set of pictures. A short list of typical reasons for photographs unsuitability is given below.

Modifications of photographs

PhotoScan can process only unmodified photos as they were taken by a digital photo camera. Processing the photos which were manually cropped or geometrically warped is likely to fail or to produce highly inaccurate results. Photometric modifications do not affect reconstruction results.

Lack of EXIF data

PhotoScan calculates initial values of sensor pixel size and focal length parameters based on the EXIF data. The better initial approximation of the parameter values is, the more accurate autocalibration of the camera can be performed. Therefore, reliable EXIF data is important for accurate reconstruction results. However 3D scene can also be reconstructed in the absence of the EXIF data. In this case PhotoScan assumes that focal length in 35 mm equivalent equals to 50 mm and tries to align the photos in accordance with this assumption. If the correct focal length value differs significantly from 50 mm, the alignment can give incorrect results or even fail. In such cases it is required to specify initial camera calibration manually.

The details of necessary EXIF tags and instructions for manual setting of the calibration parameters are given in the Camera calibration section.

Lens distortion

The distortion of the lenses used to capture the photos should be well simulated with the camera model used in the software. Generally, Brown's distortion model implemented in PhotoScan works well for frame cameras. However, since fisheye/ultra-wide angle lenses are poorly simulated by the mentioned distortion model, it is crucial to choose proper camera type in Camera Calibration dialog prior to processing of such data - the software will switch to the appropriate distortion model.

Lens calibration

It is possible to use PhotoScan for automatic lens calibration. PhotoScan uses LCD screen as a calibration target (optionally it is possible to use a printed chessboard pattern, providing that it is flat and all its cells are
squares). Lens calibration procedure supports estimation of the full camera calibration matrix, including non-linear distortion coefficients.

- **Note**

  - Lens calibration procedure can usually be skipped in common workflow, as PhotoScan calculates the calibration parameters automatically during Align Photos process. However, if the alignment results are unstable, for example, due to the lack of the tie points between the images, the lens calibration may be useful.

The following camera calibration parameters can be estimated:

- \( f \)
  - Focal length measured in pixels.

- \( c_x, c_y \)
  - Principal point coordinates, i.e. coordinates of lens optical axis interception with sensor plane in pixels.

- \( b_1, b_2 \)
  - Affinity and Skew (non-orthogonality) transformation coefficients.

- \( k_1, k_2, k_3, k_4 \)
  - Radial distortion coefficients.

- \( p_1, p_2, p_3, p_4 \)
  - Tangential distortion coefficients.

Before using lens calibration tool a set of photos of calibration pattern should be loaded in PhotoScan.

**To capture photos of the calibration pattern:**

1. Select Show Chessboard... command from the Lens submenu in the Tools menu to display the calibration pattern.

2. Use mouse scroll wheel to zoom in/out the calibration pattern. Scale the calibration pattern so that the number of squares on each side of the screen would exceed 10.

3. Capture a series of photos of the displayed calibration pattern with your camera from slightly different angles, according to the guidelines, outlined below. Minimum number of photos for a given focal length is 3.

4. If you are calibrating zoom lens, change the focal length of your lens and repeat the previous step for other focal length settings.

5. **Click anywhere on the calibration pattern or press** *Escape* **button to return to the program.**

6. Upload the captured photos to the computer.

When capturing photos of the calibration pattern, try to fulfill the following guidelines:

- Make sure that the focal length keeps constant throughout the session (in case of zoom lens).

- Avoid glare on the photos. Move the light sources away if required.

- Preferably, the whole area of the photos should be covered by calibration pattern. Move the camera closer to the LCD screen if required.
To load photos of the calibration pattern:

1. Create new chunk using the Add Chunk toolbar button on the Workspace pane or selecting Add Chunk command from the Workspace context menu (available by right-clicking on the root element on the Workspace pane). See information on using chunks in Using chunks section.

2. Select Add Photos... command from the Workflow menu.

3. In the Open dialog box, browse to the folder, containing the photos, and select files to be processed. Then click Open button.

4. Loaded photos will appear in the Photos pane.

Note

- You can open any photo by double clicking on its thumbnail in the Photos pane. To obtain good calibration, the photos should be reasonably sharp, with crisp boundaries between cells.

- If you have loaded some unwanted photos, you can easily remove them at any time.

- Before calibrating fisheye lens you need to set the corresponding Camera Type in the Camera Calibration... dialog available from the Tools menu. See information on other camera calibration settings in Camera calibration section.

To calibrate camera lens

1. Select Calibrate Lens... command from the Lens submenu in the Tools menu.

2. In the Calibrate Lens dialog box, select the desired calibration parameters. Click OK button when done.

3. The progress dialog box will appear displaying the current processing status. To cancel processing click the Cancel button.

4. The calibration results will appear on the Adjusted tab of the Camera Calibration... dialog available from the Tools menu. The adjusted values can be saved to file by using Save button on the Adjusted tab. The saved lens calibration data can later be used in another chunk or project, providing that the same camera and lens is used.

Note

- After you have saved the calibration parameters for the lens, you may proceed with the workflow steps in a separate chunk for the actual image set captured by the same camera and lens. To protect the calibration data from being refined during Align Photos process one should check Fix calibration box on the Initial tab for the chunk with the data to be processed. In this case initial calibration values will not be changed during Align Photos process.

After calibration is finished, you will be presented with the following information:

Detected chessboard corners are displayed on each photo (the photo can be opened by double clicking on its name in the Photos pane). It is preferable when the majority of the corners were detected correctly. For each detected corner the reprojection error between the detected corner position and estimated position according to the calculated calibration is also displayed. The errors are scaled x20 times for display.
Chapter 3. General workflow

Processing of images with PhotoScan includes the following main steps:

- loading photos into PhotoScan;
- inspecting loaded images, removing unnecessary images;
- aligning photos;
- building dense point cloud;
- building mesh (3D polygonal model);
- generating texture;
- exporting results.

If you are using PhotoScan in the full function (not the Demo) mode, intermediate results of the image processing can be saved at any stage in the form of project files and can be used later. The concept of projects and project files is briefly explained in the Saving intermediate results section.

The list above represents all the necessary steps involved in the construction of a textured 3D model from your photos. Some additional tools, which you may find to be useful, are described in the successive chapters.

Preferences settings

Before starting a project with PhotoScan it is recommended to adjust the program settings for your needs. In Preferences dialog (General Tab) available through the Tools menu you can indicate the path to the PhotoScan log file to be shared with the Agisoft support team in case you face any problem during the processing. Here you can also change GUI language to the one that is most convenient for you. The options are: English, Chinese, French, German, Italian, Japanese, Korean, Portuguese, Russian, Spanish.

Switch Theme in case you have preferences between Dark or Light program GUI or leave it as Classic for the simplest view. Shortcuts can be adjusted for your convenience on the General tab as well.

On the GPU Tab you need to make sure that all GPU devices detected by the program are checked. PhotoScan exploits GPU processing power that speeds up the process significantly. However, Agisoft does not recommend to use integrated graphic card adapters due to their possible unstable work under heavy load. If you have decided to switch on GPUs to boost the data processing with PhotoScan, it is recommended to uncheck "Use CPU when performing GPU accelerated processing" option, providing that the number of GPUs available is more than one.

Advanced tab allows you to switch on such advanced features like rich Python console, for example. Furthermore, you can enable loading of extra camera data from XMP (camera calibration).

To test new mesh generation method (for Build Mesh processing step), you need to check the corresponding option on the Advanced tab as well. This is recommended to be supported with Keep depth maps option (check the box on the Advanced tab). Keep depth maps option can also be beneficial in terms of saving up the processing time, in case there might be a need to rebuild dense point cloud, once generated, for a smaller part of the scene.
Loading photos

Before starting any operation it is necessary to point out what photos will be used as a source for 3D reconstruction. In fact, photographs themselves are not loaded into PhotoScan until they are needed. So, when you "load photos" you only indicate photographs that will be used for further processing.

To load a set of photos

1. Select Add Photos... command from the Workflow menu or click Add Photos toolbar button on the Workspace pane.
2. In the Add Photos dialog box browse to the folder containing the images and select files to be processed. Then click Open button.

Note

- PhotoScan accepts the following image formats: JPEG, TIFF, DNG, PNG, OpenEXR, BMP, TARGA, PPM, PGM, SEQ, ARA (thermal images) and JPEG Multi-Picture Format (MPO). Photos in any other format will not be shown in the Add Photos dialog box. To work with such photos you will need to convert them in one of the supported formats.

If you have loaded some unwanted photos, you can easily remove them at any moment.

To remove unwanted photos

1. On the Workspace pane select the photos to be removed.
2. Right-click on the selected photos and choose Remove Items command from the opened context menu, or click Remove Items toolbar button on the Workspace pane. The selected photos will be removed from the working set.

Camera groups

If all the photos or a subset of photos were captured from one camera position - camera station, for PhotoScan to process them correctly it is obligatory to move those photos to a camera group and mark the group as Camera Station. It is important that for all the photos in a Camera Station group distances between camera centers were negligibly small compared to the camera-object minimal distance. 3D model reconstruction will require at least two camera stations with overlapping photos to be present in a chunk. However, it is possible to export panoramic picture for the data captured from only one camera station. Refer to Exporting results section for guidance on panorama export.

Alternatively, camera group structure can be used to manipulate the image data in a chunk easily, e.g. to apply Disable/Enable functions to all the cameras in a group at once.

To move photos to a camera group

1. On the Workspace pane (or Photos pane) select the photos to be moved.
2. Right-click on the selected photos and choose Move Cameras - New Camera Group command from the opened context menu.
3. A new group will be added to the active chunk structure and selected photos will be moved to that group.

4. Alternatively selected photos can be moved to a camera group created earlier using Move Cameras - Camera Group - Group_name command from the context menu.

To mark group as camera station, right click on the camera group name and select Set Group Type command from the context menu.

**Inspecting loaded photos**

Loaded photos are displayed on the Workspace pane along with flags reflecting their status.

The following flags can appear next to the photo name:

**NC (Not calibrated)**
Notifies that the EXIF data available is not sufficient to estimate the camera focal length. In this case PhotoScan assumes that the corresponding photo was taken using 50mm lens (35mm film equivalent). If the actual focal length differs significantly from this value, manual calibration may be required. More details on manual camera calibration can be found in the Camera calibration section.

**NA (Not aligned)**
Notifies that external camera orientation parameters have not been estimated for the current photo yet.

Images loaded to PhotoScan will not be aligned until you perform the next step - photos alignment.

**Notifies that Camera Station type was assigned to the group.**

**Aligning photos**

Once photos are loaded into PhotoScan, they need to be aligned. At this stage PhotoScan finds the camera position and orientation for each photo and builds a sparse point cloud model.

**To align a set of photos**

1. Select Align Photos... command from the Workflow menu.

2. In the Align Photos dialog box select the desired alignment options. Click OK button when done.

3. The progress dialog box will appear displaying the current processing status. To cancel processing click Cancel button.

Alignment having been completed, computed camera positions and a sparse point cloud will be displayed. You can inspect alignment results and remove incorrectly positioned photos, if any. To see the matches between any two photos use View Matches... command from a photo context menu in the Photos pane.

Incorrectly positioned photos can be realigned.

**To realign a subset of photos**

1. Reset alignment for incorrectly positioned cameras using Reset Camera Alignment command from the photo context menu.
General workflow

2. Select photos to be realigned and use Align Selected Cameras command from the photo context menu.

3. The progress dialog box will appear displaying the current processing status. To cancel processing click Cancel button.

When the alignment step is completed, the point cloud and estimated camera positions can be exported for processing with another software if needed.

Image quality

Poor input, e.g. vague photos, can influence alignment results badly. To help you to exclude poorly focused images from processing PhotoScan suggests automatic image quality estimation feature. Images with quality value of less than 0.5 units are recommended to be disabled and thus excluded from photogrammetric processing, providing that the rest of the photos cover the whole scene to be reconstructed. To disable a photo use Disable button from the Photos pane toolbar.

PhotoScan estimates image quality for each input image. The value of the parameter is calculated based on the sharpness level of the most focused part of the picture.

To estimate image quality

1. Switch to the detailed view in the Photos pane using Details command from the Change menu on the Photos pane toolbar.

2. Select all photos to be analyzed on the Photos pane.

3. Right button click on the selected photo(s) and choose Estimate Image Quality command from the context menu.

4. Once the analysis procedure is over, a figure indicating estimated image quality value will be displayed in the Quality column on the Photos pane.

Alignment parameters

The following parameters control the photo alignment procedure and can be modified in the Align Photos dialog box:

Accuracy
Higher accuracy settings help to obtain more accurate camera position estimates. Lower accuracy settings can be used to get the rough camera positions in a shorter period of time.

While at High accuracy setting the software works with the photos of the original size, Medium setting causes image downscaling by factor of 4 (2 times by each side), at Low accuracy source files are downscaled by factor of 16, and Lowest value means further downscaling by 4 times more. Highest accuracy setting upscales the image by factor of 4. Since tie point positions are estimated on the basis of feature spots found on the source images, it may be meaningful to upscale a source photo to accurately localize a tie point. However, Highest accuracy setting is recommended only for very sharp image data and mostly for research purposes due to the corresponding processing being quite time consuming.

Pair preselection
The alignment process of large photo sets can take a long time. A significant portion of this time period is spent on matching of detected features across the photos. Image pair preselection option may speed
up this process due to selection of a subset of image pairs to be matched. In the Generic preselection mode the overlapping pairs of photos are selected by matching photos using lower accuracy setting first.

You can switch on both options to speed up the processing even more.

**Reset current alignment**

If this option is checked, all the tie, and key, and matching points will be discarded and the alignment procedure will be started from the very beginning.

Additionally the following advanced parameters can be adjusted.

**Key point limit**

The number indicates upper limit of feature points on every image to be taken into account during current processing stage. Using zero value allows PhotoScan to find as many key points as possible, but it may result in a big number of less reliable points.

**Tie point limit**

The number indicates upper limit of matching points for every image. Using zero value doesn't apply any tie point filtering.

**Apply mask to**

If apply mask to key points option is selected, areas previously masked on the photos are excluded from feature detection procedure. Apply mask to tie points option means that certain tie points are excluded from alignment procedure. Effectively this implies that if some area is masked at least on a single photo, relevant key points on the rest of the photos picturing the same area will be also ignored during alignment procedure (a tie point is a set of key points which have been matched as projections of the same 3D point on different images). This can be useful to be able to suppress background in turntable shooting scenario with only one mask. For additional information on the usage of masks please refer to the Using masks section.

**Adaptive camera model fitting**

This option enables automatic selection of camera parameters to be included into adjustment based on their reliability estimates. For data sets with strong camera geometry, like images of a building taken from all the sides around, including different levels, it helps to adjust more parameters during initial camera alignment. For data sets with weak camera geometry, like a typical aerial data set, it helps to prevent divergence of some parameters. For example, estimation of radial distortion parameters for data sets with only small central parts covered by the object is very unreliable. When the option is unchecked, PhotoScan will refine only the fixed set of parameters: focal length, principal point position, three radial distortion coefficients (K1, K2, K3) and two tangential distortion coefficients (P1, P2).

**Note**

- Tie point limit parameter allows to optimize performance for the task and does not generally effect the quality of the further model. Recommended value is 4000. Too high or too low tie point limit value may cause some parts of the dense point cloud model to be missed. The reason is that PhotoScan generates depth maps only for pairs of photos for which number of matching points is above certain limit. This limit equals to 100 matching points, unless moved up by the figure "10% of the maximum number of matching points between the photo in question and other photos, only matching points corresponding to the area within the bounding box being considered."

- The number of tie points can be reduced after the alignment process with Tie Points - Thin Point Cloud command available from Tools menu. As a results sparse point cloud will be thinned, yet the alignment will be kept unchanged.
**Incremental image alignment**

In case some extra images should be subaligned to the set of already aligned images, you can benefit from incremental image alignment option. To make it possible, two rules must be followed: 1) the scene environment should not have changed significantly (lighting conditions, etc); 2) do not forget to switch on Keep key points option in the Preferences dialog, Advanced tab BEFORE the whole processing is started.

**To subalign some extra images added to the chunk with already aligned set of images**

1. Add extra photos to the active chunk using Add photos command from the Workflow menu.
2. Open Align photos dialog from the Workflow menu.
3. Set alignment parameters for the newly added photos. IMPORTANT! Uncheck Reset alignment option.
4. Click OK. PhotoScan will consider existing key points and try to match them with key points detected on the newly added images.

**Point cloud generation based on imported camera data**

PhotoScan supports import of external and internal camera orientation parameters. Thus, if precise camera data is available for the project, it is possible to load them into PhotoScan along with the photos, to be used as initial information for 3D reconstruction job.

**To import external and internal camera parameters**

1. Select Import Cameras command from the File menu.
2. Select the format of the file to be imported.
3. Browse to the file and click Open button.
4. The data will be loaded into the software. Camera calibration data can be inspected in the Camera Calibration dialog, Adjusted tab, available from Tools menu.

Camera data can be loaded in one of the following formats: PhotoScan *.xml, BINGO *.dat, Bundler *.out, Autodesk FBX (*.fbx), VisionMap Detailed Report *.txt, Realviz RZML *.rzml.

Once the data is loaded, PhotoScan will offer to build point cloud. This step involves feature points detection and matching procedures. As a result, a sparse point cloud - 3D representation of the tie-points data, will be generated. Build Point Cloud command is available from Tools - Tie Points menu. Parameters controlling Build Point Cloud procedure are the same as the ones used at Align Photos step (see above).

**Building dense point cloud**

PhotoScan allows to generate and visualize a dense point cloud model. Based on the estimated camera positions the program calculates depth information for each camera to be combined into a single dense point cloud. PhotoScan tends to produce extra dense point clouds, which are of almost the same density, if not denser, as LIDAR point clouds. A dense point cloud can be edited within PhotoScan environment and used as a basis for such processing stages as Build Mesh, Build DEM, Build Tiled Model. Alternatively, the point cloud can be exported to an external tool for further analysis.
To build a dense point cloud

1. Check the reconstruction volume bounding box. To adjust the bounding box use the Resize Region, Move Region and Rotate Region toolbar buttons. To resize the bounding box, drag corners of the box to the desired positions; to move- hold the box with the left mouse button.

2. Select the Build Dense Cloud... command from the Workflow menu.

3. In the Build Dense Cloud dialog box select the desired reconstruction parameters. Click OK button when done.

4. The progress dialog box will appear displaying the current processing status. To cancel processing click Cancel button.

Reconstruction parameters

Quality
- Specifies the desired reconstruction quality. Higher quality settings can be used to obtain more detailed and accurate geometry, but they require longer time for processing. Interpretation of the quality parameters here is similar to that of accuracy settings given in Photo Alignment section. The only difference is that in this case Ultra High quality setting means processing of original photos, while each following step implies preliminary image size downscaling by factor of 4 (2 times by each side).

Additionally the following advanced parameters can be adjusted.

Depth filtering modes
- At the stage of dense point cloud generation reconstruction PhotoScan calculates depth maps for every image. Due to some factors, like noisy or badly focused images, there can be some outliers among the points. To sort out the outliers PhotoScan has several built-in filtering algorithms that answer the challenges of different projects.

  If there are important small details which are spatially distinguished in the scene to be reconstructed, then it is recommended to set Mild depth filtering mode, for important features not to be sorted out as outliers. This value of the parameter may also be useful for aerial projects in case the area contains poorly textured roofs, for example.

  If the area to be reconstructed does not contain meaningful small details, then it is reasonable to chose Aggressive depth filtering mode to sort out most of the outliers. This value of the parameter normally recommended for aerial data processing, however, mild filtering may be useful in some projects as well (see poorly textured roofs comment in the mild parameter value description above).

  Moderate depth filtering mode brings results that are in between the Mild and Aggressive approaches. You can experiment with the setting in case you have doubts which mode to choose.

  Additionally depth filtering can be Disabled. But this option is not recommended as the resulting dense cloud could be extremely noisy.

Calculate point colors
- This option can be unchecked in case the points color is not of interest. This will allow to save up processing time.

Reuse depth maps
- If you would like to reuse depth maps available in the chunk, select respective Quality and Depth filtering parameters values (see info next to Depth maps label on the Workspace pane) and then check Reuse depth maps option.
General workflow

Point cloud import

PhotoScan allows to import a point cloud to be interpreted at further processing stages as a dense point cloud. If you want to upload a dense point cloud got from some external source (photogrammetry technology, laser scanning, etc), you can use Import points command from the File menu. In the Import points dialog browse to a file in one of the supported formats and click Open button.

Dense point cloud can be imported in one of the following formats: Wavefront OBJ, Stanford PLY, ASPRS LAS, LAZ, ASTM E57, ASCII PTS.

Building mesh

Mesh based on point cloud data

Based on the point cloud information (Dense Cloud, Sparse Cloud, Point Cloud uploaded from external source) PhotoScan can reconstruct polygonal model - mesh.

To build a mesh

1. Check the reconstruction volume bounding box. If the model has already been referenced, the bounding box will be properly positioned automatically. Otherwise, it is important to control its position manually.

To adjust the bounding box manually, use the Resize Region, Move Region and Rotate Region toolbar buttons. Rotate the bounding box and then drag corners of the box to the desired positions - only part of the scene inside the bounding box will be reconstructed. If the Height field reconstruction method is to be applied, it is important to control the position of the red side of the bounding box: it defines reconstruction plane. In this case make sure that the bounding box is correctly oriented.

2. Select the Build Mesh... command from the Workflow menu.

3. In the Build Mesh dialog box select the desired reconstruction parameters. Click OK button when done.

4. The progress dialog box will appear displaying the current processing status. To cancel processing click Cancel button.

Reconstruction parameters

PhotoScan supports several reconstruction methods and settings, which help to produce optimal reconstructions for a given data set.

Surface type

Arbitrary surface type can be used for modeling of any kind of object. It should be selected for closed objects, such as statues, buildings, etc. It doesn't make any assumptions on the type of the object being modeled, which comes at a cost of higher memory consumption.

Height field surface type is optimized for modeling of planar surfaces, such as terrains or basereiefs. It should be selected for aerial photography processing as it requires lower amount of memory and allows for larger data sets processing.
General workflow

**Source data**

Specifies the source for the mesh generation procedure. Sparse cloud can be used for fast 3D model generation based solely on the sparse point cloud. Dense cloud setting will result in longer processing time but will generate high quality output based on the previously reconstructed dense point cloud.

**Face count**

Specifies the maximum number of polygons in the final mesh. Suggested values (High, Medium, Low) are calculated based on the number of points in the previously generated dense point cloud: the ratio is 1/5, 1/15, and 1/45 respectively. They present optimal number of polygons for a mesh of a corresponding level of detail. It is still possible for a user to indicate the target number of polygons in the final mesh according to their choice. It could be done through the Custom value of the Face count parameter. Please note that while too small number of polygons is likely to result in too rough mesh, too huge custom number (over 10 million polygons) is likely to cause model visualization problems in external software.

Additionally the following advanced parameters can be adjusted.

**Interpolation**

If interpolation mode is **Disabled** it leads to accurate reconstruction results since only areas corresponding to dense point cloud points are reconstructed. Manual hole filling is usually required at the post processing step.

With **Enabled (default)** interpolation mode PhotoScan will interpolate some surface areas within a circle of a certain radius around every dense cloud point. As a result some holes can be automatically covered. Yet some holes can still be present on the model and are to be filled at the post processing step.

In **Extrapolated** mode the program generates holeless model with extrapolated geometry. Large areas of extra geometry might be generated with this method, but they could be easily removed later using selection and cropping tools.

**Note**

- PhotoScan tends to produce 3D models with excessive geometry resolution, so it is recommended to perform mesh decimation after geometry computation. More information on mesh decimation and other 3D model geometry editing tools is given in the Editing model geometry section.

**Visibility consistent mesh**

In addition to mesh generation method described above, PhotoScan allows to generate and visualize a mesh model right from depth maps without intermediate dense cloud generation. Visibility consistent mesh generation method is experimental. It is oriented on filling the holes and can filter most of the noise out of the 3D surface, providing that visibility constraints are maintained: rays coming from cameras positions to surface points should not intersect the surface. It is also possible to prohibit surface reconstruction in designated space volume with strict visibility masks. Strict volumetric masks are useful, for example, to suppress noise between fingers by masking space between them from a single camera. Furthermore, it is recommended to suppress textureless background to prevent it from sticking to the object contours - masking out background on a single image is enough for the purpose.

**To build a mesh with new experimental method**

1. Open preferences dialog from the Tools menu. On the Advanced tab enable Use visibility consistent mesh generation method (experimental).
General workflow

2. Check the reconstruction volume bounding box. If the model has already been referenced, the bounding box will be properly positioned automatically. Otherwise, it is important to control its position manually.

   To adjust the bounding box manually, use the Resize Region, Move Region and Rotate Region toolbar buttons. Rotate the bounding box and then drag corners of the box to the desired positions - only part of the scene inside the bounding box will be reconstructed. If the Height field reconstruction method is to be applied, it is important to control the position of the red side of the bounding box: it defines reconstruction plane. In this case make sure that the bounding box is correctly oriented.

3. Select the Build Mesh... command from the Workflow menu.

4. In the Build Mesh dialog box select the desired reconstruction parameters. Click OK button when done.

5. The progress dialog box will appear displaying the current processing status. To cancel processing click Cancel button.

Reconstruction parameters

PhotoScan supports several reconstruction settings, which help to produce optimal surfaces for a given data set.

Surface type

Arbitrary surface type can be used for modeling of any kind of object. It should be selected for closed objects, such as statues, buildings, etc. It doesn't make any assumptions on the type of the object being modeled, which comes at a cost of higher memory consumption.

Visibility consistent mesh generation method is applicable to 3D surface reconstruction only. For 2.5D Height field surface type the standard processing algorithm will be run. Corresponding parameters are described in the section above.

Quality

Specifies the desired reconstruction quality. Higher quality settings can be used to obtain more detailed and accurate geometry, but they require longer time for processing. Interpretation of the quality parameters here is similar to that of accuracy settings given in Photo Alignment section. The only difference is that in this case Ultra High quality setting means processing of original photos, while each following step implies preliminary image size downscaling by factor of 4 (2 times by each side).

Additionally the following advanced parameters can be adjusted.

Use strict volumetric masking

When this option is enabled, space volume covered with mask from at least one photo will be suppressed. Each mask is strict - so you should use them as little as possible to prevent accidental suppressing some surface parts. Each mask also makes mesh reconstruction slower. For example strict volumetric masks are useful to suppress noise between fingers by masking space between them from single camera. Also this is useful to suppress textureless background stuck to object contours - by masking out background from single camera. For additional information on the usage of masks please refer to the Using masks section.

Reuse depth maps

If you would like to reuse depth maps available in the chunk, select respective Quality and Depth filtering parameters values (see info next to Depth maps label on the Workspace pane) and then check Reuse depth maps option. This method is applicable only to mild filtering mode.
Building model texture

Color calibration

If the lighting conditions have been changing significantly during capturing scenario, it is recommended to use 'Calibrate colors' option from the Tools menu before Build texture procedure. The option can help to even brightness and white balance of the images over the data set. Please note that for large data sets Calibrate colors procedure can turn out to be quite time consuming.

To calibrate colors

1. Select Calibrate colors... command from the Tools menu.
2. Select the desired colors calibration parameters in the Calibrate colors dialog box. Click OK button when done.
3. The progress dialog box will appear displaying the current processing status. To cancel processing click Cancel button.

Color calibration parameters

Source data

Defines what data should be taken as the basis for overlapping areas estimation.

- Sparse cloud - the quickest yet the roughest estimation available.
- Model - gives more precise results, but only on condition that the surface is detailed enough. This parameter value is the recommended one if the aim is to calibrate colors to improve the quality of the model texture.
- DEM - is a reasonable alternative to 'Model' value for large data sets when it is not feasible to reconstruct solid polygonal model (mesh).

Calibrate white balance

Additional option to be switched on if white balance should be evened as well.

To generate 3D model texture

1. Select Build Texture... command from the Workflow menu.
2. Select the desired texture generation parameters in the Build Texture dialog box. Click OK button when done.
3. The progress dialog box will appear displaying the current processing status. To cancel processing click Cancel button.

Texture mapping modes

The texture mapping mode determines how the object texture will be packed in the texture atlas. Proper texture mapping mode selection helps to obtain optimal texture packing and, consequently, better visual quality of the final model.

Generic

The default mode is the Generic mapping mode; it allows to parametrize texture atlas for arbitrary geometry. No assumptions regarding the type of the scene to be processed are made; program tries to create as uniform texture as possible.
Adaptive orthophoto
In the **Adaptive orthophoto** mapping mode the object surface is split into the flat part and vertical regions. The flat part of the surface is textured using the orthographic projection, while vertical regions are textured separately to maintain accurate texture representation in such regions. When in the **Adaptive orthophoto** mapping mode, the program tends to produce more compact texture representation for nearly planar scenes, while maintaining good texture quality for vertical surfaces, such as walls of the buildings.

Orthophoto
In the **Orthophoto** mapping mode the whole object surface is textured in the orthographic projection. The **Orthophoto** mapping mode produces even more compact texture representation than the **Adaptive orthophoto** mode at the expense of texture quality in vertical regions.

Single photo
The **Single photo** mapping mode allows to generate texture from a single photo. The photo to be used for texturing can be selected from 'Texture from' list.

Keep uv
The **Keep uv** mapping mode generates texture atlas using current texture parametrization. It can be used to rebuild texture atlas using different resolution or to generate the atlas for the model parametrized in the external software.

Texture generation parameters
The following parameters control various aspects of texture atlas generation:

**Texture from (Single photo mapping mode only)**
Specifies the photo to be used for texturing. Available only in the **Single photo** mapping mode.

**Blending mode (not used in Single photo mode)**
Selects the way pixel values from different photos will be combined in the final texture.

- **Mosaic** - implies two-step approach: it does blending of low frequency component for overlapping images to avoid seamline problem (weighted average, weight being dependent on a number of parameters including proximity of the pixel in question to the center of the image), while high frequency component, that is in charge of picture details, is taken from a single image - the one that presents good resolution for the area of interest while the camera view is almost along the normal to the reconstructed surface in that point.

- **Average** - uses the weighted average value of all pixels from individual photos, the weight being dependent on the same parameters that are considered for high frequency component in mosaic mode.

- **Max Intensity** - the photo which has maximum intensity of the corresponding pixel is selected.

- **Min Intensity** - the photo which has minimum intensity of the corresponding pixel is selected.

- **Disabled** - the photo to take the color value for the pixel from is chosen like the one for the high frequency component in mosaic mode.

**Texture size / count**
Specifies the size (width & height) of the texture atlas in pixels and determines the number of files for texture to be exported to. Exporting texture to several files allows to archive greater resolution of the final model texture, while export of high resolution texture to a single file can fail due to RAM limitations.
Multi-page texture atlas generation is supported for Generic mapping mode only and Keep UV option, if the imported model contains proper texture layout.

Additionally the following advanced parameters can be adjusted.

**Enable ghosting filter**

In case the scene includes some thin structures or moving objects which failed to be reconstructed as part of polygonal model, it can be useful to switch on this option to avoid ghosting effect on the resulting texture.

**Enable hole filling**

This option is enabled on default since it helps to avoid salt-and-pepper effect in case of complicated surface with numerous tiny parts shading other parts of the model. Only in case of very specific tasks might it be recommended to switch the function off.

- HDR texture generation requires HDR photos on input.

### Improving texture quality

To improve resulting texture quality it may be reasonable to exclude poorly focused images from processing at this step. PhotoScan suggests automatic image quality estimation feature. Images with quality value of less than 0.5 units are recommended to be disabled and thus excluded from texture generation procedure. To disable a photo use Disable button from the Photos pane toolbar.

PhotoScan estimates image quality as a relative sharpness of the photo with respect to other images in the data set. The value of the parameter is calculated based on the sharpness level of the most focused part of the picture.

**To estimate image quality**

1. Switch to the detailed view in the Photos pane using Details command from the Change menu on the Photos pane toolbar.
2. Select all photos to be analyzed on the Photos pane.
3. Right button click on the selected photo(s) and choose Estimate Image Quality command from the context menu.
4. Once the analysis procedure is over, a figure indicating estimated image quality value will be displayed in the Quality column on the Photos pane.

### Saving intermediate results

Certain stages of 3D model reconstruction can take a long time. The full chain of operations could eventually last for 4-6 hours when building a model from hundreds of photos. It is not always possible to complete all the operations in one run. PhotoScan allows to save intermediate results in a project file.

**PhotoScan project archive (.PSZ)**

PhotoScan Archive files (*.psz) may contain the following information:
General workflow

• List of loaded photographs with reference paths to the image files.

• Photo alignment data such as information on camera positions, sparse point cloud model and set of refined camera calibration parameters for each calibration group.

• Masks applied to the photos in project.

• Depth maps for cameras.

• Dense point cloud model.

• Reconstructed 3D polygonal model with any changes made by user. This includes mesh and texture if it was built.

• Structure of the project, i.e. number of chunks in the project and their content.

Note that since PhotoScan tends to generate extra dense point clouds and highly detailed polygonal models, project saving procedure can take up quite a long time. You can decrease compression level to speed up the saving process. However, please note that it will result in a larger project file. Compression level setting can be found on the Advanced tab of the Preferences dialog available from Tools menu.

PhotoScan project file (.PSX)

You can save the project at the end of any processing stage and return to it later. To restart work simply load the corresponding file into PhotoScan. Project files can also serve as backup files or be used to save different versions of the same model.

Project files use relative paths to reference original photos. Thus, when moving or copying the project file to another location do not forget to move or copy photographs with all the folder structure involved as well. Otherwise, PhotoScan will fail to run any operation requiring source images, although the project file including the reconstructed model will be loaded up correctly. Alternatively, you can enable Store absolute image paths option on the Advanced tab of the Preferences dialog available from Tools menu.

Exporting results

PhotoScan supports export of processing results in various representations: sparse and dense point clouds, camera calibration and camera orientation data, mesh, etc.

Point cloud and camera calibration data can be exported right after photo alignment is completed. All other export options are available after the corresponding processing step.

If you are going to export the results (point cloud / mesh) for the chunk that is not referenced, please note that the resulting file will be oriented according to a default coordinate system (see axes in the bottom right corner of the Model view), i.e. the model can be shown differently from what you see in PhotoScan window. To align the model orientation with the default coordinate system use Rotate object button from the Toolbar. Move object and Scale object instruments can be used to adjust the size and location of the unreferenced model.

In some cases editing model geometry in the external software may be required. PhotoScan supports model export for editing in external software and then allows to import it back as it is described in the Editing model geometry section of the manual.

Main export commands are available from the File menu.
**Point cloud export**

**To export sparse or dense point cloud**

1. Select Export Points... command from the File menu.
2. Browse the destination folder, choose the file type, and print in the file name. Click Save button.
3. In the Export Points dialog box select desired Type of point cloud - Sparse or Dense.
4. Indicate export parameters applicable to the selected file type.
5. Click OK button to start export.
6. The progress dialog box will appear displaying the current processing status. To cancel processing click Cancel button.

In some cases it may be reasonable to edit point cloud before exporting it. To read about point cloud editing refer to the **Editing point cloud** section of the manual.

PhotoScan supports point cloud export in the following formats:

- Wavefront OBJ
- Stanford PLY
- XYZ text file format
- ASPRS LAS
- LAZ
- ASTM E57
- ASCII PTS
- Autodesk DXF
- U3D
- potree
- Cesium 3D Tiles
- Agisoft OC3
- Topcon CL3
- PDF

**Note**

- Saving color information of the point cloud is not supported by the OBJ and DXF formats.
- Saving point normals information is not supported by the LAS, LAZ, PTS, CL3 and DXF formats.
PhotoScan supports direct uploading of the point clouds to the following resources: 4DMapper, PointBox, PointScene and Sketchfab. To publish your point cloud online use Upload Model... command from the File menu.

**Tie points and camera calibration, orientation data export**

To export camera calibration and camera orientation data select Export Cameras... command from the File menu.

PhotoScan supports camera data export in the following formats:

- Agisoft XML structure
- Bundler OUT file format
- CHAN file format
- Boujou TXT file format
- Omega Phi Kappa text file format
- Realviz RZML format
- PATB Exterior orientation
- BINGO project file
- ORIMA file
- AeroSys Exterior orientation
- Inpho project file
- Summit Evolution project
- Blocks exchange

**Note**

- Camera data export in Bundler and Boujou file formats will save sparse point cloud data in the same file.
- Camera data export in Bundler file format would not save distortion coefficients k3, k4.

To export tie points data one should choose one of the following exchange formats in the Export Cameras dialog: BINGO, ORIMA, PATB, Summit Evolution or Blocks. Tie points can be exported only along with camera calibration and orientation data.

To export / import only camera calibration data select Camera Calibration... command from the Tools menu. Using buttons it is possible to load / save camera calibration data in the following formats:

- Agisoft Camera Calibration (*.xml)
- Australis Camera Parameters (*.txt)
- PhotoModeler Camera Calibration (*.ini)
General workflow

- 3DM CalibCam Camera Parameters (*.txt)
- CalCam Camera Calibration (*.cal)
- Inpho Camera Calibration (*.txt)
- USGS Camera Calibration (*.txt)
- Z/I Distortion Grid (*.dat)

Panorama export

PhotoScan is capable of panorama stitching for images taken from the same camera position - camera station. To indicate for the software that loaded images have been taken from one camera station, one should move those photos to a camera group and assign Camera Station type to it. For information on camera groups refer to Loading photos section.

To export panorama

1. Select Export Panorama... command from the File menu.
2. Select camera group which panorama should be previewed for.
3. Choose panorama orientation in the file with the help of navigation buttons to the right of the preview window in the Export Panorama dialog.
4. Set exporting parameters: select camera groups which panorama should be exported for and indicate export file name mask.
5. Click OK button
6. Browse the destination folder and click Save button.

Additionally, you can set boundaries for the region of panorama to be exported using Setup boundaries section of the Export Panorama dialog. Text boxes in the first line (X) allow to indicate the angle in the horizontal plane and the second line (Y) serves for angle in the vertical plane limits. Image size (pix) option enables to control the dimensions of the exported image file.

PhotoScan supports panorama export in the following formats:

- JPEG
- TIFF
- PNG
- BMP
- OpenEXR
- TARGA

3D model export

To export 3D model

1. Select Export Model... command from the File menu.
2. Browse the destination folder, choose the file type, and print in the file name. Click Save button.

3. In the Export Model dialog indicate export parameters applicable to the selected file type.

4. Click OK button to start export.

5. The progress dialog box will appear displaying the current processing status. To cancel processing click Cancel button.

PhotoScan supports model export in the following formats:

- Wavefront OBJ
- 3DS file format
- VRML
- COLLADA
- Alembic
- Stanford PLY
- STL
- Autodesk FBX
- Autodesk DXF (in Polyline or 3DFace representation)
- U3D
- Adobe PDF

Some file formats (OBJ, 3DS, VRML, COLLADA, PLY, FBX) save texture image in a separate file. The texture file should be kept in the same directory as the main file describing the geometry. If the texture atlas was not built only the model geometry is exported.

PhotoScan supports direct uploading of the models to Sketchfab resource. To publish your model online use Upload Model... command from the File menu.

**Extra products to export**

In addition to main targeted products PhotoScan allows to export several other processing results, like

- Undistort photos, i.e. photos free of lens distortions (Undistort Photos... command available from Export submenu of the File menu). Undistorted photos may be exported with the applied color correction, if corresponding option is selected in the Undistort Photos dialog.

- Depth map for any image (Export Depth... command available from photo context menu).

- High resolution image of the model as it is shown in the Model view or in Ortho view mode. Capture View command available from the context menu shown on right button click in the Model or Ortho view.
Chapter 4. Improving camera alignment results

Camera calibration

Calibration groups

While carrying out photo alignment PhotoScan estimates both internal and external camera orientation parameters, including nonlinear radial distortions. For the estimation to be successful it is crucial to apply the estimation procedure separately to photos taken with different cameras. Once photos have been loaded in the program, PhotoScan automatically divides them into calibration groups according to the image resolution and/or EXIF metadata like camera type and focal length. All the actions described below could and should be applied (or not applied) to each calibration group individually.

Calibration groups can be rearranged manually.

To create a new calibration group

1. Select Camera Calibration... command from the Tools menu.
2. In the Camera Calibration dialog box, select photos to be arranged in a new group.
3. In the right-click context menu choose Create Group command.
4. A new group will be created and depicted on the left-hand part of the Camera Calibration dialog box.

To move photos from one group to another

1. Select Camera Calibration... command from the Tools menu.
2. In the Camera Calibration dialog box choose the source group on the left-hand part of the dialog.
3. Select photos to be moved and drag them to the target group on the left-hand part of the Camera Calibration dialog box.

To place each photo into a separate group you can use Split Groups command available at the right button click on a calibration group name in the left-hand part of the Camera Calibration dialog

Camera types

PhotoScan supports two major types of camera: frame camera and fisheye camera. Camera type can be set in Camera Calibration dialog box available from Tools menu.

Frame camera. If the source data within a calibration group was shot with a frame camera, for successful estimation of camera orientation parameters the information on approximate focal length (pix) is required. Obviously, to calculate focal length value in pixel it is enough to know focal length in mm along with the sensor pixel size in mm. Normally this data is extracted automatically from the EXIF metadata.

Frame camera with Fisheye lens. If extra wide lenses were used to get the source data, standard PhotoScan camera model will not allow to estimate camera parameters successfully. Fisheye camera type setting will initialize implementation of a different camera model to fit ultra-wide lens distortions.
Improving camera alignment results

In case source images lack EXIF data or the EXIF data is insufficient to calculate focal length in pixels, PhotoScan will assume that focal length equals to 50 mm (35 mm film equivalent). However, if the initial guess values differ significantly from the actual focal length, it is likely to lead to failure of the alignment process. So, if photos do not contain EXIF metadata, it is preferable to specify focal length (mm) and sensor pixel size (mm) manually. It can be done in Camera Calibration dialog box available from Tools menu. Generally, this data is indicated in camera specification or can be received from some online source. To indicate to the program that camera orientation parameters should be estimated based on the focal length and pixel size information, it is necessary to set the Type parameter on the Initial tab to Auto value.

Camera calibration parameters

Once you have tried to run the estimation procedure and got poor results, you can improve them thanks to the additional data on calibration parameters.

To specify camera calibration parameters

1. Select Camera Calibration... command from the Tools menu.
2. Select calibration group, which needs reestimation of camera orientation parameters on the left side of the Camera Calibration dialog box.
3. In the Camera Calibration dialog box, select Initial tab.
4. Modify the calibration parameters displayed in the corresponding edit boxes.
5. Set the Type to the Precalibrated value.
6. Repeat to every calibration group where applicable.
7. Click OK button to set the calibration.

Note

• Alternatively, initial calibration data can be imported from file using Load button on the Initial tab of the Camera Calibration dialog box. In addition to Agisoft calibration file format it is possible to import data from Australis, PhotoModeler, 3DM CalibCam, CalCam.

Initial calibration data will be adjusted during the Align Photos processing step. Once Align Photos processing step is finished adjusted calibration data will be displayed on the Adjusted tab of the Camera Calibration dialog box.

If very precise calibration data is available, to protect it from recalculation one should check Fix calibration box. In this case initial calibration data will not be changed during Align Photos process.

Adjusted camera calibration data can be saved to file using Save button on the Adjusted tab of the Camera Calibration dialog box.

Estimated camera distortions can be seen on the distortion plot available from context menu of a camera group in the Camera Calibration dialog. In addition, residuals graph (the second tab of the same Distortion Plot dialog) allows to evaluate how adequately the camera is described with the applied mathematical model. Note that residuals are averaged per cell of an image and then across all the images in a camera group. Scale reference under the plot indicates the scale of the distortions/residuals.

Calibration parameters list

- \( f \)
  Focal length measured in pixels.
Improving camera alignment results

**cx, cy**  
Principal point coordinates, i.e. coordinates of lens optical axis interception with sensor plane in pixels.

**b1, b2**  
Affinity and Skew (non-orthogonality) transformation coefficients.

**k1, k2, k3, k4**  
Radial distortion coefficients.

**p1, p2, p3, p4**  
Tangential distortion coefficients.

## Optimization

### Optimization of camera alignment

During photo alignment step PhotoScan automatically finds tie points and estimates intrinsic and extrinsic camera parameters. However, the accuracy of the estimates depends on many factors, like overlap between the neighbouring photos, as well as on the shape of the object surface. Thus, it is recommended to inspect alignment results in order to delete tie points with too large reprojection error if any. Please refer to Editing point cloud section for information on point cloud editing. Once the set of tie points has been edited, it is necessary to run optimization procedure to reestimate intrinsic and extrinsic camera parameters.

Optimization procedure calculates intrinsic and extrinsic camera parameters based on the tie points left after editing procedure. Providing that outliers have been removed, the estimates will be more accurate. In addition, this step involves estimation of a number of intrinsic camera parameters which are fixed at the alignment step: aspect, skew; and distortion parameters p3, p4, k4.

### To optimize camera alignment

1. Choose Optimize Cameras... command from the Tools menu.
2. In Optimize Camera Alignment dialog box check camera parameters to be optimized. Click OK button to start optimization.
3. After optimization is complete, estimated intrinsic camera parameters can be inspected on the Adjusted tab of the Camera Calibration dialog available from the Tools menu.

---

**Note**

- The model data (if any) is cleared by the optimization procedure. You will have to rebuild the model geometry after optimization.
Chapter 5. Editing

Using masks

Overview

Masks are used in PhotoScan to specify the areas on the photos which can otherwise be confusing to the program or lead to incorrect reconstruction results. Masks can be applied at the following stages of processing:

- Matching of the images
- Building depth maps
- Building mesh model using visibility consistent mesh generation method with strict volumetric masks option applied
- Building 3D model texture

Alignment of the photos

Masked areas can be excluded during feature point detection. Thus, the objects on the masked parts of the photos are not taken into account while estimating camera positions. This is important in the setups, where the object of interest is not static with respect to the scene, like when using a turn table to capture the photos.

Masking may be also useful when the object of interest occupies only a small part of the photo. In this case a small number of useful matches can be filtered out mistakenly as a noise among a much greater number of matches between background objects.

Building dense point cloud

While building dense point cloud, masked areas are not used in the depth maps computation process. Masking can be used to reduce the resulting dense cloud complexity, by eliminating the areas on the photos that are not of interest.

Masked areas are always excluded from processing during dense point cloud and texture generation stages, including Tiled Model generation process.

Let’s take for instance a set of photos of some object. Along with an object itself on each photo some background areas are present. These areas may be useful for more precise camera positioning, so it is better to use them while aligning the photos. However, impact of these areas at the building dense point cloud is exactly opposite: the resulting model will contain object of interest and its background.
Background geometry will "consume" some part of mesh polygons that could be otherwise used for modeling the main object.

Setting the masks for such background areas allows to avoid this problem and increases the precision and quality of geometry reconstruction.

**Building texture atlas**

During texture atlas generation (for single mesh model and tiled model), masked areas on the photos are not used for texturing. Masking areas on the photos that are occluded by outliers or obstacles helps to prevent the "ghosting" effect on the resulting texture atlas.

**Loading masks**

Masks can be loaded from external sources, as well as generated automatically from background images if such data is available. PhotoScan supports loading masks from the following sources:

- From alpha channel of the source photos.
- From separate images.
- Generated from background photos based on background differencing technique.
- Based on reconstructed 3D model.

**To import masks**

1. Select Import Masks... command from the File menu.
2. In the Import Mask dialog select suitable parameters. Click OK button when done.
3. When generating masks from separate or background images, the folder selection dialog will appear. Browse to the folder containing corresponding images and select it.
4. The progress dialog box will appear displaying the current processing status. To cancel processing click Cancel button.

The following parameters can be specified during mask import:

**Method**

Specifies the source of the mask data.

- From Alpha - load masks from alpha channel of the source photos.
- From File - load masks from separate images.
- From Background - generate masks from background photos.
- From Model - generate masks based on reconstructed model.

**Operation**

Specifies the action to be done in case a second mask is imported for the photo.

- Replacement - new mask will be loaded and stored instead of the original one.
- Union - two masks will be united and stored.
Editing

**Intersection** - the intersection of the two masks will be stored as a new mask for the photo.

**Difference** - only the difference between two masks will be stored as a new mask for the photo.

**Filename template (not used in From alpha mode)***

Specifies the file name template used to generate mask file names. This template can contain special tokens, that will be substituted by corresponding data for each photo being processed. The following tokens are supported:

- `{filename}` - file name of the source photo without extension.
- `{fileext}` - extension of the source photo.
- `{camera}` - camera label.
- `{filenum}` - sequential number of the mask being imported.

For example, `{filename}_mask.png` template can be used if masks are available in PNG format and have a _mask_ suffix.

**Tolerance (From Background method only)**

Specifies the tolerance threshold used for background differencing. Tolerance value should be set according to the color separation between foreground and background pixels. For larger separation higher tolerance values can be used.

**Apply to**

Specifies whether masks should be imported for the currently opened photo, active chunk or entire Workspace.

- **All cameras** - load masks for active chunk.
- **Entire workspace** - load masks for all chunks in the project.
- **Selected cameras** - load mask for the currently checked cameras (if any).
- **Current photo** - load mask for the currently opened photo (if any).

**Editing masks**

Modification of the current mask is performed by adding or subtracting selections. A selection is created with one of the supported selection tools and is not incorporated in the current mask until it is merged with a mask using Add Selection or Subtract Selection operations.

**To edit the mask**

1. Open the photo to be masked by double clicking on its name on the Workspace / Photo pane. The photo will be opened in the main window. The existing mask will be displayed as a shaded region on the photo.
2. Select the desired selection tool and generate a selection.
3. Click on Add Selection toolbar button to add current selection to the mask, or Subtract Selection to subtract the selection from the mask. Invert Selection button allows to invert current selection prior to adding or subtracting it from the mask.
The following tools can be used for creating selections:

- **Rectangle selection tool**
  Rectangle selection tool is used to select large areas or to clean up the mask after other selection tools were applied.

- **Intelligent scissors tool**
  Intelligent scissors is used to generate a selection by specifying its boundary. The boundary is formed by selecting a sequence of vertices with a mouse, which are automatically connected with segments. The segments can be formed either by straight lines, or by curved contours snapped to the object boundaries. To enable snapping, hold Ctrl key while selecting the next vertex. To complete the selection, the boundary should be closed by clicking on the first boundary vertex.

- **Intelligent paint tool**
  Intelligent paint tool is used to "paint" a selection by the mouse, continuously adding small image regions, bounded by object boundaries.

- **Magic wand tool**
  Magic Wand tool is used to select uniform areas of the image. To make a selection with a Magic Wand tool, click inside the region to be selected.

  The range of pixel colors selected by Magic Wand is controlled by the tolerance value. At lower tolerance values the tool selects fewer colors similar to the pixel you click with the Magic Wand tool. Higher value broadens the range of colors selected.

**Note**

- To add new area to the current selection hold the Ctrl key during selection of additional area.
- To reset mask selection on the current photo press Esc key.

A mask can be inverted using Invert Mask command from the Edit menu. The command is active in Photo View only. Alternatively, you can invert masks either for selected cameras or for all cameras in a chunk using Invert Masks... command from a photo context menu on the Photos pane.

The masks are generated individually for each image. If some object should be masked out, it should be masked out on all photos, where that object appears.

**Saving masks**

Created masks can be also saved for external editing or storage.

**To export masks**

1. Select Export Masks... command from the File menu.
2. In the Export Mask dialog select suitable parameters. Click OK button when done.
3. Browse to the folder where the masks should be saved and select it.
4. The progress dialog box will appear displaying the current processing status. To cancel processing click Cancel button.

The following parameters can be specified during mask export:
Export masks for
Specifies whether masks should be exported for the currently opened photo, active chunk or entire Workspace.

Current photo - save mask for the currently opened photo (if any).
Active chunk - save masks for active chunk.
Entire workspace - save masks for all chunks in the project.

File type
Specifies the type of generated files.

Single channel mask image - generates single channel black and white mask images.
Image with alpha channel - generates color images from source photos combined with mask data in alpha channel.

Mask file names
Specifies the file name template used to generate mask file names. This template can contain special tokens, that will be substituted by corresponding data for each photo being processed. The following tokens are supported:

{filename} - file name of the source photo without extension.
{fileext} - extension of the source photo.
{camera} - camera label.
{filenum} - sequential number of the mask being exported.

For example, {filename}_mask.png template can be used to export masks in PNG format with _mask suffix.

Note
- When importing/exporting mask for the current photo only, PhotoScan will prompt for the actual image instead of image folder. Mask file names parameter will not be used in this case.

Editing point cloud

The following point cloud editing tools are available in PhotoScan:

- Automatic filtering based on specified criterion (sparse cloud only)
- Automatic filtering based on applied masks (dense cloud only)
- Automatic filtering based on points colours (dense cloud only)
- Reducing number of points in cloud by setting tie point per photo limit (sparse cloud only)
- Manual points removal

Note
- Point cloud editing operation can be undone/redone using Undo/Redo command from the Edit menu.
Filtering points based on specified criterion

In some cases it may be useful to find out where the points with high reprojection error are located within the sparse cloud, or remove points representing high amount of noise. Point cloud filtering helps to select such points, which usually are supposed to be removed.

PhotoScan supports the following criteria for point cloud filtering:

Reprojection error
High reprojection error usually indicates poor localization accuracy of the corresponding point projections at the point matching step. It is also typical for false matches. Removing such points can improve accuracy of the subsequent optimization step.

Reconstruction uncertainty
High reconstruction uncertainty is typical for points, reconstructed from nearby photos with small baseline. Such points can noticeably deviate from the object surface, introducing noise in the point cloud. While removal of such points should not affect the accuracy of optimization, it may be useful to remove them before building geometry in Point Cloud mode or for better visual appearance of the point cloud.

Image count
PhotoScan reconstruct all the points that are visible at least on two photos. However, points that are visible only on two photos are likely to be located with poor accuracy. Image count filtering enables to remove such unreliable points from the cloud.

Projection Accuracy
This criterion allows to filter out points which projections were relatively poorer localised due to their bigger size.

To remove points based on specified criterion

1. Switch to Point Cloud view mode using Point Cloud toolbar button.
2. Select Gradual Selection... command from the Model menu.
3. In the Gradual Selection dialog box specify the criterion to be used for filtering. Adjust the threshold level using the slider. You can observe how the selection changes while dragging the slider. Click OK button to finalize the selection.
4. To remove selected points use Delete Selection command from the Edit menu or click Delete Selection toolbar button (or simply press Del button on the keyboard).

Filtering points based on applied masks

To remove points based on applied masks

1. Switch to Dense Cloud view mode using Dense Cloud toolbar button.
2. Choose Select Masked Points... command from the Dense Cloud submenu of the Tools menu.
3. In the Select Masked Points dialog box indicate the photos whose masks to be taken into account. Adjust the edge softness level using the slider. Click OK button to run the selection procedure.
4. To remove selected points use Delete Selection command from the Edit menu or click \[ \text{Delete Selection toolbar button} \] (or simply press Del button on the keyboard).

**Filtering points based on points colors**

**To remove points based on points colors**

1. Switch to Dense Cloud view mode using \[ \text{Dense Cloud toolbar button} \].

2. Choose Select Points by Color... command from the Dense Cloud submenu of the Tools menu.

3. In the Select Points by Color dialog box the color to be used as the criterion. Adjust the tolerance level using the slider. Click OK button to run the selection procedure.

4. To remove selected points use Delete Selection command from the Edit menu or click \[ \text{Delete Selection toolbar button} \] (or simply press Del button on the keyboard).

**Tie point per photo limit**

Tie point limit parameter could be adjusted before Align photos procedure. The number indicates the upper limit for matching points for every image. Using zero value doesn't apply any tie-point filtering.

The number of tie points can also be reduced after the alignment process with Tie Points - Thin Point Cloud command available from Tools menu. As a results sparse point cloud will be thinned, yet the alignment will be kept unchanged.

**Manual points removal**

Incorrect points can be also removed manually.

**To remove points from a point cloud manually**

1. Switch to Sparse Cloud view mode using \[ \text{Point Cloud toolbar button} \] or to Dense Cloud view mode using \[ \text{Dense Cloud toolbar button} \].

2. Select points to be removed using \[ \text{Rectangle Selection}, \text{Circle Selection or Free-Form Selection tools} \]. To add new points to the current selection hold the Ctrl key during selection of additional points. To remove some points from the current selection hold the Shift key during selection of points to be removed.

3. To delete selected points click the \[ \text{Delete Selection toolbar button} \] or select Delete Selection command from the Edit menu. To crop selection to the selected points click the \[ \text{Crop Selection toolbar button} \] or select Crop Selection command from the Edit menu.

**Editing model geometry**

The following mesh editing tools are available in PhotoScan:

- Decimation tool
• Close Holes tool
• Smooth tool
• Automatic filtering based on specified criterion
• Manual polygon removal
• Fixing mesh topology
• Refinement tool

More complex editing can be done in the external 3D editing tools. PhotoScan allows to export mesh and then import it back for this purpose.

Note
• For polygon removal operations such as manual removal and connected component filtering it is possible to undo the last mesh editing operation. There are Undo/Redo commands in the Edit menu.
• Please note that undo/redo commands are not supported for mesh decimation and this operation cannot be undone.

Decimation tool

Decimation is a tool used to decrease the geometric resolution of the model by replacing high resolution mesh with a lower resolution one, which is still capable of representing the object geometry with high accuracy. PhotoScan tends to produce 3D models with excessive geometry resolution, so mesh decimation is usually a desirable step after geometry computation.

Highly detailed models may contain hundreds of thousands polygons. While it is acceptable to work with such a complex models in 3D editor tools, in most conventional tools like Adobe Reader or Google Earth high complexity of 3D models may noticeably decrease application performance. High complexity also results in longer time required to build texture and to export model in pdf file format.

In some cases it is desirable to keep as much geometry details as possible like it is needed for scientific and archive purposes. However, if there are no special requirements it is recommended to decimate the model down to 100 000 - 200 000 polygons for exporting in PDF, and to 100 000 or even less for displaying in Google Earth and alike tools.

To decimate 3D model

1. Select Decimate Mesh... command from the Tools menu.
2. In the Decimate Mesh dialog box specify the target number of polygons, which should remain in the final model. Click on the OK button to start decimation.
3. The progress dialog box will appear displaying the current processing status. To cancel processing click on the Cancel button.

Note
• Texture atlas is discarded during decimation process. You will have to rebuild texture atlas after decimation is complete.
Close Holes tool

Close Holes tool provides possibility to repair your model if the reconstruction procedure resulted in a mesh with several holes, due to insufficient image overlap for example.

Close holes tool enables to close void areas on the model substituting photogrammetric reconstruction with extrapolation data. It is possible to control an acceptable level of accuracy indicating the maximum size of a hole to be covered with extrapolated data.

To close holes in a 3D model

1. Select Close Holes... command from the Tools menu.
2. In the Close Holes dialog box indicate the maximum size of a hole to be covered with the slider. Click on the OK button to start the procedure.
3. The progress dialog box will appear displaying the current processing status. To cancel processing click on the Cancel button.

Note

- The slider allows to set the size of a hole in relation to the size of the whole model surface.

Polygon filtering on specified criterion

In some cases reconstructed geometry may contain the cloud of small isolated mesh fragments surrounding the "main" model or big unwanted polygons. Mesh filtering based on different criteria helps to select polygons, which usually are supposed to be removed.

PhotoScan supports the following criteria for face filtering:

Connected component size

This filtering criteria allows to select isolated fragments with a certain number of polygons. The number of polygons in all isolated components to be selected is set with a slider and is indicated in relation to the number of polygons in the whole model. The components are ranged in size, so that the selection proceeds from the smallest component to the largest one.

Polygon size

This filtering criteria allows to select polygons up to a certain size. The size of the polygons to be selected is set with a slider and is indicated in relation to the size of the whole model. This function can be useful, for example, in case the geometry was reconstructed in Smooth type and there is a need to remove extra polygons automatically added by PhotoScan to fill the gaps; these polygons are often of a larger size that the rest.

To remove small isolated mesh fragments

1. Select Gradual Selection... command from the Edit menu.
2. In the Gradual Selection dialog box select Connected component size criterion.
3. Select the size of isolated components to be removed using the slider. Size of the largest component is taken for 100%. You can observe how the selection changes while dragging the slider. Click OK button to finalize the selection.
4. To remove the selected components use Delete Selection command from the Edit menu or click × 
Delete Selection toolbar button (or simply press Del button on the keyboard).

**To remove large polygons**

1. Select Gradual Selection... command from the Edit menu.

2. In the Gradual Selection dialog box select Polygon size criterion.

3. Select the size of polygons to be removed using the slider. Size of the largest polygon is taken for 100%. You can observe how the selection changes while dragging the slider. Click OK button to finalize the selection.

4. To remove the selected components use Delete Selection command from the Edit menu or click × 
Delete Selection toolbar button (or simply press Del button on the keyboard).

Note that PhotoScan always selects the fragments starting from the smallest ones. If the model contains only one component the selection will be empty.

**Manual face removal**

Unnecessary and excessive sections of model geometry can be also removed manually.

**To remove part of the mesh polygons manually**

1. Select rectangle, circle or free-form selection tool using Rectangle Selection, Circle Selection or Free-Form Selection toolbar buttons.

2. Make the selection using the mouse. To add new polygons to the current selection hold the Ctrl key 
during selection of additional polygons. To remove some polygons from the current selection hold the Shift key during selection of polygons to be excluded.

3. To delete selected polygons click the × Delete Selection toolbar button or use Delete Selection command from the Edit menu. To crop selection to the selected polygons click the Crop Selection toolbar button or use Crop Selection command from the Edit menu.

**To grow or shrink current selection**

1. To grow current selection press PageUp key in the selection mode. To grow selection by even a larger amount, press PageUp while holding Shift key pressed.

2. To shrink current selection press PageDown key in the selection mode. To shrink selection by even a larger amount, press PageDown while holding Shift key pressed.

**Fixing mesh topology**

PhotoScan is capable of basic mesh topology fixing.

**To fix mesh topology**

1. Select View Mesh Statistics... command from the Tools menu.
2. In the Mesh Statistics dialog box you can inspect mesh parameters. If there are any topological problems, Fix Topology button will be active and can be clicked to solve the problems.

3. The progress dialog box will appear displaying the current processing status. To cancel processing click on the Cancel button.

**Editing mesh in the external program**

**To export mesh for editing in the external program**

1. Select Export Model... command from the File menu.

2. In the Save As dialog box, specify the desired mesh format in the Save as type combo box. Select the file name to be used for the model and click Save button.

3. In the opened dialog box specify additional parameters specific to the selected file format. Click OK button when done.

**To import edited mesh**

1. Select Import Mesh... command from the File menu.

2. In the Open dialog box, browse to the file with the edited model and click Open.

**Note**

- PhotoScan supports loading models in Wavefront OBJ, 3DS, STL, COLLADA, Stanford PLY, Autodesk FBX, Autodesk DXF, OpenCTM and U3D file formats only. Please make sure to select one of these file formats when exporting model from the external 3D editor.

-
Chapter 6. Automation

Using chunks

When working with typical data sets, automation of general processing workflow allows to perform routine operations efficiently. PhotoScan allows to assign several processing steps to be run one by one without user intervention thanks to Batch Processing feature. Manual user intervention can be minimized even further due to ‘multiple chunk project’ concept, each chunk to include one typical data set. For a project with several chunks of the same nature, common operations available in Batch Processing dialog are applied to each selected chunk individually, thus allowing to set several data sets for automatic processing following predefined workflow pattern.

In addition, multiple chunk project could be useful when it turns out to be hard or even impossible to generate a 3D model of the whole scene in one go. This could happen, for instance, if the total amount of photographs is too large to be processed at a time. To overcome this difficulty PhotoScan offers a possibility to split the set of photos into several separate chunks within the same project. Alignment of photos, building dense point cloud, building mesh, and forming texture atlas operations can be performed for each chunk separately and then resulting 3D models can be combined together.

Working with chunks is not more difficult than using PhotoScan following the general workflow. In fact, in PhotoScan always exists at least one active chunk and all the 3D model processing workflow operations are applied to this chunk.

To work with several chunks you need to know how to create chunks and how to combine resulting 3D models from separate chunks into one model.

Creating a chunk

To create new chunk click on the Add Chunk toolbar button on the Workspace pane or select Add Chunk command from the Workspace context menu (available by right-clicking on the root element on the Workspace pane).

After the chunk is created you may load photos in it, align them, generate dense point cloud, generate mesh surface model, build texture atlas, export the models at any stage and so on. The models in the chunks are not linked with each other.

The list of all the chunks created in the current project is displayed in the Workspace pane along with flags reflecting their status.

The following flags can appear next to the chunk name:

**R (Referenced)**
Will appear when two or more chunks are aligned with each other.

To move photos from one chunk to another simply select them in the list of photos on the Workspace pane, and then drag and drop to the target chunk.

Working with chunks

All operations within the chunk are carried out following the common workflow: loading photographs, aligning them, generating dense point cloud, building mesh, building texture atlas, exporting 3D model and so on.
Note that all these operations are applied to the active chunk. When a new chunk is created it is activated automatically. Save project operation saves the content of all chunks. To save selected chunks as a separate project use Save Chunks command from the chunk context menu.

**To set another chunk as active**

1. Right-click on the chunk title on the Workspace pane.
2. Select Set Active command from the context menu.

**To remove chunk**

1. Right-click on the chunk title on the Workspace pane.
2. Select Remove Chunks command from the context menu.

To rearrange the order of chunks in the Workspace pane simply drag and drop the chunks in the pane.

**Aligning chunks**

After the "partial" 3D models are built in several chunks they can be merged together. Before merging chunks they need to be aligned.

**To align separate chunks**

1. Select Align Chunks command from the Workflow menu.
2. In the Align Chunks dialog box select chunks to be aligned, indicate reference chunk with a double-click. Set desired alignment options. Click OK button when done.
3. The progress dialog box will appear displaying the current processing status. To cancel processing click the Cancel button.

**Aligning chunks parameters**

The following parameters control the chunks alignment procedure and can be modified in the Align Chunks dialog box:

**Method**

Defines the chunks alignment method. **Point based** method aligns chunks by matching photos across all the chunks. **Camera based** method is used to align chunks based on estimated camera locations. Corresponding cameras should have the same label.

**Accuracy (Point based alignment only)**

Higher accuracy setting helps to obtain more accurate chunk alignment results. Lower accuracy setting can be used to get the rough chunk alignment in the shorter time.

**Point limit (Point based alignment only)**

The number indicates upper limit of feature points on every image to be taken into account during Point based chunks alignment.

**Fix scale**

Option is to be enabled in case the scales of the models in different chunks were set precisely and should be left unchanged during chunks alignment process.
Preselect image pairs (Point based alignment only)
The alignment process of many chunks may take a long time. A significant portion of this time is spent for matching of detected features across the photos. Image pair preselection option can speed up this process by selection of a subset of image pairs to be matched.

Constrain features by mask (Point based alignment only)
When this option is enabled, features detected in the masked image regions are discarded. For additional information on the usage of masks refer to the Using masks section.

Note
- Chunk alignment can be performed only for chunks containing aligned photos.

Merging chunks

After alignment is complete the separate chunks can be merged into a single chunk.

To merge chunks

1. Select Merge Chunks command from the Workflow menu.
2. In the Merge Chunks dialog box select chunks to be merged and the desired merging options. Click OK button when done.
3. PhotoScan will merge the separate chunks into one. The merged chunk will be displayed in the project content list on Workspace pane.

The following parameters control the chunks merging procedure and can be modified in the Merge Chunks dialog box:

Merge dense clouds
  Defines if dense clouds from the selected chunks are combined.

Merge models
  Defines if models from the selected chunks are combined.

Chunks merging result (i.e. photos, point clouds and geometry) will be stored in the new chunk and it may be treated as an ordinary chunk (e.g. the model can be textured and/or exported).

Batch processing

PhotoScan allows to perform general workflow operations with multiple chunks automatically. It is useful when dealing with a large number of chunks to be processed.

Batch processing can be applied to all chunks in the Workspace, to unprocessed chunks only, or to the chunks selected by the user. Each operation chosen in the Batch processing dialog will be applied to every selected chunk before processing will move on to the next step.

<table>
<thead>
<tr>
<th>Align Photos</th>
<th>Align/Merge Chunks</th>
<th>Save/Load Project</th>
</tr>
</thead>
<tbody>
<tr>
<td>Optimize Alignment</td>
<td>Decimate Mesh</td>
<td>Export/Import Cameras</td>
</tr>
<tr>
<td>Build Dense Cloud</td>
<td>Smooth model</td>
<td>Export Points</td>
</tr>
<tr>
<td>Build Mesh</td>
<td>Close Holes</td>
<td>Export Model</td>
</tr>
</tbody>
</table>
To start batch processing

1. Select Batch Process... command from the Workflow menu.

2. Click Add to add the desired processing stages.

3. In the Add Job dialog select the kind of operation to be performed, the list of chunks it should be applied to, and desired processing parameters. Click OK button when done.

4. Repeat the previous steps to add other processing steps as required.

5. Arrange jobs by clicking Up and Down arrows at the right of the Batch Process... dialog box.

6. Click OK button to start processing.

7. The progress dialog box will appear displaying the list and status of batch jobs and current operation progress. To cancel processing click the Cancel button.

When the batch process includes import/export features that are applied to multiple chunks it is reasonable to use the following templates in the Path field of the import/export jobs:

- `{filename}` - filename (without extension),
- `{fileext}` - file extension,
- `{camera}` - camera label,
- `{frame}` - frame index,
- `{chunklabel}` - chunk label,
- `{imagefolder}` - folder containing images of an active chunk,
- `{projectfolder}` - path to the folder containing current project,
- `{projectname}` - current project filename,
- `{projectpath}` - absolute path to the current project.

The list of tasks for batch processing can be exported to XML structured file using Save button in the Batch processing dialog and imported in a different project using Open button.
Appendix A. Graphical user interface

Application window

General view

General view of application window.

Model view

Model view tab is used for displaying 3D data as well as for mesh and point cloud editing. The view of the model depends on the current processing stage and is also controlled by mode selection buttons on the PhotoScan toolbar.
Graphical user interface

Model can be shown as a dense cloud or as a mesh in shaded, solid, wireframe or textured mode. Along with the model the results of photo alignment can be displayed. These include sparse point cloud and camera positions visualised data.

PhotoScan supports the following tools for navigation in the 3D view:

<table>
<thead>
<tr>
<th>Tool</th>
<th>Keyboard modifier</th>
</tr>
</thead>
<tbody>
<tr>
<td>Rotation Tool</td>
<td>Default</td>
</tr>
<tr>
<td>Pan Tool</td>
<td>Ctrl key pressed</td>
</tr>
<tr>
<td>Zooming Tool</td>
<td>Shift key pressed</td>
</tr>
</tbody>
</table>

All navigation tools are accessible in the navigation mode only. To enter the navigation mode click the Navigation toolbar button.

Note

- Zooming into the model can be also controlled by the mouse wheel.

Photo view

Photo view tab is used for displaying individual photos as well as masks on them.

In the Photo view tab it is allowed to draw masks on the photos.

Photo view is visible only if any photo is opened. To open a photo double-click on its name on the Workspace or Photos pane.

Switching to Photo view mode changes the contents of the Toolbar, presenting related instruments and hiding irrelevant buttons.

Workspace pane

On the Workspace pane all elements comprising the current project are displayed. These elements can include:

- List of chunks in the project
- List of cameras and camera groups in each chunk
- Tie points in each chunk
- Depth maps in each chunk
- Dense point clouds in each chunk
- 3D models in each chunk

Buttons located on the Workspace pane toolbar allow to:

- Add chunk
- Add photos
- Enable or disable certain cameras or chunks for processing at further stages.
• Remove items

Each element in the list is linked with the context menu providing quick access to some common operations.

**Photos pane**

Photos pane displays the list of photos / masks / depth maps in the active chunk in the form of thumbnails.

Buttons located on the Photos pane toolbar allow to:

• Enable / disable certain cameras
• Remove cameras
• Rotate selected photos clockwise / counterclockwise (for display purposes only)
• Reset current photo filtering option
• Switch between images / masks / depth maps thumbnails
• Increase / decrease icons' size or display detailed information on photos including EXIF data

**Console pane**

Console pane is used for:

• Displaying auxiliary information
• Displaying error messages

Buttons located on the pane toolbar allow:

• Save log (in HTML, XHTML or Plain Text format)
• Clear log

**Animation pane**

Animation pane is designed for:

• Loading the camera track
• Start / stop the camera movement according to the track
• Render the frame sequence to the form of the video file

Buttons located on the pane toolbar allow:

• Start / stop the animation according to the camera track
• Render the animation and save to the external video file
• Create track, load track and adjust track properties through Settings dialog

**Note**

• To open any pane select a corresponding command from the View menu.
# Menu commands

**File Menu**

- New: Creates an empty PhotoScan project.
- Open...: Opens PhotoScan project file.
- Append...: Appends existing PhotoScan project file to the current one.
- Save: Saves PhotoScan project file.
- Save As...: Saves PhotoScan project file with a new name.
- Export Points...: Saves sparse / dense point cloud.
- Export Model...: Saves 3D model.
- Export Cameras...: Exports camera positions, orientation data and tie points measurements.
- Export Masks...: Exports masks.
- Export Texture...: Exports model texture.
- Export Panorama...: Exports spherical panorama for camera stations.
- Undistort Photos...: Removes nonlinear distortions by warping source photos and saving the result as files.
- Render Photos...: Lenticular images generation
- Import Cameras...: Imports camera positions and orientation data.
- Import Masks...: Imports masks or creates mask from model or background.
- Import Points...: Imports points in a form of the dense point cloud.
- Import Model...: Imports polygonal mesh model.
- Import Texture...: Imports texture and applies it to the current model.
- Import Video...: Imports video in a form of frame sequence and saves the extracted frames as images.
- Upload Data...: Uploads generated products (points, textured mesh models) to one of the supported web-sites.
- Exit: Closes the application window.

**Edit Menu**

- Undo: Undoes the last editing operation.
- Redo: Redo the previously undone editing operation.
- Add selection: Adds current selection to the mask.
Graphical user interface

Edit Menu

- Subtract selection: Subtracts current selection from the mask.
- Invert Selection: Inverts current selection for the photo.
- Invert Selection: Inverts current selection of faces / points / cameras.
- Grow Selection: Grows current selection of mesh faces.
- Shrink Selection: Shrinks current selection of mesh faces.
- Delete Selection: Removes selected faces from the mesh or selected points from the point cloud.
- Crop Selection: Crops selected faces / points.
- Invert Mask: Inverts mask for the current photo.
- Reset mask: Resets mask for the current photo.
- Rotate right: Rotates the photo clockwise.
- Rotate left: Rotates the photo counterclockwise.

View Menu

- Zoom In: Increases magnification in the active view mode.
- Zoom Out: Decreases magnification in the active view mode.
- Reset View: Resets the viewport to display the complete model or photo.
- Capture view: Saves screenshot of current view of the project (Model/Ortho/Photo).
- Workspace: Shows or hides Workspace pane.
- Animation: Shows or hides Animation pane.
- Photos: Shows or hides Photos pane.
- Console: Shows or hides Console pane.
- Jobs: Shows or hides Jobs pane.
- Toolbar: Shows or hides Toolbar.
- Full Screen: Switches to / from Full Screen mode.

Workflow Menu

- Add Photos...: Loads additional photos to be processed by PhotoScan.
- Add Folder...: Loads additional photos from folders to be processed by PhotoScan.
- Align Photos...: Estimates camera positions and sparse point cloud.
Graphical user interface

**Workflow Menu**

Build Dense Cloud... Generates dense point cloud.
Build Mesh... Generates polygonal mesh model.
Build Texture... Generates texture for the mesh model.
Align Chunks... Aligns multiple chunks.
Merge Chunks... Merges multiple chunks into the single chunk.
Batch Process... Opens Batch Process dialog box.

**Model Menu**

- Navigation Switches to navigation mode.
- Rectangle Selection Rectangle selection tool for the elements of the Model view.
- Circle Selection Circle selection tool for the elements of the Model view.
- Free-form Selection Free-form selection tool for the elements of the Model view.
- Gradual selection... Selects faces / points based on the specified criterion.
- Move Object Switches to object movement tool.
- Rotate Object Switches to object rotation tool.
- Scale Object Switches to object scaling tool.
- Reset Transform Resets the transformations applied to the object.
- Move region Switches to volume movement tool.
- Rotate Region Switches to volume rotation tool.
- Resize region Switches to volume resize tool.
- Reset Region Resets the transformations applied to the volume to default.
- Show Cameras Shows or hides camera positions estimated during image alignment.
- Show Thumbnails Shows or hides image thumbnails in the camera placeholders.
- Show Region Shows or hides region selector.
- Show Trackball Shows or hides the trackball.
- Show Info Shows or hides the auxiliary on-screen information.
- Show Grid Shows or hides the grid.
Model Menu
  Show All
  Hide All
  Point Cloud
  Dense Cloud
  Shaded
  Solid
  Wireframe
  Textured
  Perspective/Orthographic
  Stereo Mode
  Predefined views

Photo Menu
  Navigation
  Rectangle Selection
  Intelligent Scissors
  Intelligent Paint
  Magic Wand
  Open Next Photo
  Open Previous Photo
  Turn Shading On/Off
  View Points
  Show All
  Hide All

Tools Menu
  Build Point Cloud...
  Thin Point Cloud...
## Graphical user interface

### Tools Menu

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>View Matches...</td>
<td>Show View Matches dialog for visual representation of the common tie points between the image pairs.</td>
</tr>
<tr>
<td>Invert Point Normals...</td>
<td>Inverts normals for the selected points of the dense cloud.</td>
</tr>
<tr>
<td>Select Points by Masks...</td>
<td>Selects dense cloud points according to the masked images.</td>
</tr>
<tr>
<td>Select Points by Color...</td>
<td>Selects dense cloud points according to the color and tolerance.</td>
</tr>
<tr>
<td>Filter By Selection</td>
<td>Filters the points in the dense cloud according to the selected points.</td>
</tr>
<tr>
<td>Reset Filter</td>
<td>Resets all applied dense cloud filters.</td>
</tr>
<tr>
<td>Compact Dense Cloud...</td>
<td>Permanently removes all deleted points from the dense cloud.</td>
</tr>
<tr>
<td>Update Dense Cloud...</td>
<td>Updates statistics of the dense cloud, including point numbers and assigned classes.</td>
</tr>
<tr>
<td>Restore Dense Cloud...</td>
<td>Restores all deleted points of the dense cloud that were once marked as removed.</td>
</tr>
<tr>
<td>Refine Mesh...</td>
<td>Starts photoconsistent mesh refinement operation.</td>
</tr>
<tr>
<td>Decimate Mesh...</td>
<td>Decimates mesh to the target face count.</td>
</tr>
<tr>
<td>Smooth Mesh...</td>
<td>Smooths mesh.</td>
</tr>
<tr>
<td>Close Holes...</td>
<td>Closes holes on the model surface.</td>
</tr>
<tr>
<td>View Mesh Statistics...</td>
<td>Collects and displays mesh statistics.</td>
</tr>
<tr>
<td>View Mesh UVs...</td>
<td>Displays mesh UV mapping.</td>
</tr>
<tr>
<td>Filter By Selection</td>
<td>Filters the faces of the polygonal model according to the selected points.</td>
</tr>
<tr>
<td>Reset Filter</td>
<td>Resets all applied mesh filters.</td>
</tr>
<tr>
<td>Calibrate Lens...</td>
<td>Shows lens calibration dialog.</td>
</tr>
<tr>
<td>Show Chessboard...</td>
<td>Displays the calibration board on screen.</td>
</tr>
<tr>
<td>Camera Calibration...</td>
<td>Shows camera calibration dialog box.</td>
</tr>
<tr>
<td>Optimize Cameras...</td>
<td>Starts the optimization of exterior and interior parameters of the aligned cameras.</td>
</tr>
<tr>
<td>Calibrate Colors...</td>
<td>Shows the color correction dialog for the brightness and white balance compensation of the images.</td>
</tr>
<tr>
<td>Set Primary Channel...</td>
<td>Shows the primary channel selection dialog.</td>
</tr>
<tr>
<td>Set Brightness...</td>
<td>Adjusts image brightness for more convenient display.</td>
</tr>
</tbody>
</table>
Graphical user interface

Tools Menu

Preferences...

Help Menu

Contents

Check for Updates...

Activate Product...

About PhotoScan...

Shows preferences dialog box.

Displays help contents.

Checks if PhotoScan update is available for download.

Activates / deactivates the product using the activation key.

Displays program information, version number and copyright.

Toolbar buttons

General commands

New

Open

Save

Creates a new PhotoScan project file.

Opens a PhotoScan project file.

Saves a PhotoScan project file.

3D view commands

Undo

Redo

Navigation

Rectangle Selection

Circle Selection

Free-Form Selection

Move region

Resize region

Rotate Region

Move Object

Rotate Object

Scale Object

Delete Selection

Crop Selection

Undo the last editing operation.

Redo the previously undone editing operation.

Navigation tool.

Rectangle selection tool.

Circle selection tool.

Free-form selection tool.

Volume translation tool.

Volume resize tool.

Volume rotation tool.

Model translation tool.

Model rotation tool.

Model resize tool.

Removes selected faces / points.

Crops selected faces / points.
Graphical user interface

3D view settings
- **Zoom In**: Increases magnification.
- **Zoom Out**: Decreases magnification.
- **Reset View**: Resets model view.
- **Point Cloud**: Displays sparse point cloud reconstructed during image alignment.
- **Dense Cloud**: Displays dense point cloud model.
- **Filter By Selection**: Filters the points in the dense cloud according to the selected points.
- **Reset Filter**: Resets all applied dense cloud filters.
- **Shaded**: Displays 3D model in the shaded mode.
- **Solid**: Displays 3D model in the solid mode.
- **Wireframe**: Displays 3D model in the wireframe mode.
- **Textured**: Displays 3D model in the textured mode.
- **Show Cameras**: Shows / hides camera positions, reconstructed during image alignment.
- **Show Thumbnails**: Shows or hides image thumbnails in the camera placeholders.
- **Show Aligned Chunks**: Shows / hides aligned chunks.

Photo view commands
- **Undo**: Undo the last mask editing operation.
- **Redo**: Redo the previously undone mask editing operation.
- **Navigation**: Switches to the navigation mode.
- **Rectangle Selection**: Rectangle selection tool.
- **Intelligent Scissors**: Intelligent scissors tool.
- **Intelligent Paint**: Intelligent paint tool.
- **Magic Wand**: Magic wand tool.
- **Add Selection**: Adds current selection to the mask.
- **Subtract Selection**: Subtracts current selection from the mask.
- **Invert Selection**: Inverts current selection.
- **Set Brightness**: Adjusts image brightness for more convenient display.
### Graphical user interface

#### Photo view commands

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>![Rotate Right]</td>
<td>Rotates the photo clockwise.</td>
</tr>
<tr>
<td>![Rotate Left]</td>
<td>Rotates the photo counterclockwise.</td>
</tr>
<tr>
<td>Zoom In</td>
<td>Increases magnification.</td>
</tr>
<tr>
<td>Zoom Out</td>
<td>Decreases magnification.</td>
</tr>
<tr>
<td>![Reset View]</td>
<td>Resets the viewport to display the whole photo.</td>
</tr>
<tr>
<td>![Show Masks]</td>
<td>Enables or disables the mask shading overlay.</td>
</tr>
<tr>
<td>![View Points]</td>
<td>Shows / hides feature points used for alignment of the photo.</td>
</tr>
</tbody>
</table>

#### Hot keys

Below is a list of default hot keys that can be customized in the Preferences dialog.

### General

<table>
<thead>
<tr>
<th>Command</th>
<th>Hot Key</th>
</tr>
</thead>
<tbody>
<tr>
<td>Create new project</td>
<td>Ctrl + N</td>
</tr>
<tr>
<td>Save project</td>
<td>Ctrl + S</td>
</tr>
<tr>
<td>Load project</td>
<td>Ctrl + O</td>
</tr>
<tr>
<td>Run Script</td>
<td>Ctrl + R</td>
</tr>
<tr>
<td>Full Screen</td>
<td>F11</td>
</tr>
</tbody>
</table>

### Model View

<table>
<thead>
<tr>
<th>Command</th>
<th>Hot Key</th>
</tr>
</thead>
<tbody>
<tr>
<td>Undo (only for Delete, Masking and Close Holes operations)</td>
<td>Ctrl + Z</td>
</tr>
<tr>
<td>Redo (only for Delete, Masking and Close Holes operations)</td>
<td>Ctrl + Y</td>
</tr>
<tr>
<td>Switch between navigation and any other previously selected mode</td>
<td>Space</td>
</tr>
<tr>
<td>Reset view</td>
<td>0</td>
</tr>
<tr>
<td>Switch to stereoview mode</td>
<td>9</td>
</tr>
<tr>
<td>Switch between orthographic and perspective view modes</td>
<td>5</td>
</tr>
<tr>
<td>Change the angle for perspective view</td>
<td>Ctrl + mouse wheel</td>
</tr>
</tbody>
</table>

### Predefined Views

<table>
<thead>
<tr>
<th>View</th>
<th>Key</th>
</tr>
</thead>
<tbody>
<tr>
<td>Top</td>
<td>7</td>
</tr>
<tr>
<td>Bottom</td>
<td>Ctrl + 7</td>
</tr>
<tr>
<td>Right</td>
<td>3</td>
</tr>
<tr>
<td>Left</td>
<td>Ctrl + 3</td>
</tr>
<tr>
<td>Front</td>
<td>1</td>
</tr>
</tbody>
</table>
Graphical user interface

Predefined Views
Back Ctrl + 1

Rotate View
Rotate Up 8
Rotate Down 2
Rotate Left 4
Rotate Right 6

Photo View
Next photo (according to Photos pane order) Page Up
Previous photo (according to Photos pane order) Page Down
Navigation mode V

Selection Tools
Rectangle selection M
Intelligent scissors L
Intelligent paint P
Magic wand W
Add selection Ctrl + Shift + A
Subtract selection Ctrl + Shift + S
Invert selection Ctrl + Shift + I
Appendix B. Supported formats

Images

<table>
<thead>
<tr>
<th>Input formats</th>
<th>Undistort formats</th>
</tr>
</thead>
<tbody>
<tr>
<td>JPG</td>
<td>JPG</td>
</tr>
<tr>
<td>TIFF</td>
<td>TIFF</td>
</tr>
<tr>
<td>PNG</td>
<td>PNG</td>
</tr>
<tr>
<td>BMP</td>
<td>BMP</td>
</tr>
<tr>
<td>OpenEXR</td>
<td>OpenEXR</td>
</tr>
<tr>
<td>JPEG 2000</td>
<td>JPEG 2000</td>
</tr>
<tr>
<td>TARGA</td>
<td></td>
</tr>
<tr>
<td>Digital Negative (DNG)</td>
<td></td>
</tr>
<tr>
<td>Portable Bit Map (PGM, PPM)</td>
<td></td>
</tr>
<tr>
<td>Multi-Picture Object (MPO)</td>
<td></td>
</tr>
<tr>
<td>Norpix Sequence (SEQ)</td>
<td></td>
</tr>
<tr>
<td>AscTec Thermal Images (ARA)</td>
<td></td>
</tr>
</tbody>
</table>

Camera calibration

<table>
<thead>
<tr>
<th>Import formats</th>
<th>Export formats</th>
</tr>
</thead>
<tbody>
<tr>
<td>Agisoft Camera Calibration (*.xml)</td>
<td>Agisoft Camera Calibration (*.xml)</td>
</tr>
<tr>
<td>Australis Camera Parameters (*.txt)</td>
<td>Australis Camera Parameters (*.txt)</td>
</tr>
<tr>
<td>Australis v.7 Camera Parameters (*.txt)</td>
<td>Australis v.7 Camera Parameters (*.txt)</td>
</tr>
<tr>
<td>PhotoModeler Camera Calibration (*.ini)</td>
<td>PhotoModeler Camera Calibration (*.ini)</td>
</tr>
<tr>
<td>3DM CalibCam Camera Parameters (*.txt)</td>
<td>3DM CalibCam Camera Parameters (*.txt)</td>
</tr>
<tr>
<td>CalCam Camera Calibration (*.cal)</td>
<td>CalCam Camera Calibration (*.cal)</td>
</tr>
<tr>
<td>Inpho Camera Calibration (*.txt)</td>
<td>Inpho Camera Calibration (*.txt)</td>
</tr>
<tr>
<td>USGS Camera Calibration (*.txt)</td>
<td>USGS Camera Calibration (*.txt)</td>
</tr>
<tr>
<td>Z/I Distortion Grid (*.dat)</td>
<td>Z/I Distortion Grid (*.dat)</td>
</tr>
</tbody>
</table>

Interior and exterior camera orientation parameters

<table>
<thead>
<tr>
<th>Import camera positions</th>
<th>Export camera positions</th>
</tr>
</thead>
<tbody>
<tr>
<td>Agisoft XML (*.xml)</td>
<td>Agisoft XML (*.xml)</td>
</tr>
<tr>
<td>Autodesk FBX (*.fbx)</td>
<td>Autodesk FBX (*.fbx)</td>
</tr>
<tr>
<td>Alembic (*.abc)</td>
<td>Alembic (*.abc)</td>
</tr>
</tbody>
</table>
**Import camera positions**
- Realviz RZML (*.rzml)
- BINGO (*.dat)
- Bundler (*.out)
- VisionMap Detailed Report (*.txt)

**Export camera positions**
- Realviz RZML (*.rzml)
- Bundler (*.out)
- CHAN files (*.chan)
- Boujou (*.txt)
- Omega Phi Kappa (*.txt)
- PATB Exterior Orientation (*.ptb)
- BINGO Exterior Orientation (*.dat)
- ORIMA (*.txt)
- AeroSys Exterior Orientation (*.orn)
- INPHO Project File (*.prj)
- Summit Evolution Project (*.smtxml)
- Blocks Exchange (*.xml)

**Tie points**

**Export matches**
- BINGO (*.dat)
- ORIMA (*.txt)
- PATB (*.ptb)
- Summit Evolution Project (*.smtxml)
- Blocks Exchange (*.xml)

**Import not available**

**Sparse/dense point cloud**

**Import formats**
- Wavefront OBJ (*.obj)
- Stanford PLY (*.ply)
- ASCII PTS (*.pts)
- ASPRS LAS (*.las)
- LAZ (*.laz)
- ASTM E57 (*.e57)

**Export formats**
- Wavefront OBJ (*.obj)
- Stanford PLY (*.ply)
- ASCII PTS (*.pts)
- ASPRS LAS (*.las)
- LAZ (*.laz)
- ASTM E57 (*.e57)
- XYZ Point Cloud (*.txt)
- Cesium 3D Tiles (*.zip)
- Universal 3D (*.u3d)
- Autodesk DXF (*.dxf)
- potree (*.zip)
- Agisoft OC3 (*.oc3)
- Topcon CL3 (*.cl3)
- Adobe 3D PDF (*.pdf)
Supported formats

### Mesh model

**Import mesh**
- Wavefront OBJ (*.obj)
- 3DS models (*.3ds)
- COLLADA (*.dae)
- Stanford PLY (*.ply)
- Alembic (*.abc)
- STL models (*.stl)
- Autodesk DXF (*.dxf)
- Autodesk FBX (*.fbx)
- Universal 3D models (*.u3d)
- OpenCTM models (*.ctm)

**Export mesh**
- Wavefront OBJ (*.obj)
- 3DS models (*.3ds)
- COLLADA (*.dae)
- Stanford PLY (*.ply)
- Alembic (*.abc)
- STL models (*.stl)
- Autodesk DXF (*.dxf)
- Autodesk FBX (*.fbx)
- Universal 3D models (*.u3d)
- VRML models (*.wrl)
- OpenSceneGraph (*.osgb)
- Adobe 3D PDF (*.pdf)

### Texture

**Import texture**
- JPG
- TIFF
- PNG
- BMP
- TARGA
- JPEG 2000
- OpenEXR

**Export texture**
- JPG
- TIFF
- PNG
- BMP
- TARGA
- JPEG 2000
- OpenEXR
Appendix C. Camera models

A camera model specifies the transformation from point coordinates in the local camera coordinate system to the pixel coordinates in the image frame.

The local camera coordinate system has origin at the camera projection center. The Z axis points towards the viewing direction, X axis points to the right, Y axis points down.

The image coordinate system has origin at the top left image pixel, with the center of the top left pixel having coordinates (0.5, 0.5). The X axis in the image coordinate system points to the right, Y axis points down. Image coordinates are measured in pixels.

Equations used to project a points in the local camera coordinate system to the image plane are provided below for each supported camera model.

The following definitions are used in the equations:

\((X, Y, Z)\) - point coordinates in the local camera coordinate system,

\((u, v)\) - projected point coordinates in the image coordinate system (in pixels),

\(f\) - focal length,

\(c_x, c_y\) - principal point offset,

\(K_1, K_2, K_3, K_4\) - radial distortion coefficients,

\(P_1, P_2, P_3, P_4\) - tangential distortion coefficients,

\(B_1, B_2\) - affinity and non-orthogonality (skew) coefficients,

\(w, h\) - image width and height in pixels.

**Frame cameras**

\[
x = \frac{X}{Z} \\
y = \frac{Y}{Z} \\
r = \sqrt{x^2 + y^2} \\
x' = x(1 + K_1r^2 + K_2r^4 + K_3r^6 + K_4r^8) + (P_1(r^2+2x^2) + 2P_2xy)(1 + P_3r^2 + P_4r^4) \\
y' = y(1 + K_1r^2 + K_2r^4 + K_3r^6 + K_4r^8) + (P_2(r^2+2y^2) + 2P_1xy)(1 + P_3r^2 + P_4r^4) \\
u = w * 0.5 + c_x + x'f + x'B_1 + y'B_2 \\
v = h * 0.5 + c_y + y'f
\]

**Fisheye cameras**

\[
x_0 = \frac{X}{Z} \\
y_0 = \frac{Y}{Z}
\]
\[ r_0 = \sqrt{x_0^2 + y_0^2} \]
\[ x = x_0 \times \tan^{-1} r_0 / r_0 \]
\[ y = y_0 \times \tan^{-1} r_0 / r_0 \]
\[ r = \sqrt{x^2 + y^2} \]
\[ x' = x(1 + K_1 r^2 + K_2 r^4 + K_3 r^6 + K_4 r^8) + (P_1 r^2 + 2P_2 x y) (1 + P_3 r^2 + P_4 r^4) \]
\[ y' = y(1 + K_1 r^2 + K_2 r^4 + K_3 r^6 + K_4 r^8) + (P_2 r^2 + 2P_1 x y) (1 + P_3 r^2 + P_4 r^4) \]
\[ u = w \times 0.5 + c_x + x' f + x' B_1 + y' B_2 \]
\[ v = h \times 0.5 + c_y + y' f \]